]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- fixed macros.in changing
[packages/rpm.git] / rpm.spec
1 # to build for athlon you need release at least 49
2
3 Summary:        Red Hat (and now also PLD) Package Manager
4 Summary(de):    Red Hat (und jetzt auch PLD) Packet-Manager
5 Summary(es):    Gestor de paquetes RPM
6 Summary(pl):    Aplikacja do zarz±dzania pakietami
7 Summary(pt_BR): Gerenciador de pacotes RPM
8 Name:           rpm
9 Version:        4.0.2
10 Release:        49
11 License:        GPL
12 Group:          Base
13 Group(de):      Gründsätzlich
14 Group(es):      Base
15 Group(pl):      Podstawowe
16 Group(pt_BR):   Base
17 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
18 Source1:        %{name}.groups
19 Source2:        %{name}.macros
20 Source3:        %{name}-install-tree
21 Source4:        %{name}-find-%{name}-provides
22 Source5:        %{name}-macros.perl
23 Source6:        %{name}-find-perl-provides
24 Source7:        %{name}-find-perl-requires
25 Source8:        %{name}-find-spec-bcond
26 Source9:        %{name}-find-lang
27 Source10:       %{name}-find-provides
28 Source11:       %{name}-find-requires
29 Source12:       %{name}-non-english-man-pages.tar.bz2
30 Source13:       %{name}-macros.python
31 Patch0:         %{name}-rpmrc.patch
32 Patch1:         %{name}-macros.patch
33 Patch2:         %{name}-arch.patch
34 Patch3:         %{name}-rpmpopt.patch
35 Patch4:         %{name}-perl-macros.patch
36 Patch5:         %{name}-db3.patch
37 Patch6:         %{name}-segv.patch
38 Patch7:         %{name}-am_fix.patch
39 Patch8:         %{name}-perl-req-perlfile.patch
40 Patch9:         %{name}-installplatform.patch
41 Patch10:        %{name}-cache.patch
42 Patch11:        %{name}-suggestions.patch
43 Patch12:        %{name}-rh-lame.patch
44 Patch13:        %{name}-glob.patch
45 Patch14:        %{name}-header_h.patch
46 Patch15:        %{name}-fast-alAddPackage.patch
47 Patch16:        %{name}-byKey.patch
48 Patch17:        %{name}-perlprov.patch
49 Patch18:        %{name}-noperldir.patch
50 Patch19:        popt-cvs20010530.patch
51 Patch20:        %{name}-noexpand.patch
52 Patch21:        %{name}-scripts-closefds.patch
53 Patch22:        %{name}-python-amfix.patch
54 Patch23:        %{name}-non-english-man-pages.patch
55 Patch24:        %{name}-progress-nontty.patch
56 Patch25:        %{name}-am_ac.patch
57 Patch26:        %{name}-python-macros.patch
58 Patch27:        %{name}-hardlink-fixes.patch
59 Patch28:        %{name}-perlprov-regonly.patch
60 Patch29:        %{name}-cxx.patch
61 Patch30:        %{name}-athlon.patch
62 Patch31:        %{name}-athlon-identify.patch
63 Patch37:        %{name}-short_circuit.patch
64 Patch38:        %{name}-section_test.patch
65 URL:            http://www.rpm.org/
66 Icon:           rpm.gif
67 BuildRequires:  autoconf >= 2.50
68 BuildRequires:  automake
69 BuildRequires:  db3-devel >= 3.1.17-9
70 BuildRequires:  db1-devel >= 1.85
71 BuildRequires:  db3-devel >= 3.1.17-9
72 BuildRequires:  gettext-devel >= 0.10.38-3
73 BuildRequires:  python-devel
74 BuildRequires:  zlib-devel
75 BuildRequires:  python-modules >= 2.2.1
76 BuildRequires:  zlib-devel >= 1.1.4
77 %if %{!?_without_static:1}%{?_without_static:0}
78 # Require static library only for static build
79 BuildRequires:  db3-static >= 3.1.17-9
80 BuildRequires:  db1-static >= 1.85
81 BuildRequires:  zlib-static
82 BuildRequires:  glibc-static >= 2.2.0
83 BuildRequires:  zlib-static >= 1.1.4
84 Obsoletes:      rpm-libs
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86 Obsoletes:      rpm-libs
87 Conflicts:      glibc < 2.2
88
89 %define         __find_provides %{SOURCE4}
90 %define         _binary_payload w9.gzdio
91
92 %define         py_ver          %(echo `python -c "import sys; print sys.version[:3]"`)
93 %define         py_prefix       %(echo `python -c "import sys; print sys.prefix"`)
94 %define         py_libdir       %{py_prefix}/lib/python%{py_ver}
95 %define         py_dyndir       %{py_libdir}/lib-dynload
96 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
97
98 %description
99 RPM is a powerful package manager, which can be used to build,
100 install, query, verify, update, and uninstall individual software
101 packages. A package consists of an archive of files, and package
102 information, including name, version, and description.
103
104 %description -l de
105 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
106 Installation, Anfrage, Verifizierung, Aktualisierung und
107 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
108 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
109 Beschreibung.
110
111 %description -l es
112 RPM es un poderoso administrador de paquetes, que puede ser usado para
113 construir, instalar, pesquisar, verificar, actualizar y desinstalar
114 paquetes individuales de software. Un paquete consiste en un
115 almacenaje de archivos, y información sobre el paquete, incluyendo
116 nombre, versión y descripción.
117
118 %description -l pl
119 RPM jest doskona³ym mened¿erem pakietów. Dziêki niemu bêdziesz móg³
120 przebudowaæ, zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje
121 dotycz±ce ka¿dego pakietu, takie jak jego opis, lista plików
122 wchodz±cych w sk³ad pakietu, zale¿no¶ci od innych pakietów, s±
123 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
124 odpytywania programu rpm.
125
126 %description -l pt_BR
127 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
128 construir, instalar, pesquisar, verificar, atualizar e desinstalar
129 pacotes individuais de software. Um pacote consiste de um conjunto de
130 arquivos e informações adicionais, incluindo nome, versão e descrição
131 do pacote, permissões dos arquivos, etc.
132
133 %package devel
134 Summary:        Header files and libraries
135 Summary(de):    Header-Dateien uns Libraries
136 Summary(es):    Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
137 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
138 Group(de):      Entwicklung/Libraries
139 Group(es):      Desarrollo/Bibliotecas
140 Group(fr):      Development/Librairies
141 Group(pl):      Programowanie/Biblioteki
142 Group(pt_BR):   Desenvolvimento/Bibliotecas
143 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
144 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
145 Summary(pt_BR): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
146 Group:          Development/Libraries
147 Requires:       %{name} = %{version}
148 Requires:       popt-devel
149
150 %description devel
151 The RPM packaging system includes a C library that makes it easy to
152 manipulate RPM packages and databases. It is intended to ease the
153 creation of graphical package managers and other tools that need
154 intimate knowledge of RPM packages.
155
156 %description devel -l de
157 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
158 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
159 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
160 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
161
162 %description devel -l es
163 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
164 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
165 facilitar la creación de administradores gráficos de paquetes y otras
166 herramientas que necesiten un conocimiento profundo de paquetes RPM.
167
168 %description devel -l pl
169 System RPM zawiera bibliotekê C, która u³atwia manipulowanie pakietami
170 RPM oraz bazami danych. W zamiarze ma to upro¶ciæ tworzenie
171 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
172 szczegó³owej wiedzy na temat pakietów RPM.
173
174 %description devel -l pt_BR
175 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
176 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
177 facilitar a criação de gerenciadores gráficos de pacotes e outras
178 ferramentas que precisem de conhecimento profundo de pacotes RPM.
179
180 %package static
181 Summary:        RPM static libraries
182 Summary(de):    RPMs statische Libraries
183 Summary(pl):    Biblioteki statyczne RPM-a
184 Group(de):      Entwicklung/Libraries
185 Group(es):      Desarrollo/Bibliotecas
186 Group(fr):      Development/Librairies
187 Group(pl):      Programowanie/Biblioteki
188 Group(pt_BR):   Desenvolvimento/Bibliotecas
189 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
190 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
191 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
192 Group:          Development/Libraries
193 Requires:       %{name}-devel = %{version}
194
195 %description static
196 RPM static libraries.
197
198 %description static -l de
199 RPMs statische Libraries.
200
201 %description static -l pl
202 Biblioteki statyczne RPM-a.
203
204 %description static -l pt_BR
205 Bibliotecas estáticas para desenvolvimento.
206
207 %package utils
208 Summary:        Additional utilities for managing rpm packages and database
209 Summary(de):    Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
210 Group(de):      Applikationen/Datei
211 Group(pl):      Aplikacje/Pliki
212 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
213 Group:          Applications/File
214 Requires:       %{name} = %{version}
215
216 %description utils
217 Additional utilities for managing rpm packages and database.
218
219 %description utils -l de
220 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
221
222 %description utils -l pl
223 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
224
225 %package perlprov
226 Summary:        Additional utilities for checking perl provides/requires in rpm packages
227 Summary(de):    Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
228 Group(de):      Applikationen/Datei
229 Group(pl):      Aplikacje/Pliki
230 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
231 Group:          Applications/File
232 Requires:       perl-modules
233 Requires:       findutils
234
235 %description perlprov
236 Additional utilities for checking perl provides/requires in rpm
237 packages.
238
239 %description perlprov -l de
240 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
241
242 %description perlprov -l pl
243 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
244 pakietach rpm.
245
246 %package pythonprov
247 Summary:        Python macros, which simplifies creation of rpm packages with Python software
248 Group(de):      Applikationen/Datei
249 Group(pl):      Aplikacje/Pliki
250 Summary(pl):    Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w Pythonie
251 Requires:       python
252 Requires:       %{name} = %{version}
253 Requires:       python-modules
254
255 %description pythonprov
256 Python macros, which simplifies creation of rpm packages with Python
257 software.
258
259 %description pythonprov -l pl
260 Makra u³atwiaj±ce tworzenie pakietów rpm z programami napisanymi w
261 %package python
262
263 %package -n python-rpm
264 Summary:        Python interface to RPM library
265 Group:          Development/Languages/Python
266 Group(de):      Entwicklung/Sprachen/Python
267 Group(pl):      Programowanie/Jêzyki/Python
268 Summary(pt_BR): Módulo Python para aplicativos que manipulam pacotes RPM
269 %pyrequires_eq  python
270 %description python
271
272 %description -n python-rpm
273 The rpm-python package contains a module which permits applications
274 written in the Python programming language to use the interface
275 supplied by RPM (RPM Package Manager) libraries.
276
277 This package should be installed if you want to develop Python
278 %description python -l pl
279
280 %description -n python-rpm -l pl
281 Pakiet rpm-python zawiera modu³, który pozwala aplikacjom napisanym w
282 Pythonie na u¿ywanie interfejsu dostarczanego przez biblioteki RPM-a.
283
284 Pakiet ten powinien zostaæ zainstalowany, je¶li chcesz pisaæ w
285 %description python -l pt_BR
286
287 %description -n python-rpm -l pt_BR
288 O pacote rpm-python contém um módulo que permite que aplicações
289 escritas em Python utilizem a interface fornecida pelas bibliotecas
290 RPM (RPM Package Manager).
291
292 Esse pacote deve ser instalado se você quiser desenvolver programas em
293 Python para manipular pacotes e bancos de dados RPM.
294
295 %package build
296 Summary:        Scripts for building binary RPM packages
297 Summary(de):    Scripts fürs Bauen binärer RPM-Pakete
298 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPM-ów
299 Group(de):      Applikationen/Datei
300 Group(pl):      Aplikacje/Pliki
301 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
302 Group:          Applications/File
303 Requires:       %{name} = %{version}
304 Requires:       /bin/id
305 Requires:       awk
306 Requires:       binutils
307 Requires:       diffutils
308 Requires:       file >= 3.31
309 Requires:       fileutils
310 Requires:       findutils
311 %ifarch athlon
312 Requires:       gcc >= 3.0.3
313 %else
314 Requires:       gcc
315 Requires:       glibc-devel
316 Requires:       grep
317 Requires:       gzip
318 Requires:       make
319 Requires:       patch
320 Requires:       popt >= 1.6.2-2
321 Requires:       sed
322 Requires:       tar
323 Requires:       textutils
324
325 %description build
326 Scripts for building binary RPM packages.
327
328 %description build -l de
329 Scripts fürs Bauen binärer RPM-Pakete.
330
331 %description build -l pl
332 Skrypty pomocnicze do budowania binarnych RPM-ów.
333
334 %description build -l pt_BR
335 Este pacote contém scripts e programas executáveis que são usados para
336 construir pacotes usando o RPM.
337
338 %prep
339 %setup -q -a12
340 %patch0 -p1
341 %patch1 -p1
342 %patch2 -p1
343 %patch3 -p1
344 %patch4 -p1
345 %patch5 -p1
346 %patch6 -p1
347 %patch7 -p1
348 %patch8 -p1
349 %patch11 -p0
350 %patch12 -p0
351 %patch11 -p0
352 %patch12 -p0
353 %patch15 -p0
354 %patch16 -p0
355 %patch15 -p0
356 %patch16 -p0
357 %patch17 -p1
358 %patch18 -p1
359 %patch19 -p1
360 %patch22 -p1
361 %patch23 -p1
362 %patch24 -p1
363 %patch25 -p1
364 %patch26 -p0
365 %patch27 -p1
366 %patch28 -p1
367 %patch29 -p1
368 %patch30 -p1
369
370 %ifarch athlon
371 %patch31 -p1
372 %endif
373 %patch31 -p1
374 %patch36 -p1
375 %patch37 -p1
376 %patch38 -p1
377
378 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
379 cp -f platform.in macros.pld.in
380 install %{SOURCE9} scripts/find-lang.sh
381 install %{SOURCE13} macros.python.in
382 install %{SOURCE6} scripts/find-perl-provides
383 install %{SOURCE7} scripts/find-perl-requires
384 install %{SOURCE9} scripts/find-lang.sh
385
386 (cd scripts;
387 mv -f perl.req perl.req.in
388 mv -f perl.prov perl.prov.in)
389 %build
390 # generate Group translations to *.po
391 awk -f %{SOURCE14} %{SOURCE1}
392
393 cd popt
394 autoconf
395 automake -a -c
396 aclocal
397 autoheader
398 automake -a -c -f
399 %{__automake}
400 cd ..
401
402 rm -f missing
403 libtoolize --force --copy
404 autoconf
405 # ugly workaround for automake
406 sed -e 's#cpio.c $(DBLIBOBJS) depends.c#cpio.c depends.c#g' \
407         lib/Makefile.am > lib/Makefile.am.new
408 mv -f lib/Makefile.am.new lib/Makefile.am
409 automake -a -c
410 sed -e 's#cpio.c depends.c#cpio.c $(DBLIBOBJS) depends.c#g' \
411         lib/Makefile.in > lib/Makefile.in.new
412 mv -f lib/Makefile.in.new lib/Makefile.in
413
414 sed -e 's#python1.5#python%{py_ver}#g' \
415         python/Makefile.in > python/Makefile.in.new
416 mv -f python/Makefile.in.new python/Makefile.in
417
418 sed -e 's#python1.5#python%{py_ver}#g' \
419         python/Makefile.in > python/Makefile.in.new
420 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
421         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
422 # config.guess doesn't handle athlon, so we have to change it by hand.
423 # rpm checks for CPU type at runtime, but it looks better
424 sed -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' macros.in | \
425         sed 's|@host_cpu@|%{_target_cpu}|' > macros.tmp
426         --enable-v1-packages \
427         --with-python
428 %configure \
429         --enable-shared \
430         --enable-v1-packages \
431         --with-python
432
433
434 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
435
436 %install
437 rm -rf $RPM_BUILD_ROOT
438
439 %{__make} install \
440         DESTDIR=$RPM_BUILD_ROOT \
441         pkgbindir="%{_bindir}"
442
443 install macros.perl $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
444 install macros.python $RPM_BUILD_ROOT%{_libdir}/rpm/macros.python
445
446 install %{SOURCE1} doc/manual/groups
447 install %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
448 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
449 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/rpm/find-provides
450 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/rpm/find-requires
451 install %{SOURCE15} $RPM_BUILD_ROOT%{_libdir}/rpm/compress-doc
452
453 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
454
455 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm
456 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
457 # customized rpm macros - global for host
458 #
459 #%%_install_langs pl_PL:en_US
460 %%distribution PLD
461 EOF
462
463 %find_lang %{name}
464
465 # DON'T BREAK BUILD TREE!!!
466 # rm -f doc/manual/Makefile*
467
468 gzip -9nf RPM-PGP-KEY CHANGES doc/manual/*
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %post   -p /sbin/ldconfig
474 %postun -p /sbin/ldconfig
475
476 %attr(755,root,root) %{_libdir}/rpm/rpmdb
477 %attr(755,root,root) %{_libdir}/rpm/rpmq
478 %attr(755,root,root) %{_libdir}/rpm/rpmk
479 %attr(755,root,root) %{_libdir}/rpm/rpmv
480 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
481 %attr(755,root,root) %{_libdir}/rpm/rpmdb
482 %attr(755,root,root) %{_libdir}/rpm/rpmq
483 %attr(755,root,root) %{_libdir}/rpm/rpmk
484 %attr(755,root,root) %{_libdir}/rpm/rpmv
485 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
486
487 %dir %{_sysconfdir}/rpm
488 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/rpm/macros
489
490 %{_mandir}/man8/rpm.8*
491 %lang(fr) %{_mandir}/fr/man8/rpm.8*
492 %lang(ja) %{_mandir}/ja/man8/rpm.8*
493 %lang(ko) %{_mandir}/ko/man8/rpm.8*
494 %lang(pl) %{_mandir}/pl/man8/rpm.8*
495 %lang(ru) %{_mandir}/ru/man8/rpm.8*
496 %lang(sk) %{_mandir}/sk/man8/rpm.8*
497
498 %dir /var/lib/rpm
499 %dir %{_libdir}/rpm
500
501 %{_libdir}/rpm/macros.python
502 %{_libdir}/rpm/noarch-linux
503 %{_libdir}/rpm/noarch-pld-linux
504 %{_libdir}/rpm/rpmrc
505 %{_libdir}/rpm/rpmpopt*
506 %{_libdir}/rpm/macros
507 %{_libdir}/rpm/noarch-linux
508 %{_libdir}/rpm/noarch-pld-linux
509 %ifarch i386 i486 i586 i686 athlon
510 %{_libdir}/rpm/i?86*
511 %{_libdir}/rpm/athlon*
512 %endif
513 %ifarch sparc sparc64
514 %{_libdir}/rpm/sparc*
515 %endif
516 %ifarch alpha
517 %{_libdir}/rpm/alpha*
518 %endif
519 %ifarch ppc
520 %{_libdir}/rpm/ppc*
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_bindir}/rpmbuild
523 %attr(755,root,root) %{_bindir}/rpme
524 %attr(755,root,root) %{_bindir}/rpmi
525 %attr(755,root,root) %{_bindir}/rpmu
526 %attr(755,root,root) %{_libdir}/rpm/find-requires
527 %attr(755,root,root) %{_libdir}/rpm/find-provides
528 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
529 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
530 %attr(755,root,root) %{_libdir}/rpm/find-lang.sh
531 %attr(755,root,root) %{_libdir}/rpm/mkinstalldirs
532 %attr(755,root,root) %{_libdir}/rpm/getpo.sh
533 %attr(755,root,root) %{_libdir}/rpm/install-build-tree
534 %attr(755,root,root) %{_libdir}/rpm/brp-*
535 %attr(755,root,root) %{_libdir}/rpm/check-prereqs
536 %attr(755,root,root) %{_libdir}/rpm/compress-doc
537 %attr(755,root,root) %{_libdir}/rpm/cpanflute
538 %attr(755,root,root) %{_libdir}/rpm/http.req
539 %attr(755,root,root) %{_libdir}/rpm/magic.*
540 %attr(755,root,root) %{_libdir}/rpm/rpmi
541 %attr(755,root,root) %{_libdir}/rpm/u_pkg.sh
542 %attr(755,root,root) %{_libdir}/rpm/rpme
543 %attr(755,root,root) %{_libdir}/rpm/rpmu
544 %attr(755,root,root) %{_libdir}/rpm/rpmb
545 %attr(755,root,root) %{_libdir}/rpm/rpmi
546 %attr(755,root,root) %{_libdir}/rpm/rpmt
547 %attr(755,root,root) %{_libdir}/rpm/rpme
548 %attr(755,root,root) %{_libdir}/librpm*.la
549 %attr(755,root,root) %{_libdir}/librpm*.so
550 %files devel
551 %defattr(644,root,root,755)
552 %{_includedir}/rpm
553 %attr(755,root,root) %{_libdir}/librpm*.la
554 %attr(755,root,root) %{_libdir}/librpm*.so
555
556 %files static
557 %attr(755,root,root) %{_bindir}/*
558 %files utils
559 %defattr(644,root,root,755)
560 %{_mandir}/man1/*
561 %attr(755,root,root) %{_bindir}/javadeps
562 %attr(755,root,root) %{_bindir}/rpm2cpio
563
564 %{_mandir}/man8/rpm2cpio.8*
565 %{_mandir}/man1/*
566 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
567 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
568 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
569 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
570
571 %files perlprov
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/rpm/perl*
574 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
575 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
576 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
577 %attr(755,root,root) %{_libdir}/rpm/find-req.pl
578 %attr(755,root,root) %{_libdir}/rpm/get_magic.pl
579
580 %{_libdir}/rpm/macros.perl
581 %files python
582 %defattr(644,root,root,755)
583 %{py_sitedir}/*.so
584 %{_libdir}/rpm/macros.python
585
586 %files -n python-rpm
587 %defattr(755,root,root,755)
588 %{py_sitedir}/*.so
This page took 0.558801 seconds and 3 git commands to generate.