]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
777d0fb6968b4d8c1a26aee3769c1336b41efdf7
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4 #   matches ELF first
5 # - repackaging when lzma is not installed (todo: fix digest signature of header)
6 #   rpmbuild computes digest when writing package to temporary file, then adds a few
7 #   tags (incl. digest) and writes whole package to destination file;
8 #   repackaging uses unchanged "immutable header" image from original rpm, also
9 #   preserving payload format and compressor from original rpm, _not_ current settings
10 #
11 # Conditional build:
12 %bcond_with     static          # build static rpm+rpmi
13 %bcond_without  apidocs         # don't generate documentation with doxygen
14 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
15 %bcond_without  python          # don't build python bindings
16 %bcond_without  selinux         # build without selinux support
17 %bcond_without  system_libmagic # don't use system libmagic
18 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
19 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
20 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
21 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
22 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
23
24 # versions of required libraries
25 %define reqdb_ver       4.5.20
26 %define reqpopt_ver     1.10.8
27 %define beecrypt_ver    2:4.1.2-4
28 %define sover   4.4
29 Summary:        RPM Package Manager
30 Summary(de.UTF-8):      RPM Packet-Manager
31 Summary(es.UTF-8):      Gestor de paquetes RPM
32 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
33 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
34 Summary(ru.UTF-8):      Менеджер пакетов от RPM
35 Summary(uk.UTF-8):      Менеджер пакетів від RPM
36 Name:           rpm
37 Version:        4.4.9
38 Release:        0.1
39 License:        GPL
40 Group:          Base
41 Source0:        ftp://jbj.org/pub/rpm-4.4.x/%{name}-%{version}.tar.gz
42 # Source0-md5:  210b768006e7d88dd8a3bcd498ea27f6
43 Source1:        %{name}.groups
44 Source2:        %{name}.platform
45 Source3:        %{name}-install-tree
46 Source4:        %{name}-find-spec-bcond
47 Source5:        %{name}-find-lang
48 Source6:        %{name}-groups-po.awk
49 Source7:        %{name}-compress-doc
50 Source8:        %{name}-check-files
51 Source9:        %{name}-php-provides
52 Source10:       %{name}-php-requires
53 Source11:       %{name}.sysinfo
54 Source12:       perl.prov
55 Source13:       %{name}-user_group.sh
56 Source14:       %{name}.sysconfig
57 Source30:       builder
58 Source31:       adapter.awk
59 Source32:       pldnotify.awk
60 # http://svn.pld-linux.org/banner.sh/
61 Source33:       banner.sh
62 Patch0:         %{name}-pl.po.patch
63 Patch1:         %{name}-rpmrc.patch
64 Patch2:         %{name}-arch.patch
65 Patch3:         %{name}-rpmpopt.patch
66 Patch4:         %{name}-perl-macros.patch
67 Patch5:         %{name}-perl-req-perlfile.patch
68 Patch6:         %{name}-noexpand.patch
69 Patch7:         %{name}-scripts-closefds.patch
70 Patch8:         %{name}-python-macros.patch
71 Patch9:         %{name}-gettext-in-header.patch
72 Patch10:        %{name}-compress-doc.patch
73 Patch11:        %{name}-rpmdeps-segv.patch
74 Patch12:        %{name}-system_libs.patch
75 Patch13:        %{name}-bb-and-short-circuit.patch
76 Patch14:        %{name}-etc_dir.patch
77 Patch15:        %{name}-system_libs-more.patch
78 Patch16:        %{name}-php-deps.patch
79 Patch17:        %{name}-ldconfig-always.patch
80 Patch18:        %{name}-perl_req.patch
81 Patch19:        %{name}-link.patch
82 Patch20:        %{name}-magic-usesystem.patch
83 Patch21:        %{name}-dontneedutils.patch
84 Patch22:        %{name}-provides-dont-obsolete.patch
85 Patch23:        %{name}-pkgconfigdeps.patch
86 Patch24:        %{name}-po.patch
87 Patch25:        %{name}-glob.patch
88 Patch26:        %{name}-notsc.patch
89 Patch27:        %{name}-hack-norpmlibdep.patch
90 Patch28:        %{name}-makefile-no_myLDADD_deps.patch
91 Patch29:        %{name}-ds.patch
92 Patch30:        %{name}-locale.patch
93 Patch31:        %{name}-missing-prototypes.patch
94 Patch32:        %{name}-pld-autodep.patch
95 Patch33:        %{name}-arch-x86_64.patch
96 Patch34:        %{name}-epoch0.patch
97 Patch35:        %{name}-perl_req-INC_dirs.patch
98 Patch36:        %{name}-debuginfo.patch
99 Patch37:        %{name}-doxygen_hack.patch
100 Patch38:        %{name}-empty-rpmlock-path.patch
101 Patch39:        %{name}-version.patch
102 Patch41:        %{name}-reduce-stack-usage.patch
103 Patch42:        %{name}-old-fileconflicts-behaviour.patch
104
105 Patch44:        %{name}-no-neon.patch
106 Patch45:        %{name}-no-sqlite.patch
107 Patch46:        %{name}-mono.patch
108
109 Patch49:        %{name}-p4.patch
110 Patch50:        %{name}-macros.patch
111 Patch51:        %{name}-cleanlibdirs.patch
112 Patch52:        %{name}-morearchs.patch
113
114 Patch55:        %{name}-truncate-cvslog.patch
115
116 Patch57:        %{name}-as_needed-fix.patch
117 Patch58:        %{name}-repackage-wo-lzma.patch
118 Patch59:        %{name}-libtool-deps.patch
119
120 Patch64:        %{name}-iconv-translit.patch
121 URL:            http://wraptastic.org/
122 BuildRequires:  autoconf >= 2.57
123 BuildRequires:  automake >= 1.4
124 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
125 BuildRequires:  bzip2-devel >= 1.0.2-17
126 BuildRequires:  db-devel >= %{reqdb_ver}
127 BuildRequires:  elfutils-devel >= 0.108
128 BuildRequires:  gettext-devel >= 0.11.4-2
129 %{?with_system_libmagic:BuildRequires:  libmagic-devel}
130 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
131 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
132 BuildRequires:  libstdc++-devel
133 BuildRequires:  libtool >= 1:1.4.2-9
134 %if %{with neon}
135 BuildRequires:  libxml2-devel
136 BuildRequires:  neon-devel >= 0.25.5
137 %endif
138 BuildRequires:  patch >= 2.2
139 BuildRequires:  popt-devel >= %{reqpopt_ver}
140 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
141 BuildRequires:  python-modules >= 1:2.5
142 BuildRequires:  rpm-perlprov
143 %{?with_python:BuildRequires:   rpm-pythonprov}
144 BuildRequires:  zlib-devel
145 %if %{with apidocs}
146 BuildRequires:  doxygen
147 BuildRequires:  ghostscript
148 BuildRequires:  graphviz
149 BuildRequires:  tetex-pdftex
150 %endif
151 %if %{with static}
152 # Require static library only for static build
153 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
154 BuildRequires:  bzip2-static >= 1.0.2-17
155 BuildRequires:  db-static >= %{reqdb_ver}
156 BuildRequires:  elfutils-static
157 BuildRequires:  glibc-static >= 2.2.94
158 %{?with_system_libmagic:BuildRequires:  libmagic-static}
159 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
160 BuildRequires:  popt-static >= %{reqpopt_ver}
161 BuildRequires:  zlib-static
162 %endif
163 Requires:       %{name}-base = %{version}-%{release}
164 Requires:       %{name}-lib = %{version}-%{release}
165 Requires:       beecrypt >= %{beecrypt_ver}
166 Requires:       popt >= %{reqpopt_ver}
167 %{!?with_static:Obsoletes:      rpm-utils-static}
168 Conflicts:      glibc < 2.2.92
169 # ABI changes in rpm, new poldek needed
170 Conflicts:      poldek < 0.20.1-0.20070105.0
171 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
172
173 %define         _binary_payload         w9.gzdio
174 %define         _noPayloadPrefix        1
175
176 # don't require very fresh rpm.macros to build
177 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
178 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
179 %define         ppc     ppc ppc7400 ppc7450
180 %define         x8664   amd64 ia32e x86_64
181
182 # stabilize new build environment
183 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
184 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
185 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
186
187 %define         _rpmlibdir /usr/lib/rpm
188
189 %define         specflags       -fno-strict-aliasing
190
191 %description
192 RPM is a powerful package manager, which can be used to build,
193 install, query, verify, update, and uninstall individual software
194 packages. A package consists of an archive of files, and package
195 information, including name, version, and description.
196
197 %description -l de.UTF-8
198 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
199 Installation, Anfrage, Verifizierung, Aktualisierung und
200 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
201 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
202 Beschreibung.
203
204 %description -l es.UTF-8
205 RPM es un poderoso administrador de paquetes, que puede ser usado para
206 construir, instalar, pesquisar, verificar, actualizar y desinstalar
207 paquetes individuales de software. Un paquete consiste en un
208 almacenaje de archivos, y información sobre el paquete, incluyendo
209 nombre, versión y descripción.
210
211 %description -l pl.UTF-8
212 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
213 przebudowanie, instalację czy weryfikację dowolnego pakietu.
214 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
215 plików wchodzących w skład pakietu, zależności od innych pakietów, są
216 przechowywane w bazie danych i można je uzyskać za pomocą opcji
217 odpytywania programu rpm.
218
219 %description -l pt_BR.UTF-8
220 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
221 construir, instalar, pesquisar, verificar, atualizar e desinstalar
222 pacotes individuais de software. Um pacote consiste de um conjunto de
223 arquivos e informações adicionais, incluindo nome, versão e descrição
224 do pacote, permissões dos arquivos, etc.
225
226 %description -l ru.UTF-8
227 RPM - это мощный менеджер пакетов, который может быть использован для
228 создания, инсталляции, запросов (query), проверки, обновления и
229 удаления программных пакетов. Пакет состоит из файлового архива и
230 служебной информации, включающей название, версию, описание и другие
231 данные о пакете.
232
233 %description -l uk.UTF-8
234 RPM - це потужний менеджер пакетів, що може бути використаний для
235 створення, інсталяції, запитів (query), перевірки, поновлення та
236 видалення програмних пакетів. Пакет складається з файлового архіву та
237 службової інформації, що містить назву, версію, опис та іншу
238 інформацію про пакет.
239
240 %package base
241 Summary:        RPM base package - scripts used by rpm packages themselves
242 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
243 Group:          Base
244 Requires:       filesystem
245 Obsoletes:      vserver-rpm
246
247 %description base
248 The RPM base package contains scripts used by rpm packages themselves.
249 These include:
250 - scripts for adding/removing groups and users needed for rpm
251   packages,
252 - banner.sh to display %%banner messages from rpm scriptlets.
253
254 %description base -l pl.UTF-8
255 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
256 Zawiera on:
257 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
258 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
259
260 %package lib
261 Summary:        RPMs library
262 Summary(pl.UTF-8):      Biblioteki RPM-a
263 Group:          Libraries
264 Requires:       beecrypt >= %{beecrypt_ver}
265 Requires:       db >= %{reqdb_ver}
266 %{?with_selinux:Requires:       libselinux >= 1.18}
267 %{?with_system_libmagic:Requires:       libmagic >= 1.15-2}
268 Requires:       popt >= %{reqpopt_ver}
269 Obsoletes:      rpm-libs
270 # avoid SEGV caused by mixed db versions
271 Conflicts:      poldek < 0.18.1-16
272 %{?with_suggest_tags:Suggests:  lzma}
273
274 %description lib
275 RPMs library.
276
277 %description lib -l pl.UTF-8
278 Biblioteki RPM-a.
279
280 %package devel
281 Summary:        Header files for rpm libraries
282 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
283 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
284 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
285 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
286 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
287 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
288 Group:          Development/Libraries
289 Requires:       %{name}-lib = %{version}-%{release}
290 Requires:       beecrypt-devel >= %{beecrypt_ver}
291 Requires:       bzip2-devel
292 Requires:       db-devel >= %{reqdb_ver}
293 Requires:       elfutils-devel
294 %{?with_system_libmagic:Requires:       libmagic-devel}
295 %{?with_selinux:Requires:       libselinux-devel}
296 Requires:       popt-devel >= %{reqpopt_ver}
297 Requires:       zlib-devel
298
299 %description devel
300 The RPM packaging system includes C libraries that make it easy to
301 manipulate RPM packages and databases. They are intended to ease the
302 creation of graphical package managers and other tools that need
303 intimate knowledge of RPM packages. This package contains header files
304 for these libraries.
305
306 %description devel -l de.UTF-8
307 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
308 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
309 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
310 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
311
312 %description devel -l es.UTF-8
313 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
314 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
315 facilitar la creación de administradores gráficos de paquetes y otras
316 herramientas que necesiten un conocimiento profundo de paquetes RPM.
317
318 %description devel -l pl.UTF-8
319 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
320 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
321 graficznych programów zarządzających pakietami oraz innych narzędzi,
322 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
323 zawiera pliki nagłówkowe wspomnianych bibliotek.
324
325 %description devel -l pt_BR.UTF-8
326 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
327 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
328 facilitar a criação de gerenciadores gráficos de pacotes e outras
329 ferramentas que precisem de conhecimento profundo de pacotes RPM.
330
331 %description devel -l ru.UTF-8
332 Система управления пакетами RPM содержит библиотеку C, которая
333 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
334 Эта библиотека предназначена для облегчения создания графических
335 пакетных менеджеров и других утилит, которым необходимо работать с
336 пакетами RPM.
337
338 %description devel -l uk.UTF-8
339 Система керування пакетами RPM містить бібліотеку C, котра спрощує
340 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
341 призначена для полегшення створення графічних пакетних менеджерів та
342 інших утиліт, що працюють з пакетами RPM.
343
344 %package static
345 Summary:        RPM static libraries
346 Summary(de.UTF-8):      RPMs statische Libraries
347 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
348 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
349 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
350 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
351 Group:          Development/Libraries
352 Requires:       %{name}-devel = %{version}-%{release}
353 Requires:       beecrypt-static >= %{beecrypt_ver}
354 Requires:       bzip2-static
355 Requires:       db-static >= %{reqdb_ver}
356 Requires:       elfutils-static
357 %{?with_system_libmagic:Requires:       libmagic-static}
358 Requires:       popt-static >= %{reqpopt_ver}
359 Requires:       zlib-static
360
361 %description static
362 RPM static libraries.
363
364 %description static -l de.UTF-8
365 RPMs statische Libraries.
366
367 %description static -l pl.UTF-8
368 Biblioteki statyczne RPM-a.
369
370 %description static -l pt_BR.UTF-8
371 Bibliotecas estáticas para desenvolvimento.
372
373 %description static -l ru.UTF-8
374 Система управления пакетами RPM содержит библиотеку C, которая
375 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
376 Это статическая библиотека RPM.
377
378 %description static -l uk.UTF-8
379 Система керування пакетами RPM містить бібліотеку C, котра спрощує
380 роботу з пакетами RPM та відповідними базами даних. Це статична
381 бібліотека RPM.
382
383 %package utils
384 Summary:        Additional utilities for managing rpm packages and database
385 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
386 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
387 Group:          Applications/File
388 Requires:       %{name} = %{version}-%{release}
389 Requires:       popt >= %{reqpopt_ver}
390
391 %description utils
392 Additional utilities for managing rpm packages and database.
393
394 %description utils -l de.UTF-8
395 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
396
397 %description utils -l pl.UTF-8
398 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
399
400 %package utils-perl
401 Summary:        Additional utilities for managing rpm packages and database
402 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
403 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
404 Group:          Applications/File
405 Requires:       %{name}-utils = %{version}-%{release}
406 Requires:       popt >= %{reqpopt_ver}
407
408 %description utils-perl
409 Additional utilities for managing rpm packages and database.
410
411 %description utils-perl -l de.UTF-8
412 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
413
414 %description utils-perl -l pl.UTF-8
415 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
416
417 %package utils-static
418 Summary:        Static rpm utilities
419 Summary(pl.UTF-8):      Statyczne narzędzia rpm
420 Group:          Applications/System
421 Requires:       %{name} = %{version}-%{release}
422
423 %description utils-static
424 Static rpm utilities for repairing system in case something with
425 shared libraries used by rpm become broken. Currently it contains rpmi
426 binary, which can be used to install/upgrade/remove packages without
427 using shared libraries (well, in fact with exception of NSS modules).
428
429 %description utils-static -l pl.UTF-8
430 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
431 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
432 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
433 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
434 (z wyjątkiem modułów NSS).
435
436 %package build
437 Summary:        Scripts for building binary RPM packages
438 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
439 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
440 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
441 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
442 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
443 Group:          Applications/File
444 Requires(pre):  findutils
445 Requires:       %{name}-build-macros >= 1.314
446 Requires:       %{name}-utils = %{version}-%{release}
447 Requires:       /bin/id
448 Requires:       awk
449 # we need fixed binutils for -feliminate-dwarf2-dups
450 Requires:       binutils >= 3:2.17.50.0.3-2
451 Requires:       bzip2
452 Requires:       chrpath >= 0.10-4
453 Requires:       cpio
454 Requires:       diffutils
455 Requires:       elfutils
456 Requires:       file >= 4.17
457 Requires:       fileutils
458 Requires:       findutils
459 Requires:       gcc >= 5:3.4
460 Requires:       glibc-devel
461 Requires:       grep
462 Requires:       gzip
463 Requires:       lzma
464 Requires:       make
465 Requires:       patch
466 Requires:       sed
467 Requires:       sh-utils
468 Requires:       tar
469 Requires:       textutils
470 Provides:       rpmbuild(monoautodeps)
471 Provides:       rpmbuild(noauto) = 3
472 %ifarch %{x8664}
473 Conflicts:      automake < 1:1.7.9-2
474 Conflicts:      libtool < 2:1.5-13
475 %endif
476
477 %description build
478 Scripts for building binary RPM packages.
479
480 %description build -l de.UTF-8
481 Scripts fürs Bauen binärer RPM-Pakete.
482
483 %description build -l pl.UTF-8
484 Skrypty pomocnicze do budowania binarnych RPM-ów.
485
486 %description build -l pt_BR.UTF-8
487 Este pacote contém scripts e programas executáveis que são usados para
488 construir pacotes usando o RPM.
489
490 %description build -l ru.UTF-8
491 Различные вспомогательные скрипты и исполняемые программы, которые
492 используются для сборки RPM'ов.
493
494 %description build -l uk.UTF-8
495 Різноманітні допоміжні скрипти та утиліти, які використовуються для
496 побудови RPM'ів.
497
498 %package build-tools
499 Summary:        Scripts for managing .spec files and building RPM packages
500 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
501 Summary(pl.UTF-8):      Skrypty pomocnicze do zarządznia plikami .spec i budowania RPM-ów
502 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
503 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
504 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
505 Group:          Applications/File
506 Requires:       %{name}-build = %{version}-%{release}
507 # these are optional
508 #Requires:      cvs
509 Requires:       wget
510
511 %description build-tools
512 Scripts for managing .spec files and building RPM packages.
513
514 %description build-tools -l de.UTF-8
515 Scripts fürs Bauen RPM-Pakete.
516
517 %description build-tools -l pl.UTF-8
518 Skrypty pomocnicze do zarządzania plikami .spec i do budowania RPM-ów.
519
520 %description build-tools -l pt_BR.UTF-8
521 Este pacote contém scripts e programas executáveis que são usados para
522 construir pacotes usando o RPM.
523
524 %description build-tools -l ru.UTF-8
525 Различные вспомогательные скрипты и исполняемые программы, которые
526 используются для сборки RPM'ов.
527
528 %description build-tools -l uk.UTF-8
529 Різноманітні допоміжні скрипти та утиліти, які використовуються для
530 побудови RPM'ів.
531
532 %package perlprov
533 Summary:        Additional utilities for checking perl provides/requires in rpm packages
534 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
535 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w pakietach rpm
536 Group:          Applications/File
537 Requires:       %{name} = %{version}-%{release}
538 Requires:       perl-devel
539 Requires:       perl-modules
540
541 %description perlprov
542 Additional utilities for checking perl provides/requires in rpm
543 packages.
544
545 %description perlprov -l de.UTF-8
546 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
547
548 %description perlprov -l pl.UTF-8
549 Dodatkowe narzędzia do sprawdzenia zależności skryptów perla w
550 pakietach rpm.
551
552 %package pythonprov
553 Summary:        Python macros, which simplifies creation of rpm packages with Python software
554 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w Pythonie
555 Group:          Applications/File
556 Requires:       %{name} = %{version}-%{release}
557 Requires:       python
558 Requires:       python-modules
559
560 %description pythonprov
561 Python macros, which simplifies creation of rpm packages with Python
562 software.
563
564 %description pythonprov -l pl.UTF-8
565 Makra ułatwiające tworzenie pakietów rpm z programami napisanymi w
566 Pythonie.
567
568 %package php-pearprov
569 Summary:        Additional utilities for managing rpm packages and database
570 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w rpm
571 Group:          Applications/File
572 Requires:       %{name} = %{version}-%{release}
573 Requires:       sed >= 4.0
574
575 %description php-pearprov
576 Additional utilities for checking php pear provides/requires in rpm
577 packages.
578
579 %description php-pearprov -l pl.UTF-8
580 Dodatkowe narzędzia do sprawdzenia zależności skryptów php pear w
581 pakietach rpm.
582
583 %package -n python-rpm
584 Summary:        Python interface to RPM library
585 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
586 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
587 Group:          Development/Languages/Python
588 Requires:       %{name} = %{version}-%{release}
589 %pyrequires_eq  python
590 Obsoletes:      rpm-python
591
592 %description -n python-rpm
593 The rpm-python package contains a module which permits applications
594 written in the Python programming language to use the interface
595 supplied by RPM (RPM Package Manager) libraries.
596
597 This package should be installed if you want to develop Python
598 programs that will manipulate RPM packages and databases.
599
600 %description -n python-rpm -l pl.UTF-8
601 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
602 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
603
604 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
605 Pythonie programy manipulujące pakietami i bazami danych rpm.
606
607 %description -n python-rpm -l pt_BR.UTF-8
608 O pacote rpm-python contém um módulo que permite que aplicações
609 escritas em Python utilizem a interface fornecida pelas bibliotecas
610 RPM (RPM Package Manager).
611
612 Esse pacote deve ser instalado se você quiser desenvolver programas em
613 Python para manipular pacotes e bancos de dados RPM.
614
615 %package apidocs
616 Summary:        RPM API documentation and guides
617 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
618 Group:          Documentation
619
620 %description apidocs
621 Documentation for RPM API and guides in HTML format generated from rpm
622 sources by doxygen.
623
624 %description apidocs -l pl.UTF-8
625 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
626 źrodeł RPM-a przez doxygen.
627
628 %prep
629 %setup -q
630 # merged
631 #%patch0 -p1
632 %patch1 -p1
633 %patch2 -p1
634 %patch3 -p1
635 %patch4 -p1
636 %patch5 -p1
637 %patch6 -p1
638 %patch7 -p1
639 %patch8 -p1
640 %patch9 -p1
641 %patch10 -p1
642 # obsolete
643 #%patch11 -p1
644 %patch12 -p1
645 %patch13 -p1
646 %patch14 -p1
647 %patch15 -p1
648 %patch16 -p1
649 %patch17 -p1
650 %patch18 -p1
651 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
652 #cp -f platform.in macros.pld.in # what for?
653 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
654 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
655 echo '# obsoleted file' > macros.python
656 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
657 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
658 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
659 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
660 install %{SOURCE5} scripts/find-lang.sh
661 install %{SOURCE9} scripts/php.prov.in
662 install %{SOURCE10} scripts/php.req.in
663 install %{SOURCE12} scripts/perl.prov
664 # obsolete
665 #%patch19 -p1
666 %patch20 -p1
667 %patch21 -p1
668 %patch22 -p1
669 %patch23 -p1
670 # merged
671 #%patch24 -p1
672 # merged
673 #%patch25 -p1
674 %patch26 -p1
675 %patch27 -p1
676 %patch28 -p1
677 # merged
678 #%patch29 -p1
679 # merged
680 #%patch30 -p1
681 %patch31 -p1
682 # FIXME!
683 # %patch32 -p1
684 # merged
685 # %patch33 -p1
686 %patch34 -p1
687 %patch35 -p0
688 %patch36 -p1
689 # FIXME
690 #%patch37 -p1
691 # CHECK ME
692 #%patch38 -p1
693 # obsolete
694 #%patch39 -p1
695 %patch41 -p1
696 %patch42 -p1
697 %{!?with_neon:%patch44 -p1}
698 # WTF? this is merged?
699 #%patch45 -p1
700 %patch46 -p1
701 %patch49 -p1
702 %patch50 -p1
703 %patch51 -p1
704 #%patch52 -p1
705 %patch55 -p1
706 %patch57 -p1
707 %patch58 -p1
708 %patch59 -p1
709 # CHECK ME
710 #%patch64 -p1
711
712 cd scripts
713 mv -f perl.req perl.req.in
714 mv -f perl.prov perl.prov.in
715 cd ..
716
717 mv -f po/{no,nb}.po
718 mv -f po/{sr,sr@Latn}.po
719
720 rm -rf sqlite zlib db db3 popt rpmdb/db.h
721
722 # generate Group translations to *.po
723 awk -f %{SOURCE6} %{SOURCE1}
724
725 # update macros paths
726 for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
727         sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
728         mv -f ${f}.tmp $f
729 done
730
731 %build
732 %if %{with system_libmagic}
733 rm -rf file
734 %else
735 cd file
736 %{__libtoolize}
737 %{__aclocal}
738 %{__autoheader}
739 %{__autoconf}
740 %{__automake}
741 cd ..
742 %endif
743
744 %{__libtoolize}
745 %{__gettextize}
746 %{__aclocal}
747 %{__autoheader}
748 %{__autoconf}
749 %{__automake}
750
751 # config.guess doesn't handle athlon, so we have to change it by hand.
752 # rpm checks for CPU type at runtime, but it looks better
753 sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
754
755 # pass CC and CXX too in case of building with some older configure macro
756 # disable perl-RPM2 build, we have it in separate spec
757 %configure \
758         CC="%{__newcc}" \
759         CXX="%{__newcxx}" \
760         CPP="%{__newcpp}" \
761         WITH_PERL_VERSION=no \
762         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
763         --enable-shared \
764         --enable-static \
765         %{!?with_apidocs:--without-apidocs} \
766         %{?with_python:--with-python=2.5} \
767         %{!?with_python:--without-python} \
768         %{!?with_selinux:--without-selinux} \
769         --without-db
770
771 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
772 %{__make} \
773         CC="%{__cc}" \
774         CXX="%{__cxx}" \
775         CPP="%{__cpp}" \
776         pylibdir=%{py_libdir} \
777         myLDFLAGS="%{rpmldflags}" \
778         file_LDFLAGS= \
779         debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt" \
780         staticLDFLAGS=%{?with_static:-all-static}
781
782 %{?with_apidocs:%{__make} doxygen}
783
784 %install
785 rm -rf $RPM_BUILD_ROOT
786 install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
787
788 %{__make} install \
789         DESTDIR=$RPM_BUILD_ROOT \
790         staticLDFLAGS=%{?with_static:-all-static} \
791         pylibdir=%{py_libdir} \
792         pkgbindir="%{_bindir}"
793
794 echo "%{_target_cpu}-%{_target_vendor}-linux-gnu" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
795
796 %ifarch %{ppc}
797 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
798 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
799 %endif
800
801 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
802 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
803 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
804
805 # not installed since 4.4.8 (-tools-perl subpackage)
806 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
807
808 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
809 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
810 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
811 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
812
813 install %{SOURCE1} doc/manual/groups
814 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
815 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
816 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
817 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
818 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
819 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
820 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
821 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
822
823 install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
824 install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
825 install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
826 install %{SOURCE33} $RPM_BUILD_ROOT%{_bindir}/banner.sh
827
828 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
829
830 install rpmio/ugid.h $RPM_BUILD_ROOT%{_includedir}/rpm
831
832 # obsolete but still installed
833 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpmrc
834
835 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
836 # customized rpm macros - global for host
837 #
838 #%%_install_langs pl_PL:en_US
839 %%distribution PLD
840 #
841 # remove or replace with file_contexts path if you want to use custom
842 # SELinux file contexts policy instead of one stored in packages payload
843 %%_install_file_context_path    %%{nil}
844 %%_verify_file_context_path     %%{nil}
845
846 # If non-zero, all erasures will be automagically repackaged.
847 #%%_repackage_all_erasures    1
848 EOF
849
850 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
851 # global list of files (regexps) which don't generate Provides
852 EOF
853 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
854 # global list of script capabilities (regexps) not to be used in Provides
855 EOF
856 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
857 # global list of files (regexps) which don't generate Requires
858 ^%{_examplesdir}/
859 ^%{_docdir}/
860 EOF
861 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
862 # global list of script capabilities (regexps) not to be used in Requires
863 EOF
864 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
865 # global list of capabilities (SONAME, perl(module), php(module) regexps)
866 # which don't generate dependencies on package NAMES
867 # -- OpenGL implementation
868 ^libGL.so.1
869 ^libGLU.so.1
870 ^libOSMesa.so
871 # -- Glide
872 ^libglide3.so.3
873 # -- mozilla
874 ^libgtkmozembed.so
875 ^libgtksuperwin.so
876 ^libxpcom.so
877 # -- X11 implementation
878 ^libFS.so
879 ^libI810XvMC.so
880 ^libICE.so
881 ^libSM.so
882 ^libX11.so
883 ^libXRes.so
884 ^libXTrap.so
885 ^libXaw.so
886 ^libXcomposite.so
887 ^libXcursor.so
888 ^libXdamage.so
889 ^libXdmcp.so
890 ^libXevie.so
891 ^libXext.so
892 ^libXfixes.so
893 ^libXfont.so
894 ^libXfontcache.so
895 ^libXft.so
896 ^libXi.so
897 ^libXinerama.so
898 ^libXmu.so
899 ^libXmuu.so
900 ^libXp.so
901 ^libXpm.so
902 ^libXrandr.so
903 ^libXrender.so
904 ^libXss.so
905 ^libXt.so
906 ^libXtst.so
907 ^libXv.so
908 ^libXvMC.so
909 ^libXxf86dga.so
910 ^libXxf86misc.so
911 ^libXxf86rush.so
912 ^libXxf86vm.so
913 ^libdps.so
914 ^libdpstk.so
915 ^libfontenc.so
916 ^libpsres.so
917 ^libxkbfile.so
918 ^libxkbui.so
919 # -- fam / gamin
920 ^libfam.so.0
921 EOF
922 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
923 # global list of file masks not to be compressed in DOCDIR
924 EOF
925
926 # for rpm -e|-U --repackage
927 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
928 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
929
930 # move libs to /lib
931 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
932         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
933         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
934 done
935
936 # remove arch dependant macros which have no use on noarch
937 %{__sed} -i -e '
938 /{__spec_install_post_strip}/d
939 /{__spec_install_post_chrpath}/d
940 /{__spec_install_post_compress_modules}/d
941 ' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
942
943 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
944 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
945
946 rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
947
948 # (currently) not used or supported in PLD
949 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/{Specfile.pm,cpanflute,cpanflute2,find-provides,find-requires,freshen.sh,http.req,magic.prov,magic.req,perldeps.pl,sql.prov,sql.req,tcl.req}
950 # wrong location, not used anyway
951 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
952 # manuals for utils dropped in 4.4.8 (?)
953 #rm -f $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
954
955 %find_lang %{name}
956
957 rm -rf manual
958 cp -a doc/manual manual
959 rm -f manual/Makefile*
960
961 %clean
962 rm -rf $RPM_BUILD_ROOT
963
964 %post   lib -p /sbin/ldconfig
965 %postun lib -p /sbin/ldconfig
966
967 %pre build
968 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
969
970 %files -f %{name}.lang
971 %defattr(644,root,root,755)
972 %doc CHANGES CREDITS README wdj/JBJ-GPG-KEY manual/*
973
974 %attr(755,root,root) /bin/rpm
975 #%attr(755,root,root) %{_bindir}/rpmdb
976 #%attr(755,root,root) %{_bindir}/rpmquery
977 #%attr(755,root,root) %{_bindir}/rpmsign
978 #%attr(755,root,root) %{_bindir}/rpmverify
979
980 %dir %{_sysconfdir}/rpm
981 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
982 # these are ok to be replaced
983 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
984 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
985
986
987 %{_mandir}/man8/rpm.8*
988 %lang(fr) %{_mandir}/fr/man8/rpm.8*
989 %lang(ja) %{_mandir}/ja/man8/rpm.8*
990 %lang(ko) %{_mandir}/ko/man8/rpm.8*
991 %lang(pl) %{_mandir}/pl/man8/rpm.8*
992 %lang(ru) %{_mandir}/ru/man8/rpm.8*
993 %lang(sk) %{_mandir}/sk/man8/rpm.8*
994
995 %dir /var/lib/rpm
996 %dir %attr(700,root,root) /var/spool/repackage
997 %dir /var/lock/rpm
998 /var/lock/rpm/transaction
999
1000 #%attr(755,root,root) %{_rpmlibdir}/rpmd
1001 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
1002 #%attr(755,root,root) %{_rpmlibdir}/rpmk
1003 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
1004
1005 %{_rpmlibdir}/rpmpopt*
1006 %{_rpmlibdir}/macros
1007
1008 %files base
1009 %defattr(644,root,root,755)
1010 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1011 %dir %{_rpmlibdir}
1012 %attr(755,root,root) %{_bindir}/banner.sh
1013 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1014 %dir /var/lib/banner
1015
1016 %files lib
1017 %defattr(644,root,root,755)
1018 %attr(755,root,root) /%{_lib}/librpm*-*.so
1019 %attr(755,root,root) %{_libdir}/librpm*-*.so
1020
1021 %files devel
1022 %defattr(644,root,root,755)
1023 %{_includedir}/rpm
1024 %{_libdir}/librpm*.la
1025 %attr(755,root,root) %{_libdir}/librpm.so
1026 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1027 %attr(755,root,root) %{_libdir}/librpmio.so
1028 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1029 %attr(755,root,root) %{_libdir}/librpmdb.so
1030 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1031 %attr(755,root,root) %{_libdir}/librpmbuild.so
1032
1033 %files static
1034 %defattr(644,root,root,755)
1035 %{_libdir}/librpm*.a
1036
1037 %files utils
1038 %defattr(644,root,root,755)
1039 %attr(755,root,root) %{_bindir}/debugedit
1040 %attr(755,root,root) %{_bindir}/rpm2cpio
1041 %attr(755,root,root) %{_bindir}/rpmdeps
1042 %{!?with_system_libmagic:%attr(755,root,root) %{_bindir}/rpmfile}
1043 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1044 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
1045 %attr(755,root,root) %{_rpmlibdir}/tgpg
1046 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1047 %{_mandir}/man8/rpm2cpio.8*
1048 %{_mandir}/man8/rpmdeps.8*
1049 #%{_mandir}/man8/rpmcache.8*
1050 #%{_mandir}/man8/rpmgraph.8*
1051 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1052 #%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1053 #%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1054 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1055 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1056 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1057 #%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1058 #%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1059 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1060
1061 %files utils-perl
1062 %defattr(644,root,root,755)
1063 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1064
1065 %if %{with static}
1066 %files utils-static
1067 %defattr(644,root,root,755)
1068 %attr(755,root,root) %{_bindir}/rpm[ieu]
1069 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1070 %endif
1071
1072 %files build
1073 %defattr(644,root,root,755)
1074 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1075 %attr(755,root,root) %{_rpmlibdir}/brp-*
1076 %attr(755,root,root) %{_rpmlibdir}/check-files
1077 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1078 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1079 %attr(755,root,root) %{_rpmlibdir}/config.*
1080 %attr(755,root,root) %{_rpmlibdir}/cross-build
1081 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1082 %attr(755,root,root) %{_rpmlibdir}/find-lang.sh
1083 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1084 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1085 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1086 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1087 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1088 # needs jar (any jdk), jcf-dump (gcc-java) to work
1089 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1090 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1091 # needs hacked pkg-config to return anything
1092 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1093 %attr(755,root,root) %{_rpmlibdir}/rpmb
1094 %attr(755,root,root) %{_rpmlibdir}/rpmt
1095 %{_rpmlibdir}/noarch-*
1096 %ifarch %{ix86}
1097 %{_rpmlibdir}/i?86*
1098 %{_rpmlibdir}/pentium*
1099 %{_rpmlibdir}/athlon*
1100 %endif
1101 %ifarch alpha
1102 %{_rpmlibdir}/alpha*
1103 %endif
1104 %ifarch ia64
1105 %{_rpmlibdir}/ia64*
1106 %endif
1107 %ifarch mips mipsel mips64 mips64el
1108 %{_rpmlibdir}/mips*
1109 %endif
1110 %ifarch %{ppc}
1111 %{_rpmlibdir}/ppc*
1112 %endif
1113 %ifarch sparc sparc64
1114 %{_rpmlibdir}/sparc*
1115 %endif
1116 %ifarch %{x8664}
1117 %{_rpmlibdir}/x86_64*
1118 %endif
1119 # must be here for "Requires: rpm-*prov" to work
1120 %{_rpmlibdir}/macros.mono
1121 %{_rpmlibdir}/macros.perl
1122 %{_rpmlibdir}/macros.php
1123 # not used yet ... these six depend on perl
1124 #%attr(755,root,root) %{_rpmlibdir}/http.req
1125 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1126 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1127 #%{_rpmlibdir}/sql.prov
1128 #%{_rpmlibdir}/sql.req
1129 #%{_rpmlibdir}/tcl.req
1130
1131 %attr(755,root,root) %{_bindir}/gendiff
1132 %attr(755,root,root) %{_bindir}/rpmbuild
1133
1134 %{_mandir}/man1/gendiff.1*
1135 %{_mandir}/man8/rpmbuild.8*
1136 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1137 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1138 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1139
1140 %files build-tools
1141 %defattr(644,root,root,755)
1142 %attr(755,root,root) %{_bindir}/builder
1143 %attr(755,root,root) %{_bindir}/adapter.awk
1144 %attr(755,root,root) %{_bindir}/pldnotify.awk
1145
1146 %files perlprov
1147 %defattr(644,root,root,755)
1148 %attr(755,root,root) %{_rpmlibdir}/perl.*
1149 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1150 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1151 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1152 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1153 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1154 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1155
1156 %files pythonprov
1157 %defattr(644,root,root,755)
1158 %{_rpmlibdir}/macros.python
1159 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1160
1161 %files php-pearprov
1162 %defattr(644,root,root,755)
1163 %attr(755,root,root) %{_rpmlibdir}/php*
1164 %attr(755,root,root) %{_rpmlibdir}/find-php*
1165
1166 %if %{with python}
1167 %files -n python-rpm
1168 %defattr(644,root,root,755)
1169 %dir %{py_sitedir}/rpm
1170 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1171 %{py_sitedir}/rpm/*.py[co]
1172 %endif
1173
1174 %if %{with apidocs}
1175 %files apidocs
1176 %defattr(644,root,root,755)
1177 %doc apidocs
1178 %endif
This page took 0.127821 seconds and 2 git commands to generate.