]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- fixed libtool-deps patch, release 5
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4 #   matches ELF first
5 # - repackaging when lzma is not installed (todo: fix digest signature of header)
6 #   rpmbuild computes digest when writing package to temporary file, then adds a few
7 #   tags (incl. digest) and writes whole package to destination file;
8 #   repackaging uses unchanged "immutable header" image from original rpm, also
9 #   preserving payload format and compressor from original rpm, _not_ current settings
10 #
11 # Conditional build:
12 %bcond_with     static          # build static rpm+rpmi
13 %bcond_without  apidocs         # don't generate documentation with doxygen
14 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
15 %bcond_without  python          # don't build python bindings
16 %bcond_without  selinux         # build without selinux support
17 %bcond_without  system_libmagic # don't use system libmagic
18 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
19 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
20 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
21 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
22 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
23
24 # versions of required libraries
25 %define reqdb_ver       4.6.18
26 %define reqpopt_ver     1.10.8
27 %define beecrypt_ver    2:4.1.2-4
28 %define sover   4.4
29 Summary:        RPM Package Manager
30 Summary(de.UTF-8):      RPM Packet-Manager
31 Summary(es.UTF-8):      Gestor de paquetes RPM
32 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
33 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
34 Summary(ru.UTF-8):      Менеджер пакетов от RPM
35 Summary(uk.UTF-8):      Менеджер пакетів від RPM
36 Name:           rpm
37 Version:        4.4.9
38 Release:        5
39 License:        GPL
40 Group:          Base
41 Source0:        http://rpm5.org/files/rpm/rpm-4.4/%{name}-%{version}.tar.gz
42 # Source0-md5:  210b768006e7d88dd8a3bcd498ea27f6
43 Source1:        %{name}.groups
44 Source2:        %{name}.platform
45 Source3:        %{name}-install-tree
46 Source4:        %{name}-find-spec-bcond
47 Source5:        %{name}-find-lang
48 Source6:        %{name}-groups-po.awk
49 Source7:        %{name}-compress-doc
50 Source8:        %{name}-check-files
51 Source9:        %{name}-php-provides
52 Source10:       %{name}-php-requires
53 Source11:       %{name}.sysinfo
54 Source12:       perl.prov
55 Source13:       %{name}-user_group.sh
56 Source14:       %{name}.sysconfig
57 Source15:       %{name}-macros.java
58 Source16:       %{name}-java-requires
59 Source30:       builder
60 Source31:       adapter.awk
61 Source32:       pldnotify.awk
62 # http://svn.pld-linux.org/banner.sh/
63 Source33:       banner.sh
64 Patch0:         %{name}-pl.po.patch
65 Patch1:         %{name}-rpmrc.patch
66 Patch2:         %{name}-arch.patch
67 Patch3:         %{name}-rpmpopt.patch
68 Patch4:         %{name}-perl-macros.patch
69 Patch5:         %{name}-perl-req-perlfile.patch
70 Patch6:         %{name}-noexpand.patch
71 Patch7:         %{name}-scripts-closefds.patch
72 Patch8:         %{name}-python-macros.patch
73 Patch9:         %{name}-gettext-in-header.patch
74 Patch10:        %{name}-compress-doc.patch
75 Patch11:        %{name}-Nmalloc.patch
76 Patch12:        %{name}-system_libs.patch
77 Patch13:        %{name}-bb-and-short-circuit.patch
78 Patch14:        %{name}-etc_dir.patch
79 Patch15:        %{name}-system_libs-more.patch
80 Patch16:        %{name}-php-deps.patch
81 Patch17:        %{name}-ldconfig-always.patch
82 Patch18:        %{name}-perl_req.patch
83 Patch19:        %{name}-link.patch
84 Patch20:        %{name}-magic-usesystem.patch
85 Patch21:        %{name}-dontneedutils.patch
86 Patch22:        %{name}-provides-dont-obsolete.patch
87 Patch23:        %{name}-pkgconfigdeps.patch
88 Patch24:        %{name}-po.patch
89 Patch25:        %{name}-rpm2cpio-payload.patch
90 Patch26:        %{name}-notsc.patch
91 Patch27:        %{name}-hack-norpmlibdep.patch
92 Patch28:        %{name}-makefile-no_myLDADD_deps.patch
93 Patch29:        %{name}-macros-dbhash.patch
94 Patch31:        %{name}-missing-prototypes.patch
95 Patch32:        %{name}-pld-autodep.patch
96 Patch33:        %{name}-arch-x86_64.patch
97 Patch34:        %{name}-epoch0.patch
98 Patch35:        %{name}-perl_req-INC_dirs.patch
99 Patch36:        %{name}-debuginfo.patch
100 Patch37:        %{name}-doxygen_hack.patch
101
102 Patch41:        %{name}-reduce-stack-usage.patch
103 Patch42:        %{name}-old-fileconflicts-behaviour.patch
104
105 Patch44:        %{name}-no-neon.patch
106 Patch45:        %{name}-no-sqlite.patch
107 Patch46:        %{name}-mono.patch
108 Patch47:        %{name}-javadeps.patch
109
110 Patch49:        %{name}-p4.patch
111 Patch50:        %{name}-macros.patch
112 Patch51:        %{name}-cleanlibdirs.patch
113 Patch52:        %{name}-morearchs.patch
114
115 Patch55:        %{name}-truncate-cvslog.patch
116
117 Patch57:        %{name}-as_needed-fix.patch
118 Patch58:        %{name}-repackage-wo-lzma.patch
119 Patch59:        %{name}-libtool-deps.patch
120 Patch60:        %{name}-obsolete-rpmrc.patch
121 Patch61:        %{name}-sparc64.patch
122 Patch62:        %{name}-rpmdb.patch
123 URL:            http://rpm5.org/
124 BuildRequires:  autoconf >= 2.57
125 BuildRequires:  automake >= 1.4
126 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
127 BuildRequires:  bzip2-devel >= 1.0.2-17
128 BuildRequires:  db-devel >= %{reqdb_ver}
129 BuildRequires:  elfutils-devel >= 0.108
130 %ifnarch sparc64
131 # -fPIE/-pie
132 BuildRequires:  gcc >= 5:3.4
133 %endif
134 BuildRequires:  gettext-devel >= 0.11.4-2
135 %{?with_system_libmagic:BuildRequires:  libmagic-devel}
136 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
137 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
138 BuildRequires:  libstdc++-devel
139 BuildRequires:  libtool >= 1:1.4.2-9
140 %if %{with neon}
141 BuildRequires:  libxml2-devel
142 BuildRequires:  neon-devel >= 0.25.5
143 %endif
144 BuildRequires:  patch >= 2.2
145 BuildRequires:  popt-devel >= %{reqpopt_ver}
146 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
147 BuildRequires:  python-modules >= 1:2.5
148 BuildRequires:  rpm-perlprov
149 %{?with_python:BuildRequires:   rpm-pythonprov}
150 BuildRequires:  zlib-devel
151 %if %{with apidocs}
152 BuildRequires:  doxygen
153 BuildRequires:  ghostscript
154 BuildRequires:  graphviz
155 BuildRequires:  tetex-pdftex
156 %endif
157 %if %{with static}
158 # Require static library only for static build
159 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
160 BuildRequires:  bzip2-static >= 1.0.2-17
161 BuildRequires:  db-static >= %{reqdb_ver}
162 BuildRequires:  elfutils-static
163 BuildRequires:  glibc-static >= 2.2.94
164 %{?with_system_libmagic:BuildRequires:  libmagic-static}
165 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
166 BuildRequires:  popt-static >= %{reqpopt_ver}
167 BuildRequires:  zlib-static
168 %endif
169 Requires:       %{name}-base = %{version}-%{release}
170 Requires:       %{name}-lib = %{version}-%{release}
171 Requires:       beecrypt >= %{beecrypt_ver}
172 Requires:       popt >= %{reqpopt_ver}
173 %{!?with_static:Obsoletes:      rpm-utils-static}
174 Conflicts:      glibc < 2.2.92
175 # ABI changes in rpm, new poldek needed
176 Conflicts:      poldek < 0.20.1-0.20070108.1.4
177 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
178
179 %define         _binary_payload         w9.gzdio
180 %define         _noPayloadPrefix        1
181
182 # don't require very fresh rpm.macros to build
183 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
184 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
185 %define         ppc     ppc ppc7400 ppc7450
186 %define         x8664   amd64 ia32e x86_64
187
188 # stabilize new build environment
189 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
190 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
191 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
192
193 %define         _rpmlibdir /usr/lib/rpm
194
195 %define         specflags       -fno-strict-aliasing
196
197 %description
198 RPM is a powerful package manager, which can be used to build,
199 install, query, verify, update, and uninstall individual software
200 packages. A package consists of an archive of files, and package
201 information, including name, version, and description.
202
203 %description -l de.UTF-8
204 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
205 Installation, Anfrage, Verifizierung, Aktualisierung und
206 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
207 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
208 Beschreibung.
209
210 %description -l es.UTF-8
211 RPM es un poderoso administrador de paquetes, que puede ser usado para
212 construir, instalar, pesquisar, verificar, actualizar y desinstalar
213 paquetes individuales de software. Un paquete consiste en un
214 almacenaje de archivos, y información sobre el paquete, incluyendo
215 nombre, versión y descripción.
216
217 %description -l pl.UTF-8
218 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
219 przebudowanie, instalację czy weryfikację dowolnego pakietu.
220 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
221 plików wchodzących w skład pakietu, zależności od innych pakietów, są
222 przechowywane w bazie danych i można je uzyskać za pomocą opcji
223 odpytywania programu rpm.
224
225 %description -l pt_BR.UTF-8
226 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
227 construir, instalar, pesquisar, verificar, atualizar e desinstalar
228 pacotes individuais de software. Um pacote consiste de um conjunto de
229 arquivos e informações adicionais, incluindo nome, versão e descrição
230 do pacote, permissões dos arquivos, etc.
231
232 %description -l ru.UTF-8
233 RPM - это мощный менеджер пакетов, который может быть использован для
234 создания, инсталляции, запросов (query), проверки, обновления и
235 удаления программных пакетов. Пакет состоит из файлового архива и
236 служебной информации, включающей название, версию, описание и другие
237 данные о пакете.
238
239 %description -l uk.UTF-8
240 RPM - це потужний менеджер пакетів, що може бути використаний для
241 створення, інсталяції, запитів (query), перевірки, поновлення та
242 видалення програмних пакетів. Пакет складається з файлового архіву та
243 службової інформації, що містить назву, версію, опис та іншу
244 інформацію про пакет.
245
246 %package base
247 Summary:        RPM base package - scripts used by rpm packages themselves
248 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
249 Group:          Base
250 Requires:       filesystem
251 Obsoletes:      vserver-rpm
252
253 %description base
254 The RPM base package contains scripts used by rpm packages themselves.
255 These include:
256 - scripts for adding/removing groups and users needed for rpm
257   packages,
258 - banner.sh to display %%banner messages from rpm scriptlets.
259
260 %description base -l pl.UTF-8
261 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
262 Zawiera on:
263 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
264 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
265
266 %package lib
267 Summary:        RPMs library
268 Summary(pl.UTF-8):      Biblioteki RPM-a
269 Group:          Libraries
270 Requires:       beecrypt >= %{beecrypt_ver}
271 Requires:       db >= %{reqdb_ver}
272 %{?with_selinux:Requires:       libselinux >= 1.18}
273 %{?with_system_libmagic:Requires:       libmagic >= 1.15-2}
274 Requires:       popt >= %{reqpopt_ver}
275 Obsoletes:      rpm-libs
276 # avoid SEGV caused by mixed db versions
277 Conflicts:      poldek < 0.18.1-16
278 %{?with_suggest_tags:Suggests:  lzma}
279
280 %description lib
281 RPMs library.
282
283 %description lib -l pl.UTF-8
284 Biblioteki RPM-a.
285
286 %package devel
287 Summary:        Header files for rpm libraries
288 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
289 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
290 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
291 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
292 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
293 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
294 Group:          Development/Libraries
295 Requires:       %{name}-lib = %{version}-%{release}
296 Requires:       beecrypt-devel >= %{beecrypt_ver}
297 Requires:       bzip2-devel
298 Requires:       db-devel >= %{reqdb_ver}
299 Requires:       elfutils-devel
300 %{?with_system_libmagic:Requires:       libmagic-devel}
301 %{?with_selinux:Requires:       libselinux-devel}
302 Requires:       popt-devel >= %{reqpopt_ver}
303 Requires:       zlib-devel
304
305 %description devel
306 The RPM packaging system includes C libraries that make it easy to
307 manipulate RPM packages and databases. They are intended to ease the
308 creation of graphical package managers and other tools that need
309 intimate knowledge of RPM packages. This package contains header files
310 for these libraries.
311
312 %description devel -l de.UTF-8
313 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
314 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
315 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
316 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
317
318 %description devel -l es.UTF-8
319 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
320 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
321 facilitar la creación de administradores gráficos de paquetes y otras
322 herramientas que necesiten un conocimiento profundo de paquetes RPM.
323
324 %description devel -l pl.UTF-8
325 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
326 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
327 graficznych programów zarządzających pakietami oraz innych narzędzi,
328 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
329 zawiera pliki nagłówkowe wspomnianych bibliotek.
330
331 %description devel -l pt_BR.UTF-8
332 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
333 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
334 facilitar a criação de gerenciadores gráficos de pacotes e outras
335 ferramentas que precisem de conhecimento profundo de pacotes RPM.
336
337 %description devel -l ru.UTF-8
338 Система управления пакетами RPM содержит библиотеку C, которая
339 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
340 Эта библиотека предназначена для облегчения создания графических
341 пакетных менеджеров и других утилит, которым необходимо работать с
342 пакетами RPM.
343
344 %description devel -l uk.UTF-8
345 Система керування пакетами RPM містить бібліотеку C, котра спрощує
346 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
347 призначена для полегшення створення графічних пакетних менеджерів та
348 інших утиліт, що працюють з пакетами RPM.
349
350 %package static
351 Summary:        RPM static libraries
352 Summary(de.UTF-8):      RPMs statische Libraries
353 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
354 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
355 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
356 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
357 Group:          Development/Libraries
358 Requires:       %{name}-devel = %{version}-%{release}
359 Requires:       beecrypt-static >= %{beecrypt_ver}
360 Requires:       bzip2-static
361 Requires:       db-static >= %{reqdb_ver}
362 Requires:       elfutils-static
363 %{?with_system_libmagic:Requires:       libmagic-static}
364 Requires:       popt-static >= %{reqpopt_ver}
365 Requires:       zlib-static
366
367 %description static
368 RPM static libraries.
369
370 %description static -l de.UTF-8
371 RPMs statische Libraries.
372
373 %description static -l pl.UTF-8
374 Biblioteki statyczne RPM-a.
375
376 %description static -l pt_BR.UTF-8
377 Bibliotecas estáticas para desenvolvimento.
378
379 %description static -l ru.UTF-8
380 Система управления пакетами RPM содержит библиотеку C, которая
381 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
382 Это статическая библиотека RPM.
383
384 %description static -l uk.UTF-8
385 Система керування пакетами RPM містить бібліотеку C, котра спрощує
386 роботу з пакетами RPM та відповідними базами даних. Це статична
387 бібліотека RPM.
388
389 %package utils
390 Summary:        Additional utilities for managing RPM packages and database
391 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
392 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
393 Group:          Applications/File
394 Requires:       %{name} = %{version}-%{release}
395 Requires:       popt >= %{reqpopt_ver}
396
397 %description utils
398 Additional utilities for managing RPM packages and database.
399
400 %description utils -l de.UTF-8
401 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
402
403 %description utils -l pl.UTF-8
404 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
405
406 %package utils-perl
407 Summary:        Additional utilities for managing RPM packages and database
408 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
409 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
410 Group:          Applications/File
411 Requires:       %{name}-utils = %{version}-%{release}
412 Requires:       popt >= %{reqpopt_ver}
413
414 %description utils-perl
415 Additional utilities for managing RPM packages and database.
416
417 %description utils-perl -l de.UTF-8
418 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
419
420 %description utils-perl -l pl.UTF-8
421 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
422
423 %package utils-static
424 Summary:        Static rpm utilities
425 Summary(pl.UTF-8):      Statyczne narzędzia rpm
426 Group:          Applications/System
427 Requires:       %{name} = %{version}-%{release}
428
429 %description utils-static
430 Static rpm utilities for repairing system in case something with
431 shared libraries used by rpm become broken. Currently it contains rpmi
432 binary, which can be used to install/upgrade/remove packages without
433 using shared libraries (well, in fact with exception of NSS modules).
434
435 %description utils-static -l pl.UTF-8
436 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
437 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
438 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
439 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
440 (z wyjątkiem modułów NSS).
441
442 %package build
443 Summary:        Scripts for building binary RPM packages
444 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
445 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
446 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
447 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
448 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
449 Group:          Applications/File
450 Requires(pre):  findutils
451 Requires:       %{name}-build-macros >= 1.314
452 Requires:       %{name}-utils = %{version}-%{release}
453 Requires:       /bin/id
454 Requires:       awk
455 # we need fixed binutils for -feliminate-dwarf2-dups
456 Requires:       binutils >= 3:2.17.50.0.3-2
457 Requires:       bzip2
458 Requires:       chrpath >= 0.10-4
459 Requires:       cpio
460 Requires:       diffutils
461 Requires:       elfutils
462 Requires:       file >= 4.17
463 Requires:       fileutils
464 Requires:       findutils
465 Requires:       gcc >= 5:3.4
466 Requires:       glibc-devel
467 Requires:       grep
468 Requires:       gzip
469 Requires:       lzma
470 Requires:       make
471 Requires:       patch
472 Requires:       sed
473 Requires:       sh-utils
474 Requires:       tar
475 Requires:       textutils
476 Provides:       rpmbuild(monoautodeps)
477 Provides:       rpmbuild(noauto) = 3
478 %ifarch %{x8664}
479 Conflicts:      automake < 1:1.7.9-2
480 Conflicts:      libtool < 2:1.5-13
481 %endif
482
483 %description build
484 Scripts for building binary RPM packages.
485
486 %description build -l de.UTF-8
487 Scripts fürs Bauen binärer RPM-Pakete.
488
489 %description build -l pl.UTF-8
490 Skrypty pomocnicze do budowania binarnych RPM-ów.
491
492 %description build -l pt_BR.UTF-8
493 Este pacote contém scripts e programas executáveis que são usados para
494 construir pacotes usando o RPM.
495
496 %description build -l ru.UTF-8
497 Различные вспомогательные скрипты и исполняемые программы, которые
498 используются для сборки RPM'ов.
499
500 %description build -l uk.UTF-8
501 Різноманітні допоміжні скрипти та утиліти, які використовуються для
502 побудови RPM'ів.
503
504 %package build-tools
505 Summary:        Scripts for managing .spec files and building RPM packages
506 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
507 Summary(pl.UTF-8):      Skrypty pomocnicze do zarządznia plikami .spec i budowania RPM-ów
508 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
509 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
510 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
511 Group:          Applications/File
512 Requires:       %{name}-build = %{version}-%{release}
513 # these are optional
514 #Requires:      cvs
515 Requires:       wget
516
517 %description build-tools
518 Scripts for managing .spec files and building RPM packages.
519
520 %description build-tools -l de.UTF-8
521 Scripts fürs Bauen RPM-Pakete.
522
523 %description build-tools -l pl.UTF-8
524 Skrypty pomocnicze do zarządzania plikami .spec i do budowania RPM-ów.
525
526 %description build-tools -l pt_BR.UTF-8
527 Este pacote contém scripts e programas executáveis que são usados para
528 construir pacotes usando o RPM.
529
530 %description build-tools -l ru.UTF-8
531 Различные вспомогательные скрипты и исполняемые программы, которые
532 используются для сборки RPM'ов.
533
534 %description build-tools -l uk.UTF-8
535 Різноманітні допоміжні скрипти та утиліти, які використовуються для
536 побудови RPM'ів.
537
538 %package javaprov
539 Summary:        Additional utilities for checking Java provides/requires in RPM packages
540 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
541 Group:          Applications/File
542 Requires:       %{name} = %{version}-%{release}
543 Requires:       file
544 Requires:       findutils >= 1:4.2.26
545 Requires:       mktemp
546 Requires:       unzip
547
548 %description javaprov
549 Additional utilities for checking Java provides/requires in RPM
550 packages.
551
552 %description javaprov -l pl.UTF-8
553 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
554 RPM.
555
556 %package perlprov
557 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
558 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
559 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
560 Group:          Applications/File
561 Requires:       %{name} = %{version}-%{release}
562 Requires:       perl-devel
563 Requires:       perl-modules
564
565 %description perlprov
566 Additional utilities for checking Perl provides/requires in RPM
567 packages.
568
569 %description perlprov -l de.UTF-8
570 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
571
572 %description perlprov -l pl.UTF-8
573 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
574 pakietach RPM.
575
576 %package pythonprov
577 Summary:        Python macros, which simplifies creation of RPM packages with Python software
578 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
579 Group:          Applications/File
580 Requires:       %{name} = %{version}-%{release}
581 Requires:       python
582 Requires:       python-modules
583
584 %description pythonprov
585 Python macros, which simplifies creation of RPM packages with Python
586 software.
587
588 %description pythonprov -l pl.UTF-8
589 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
590 Pythonie.
591
592 %package php-pearprov
593 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
594 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
595 Group:          Applications/File
596 Requires:       %{name} = %{version}-%{release}
597 Requires:       sed >= 4.0
598
599 %description php-pearprov
600 Additional utilities for checking PHP PEAR provides/requires in RPM
601 packages.
602
603 %description php-pearprov -l pl.UTF-8
604 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
605 pakietach RPM.
606
607 %package -n python-rpm
608 Summary:        Python interface to RPM library
609 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
610 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
611 Group:          Development/Languages/Python
612 Requires:       %{name} = %{version}-%{release}
613 %pyrequires_eq  python
614 Obsoletes:      rpm-python
615
616 %description -n python-rpm
617 The rpm-python package contains a module which permits applications
618 written in the Python programming language to use the interface
619 supplied by RPM (RPM Package Manager) libraries.
620
621 This package should be installed if you want to develop Python
622 programs that will manipulate RPM packages and databases.
623
624 %description -n python-rpm -l pl.UTF-8
625 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
626 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
627
628 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
629 Pythonie programy manipulujące pakietami i bazami danych rpm.
630
631 %description -n python-rpm -l pt_BR.UTF-8
632 O pacote rpm-python contém um módulo que permite que aplicações
633 escritas em Python utilizem a interface fornecida pelas bibliotecas
634 RPM (RPM Package Manager).
635
636 Esse pacote deve ser instalado se você quiser desenvolver programas em
637 Python para manipular pacotes e bancos de dados RPM.
638
639 %package apidocs
640 Summary:        RPM API documentation and guides
641 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
642 Group:          Documentation
643
644 %description apidocs
645 Documentation for RPM API and guides in HTML format generated from rpm
646 sources by doxygen.
647
648 %description apidocs -l pl.UTF-8
649 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
650 źrodeł RPM-a przez doxygen.
651
652 %prep
653 %setup -q
654 %patch0 -p1
655 %patch1 -p1
656 %patch2 -p1
657 %patch3 -p1
658 %patch4 -p1
659 %patch5 -p1
660 %patch6 -p1
661 %patch7 -p1
662 %patch8 -p1
663 %patch9 -p1
664 %patch10 -p1
665 %patch11 -p1
666 %patch12 -p1
667 %patch13 -p1
668 %patch14 -p1
669 %patch15 -p1
670 %patch16 -p1
671 %patch17 -p1
672 %patch18 -p1
673 sed -e 's/^/@pld@/' %{SOURCE2} >>platform.in
674 #cp -f platform.in macros.pld.in # what for?
675 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
676 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
677 echo '# obsoleted file' > macros.python
678 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
679 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
680 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
681 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
682 install %{SOURCE5} scripts/find-lang.sh
683 install %{SOURCE9} scripts/php.prov.in
684 install %{SOURCE10} scripts/php.req.in
685 install %{SOURCE12} scripts/perl.prov
686 %patch19 -p1
687 %patch20 -p1
688 %patch21 -p1
689 %patch22 -p1
690 %patch23 -p1
691 %patch24 -p1
692 %patch25 -p1
693 %patch26 -p1
694 %patch27 -p1
695 %patch28 -p1
696 %patch29 -p1
697 %patch31 -p1
698 %patch32 -p1
699 %patch33 -p1
700 %patch34 -p1
701 %patch35 -p0
702 %patch36 -p1
703 %patch37 -p1
704 %patch41 -p1
705 %patch42 -p1
706 %{!?with_neon:%patch44 -p1}
707 %patch45 -p1
708 %patch46 -p1
709 %patch47 -p1
710 %patch49 -p1
711 %patch50 -p1
712 %patch51 -p1
713 #%patch52 -p1
714 %patch55 -p1
715 %patch57 -p1
716 %patch58 -p1
717 %patch59 -p1
718 %patch60 -p1
719 %ifarch sparc64
720 %patch61 -p1
721 %endif
722 %patch62 -p1
723
724 cd scripts
725 mv -f perl.req perl.req.in
726 mv -f perl.prov perl.prov.in
727 cd ..
728
729 mv -f po/{no,nb}.po
730 mv -f po/{sr,sr@Latn}.po
731
732 rm -rf sqlite zlib db db3 popt rpmdb/db.h
733
734 # generate Group translations to *.po
735 awk -f %{SOURCE6} %{SOURCE1}
736
737 # update macros paths
738 for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
739         sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
740         mv -f ${f}.tmp $f
741 done
742
743 %build
744 %if %{with system_libmagic}
745 rm -rf file
746 %else
747 cd file
748 %{__libtoolize}
749 %{__aclocal}
750 %{__autoheader}
751 %{__autoconf}
752 %{__automake}
753 cd ..
754 %endif
755
756 %{__libtoolize}
757 %{__gettextize}
758 %{__aclocal}
759 %{__autoheader}
760 %{__autoconf}
761 %{__automake}
762
763 # config.guess doesn't handle athlon, so we have to change it by hand.
764 # rpm checks for CPU type at runtime, but it looks better
765 sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
766
767 # pass CC and CXX too in case of building with some older configure macro
768 # disable perl-RPM2 build, we have it in separate spec
769 %configure \
770         CC="%{__newcc}" \
771         CXX="%{__newcxx}" \
772         CPP="%{__newcpp}" \
773         WITH_PERL_VERSION=no \
774         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
775         --enable-shared \
776         --enable-static \
777         %{!?with_apidocs:--without-apidocs} \
778         %{?with_python:--with-python=2.5} \
779         %{!?with_python:--without-python} \
780         %{!?with_selinux:--without-selinux} \
781         --without-db
782
783 # file_LDFLAGS, debugedit_LDADD - no need to link "file" and "debugedit" statically
784 %{__make} \
785         CC="%{__cc}" \
786         CXX="%{__cxx}" \
787         CPP="%{__cpp}" \
788         pylibdir=%{py_libdir} \
789         myLDFLAGS="%{rpmldflags}" \
790         file_LDFLAGS= \
791         debugedit_LDADD="\$(WITH_LIBELF_LIB) -lpopt" \
792         staticLDFLAGS=%{?with_static:-all-static}
793
794 %install
795 rm -rf $RPM_BUILD_ROOT
796 install -d $RPM_BUILD_ROOT{/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
797
798 %{__make} install \
799         DESTDIR=$RPM_BUILD_ROOT \
800         staticLDFLAGS=%{?with_static:-all-static} \
801         pylibdir=%{py_libdir} \
802         pkgbindir="%{_bindir}"
803
804 # first platform file entry can't contain regexps
805 echo "%{_target_cpu}-%{_target_vendor}-linux" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
806
807 # x86_64 things
808 %ifarch x86_64
809 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
810 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
811 %endif
812
813 %ifarch amd64
814 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
815 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
816 %endif
817
818 %ifarch ia32e
819 echo "ia32e-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
820 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
821 %endif
822
823 # x86 things
824 %ifarch athlon %{x8664}
825 echo "athlon-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
826 %endif
827 %ifarch pentium4 athlon %{x8664}
828 echo "pentium4-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
829 %endif
830 %ifarch pentium3 pentium4 athlon %{x8664}
831 echo "pentium3-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
832 %endif
833 %ifarch i686 pentium3 pentium4 athlon %{x8664}
834 echo "i686-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
835 %endif
836 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
837 echo "i586-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
838 %endif
839 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
840 echo "i486-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
841 %endif
842 %ifarch %{ix86} %{x8664}
843 echo "i386-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
844 %endif
845
846 # ppc
847 %ifarch ppc
848 echo "ppc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
849 echo "powerpc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
850 %endif
851
852 # noarch
853 echo "noarch-[^-]*-.*" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
854
855 %ifarch %{ppc}
856 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
857 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
858 %endif
859
860 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
861 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
862 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
863
864 # not installed since 4.4.8 (-tools-perl subpackage)
865 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
866
867 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
868 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
869 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
870 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
871 install %{SOURCE15}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
872
873 install %{SOURCE1} doc/manual/groups
874 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
875 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
876 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
877 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
878 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
879 install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
880 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
881 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
882 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
883
884 install %{SOURCE30} $RPM_BUILD_ROOT%{_bindir}/builder
885 install %{SOURCE31} $RPM_BUILD_ROOT%{_bindir}/adapter.awk
886 install %{SOURCE32} $RPM_BUILD_ROOT%{_bindir}/pldnotify.awk
887 install %{SOURCE33} $RPM_BUILD_ROOT%{_bindir}/banner.sh
888
889 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
890
891 # obsolete but still installed
892 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpmrc
893
894 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
895 # customized rpm macros - global for host
896 #
897 #%%_install_langs pl_PL:en_US
898 %%distribution PLD
899 #
900 # remove or replace with file_contexts path if you want to use custom
901 # SELinux file contexts policy instead of one stored in packages payload
902 %%_install_file_context_path    %%{nil}
903 %%_verify_file_context_path     %%{nil}
904
905 # If non-zero, all erasures will be automagically repackaged.
906 #%%_repackage_all_erasures    1
907 EOF
908
909 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
910 # global list of files (regexps) which don't generate Provides
911 EOF
912 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
913 # global list of script capabilities (regexps) not to be used in Provides
914 EOF
915 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
916 # global list of files (regexps) which don't generate Requires
917 ^%{_examplesdir}/
918 ^%{_docdir}/
919 EOF
920 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
921 # global list of script capabilities (regexps) not to be used in Requires
922 EOF
923 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
924 # global list of capabilities (SONAME, perl(module), php(module) regexps)
925 # which don't generate dependencies on package NAMES
926 # -- OpenGL implementation
927 ^libGL.so.1
928 ^libGLU.so.1
929 ^libOSMesa.so
930 # -- Glide
931 ^libglide3.so.3
932 # -- mozilla
933 ^libgtkmozembed.so
934 ^libgtksuperwin.so
935 ^libxpcom.so
936 # -- X11 implementation
937 ^libFS.so
938 ^libI810XvMC.so
939 ^libICE.so
940 ^libSM.so
941 ^libX11.so
942 ^libXRes.so
943 ^libXTrap.so
944 ^libXaw.so
945 ^libXcomposite.so
946 ^libXcursor.so
947 ^libXdamage.so
948 ^libXdmcp.so
949 ^libXevie.so
950 ^libXext.so
951 ^libXfixes.so
952 ^libXfont.so
953 ^libXfontcache.so
954 ^libXft.so
955 ^libXi.so
956 ^libXinerama.so
957 ^libXmu.so
958 ^libXmuu.so
959 ^libXp.so
960 ^libXpm.so
961 ^libXrandr.so
962 ^libXrender.so
963 ^libXss.so
964 ^libXt.so
965 ^libXtst.so
966 ^libXv.so
967 ^libXvMC.so
968 ^libXxf86dga.so
969 ^libXxf86misc.so
970 ^libXxf86rush.so
971 ^libXxf86vm.so
972 ^libdps.so
973 ^libdpstk.so
974 ^libfontenc.so
975 ^libpsres.so
976 ^libxkbfile.so
977 ^libxkbui.so
978 # -- fam / gamin
979 ^libfam.so.0
980 EOF
981 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
982 # global list of file masks not to be compressed in DOCDIR
983 EOF
984
985 # for rpm -e|-U --repackage
986 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
987 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
988
989 # move libs to /lib
990 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so ; do
991         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
992         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
993 done
994
995 # remove arch dependant macros which have no use on noarch
996 %{__sed} -i -e '
997 /{__spec_install_post_strip}/d
998 /{__spec_install_post_chrpath}/d
999 /{__spec_install_post_compress_modules}/d
1000 ' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
1001
1002 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1003 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
1004
1005 rm -f $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
1006
1007 # (currently) not used or supported in PLD
1008 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/{Specfile.pm,cpanflute,cpanflute2,find-provides,find-requires,freshen.sh,http.req,magic.prov,magic.req,perldeps.pl,sql.prov,sql.req,tcl.req}
1009 # wrong location, not used anyway
1010 rm -f $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
1011 # manuals for utils dropped in 4.4.8 (?)
1012 #rm -f $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
1013
1014 %find_lang %{name}
1015
1016 rm -rf manual
1017 cp -a doc/manual manual
1018 rm -f manual/Makefile*
1019
1020 %clean
1021 rm -rf $RPM_BUILD_ROOT
1022
1023 %post   lib -p /sbin/ldconfig
1024 %postun lib -p /sbin/ldconfig
1025
1026 %pre build
1027 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
1028
1029 %files -f %{name}.lang
1030 %defattr(644,root,root,755)
1031 %doc CHANGES CREDITS README wdj/JBJ-GPG-KEY manual/*
1032
1033 %attr(755,root,root) /bin/rpm
1034 #%attr(755,root,root) %{_bindir}/rpmdb
1035 #%attr(755,root,root) %{_bindir}/rpmquery
1036 #%attr(755,root,root) %{_bindir}/rpmsign
1037 #%attr(755,root,root) %{_bindir}/rpmverify
1038
1039 %dir %{_sysconfdir}/rpm
1040 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1041 # these are ok to be replaced
1042 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
1043 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1044
1045
1046 %{_mandir}/man8/rpm.8*
1047 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1048 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1049 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1050 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1051 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1052 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1053
1054 %dir /var/lib/rpm
1055 %dir %attr(700,root,root) /var/spool/repackage
1056 %dir /var/lock/rpm
1057 /var/lock/rpm/transaction
1058
1059 #%attr(755,root,root) %{_rpmlibdir}/rpmd
1060 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
1061 #%attr(755,root,root) %{_rpmlibdir}/rpmk
1062 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
1063
1064 %{_rpmlibdir}/rpmpopt*
1065 %{_rpmlibdir}/macros
1066
1067 %files base
1068 %defattr(644,root,root,755)
1069 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1070 %dir %{_rpmlibdir}
1071 %attr(755,root,root) %{_bindir}/banner.sh
1072 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1073 %dir /var/lib/banner
1074
1075 %files lib
1076 %defattr(644,root,root,755)
1077 %attr(755,root,root) /%{_lib}/librpm*-*.so
1078 %attr(755,root,root) %{_libdir}/librpm*-*.so
1079
1080 %files devel
1081 %defattr(644,root,root,755)
1082 %{_includedir}/rpm
1083 %{_libdir}/librpm*.la
1084 %attr(755,root,root) %{_libdir}/librpm.so
1085 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1086 %attr(755,root,root) %{_libdir}/librpmio.so
1087 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1088 %attr(755,root,root) %{_libdir}/librpmdb.so
1089 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1090 %attr(755,root,root) %{_libdir}/librpmbuild.so
1091
1092 %files static
1093 %defattr(644,root,root,755)
1094 %{_libdir}/librpm*.a
1095
1096 %files utils
1097 %defattr(644,root,root,755)
1098 %attr(755,root,root) %{_bindir}/debugedit
1099 %attr(755,root,root) %{_bindir}/rpm2cpio
1100 %attr(755,root,root) %{_bindir}/rpmdeps
1101 %{!?with_system_libmagic:%attr(755,root,root) %{_bindir}/rpmfile}
1102 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1103 %attr(755,root,root) %{_rpmlibdir}/tgpg
1104 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1105 %{_mandir}/man8/rpm2cpio.8*
1106 %{_mandir}/man8/rpmdeps.8*
1107 #%{_mandir}/man8/rpmcache.8*
1108 #%{_mandir}/man8/rpmgraph.8*
1109 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1110 #%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1111 #%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1112 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1113 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1114 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1115 #%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1116 #%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1117 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1118
1119 %files utils-perl
1120 %defattr(644,root,root,755)
1121 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1122
1123 %if %{with static}
1124 %files utils-static
1125 %defattr(644,root,root,755)
1126 %attr(755,root,root) %{_bindir}/rpm[ieu]
1127 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1128 %endif
1129
1130 %files build
1131 %defattr(644,root,root,755)
1132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1133 %attr(755,root,root) %{_rpmlibdir}/brp-*
1134 %attr(755,root,root) %{_rpmlibdir}/check-files
1135 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1136 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1137 %attr(755,root,root) %{_rpmlibdir}/config.*
1138 %attr(755,root,root) %{_rpmlibdir}/cross-build
1139 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1140 %attr(755,root,root) %{_rpmlibdir}/find-lang.sh
1141 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1142 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1143 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1144 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1145 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1146 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1147 # needs hacked pkg-config to return anything
1148 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1149 %attr(755,root,root) %{_rpmlibdir}/rpmb
1150 %attr(755,root,root) %{_rpmlibdir}/rpmt
1151 %{_rpmlibdir}/noarch-*
1152 %ifarch %{ix86}
1153 %{_rpmlibdir}/i?86*
1154 %{_rpmlibdir}/pentium*
1155 %{_rpmlibdir}/athlon*
1156 %endif
1157 %ifarch alpha
1158 %{_rpmlibdir}/alpha*
1159 %endif
1160 %ifarch ia64
1161 %{_rpmlibdir}/ia64*
1162 %endif
1163 %ifarch mips mipsel mips64 mips64el
1164 %{_rpmlibdir}/mips*
1165 %endif
1166 %ifarch %{ppc}
1167 %{_rpmlibdir}/ppc*
1168 %endif
1169 %ifarch sparc sparc64
1170 %{_rpmlibdir}/sparc*
1171 %endif
1172 %ifarch %{x8664}
1173 %{_rpmlibdir}/amd64*
1174 %{_rpmlibdir}/ia32e*
1175 %{_rpmlibdir}/x86_64*
1176 %endif
1177 # must be here for "Requires: rpm-*prov" to work
1178 %{_rpmlibdir}/macros.java
1179 %{_rpmlibdir}/macros.mono
1180 %{_rpmlibdir}/macros.perl
1181 %{_rpmlibdir}/macros.php
1182 # not used yet ... these six depend on perl
1183 #%attr(755,root,root) %{_rpmlibdir}/http.req
1184 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1185 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1186 #%{_rpmlibdir}/sql.prov
1187 #%{_rpmlibdir}/sql.req
1188 #%{_rpmlibdir}/tcl.req
1189
1190 %attr(755,root,root) %{_bindir}/gendiff
1191 %attr(755,root,root) %{_bindir}/rpmbuild
1192
1193 %{_mandir}/man1/gendiff.1*
1194 %{_mandir}/man8/rpmbuild.8*
1195 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1196 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1197 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1198
1199 %files build-tools
1200 %defattr(644,root,root,755)
1201 %attr(755,root,root) %{_bindir}/builder
1202 %attr(755,root,root) %{_bindir}/adapter.awk
1203 %attr(755,root,root) %{_bindir}/pldnotify.awk
1204
1205 %files javaprov
1206 %defattr(644,root,root,755)
1207 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1208 # needs jar (any jdk), jcf-dump (gcc-java) to work
1209 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1210
1211 %files perlprov
1212 %defattr(644,root,root,755)
1213 %attr(755,root,root) %{_rpmlibdir}/perl.*
1214 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1215 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1216 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1217 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1218 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1219 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1220
1221 %files pythonprov
1222 %defattr(644,root,root,755)
1223 %{_rpmlibdir}/macros.python
1224 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1225
1226 %files php-pearprov
1227 %defattr(644,root,root,755)
1228 %attr(755,root,root) %{_rpmlibdir}/php*
1229 %attr(755,root,root) %{_rpmlibdir}/find-php*
1230
1231 %if %{with python}
1232 %files -n python-rpm
1233 %defattr(644,root,root,755)
1234 %dir %{py_sitedir}/rpm
1235 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1236 %{py_sitedir}/rpm/*.py[co]
1237 %endif
1238
1239 %if %{with apidocs}
1240 %files apidocs
1241 %defattr(644,root,root,755)
1242 %doc apidocs
1243 %endif
This page took 0.274755 seconds and 3 git commands to generate.