]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
6d5c49445c88efa136ac2a3b66813dad1fe38914
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
4 #   matches ELF first
5 # - repackaging when lzma is not installed (todo: fix digest signature of header)
6 #   rpmbuild computes digest when writing package to temporary file, then adds a few
7 #   tags (incl. digest) and writes whole package to destination file;
8 #   repackaging uses unchanged "immutable header" image from original rpm, also
9 #   preserving payload format and compressor from original rpm, _not_ current settings
10 # - TODO: add macros for some ppc, mipsel, alpha and sparc
11 #
12 # Conditional build:
13 %bcond_with     static          # build static rpm+rpmi
14 %bcond_with     autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
15 %bcond_without  python          # don't build python bindings
16 %bcond_without  selinux         # build without selinux support
17 %bcond_without  suggest_tags    # build without Suggest tag (bootstrapping)
18 %bcond_with     neon            # build with HTTP/WebDAV support (neon library)
19 %bcond_without  db              # BerkeleyDB
20 %bcond_with     sqlite          # build with SQLite support
21 %bcond_with     sqlite_dbapi    # default database backend is sqlite
22 # force_cc              - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
23 # force_cxx             - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
24 # force_cpp             - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
25 #
26 %if %{with sqlite_dbapi}
27 %define with_sqlite     1
28 %endif
29
30 %if %{without db} && %{without sqlite}
31 %{error:Need db or sqlite}
32 ERROR
33 %endif
34
35 #
36 # versions of required libraries
37 %define reqdb_ver       4.6.18
38 %define reqpopt_ver     1.10.8
39 %define beecrypt_ver    2:4.1.2-4
40 %define sover   5.0
41 Summary:        RPM Package Manager
42 Summary(de.UTF-8):      RPM Packet-Manager
43 Summary(es.UTF-8):      Gestor de paquetes RPM
44 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
45 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
46 Summary(ru.UTF-8):      Менеджер пакетов от RPM
47 Summary(uk.UTF-8):      Менеджер пакетів від RPM
48 Name:           rpm
49 Version:        5.0
50 Release:        0.1
51 License:        GPL
52 Group:          Base
53 Source0:        %{name}-20070927.tar.gz
54 # Source0-md5:  cf0bda3a41b74d68b36ef078edfafc6d
55 Source1:        %{name}.groups
56 Source2:        %{name}.platform
57 Source3:        %{name}-install-tree
58 Source4:        %{name}-find-spec-bcond
59 Source5:        %{name}-find-lang
60 Source6:        %{name}-groups-po.awk
61 Source7:        %{name}-compress-doc
62 Source8:        %{name}-check-files
63 Source9:        %{name}-php-provides
64 Source10:       %{name}-php-requires
65 Source11:       %{name}.sysinfo
66 Source12:       perl.prov
67 Source13:       %{name}-user_group.sh
68 Source14:       %{name}.sysconfig
69 Source15:       %{name}-macros.java
70 Source16:       %{name}-java-requires
71 # http://svn.pld-linux.org/banner.sh/
72 Source17:       banner.sh
73 Source18:       %{name}-pld.macros
74
75 Source100:      %{name}-macros-athlon
76 Source101:      %{name}-macros-i386
77 Source102:      %{name}-macros-i486
78 Source103:      %{name}-macros-i586
79 Source104:      %{name}-macros-i686
80 Source105:      %{name}-macros-noarch
81 Source106:      %{name}-macros-pentium3
82 Source107:      %{name}-macros-pentium4
83 Source108:      %{name}-macros-ppc
84 Source109:      %{name}-macros-x86_64
85 Source110:      %{name}-macros-ia32e
86 Source111:      %{name}-macros-amd64
87
88 Patch0:         %{name}-pl.po.patch
89
90 Patch3:         %{name}-rpmpopt.patch
91 Patch4:         %{name}-perl-macros.patch
92 Patch5:         %{name}-perl-req-perlfile.patch
93 Patch6:         %{name}-noexpand.patch
94 Patch7:         %{name}-scripts-closefds.patch
95 Patch8:         %{name}-php-macros.patch
96 Patch9:         %{name}-gettext-in-header.patch
97 Patch10:        %{name}-compress-doc.patch
98
99 Patch14:        %{name}-etc_dir.patch
100 Patch16:        %{name}-php-deps.patch
101
102 Patch18:        %{name}-perl_req.patch
103
104 Patch23:        %{name}-pkgconfigdeps.patch
105
106 Patch25:        %{name}-rpm2cpio-payload.patch
107 Patch26:        %{name}-notsc.patch
108 Patch27:        %{name}-hack-norpmlibdep.patch
109
110 Patch31:        %{name}-missing-prototypes.patch
111 Patch32:        %{name}-pld-autodep.patch
112 Patch34:        %{name}-epoch0.patch
113 Patch35:        %{name}-perl_req-INC_dirs.patch
114 Patch36:        %{name}-debuginfo.patch
115 Patch37:        %{name}-doxygen_hack.patch
116
117 Patch41:        %{name}-reduce-stack-usage.patch
118 Patch42:        %{name}-old-fileconflicts-behaviour.patch
119
120 Patch46:        %{name}-mono.patch
121 Patch47:        %{name}-javadeps.patch
122
123 Patch52:        %{name}-morearchs.patch
124
125 Patch55:        %{name}-truncate-cvslog.patch
126
127 Patch58:        %{name}-repackage-wo-lzma.patch
128 Patch59:        %{name}-libtool-deps.patch
129
130 Patch61:        %{name}-sparc64.patch
131 URL:            http://rpm5.org/
132 BuildRequires:  autoconf >= 2.57
133 BuildRequires:  automake >= 1.4
134 BuildRequires:  beecrypt-devel >= %{beecrypt_ver}
135 BuildRequires:  bzip2-devel >= 1.0.2-17
136 %{?with_db:BuildRequires:       db-devel >= %{reqdb_ver}}
137 BuildRequires:  elfutils-devel >= 0.108
138 %ifnarch sparc64
139 # -fPIE/-pie
140 BuildRequires:  gcc >= 5:3.4
141 %endif
142 BuildRequires:  gettext-devel >= 0.11.4-2
143 BuildRequires:  libmagic-devel
144 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.18}
145 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
146 BuildRequires:  libstdc++-devel
147 BuildRequires:  libtool >= 1:1.4.2-9
148 %if %{with neon}
149 BuildRequires:  libxml2-devel
150 BuildRequires:  neon-devel >= 0.25.5
151 %endif
152 BuildRequires:  patch >= 2.2
153 BuildRequires:  popt-devel >= %{reqpopt_ver}
154 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
155 BuildRequires:  python-modules >= 1:2.5
156 BuildRequires:  rpm-perlprov
157 %{?with_python:BuildRequires:   rpm-pythonprov}
158 %{?with_sqlite:BuildRequires:   sqlite3-devel}
159 BuildRequires:  zlib-devel
160 %if %{with static}
161 # Require static library only for static build
162 BuildRequires:  beecrypt-static >= %{beecrypt_ver}
163 BuildRequires:  bzip2-static >= 1.0.2-17
164 %{?with_db:BuildRequires:       db-static >= %{reqdb_ver}}
165 BuildRequires:  elfutils-static
166 BuildRequires:  glibc-static >= 2.2.94
167 BuildRequires:  libmagic-static
168 %{?with_selinux:BuildRequires:  libselinux-static >= 1.18}
169 BuildRequires:  popt-static >= %{reqpopt_ver}
170 BuildRequires:  zlib-static
171 %endif
172 Requires:       %{name}-base = %{version}-%{release}
173 Requires:       %{name}-lib = %{version}-%{release}
174 Requires:       beecrypt >= %{beecrypt_ver}
175 Requires:       popt >= %{reqpopt_ver}
176 %{!?with_static:Obsoletes:      rpm-utils-static}
177 Conflicts:      glibc < 2.2.92
178 # db4.6 poldek needed
179 Conflicts:      poldek < 0.21-0.20070703.00.3
180 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
181
182 %define         _binary_payload         w9.gzdio
183 %define         _noPayloadPrefix        1
184
185 # don't require very fresh rpm.macros to build
186 %define         __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
187 %define         ix86    i386 i486 i586 i686 athlon pentium3 pentium4
188 %define         ppc     ppc ppc7400 ppc7450
189 %define         x8664   amd64 ia32e x86_64
190
191 # stabilize new build environment
192 %define         __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
193 %define         __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
194 %define         __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
195
196 %define         _rpmlibdir /usr/lib/rpm
197
198 %define         specflags       -fno-strict-aliasing
199
200 %description
201 RPM is a powerful package manager, which can be used to build,
202 install, query, verify, update, and uninstall individual software
203 packages. A package consists of an archive of files, and package
204 information, including name, version, and description.
205
206 %description -l de.UTF-8
207 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
208 Installation, Anfrage, Verifizierung, Aktualisierung und
209 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
210 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
211 Beschreibung.
212
213 %description -l es.UTF-8
214 RPM es un poderoso administrador de paquetes, que puede ser usado para
215 construir, instalar, pesquisar, verificar, actualizar y desinstalar
216 paquetes individuales de software. Un paquete consiste en un
217 almacenaje de archivos, y información sobre el paquete, incluyendo
218 nombre, versión y descripción.
219
220 %description -l pl.UTF-8
221 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
222 przebudowanie, instalację czy weryfikację dowolnego pakietu.
223 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
224 plików wchodzących w skład pakietu, zależności od innych pakietów, są
225 przechowywane w bazie danych i można je uzyskać za pomocą opcji
226 odpytywania programu rpm.
227
228 %description -l pt_BR.UTF-8
229 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
230 construir, instalar, pesquisar, verificar, atualizar e desinstalar
231 pacotes individuais de software. Um pacote consiste de um conjunto de
232 arquivos e informações adicionais, incluindo nome, versão e descrição
233 do pacote, permissões dos arquivos, etc.
234
235 %description -l ru.UTF-8
236 RPM - это мощный менеджер пакетов, который может быть использован для
237 создания, инсталляции, запросов (query), проверки, обновления и
238 удаления программных пакетов. Пакет состоит из файлового архива и
239 служебной информации, включающей название, версию, описание и другие
240 данные о пакете.
241
242 %description -l uk.UTF-8
243 RPM - це потужний менеджер пакетів, що може бути використаний для
244 створення, інсталяції, запитів (query), перевірки, поновлення та
245 видалення програмних пакетів. Пакет складається з файлового архіву та
246 службової інформації, що містить назву, версію, опис та іншу
247 інформацію про пакет.
248
249 %package base
250 Summary:        RPM base package - scripts used by rpm packages themselves
251 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
252 Group:          Base
253 Requires:       filesystem
254 Obsoletes:      vserver-rpm
255
256 %description base
257 The RPM base package contains scripts used by rpm packages themselves.
258 These include:
259 - scripts for adding/removing groups and users needed for rpm
260   packages,
261 - banner.sh to display %%banner messages from rpm scriptlets.
262
263 %description base -l pl.UTF-8
264 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
265 Zawiera on:
266 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
267 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
268
269 %package lib
270 Summary:        RPMs library
271 Summary(pl.UTF-8):      Biblioteki RPM-a
272 Group:          Libraries
273 Requires:       beecrypt >= %{beecrypt_ver}
274 %{?with_db:Requires:    db >= %{reqdb_ver}}
275 %{?with_selinux:Requires:       libselinux >= 1.18}
276 Requires:       libmagic >= 1.15-2
277 Requires:       popt >= %{reqpopt_ver}
278 Obsoletes:      rpm-libs
279 Obsoletes:      rpm-apidocs
280 # avoid SEGV caused by mixed db versions
281 Conflicts:      poldek < 0.18.1-16
282 %{?with_suggest_tags:Suggests:  lzma}
283
284 %description lib
285 RPMs library.
286
287 %description lib -l pl.UTF-8
288 Biblioteki RPM-a.
289
290 %package devel
291 Summary:        Header files for rpm libraries
292 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
293 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
294 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
295 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
296 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
297 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
298 Group:          Development/Libraries
299 Requires:       %{name}-lib = %{version}-%{release}
300 Requires:       beecrypt-devel >= %{beecrypt_ver}
301 Requires:       bzip2-devel
302 %{?with_db:Requires:    db-devel >= %{reqdb_ver}}
303 Requires:       elfutils-devel
304 Requires:       libmagic-devel
305 %{?with_selinux:Requires:       libselinux-devel}
306 Requires:       popt-devel >= %{reqpopt_ver}
307 Requires:       zlib-devel
308
309 %description devel
310 The RPM packaging system includes C libraries that make it easy to
311 manipulate RPM packages and databases. They are intended to ease the
312 creation of graphical package managers and other tools that need
313 intimate knowledge of RPM packages. This package contains header files
314 for these libraries.
315
316 %description devel -l de.UTF-8
317 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
318 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
319 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
320 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
321
322 %description devel -l es.UTF-8
323 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
324 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
325 facilitar la creación de administradores gráficos de paquetes y otras
326 herramientas que necesiten un conocimiento profundo de paquetes RPM.
327
328 %description devel -l pl.UTF-8
329 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
330 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
331 graficznych programów zarządzających pakietami oraz innych narzędzi,
332 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
333 zawiera pliki nagłówkowe wspomnianych bibliotek.
334
335 %description devel -l pt_BR.UTF-8
336 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
337 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
338 facilitar a criação de gerenciadores gráficos de pacotes e outras
339 ferramentas que precisem de conhecimento profundo de pacotes RPM.
340
341 %description devel -l ru.UTF-8
342 Система управления пакетами RPM содержит библиотеку C, которая
343 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
344 Эта библиотека предназначена для облегчения создания графических
345 пакетных менеджеров и других утилит, которым необходимо работать с
346 пакетами RPM.
347
348 %description devel -l uk.UTF-8
349 Система керування пакетами RPM містить бібліотеку C, котра спрощує
350 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
351 призначена для полегшення створення графічних пакетних менеджерів та
352 інших утиліт, що працюють з пакетами RPM.
353
354 %package static
355 Summary:        RPM static libraries
356 Summary(de.UTF-8):      RPMs statische Libraries
357 Summary(pl.UTF-8):      Biblioteki statyczne RPM-a
358 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o desenvolvimento de aplicações RPM
359 Summary(ru.UTF-8):      Статическая библиотека для программ, работающих с rpm-пакетами
360 Summary(uk.UTF-8):      Статична бібліотека для програм, що працюють з пакетами rpm
361 Group:          Development/Libraries
362 Requires:       %{name}-devel = %{version}-%{release}
363 Requires:       beecrypt-static >= %{beecrypt_ver}
364 Requires:       bzip2-static
365 %{?with_db:Requires:    db-static >= %{reqdb_ver}}
366 Requires:       elfutils-static
367 Requires:       libmagic-static
368 Requires:       popt-static >= %{reqpopt_ver}
369 Requires:       zlib-static
370
371 %description static
372 RPM static libraries.
373
374 %description static -l de.UTF-8
375 RPMs statische Libraries.
376
377 %description static -l pl.UTF-8
378 Biblioteki statyczne RPM-a.
379
380 %description static -l pt_BR.UTF-8
381 Bibliotecas estáticas para desenvolvimento.
382
383 %description static -l ru.UTF-8
384 Система управления пакетами RPM содержит библиотеку C, которая
385 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
386 Это статическая библиотека RPM.
387
388 %description static -l uk.UTF-8
389 Система керування пакетами RPM містить бібліотеку C, котра спрощує
390 роботу з пакетами RPM та відповідними базами даних. Це статична
391 бібліотека RPM.
392
393 %package utils
394 Summary:        Additional utilities for managing RPM packages and database
395 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
396 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
397 Group:          Applications/File
398 Requires:       %{name} = %{version}-%{release}
399 Requires:       popt >= %{reqpopt_ver}
400
401 %description utils
402 Additional utilities for managing RPM packages and database.
403
404 %description utils -l de.UTF-8
405 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
406
407 %description utils -l pl.UTF-8
408 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
409
410 %package utils-perl
411 Summary:        Additional utilities for managing RPM packages and database
412 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
413 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
414 Group:          Applications/File
415 Requires:       %{name}-utils = %{version}-%{release}
416 Requires:       popt >= %{reqpopt_ver}
417
418 %description utils-perl
419 Additional utilities for managing RPM packages and database.
420
421 %description utils-perl -l de.UTF-8
422 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
423
424 %description utils-perl -l pl.UTF-8
425 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
426
427 %package utils-static
428 Summary:        Static rpm utilities
429 Summary(pl.UTF-8):      Statyczne narzędzia rpm
430 Group:          Applications/System
431 Requires:       %{name} = %{version}-%{release}
432
433 %description utils-static
434 Static rpm utilities for repairing system in case something with
435 shared libraries used by rpm become broken. Currently it contains rpmi
436 binary, which can be used to install/upgrade/remove packages without
437 using shared libraries (well, in fact with exception of NSS modules).
438
439 %description utils-static -l pl.UTF-8
440 Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
441 związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
442 Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
443 uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
444 (z wyjątkiem modułów NSS).
445
446 %package build
447 Summary:        Scripts for building binary RPM packages
448 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
449 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
450 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
451 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
452 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
453 Group:          Applications/File
454 Requires(pre):  findutils
455 Requires:       %{name}-build-macros >= 1.314
456 Requires:       %{name}-utils = %{version}-%{release}
457 Requires:       /bin/id
458 Requires:       awk
459 # we need fixed binutils for -feliminate-dwarf2-dups
460 Requires:       binutils >= 3:2.17.50.0.3-2
461 Requires:       bzip2
462 Requires:       chrpath >= 0.10-4
463 Requires:       cpio
464 Requires:       diffutils
465 Requires:       elfutils
466 Requires:       file >= 4.17
467 Requires:       fileutils
468 Requires:       findutils
469 Requires:       gcc >= 5:3.4
470 Requires:       glibc-devel
471 Requires:       grep
472 Requires:       gzip
473 Requires:       lzma
474 Requires:       make
475 Requires:       patch
476 Requires:       sed
477 Requires:       sh-utils
478 Requires:       tar
479 Requires:       textutils
480 Provides:       rpmbuild(monoautodeps)
481 Provides:       rpmbuild(noauto) = 3
482 %ifarch %{x8664}
483 Conflicts:      automake < 1:1.7.9-2
484 Conflicts:      libtool < 2:1.5-13
485 %endif
486
487 %description build
488 Scripts for building binary RPM packages.
489
490 %description build -l de.UTF-8
491 Scripts fürs Bauen binärer RPM-Pakete.
492
493 %description build -l pl.UTF-8
494 Skrypty pomocnicze do budowania binarnych RPM-ów.
495
496 %description build -l pt_BR.UTF-8
497 Este pacote contém scripts e programas executáveis que são usados para
498 construir pacotes usando o RPM.
499
500 %description build -l ru.UTF-8
501 Различные вспомогательные скрипты и исполняемые программы, которые
502 используются для сборки RPM'ов.
503
504 %description build -l uk.UTF-8
505 Різноманітні допоміжні скрипти та утиліти, які використовуються для
506 побудови RPM'ів.
507
508 %package javaprov
509 Summary:        Additional utilities for checking Java provides/requires in RPM packages
510 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
511 Group:          Applications/File
512 Requires:       %{name} = %{version}-%{release}
513 Requires:       file
514 Requires:       findutils >= 1:4.2.26
515 Requires:       mktemp
516 Requires:       unzip
517
518 %description javaprov
519 Additional utilities for checking Java provides/requires in RPM
520 packages.
521
522 %description javaprov -l pl.UTF-8
523 Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
524 RPM.
525
526 %package perlprov
527 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
528 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
529 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
530 Group:          Applications/File
531 Requires:       %{name} = %{version}-%{release}
532 Requires:       perl-devel
533 Requires:       perl-modules
534
535 %description perlprov
536 Additional utilities for checking Perl provides/requires in RPM
537 packages.
538
539 %description perlprov -l de.UTF-8
540 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
541
542 %description perlprov -l pl.UTF-8
543 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
544 pakietach RPM.
545
546 %package pythonprov
547 Summary:        Python macros, which simplifies creation of RPM packages with Python software
548 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
549 Group:          Applications/File
550 Requires:       %{name} = %{version}-%{release}
551 Requires:       python
552 Requires:       python-modules
553
554 %description pythonprov
555 Python macros, which simplifies creation of RPM packages with Python
556 software.
557
558 %description pythonprov -l pl.UTF-8
559 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
560 Pythonie.
561
562 %package php-pearprov
563 Summary:        Additional utilities for checking PHP PEAR provides/requires in RPM packages
564 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
565 Group:          Applications/File
566 Requires:       %{name} = %{version}-%{release}
567 Requires:       sed >= 4.0
568
569 %description php-pearprov
570 Additional utilities for checking PHP PEAR provides/requires in RPM
571 packages.
572
573 %description php-pearprov -l pl.UTF-8
574 Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
575 pakietach RPM.
576
577 %package -n python-rpm
578 Summary:        Python interface to RPM library
579 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki RPM-a
580 Summary(pt_BR.UTF-8):   Módulo Python para aplicativos que manipulam pacotes RPM
581 Group:          Development/Languages/Python
582 Requires:       %{name} = %{version}-%{release}
583 %pyrequires_eq  python
584 Obsoletes:      rpm-python
585
586 %description -n python-rpm
587 The rpm-python package contains a module which permits applications
588 written in the Python programming language to use the interface
589 supplied by RPM (RPM Package Manager) libraries.
590
591 This package should be installed if you want to develop Python
592 programs that will manipulate RPM packages and databases.
593
594 %description -n python-rpm -l pl.UTF-8
595 Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
596 Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
597
598 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
599 Pythonie programy manipulujące pakietami i bazami danych rpm.
600
601 %description -n python-rpm -l pt_BR.UTF-8
602 O pacote rpm-python contém um módulo que permite que aplicações
603 escritas em Python utilizem a interface fornecida pelas bibliotecas
604 RPM (RPM Package Manager).
605
606 Esse pacote deve ser instalado se você quiser desenvolver programas em
607 Python para manipular pacotes e bancos de dados RPM.
608
609 %prep
610 %setup -q -n %{name}
611 sed -i -e 's# no # nb #g' configure.ac
612 mv po/no.po po/nb.po
613 sed -i -e 's# sr # sr@Latn #g' configure.ac
614 mv -f po/{sr,sr@Latn}.po
615
616 sed -i -e 's#${prefix}/lib/python@WITH_PYTHON_VERSION@#@WITH_PYTHON_LIBDIR@#g' python/rpm/Makefile.am
617
618 # APPLIED ALREADY?
619 #%patch0 -p1
620 %patch3 -p1
621 %patch4 -p1
622 %patch5 -p1
623 %patch6 -p1
624 %patch7 -p1
625 %patch8 -p1
626 %patch9 -p1
627 %patch10 -p1
628 # CHECK ME
629 #%patch14 -p1
630 %patch16 -p1
631 %patch18 -p1
632 echo '%%define  __perl_provides %%{__perl} /usr/lib/rpm/perl.prov' > macros.perl
633 echo '%%define  __perl_requires %%{__perl} /usr/lib/rpm/perl.req' >> macros.perl
634 echo '# obsoleted file' > macros.python
635 echo '%%define  __php_provides  /usr/lib/rpm/php.prov' > macros.php
636 echo '%%define  __php_requires  /usr/lib/rpm/php.req' >> macros.php
637 echo '%%define  __mono_provides /usr/lib/rpm/mono-find-provides' > macros.mono
638 echo '%%define  __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
639 install %{SOURCE5} scripts/find-lang.sh
640 install %{SOURCE9} scripts/php.prov.in
641 install %{SOURCE10} scripts/php.req.in
642 install %{SOURCE12} scripts/perl.prov
643 %patch23 -p1
644 %patch25 -p1
645 %ifarch i386
646 # disable TSC
647 %patch26 -p1
648 %endif
649 %patch27 -p1
650 # CHECK ME
651 #%patch31 -p1
652 %patch32 -p1
653 %patch34 -p1
654 %patch35 -p0
655 %patch36 -p1
656 %patch37 -p1
657 # CHECK ME
658 #%patch41 -p1
659 %patch42 -p1
660 # CHECK ME, PROBABLY WILL NEED TO HANLE IN OTHER WAY since rpmfcSCRIPT already handles mono
661 #%patch46 -p1
662 %patch47 -p1
663 # OLD COMMENTED OUT
664 #%patch52 -p1
665 %patch55 -p1
666 %patch58 -p1
667 %patch59 -p1
668 %ifarch sparc64
669 %patch61 -p1
670 %endif
671
672 cd scripts
673 mv -f perl.req perl.req.in
674 mv -f perl.prov perl.prov.in
675 cd ..
676
677 # generate Group translations to *.po
678 awk -f %{SOURCE6} %{SOURCE1}
679
680 # update macros paths
681 #for f in doc{,/ja,/pl}/rpm.8 doc{,/ja,/pl}/rpmbuild.8 ; do
682 #       sed -e 's@lib/rpm/redhat@lib/rpm/pld@g' $f > ${f}.tmp
683 #       mv -f ${f}.tmp $f
684 #done
685
686 %build
687 %{__libtoolize}
688 %{__autopoint}
689 %{__aclocal}
690 %{__autoheader}
691 %{__autoconf}
692 %{__automake}
693
694 # config.guess doesn't handle athlon, so we have to change it by hand.
695 # rpm checks for CPU type at runtime, but it looks better
696 #sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
697
698 # pass CC and CXX too in case of building with some older configure macro
699 # disable perl-RPM2 build, we have it in separate spec
700 %configure \
701         CC="%{__newcc}" \
702         CXX="%{__newcxx}" \
703         CPP="%{__newcpp}" \
704         WITH_PERL_VERSION=no \
705         %{?with_autoreqdep:--enable-adding-packages-names-in-autogenerated-dependancies} \
706         --enable-shared \
707         --enable-static \
708         %{?with_python:--with-python=2.5 --with-python-lib-dir=%{py_libdir}} \
709         %{!?with_python:--without-python} \
710         --with%{!?with_selinux:out}-selinux \
711         --with-libelf \
712         --with-zlib=external \
713         --with-bzip2=external \
714         --with-beecrypt=external \
715         --with-neon=%{?with_neon:external}%{!?with_neon:no} \
716         --with-file=external \
717         --with-popt=external \
718         --with-db=%{?with_db:external}%{!?with_db:no} \
719         --with-sqlite=%{?with_sqlite:external}%{!?with_sqlite:no} \
720         --with-dbapi=%{!?sqlite_dbapi:db}%{?sqlite_dbapi:sqlite} \
721         --with-lua=none \
722         --with-pcre=external \
723         --with-keyutils=none \
724         --without-path-versioned \
725         --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.pld:%{_rpmlibdir}/macros.build:%{_rpmlibdir}/%%{_target}/macros:%{_sysconfdir}/macros.*:%{_sysconfdir}/macros:%{_sysconfdir}/%%{_target}/macros:~/etc/rpmmacros:~/etc/.rpmmacros:~/.rpmmacros' \
726         --with-bugreport="http://bugs.pld-linux.org/"
727
728 %{__make} \
729         CC="%{__cc}" \
730         CXX="%{__cxx}" \
731         CPP="%{__cpp}"
732
733 %install
734 rm -rf $RPM_BUILD_ROOT
735 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner}
736
737 %{__make} install \
738         pkgconfigdir=%{_pkgconfigdir} \
739         DESTDIR=$RPM_BUILD_ROOT
740
741 # install ARCH macros
742 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
743 install %{SOURCE105} $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
744
745 %ifarch %{ix86}
746 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
747 install %{SOURCE100} $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
748 install %{SOURCE101} $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
749 install %{SOURCE102} $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
750 install %{SOURCE103} $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
751 install %{SOURCE104} $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
752 install %{SOURCE106} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
753 install %{SOURCE107} $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
754 %endif
755
756 %ifarch %{x8664}
757 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
758 install %{SOURCE109} $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
759 install %{SOURCE110} $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
760 install %{SOURCE111} $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
761 %endif
762
763 %ifarch %{ppc}
764 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
765 install %{SOURCE108} $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
766 %endif
767
768 # first platform file entry can't contain regexps
769 echo "%{_target_cpu}-%{_target_vendor}-linux" > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
770
771 # x86_64 things
772 %ifarch x86_64
773 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
774 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
775 %endif
776
777 %ifarch amd64
778 echo "amd64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
779 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
780 %endif
781
782 %ifarch ia32e
783 echo "ia32e-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
784 echo "x86_64-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
785 %endif
786
787 # x86 things
788 %ifarch athlon %{x8664}
789 echo "athlon-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
790 %endif
791 %ifarch pentium4 athlon %{x8664}
792 echo "pentium4-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
793 %endif
794 %ifarch pentium3 pentium4 athlon %{x8664}
795 echo "pentium3-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
796 %endif
797 %ifarch i686 pentium3 pentium4 athlon %{x8664}
798 echo "i686-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
799 %endif
800 %ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
801 echo "i586-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
802 %endif
803 %ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
804 echo "i486-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
805 %endif
806 %ifarch %{ix86} %{x8664}
807 echo "i386-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
808 %endif
809
810 # ppc
811 %ifarch ppc
812 echo "ppc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
813 echo "powerpc-[^-]*-linux(-gnu)?" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
814 %endif
815
816 # noarch
817 echo "noarch-[^-]*-.*" >> $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
818
819 %ifarch %{ppc}
820 #sed -e '/_target_platform/s/[%]{_target_cpu}/ppc/' \
821 #       -i $RPM_BUILD_ROOT%{_rpmlibdir}/ppc74[05]0-linux/macros
822 %endif
823
824 rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
825 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
826 rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
827
828 # not installed since 4.4.8 (-tools-perl subpackage)
829 install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
830
831 install macros.perl     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.perl
832 install macros.python   $RPM_BUILD_ROOT%{_rpmlibdir}/macros.python
833 install macros.php      $RPM_BUILD_ROOT%{_rpmlibdir}/macros.php
834 install macros.mono     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.mono
835 install %{SOURCE15}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.java
836 install %{SOURCE18}     $RPM_BUILD_ROOT%{_rpmlibdir}/macros.pld
837
838 install %{SOURCE1} doc/manual/groups
839 install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
840 install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
841 install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
842 install %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/check-files
843 install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
844 install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
845 install scripts/find-php*       $RPM_BUILD_ROOT%{_rpmlibdir}
846 install scripts/php.{prov,req}  $RPM_BUILD_ROOT%{_rpmlibdir}
847 install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
848
849 install %{SOURCE17} $RPM_BUILD_ROOT%{_bindir}/banner.sh
850
851 install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
852
853 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros <<EOF
854 # customized rpm macros - global for host
855 #
856 #%%_install_langs pl_PL:en_US
857 %%distribution PLD
858 #
859 # remove or replace with file_contexts path if you want to use custom
860 # SELinux file contexts policy instead of one stored in packages payload
861 %%_install_file_context_path    %%{nil}
862 %%_verify_file_context_path     %%{nil}
863
864 # If non-zero, all erasures will be automagically repackaged.
865 #%%_repackage_all_erasures    1
866 EOF
867
868 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles <<EOF
869 # global list of files (regexps) which don't generate Provides
870 EOF
871 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov <<EOF
872 # global list of script capabilities (regexps) not to be used in Provides
873 EOF
874 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles <<EOF
875 # global list of files (regexps) which don't generate Requires
876 ^%{_examplesdir}/
877 ^%{_docdir}/
878 EOF
879 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq <<EOF
880 # global list of script capabilities (regexps) not to be used in Requires
881 EOF
882 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep <<EOF
883 # global list of capabilities (SONAME, perl(module), php(module) regexps)
884 # which don't generate dependencies on package NAMES
885 # -- OpenGL implementation
886 ^libGL.so.1
887 ^libGLU.so.1
888 ^libOSMesa.so
889 # -- Glide
890 ^libglide3.so.3
891 # -- mozilla
892 ^libgtkmozembed.so
893 ^libgtksuperwin.so
894 ^libxpcom.so
895 # -- X11 implementation
896 ^libFS.so
897 ^libI810XvMC.so
898 ^libICE.so
899 ^libSM.so
900 ^libX11.so
901 ^libXRes.so
902 ^libXTrap.so
903 ^libXaw.so
904 ^libXcomposite.so
905 ^libXcursor.so
906 ^libXdamage.so
907 ^libXdmcp.so
908 ^libXevie.so
909 ^libXext.so
910 ^libXfixes.so
911 ^libXfont.so
912 ^libXfontcache.so
913 ^libXft.so
914 ^libXi.so
915 ^libXinerama.so
916 ^libXmu.so
917 ^libXmuu.so
918 ^libXp.so
919 ^libXpm.so
920 ^libXrandr.so
921 ^libXrender.so
922 ^libXss.so
923 ^libXt.so
924 ^libXtst.so
925 ^libXv.so
926 ^libXvMC.so
927 ^libXxf86dga.so
928 ^libXxf86misc.so
929 ^libXxf86rush.so
930 ^libXxf86vm.so
931 ^libdps.so
932 ^libdpstk.so
933 ^libfontenc.so
934 ^libpsres.so
935 ^libxkbfile.so
936 ^libxkbui.so
937 # -- fam / gamin
938 ^libfam.so.0
939 EOF
940 cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc <<EOF
941 # global list of file masks not to be compressed in DOCDIR
942 EOF
943
944 # for rpm -e|-U --repackage
945 install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
946 touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
947
948 # mov rpm to /bin
949 mv -f $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
950 # move libs to /lib
951 for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so; do
952         mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
953         ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
954 done
955
956 # remove arch dependant macros which have no use on noarch
957 #%{__sed} -i -e '
958 #/{__spec_install_post_strip}/d
959 #/{__spec_install_post_chrpath}/d
960 #/{__spec_install_post_compress_modules}/d
961 #' $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
962
963 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
964 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
965
966 rm $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
967
968 # wrong location, not used anyway
969 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
970 # manuals for utils dropped in 4.4.8 (?)
971 #rm $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/{rpmcache,rpmgraph}.8
972
973 %find_lang %{name}
974
975 rm -rf manual
976 cp -a doc/manual manual
977 rm -f manual/Makefile*
978
979 %clean
980 rm -rf $RPM_BUILD_ROOT
981
982 %post   lib -p /sbin/ldconfig
983 %postun lib -p /sbin/ldconfig
984
985 %pre build
986 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
987
988 %files -f %{name}.lang
989 %defattr(644,root,root,755)
990 %doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
991
992 %attr(755,root,root) /bin/rpm
993 #%attr(755,root,root) %{_bindir}/rpmdb
994 #%attr(755,root,root) %{_bindir}/rpmquery
995 #%attr(755,root,root) %{_bindir}/rpmsign
996 #%attr(755,root,root) %{_bindir}/rpmverify
997
998 %dir %{_sysconfdir}/rpm
999 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
1000 # these are ok to be replaced
1001 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo
1002 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1003
1004
1005 %{_mandir}/man8/rpm.8*
1006 %lang(fr) %{_mandir}/fr/man8/rpm.8*
1007 %lang(ja) %{_mandir}/ja/man8/rpm.8*
1008 %lang(ko) %{_mandir}/ko/man8/rpm.8*
1009 %lang(pl) %{_mandir}/pl/man8/rpm.8*
1010 %lang(ru) %{_mandir}/ru/man8/rpm.8*
1011 %lang(sk) %{_mandir}/sk/man8/rpm.8*
1012
1013 %dir /var/lib/rpm
1014 %dir %attr(700,root,root) /var/spool/repackage
1015 %dir /var/lock/rpm
1016 /var/lock/rpm/transaction
1017
1018 #%attr(755,root,root) %{_rpmlibdir}/rpmd
1019 #%{!?with_static:%attr(755,root,root) %{_rpmlibdir}/rpm[eiu]}
1020 #%attr(755,root,root) %{_rpmlibdir}/rpmk
1021 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
1022
1023 %{_rpmlibdir}/rpmpopt*
1024 %{_rpmlibdir}/macros
1025 %{_rpmlibdir}/macros.pld
1026
1027 %files base
1028 %defattr(644,root,root,755)
1029 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1030 %dir %{_rpmlibdir}
1031 %attr(755,root,root) %{_bindir}/banner.sh
1032 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
1033 %dir /var/lib/banner
1034
1035 %files lib
1036 %defattr(644,root,root,755)
1037 %attr(755,root,root) /%{_lib}/librpm*-*.so
1038 %attr(755,root,root) %{_libdir}/librpm*-*.so
1039
1040 %files devel
1041 %defattr(644,root,root,755)
1042 %{_includedir}/rpm
1043 %{_libdir}/librpm*.la
1044 %{_pkgconfigdir}/*.pc
1045 %attr(755,root,root) %{_libdir}/librpm.so
1046 %attr(755,root,root) %{_libdir}/librpm-%{sover}.so
1047 %attr(755,root,root) %{_libdir}/librpmio.so
1048 %attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
1049 %attr(755,root,root) %{_libdir}/librpmdb.so
1050 %attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
1051 %attr(755,root,root) %{_libdir}/librpmbuild.so
1052
1053 %files static
1054 %defattr(644,root,root,755)
1055 %{_libdir}/librpm*.a
1056
1057 %files utils
1058 %defattr(644,root,root,755)
1059 %attr(755,root,root) %{_bindir}/rpmconstant
1060 %attr(755,root,root) %{_bindir}/rpm2cpio
1061 %attr(755,root,root) %{_rpmlibdir}/rpmcache
1062 %attr(755,root,root) %{_rpmlibdir}/rpmcmp
1063 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
1064 %attr(755,root,root) %{_rpmlibdir}/debugedit
1065 %attr(755,root,root) %{_rpmlibdir}/rpmdigest
1066 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
1067 %attr(755,root,root) %{_rpmlibdir}/tgpg
1068 %attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
1069 %{_mandir}/man8/rpm2cpio.8*
1070 %{_mandir}/man8/rpmdeps.8*
1071 #%{_mandir}/man8/rpmcache.8*
1072 #%{_mandir}/man8/rpmgraph.8*
1073 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
1074 #%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
1075 #%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1076 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1077 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1078 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
1079 #%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
1080 #%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
1081 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1082
1083 %files utils-perl
1084 %defattr(644,root,root,755)
1085 %attr(755,root,root) %{_rpmlibdir}/rpmdiff*
1086
1087 %if %{with static}
1088 %files utils-static
1089 %defattr(644,root,root,755)
1090 %attr(755,root,root) %{_bindir}/rpm[ieu]
1091 %attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1092 %endif
1093
1094 %files build
1095 %defattr(644,root,root,755)
1096 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
1097 %attr(755,root,root) %{_rpmlibdir}/brp-*
1098 %attr(755,root,root) %{_rpmlibdir}/check-files
1099 # %attr(755,root,root) %{_rpmlibdir}/check-prereqs
1100 %attr(755,root,root) %{_rpmlibdir}/compress-doc
1101 #%attr(755,root,root) %{_rpmlibdir}/config.*
1102 %attr(755,root,root) %{_rpmlibdir}/cross-build
1103 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
1104 %attr(755,root,root) %{_rpmlibdir}/find-lang.sh
1105 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
1106 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
1107 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
1108 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
1109 %attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
1110 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
1111 # needs hacked pkg-config to return anything
1112 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
1113 #%attr(755,root,root) %{_rpmlibdir}/rpmb
1114 #%attr(755,root,root) %{_rpmlibdir}/rpmt
1115 %{_rpmlibdir}/noarch-*
1116 %ifarch %{ix86}
1117 %{_rpmlibdir}/i?86*
1118 %{_rpmlibdir}/pentium*
1119 %{_rpmlibdir}/athlon*
1120 %endif
1121 %ifarch alpha
1122 %{_rpmlibdir}/alpha*
1123 %endif
1124 %ifarch ia64
1125 %{_rpmlibdir}/ia64*
1126 %endif
1127 %ifarch mips mipsel mips64 mips64el
1128 %{_rpmlibdir}/mips*
1129 %endif
1130 %ifarch %{ppc}
1131 %{_rpmlibdir}/ppc*
1132 %endif
1133 %ifarch sparc sparc64
1134 %{_rpmlibdir}/sparc*
1135 %endif
1136 %ifarch %{x8664}
1137 %{_rpmlibdir}/amd64*
1138 %{_rpmlibdir}/ia32e*
1139 %{_rpmlibdir}/x86_64*
1140 %endif
1141 # must be here for "Requires: rpm-*prov" to work
1142 %{_rpmlibdir}/macros.java
1143 %{_rpmlibdir}/macros.mono
1144 %{_rpmlibdir}/macros.perl
1145 %{_rpmlibdir}/macros.php
1146 # not used yet ... these six depend on perl
1147 #%attr(755,root,root) %{_rpmlibdir}/http.req
1148 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
1149 #%attr(755,root,root) %{_rpmlibdir}/magic.req
1150 #%{_rpmlibdir}/sql.prov
1151 #%{_rpmlibdir}/sql.req
1152 #%{_rpmlibdir}/tcl.req
1153
1154 %attr(755,root,root) %{_bindir}/gendiff
1155 %attr(755,root,root) %{_bindir}/rpmbuild
1156
1157 %{_mandir}/man1/gendiff.1*
1158 %{_mandir}/man8/rpmbuild.8*
1159 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1160 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
1161 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
1162
1163 %files javaprov
1164 %defattr(644,root,root,755)
1165 %attr(755,root,root) %{_rpmlibdir}/java-find-requires
1166 # needs jar (any jdk), jcf-dump (gcc-java) to work
1167 %attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1168
1169 %files perlprov
1170 %defattr(644,root,root,755)
1171 %attr(755,root,root) %{_rpmlibdir}/perl.*
1172 #%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
1173 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
1174 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
1175 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
1176 #%attr(755,root,root) %{_rpmlibdir}/find-req.pl
1177 #%attr(755,root,root) %{_rpmlibdir}/get_magic.pl
1178
1179 %files pythonprov
1180 %defattr(644,root,root,755)
1181 %{_rpmlibdir}/macros.python
1182 %attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
1183
1184 %files php-pearprov
1185 %defattr(644,root,root,755)
1186 %attr(755,root,root) %{_rpmlibdir}/php*
1187 %attr(755,root,root) %{_rpmlibdir}/find-php*
1188
1189 %if %{with python}
1190 %files -n python-rpm
1191 %defattr(644,root,root,755)
1192 %dir %{py_sitedir}/rpm
1193 %attr(755,root,root) %{py_sitedir}/rpm/*.so
1194 %{py_sitedir}/rpm/*.py[co]
1195 %endif
This page took 0.142689 seconds and 2 git commands to generate.