]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
67e604fd1435d3002bc0dc3bfd9f7ac33aa2a3a7
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        3.0
5 Release:        8
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source2:        rpm.8pl
12 Source3:        rpm.macros
13 Patch0:         rpm-rpmrc.patch
14 Patch1:         rpm-i18n.patch
15 Patch2:         rpm-find-requires.patch
16 Patch3:         rpm-macros.patch
17 Patch4:         rpm-po.patch
18 Patch37:        %{name}-short_circuit.patch
19 Patch38:        %{name}-section_test.patch
20 #BuildPrereq:   bzip2-static
21 #BuildPrereq:   gdbm-static
22 #BuildPrereq:   zlib-static
23 #BuildPrereq:   patch >= 2.2
24 #BuildPrereq:   libtool
25 #BuildPrereq:   automake
26 #BuildPrereq:   autoconf
27 #BuildPrereq:   gettext
28 Requires:       glibc >= 2.1
29 BuildRoot:      /tmp/%{name}-%{version}-root
30 Obsoletes:      rpm-libs
31 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
32 RPM is a powerful package manager, which can be used to build, install, 
33 query, verify, update, and uninstall individual software packages. A 
34 package consists of an archive of files, and package information, including 
35 name, version, and description.
36 packages. A package consists of an archive of files, and package
37 nombre, versión y descripción.
38 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
39 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
40 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
41 systemu.
42 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
43 %package        devel
44 Summary:        Header files and libraries 
45 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
46 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
47 Group(pl):      Programowanie/Biblioteki
48 Requires:       %{name} = %{version}
49 Requires:       %{name} = %{version}
50 Requires:       popt-devel
51
52 %description devel
53 The RPM packaging system includes a C library that makes it easy to
54 manipulate RPM packages and databases. It is intended to ease the
55 creation of graphical package managers and other tools that need
56 %description -l pl devel
57 Pliki nag³ówkowe i biblioteki statyczne.
58 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
59 construir pacotes usando o RPM.
60 %setup  -q
61 %patch0 -p1 
62 %patch1 -p1
63 %patch2 -p1
64 %patch1 -p1
65 %patch4 -p1 
66 install %{SOURCE13} macros.python.in
67 mv -f perl.prov perl.prov.in)
68 ( cd popt; 
69 libtoolize --copy --force
70 aclocal
71 autoheader
72 automake
73 autoconf
74 LDFLAGS="-s" CFLAGS="$RPM_OPT_FLAGS" \
75 ./configure \
76         --prefix=/usr
77 )
78
79 libtoolize --copy --force
80 aclocal
81 autoheader
82 automake
83 autoconf
84 LDFLAGS="-s" CFLAGS="$RPM_OPT_FLAGS" \
85 ./configure \
86         --prefix=/usr \
87         --disable-shared
88 make
89         --with-python
90
91
92 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
93 install -d $RPM_BUILD_ROOT/var/lib/rpm \
94         $RPM_BUILD_ROOT/usr/man/{ru,pl}/man8
95
96 make DESTDIR="$RPM_BUILD_ROOT" install
97
98 install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/rpm/macros.pld
99         pkgbindir="%{_bindir}"
100 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
101 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
102 install %{SOURCE2} $RPM_BUILD_ROOT/usr/man/pl/man8/rpm.8
103
104 install %{SOURCE1} docs/groups
105 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
106 strip  $RPM_BUILD_ROOT/bin/rpm
107
108 gzip -9fn $RPM_BUILD_ROOT/usr/man/{{ru,pl}/man8/*,man8/*} \
109         RPM-PGP-KEY CHANGES docs/*
110
111 %post
112 /bin/rpm --initdb
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118
119 %doc RPM-PGP-KEY.gz CHANGES.gz docs/*
120 %postun -p /sbin/ldconfig
121
122 %attr(755,root,root) /usr/bin/gendiff
123 %attr(755,root,root) /usr/bin/rpm2cpio
124 %attr(755,root,root) %{_libdir}/rpm/rpmdb
125 /usr/man/man8/*
126 %lang(ru) /usr/man/ru/man8/*
127 %lang(pl) /usr/man/pl/man8/*
128
129 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
130 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
131 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
132 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
133 %lang(pl)    /usr/share/locale/pl/LC_MESSAGES/rpm.mo
134 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
135 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
136 %lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
137 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
138 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
139 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
140 %lang(ru) %{_mandir}/ru/man8/rpm.8*
141 %attr(755,root,root) %dir /var/lib/rpm
142
143 %dir /usr/lib/rpm
144 %attr(755,root,root) /usr/lib/rpm/find-*
145 %attr(755,root,root) /usr/lib/rpm/freshen.sh
146 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
147 %attr(755,root,root) /usr/lib/rpm/config.*
148 %attr(755,root,root) /usr/lib/rpm/getpo.sh
149
150 /usr/lib/rpm/rpm*
151 /usr/lib/rpm/macros*
152
153 %attr(755,root,root) %{_libdir}/rpm/rpmb
154 %attr(755,root,root) %{_libdir}/rpm/rpmi
155 %attr(755,root,root) %{_libdir}/rpm/rpmt
156 /usr/include/rpm
157 /usr/lib/librpm*.a
158 %files utils
159 %files -n python-rpm
160 * Mon Apr 19 1999 Artur Frysiak <wiget@pld.org.pl>
161   [3.0-7]
162 - upgraded to 3.0
163 - added polish man page
164 - added macros for PLD
165
166 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
167   [2.5.6-5]
168 - added rpm-find-requires.patch with beter finding list packages containing
169   required shared libraries (Artur Frysiak <wiget@usa.net>),
170 - added ru man pages,
171 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
172   dlopen() some shared glibc libraries),
173 - removed man group from man pages.
174
175 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
176   [2.5.6-4d]
177 - fixed ignorance about international character sets.
178
179 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
180   [2.5.6-1d]
181 - updated to latest stable version,
182 - added URL,
183 - added Group(pl) && changed gropup to Base,
184 - added small patch against GNU libc-2.1.
185
186 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
187   [2.5.5-1d]
188 - updated to 2.5.5. 
189
190 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
191   [2.5.2-2d]
192 - translation modified for pl,
193 - compressed man pages && documentation,
194 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
195 - moved /usr/src/redhat to /usr/src/rpm.
196
197 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
198   [2.5.2-2]
199 - fixed tr.po,
200 - added -q %setup parameter,
201 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
202 - added using %%{name} and %%{version} in Source,
203 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
204 - added %attr and %defattr macros in %files (allow build package from
205   non-root account),
206 - build against GNU libc-2.1.
207
208 Revision 1.79  2000/02/17 03:42:17  kloczek
209 - release 25,
210 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
211   /bin.
This page took 0.037107 seconds and 3 git commands to generate.