]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
-removed libpopt.a
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        2.92
5 Release:        11
6 Group:          Base
7 Group(pl):      Bazowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-2.5.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source2:        rpm.8pl
12 Patch0:         rpm-rpmrc.patch
13 Patch1:         rpm-i18n.patch
14 Patch2:         rpm-find-requires.patch
15 Patch37:        %{name}-short_circuit.patch
16 Icon:           rpm.gif
17 Requires:       glibc >= 2.1
18 BuildRoot:      /tmp/%{name}-%{version}-root
19 Obsoletes:      rpm-libs
20 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
21 RPM is a powerful package manager, which can be used to build, install, 
22 query, verify, update, and uninstall individual software packages. A 
23 package consists of an archive of files, and package information, including 
24 name, version, and description.
25 packages. A package consists of an archive of files, and package
26 nombre, versión y descripción.
27 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
28 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
29 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
30 systemu.
31 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
32 %package        devel
33 Summary:        Header files and libraries 
34 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
35 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
36 Group(pl):      Programowanie/Biblioteki
37 Requires:       %{name} = %{version}
38 Requires:       %{name} = %{version}
39 Requires:       popt-devel
40
41 %description devel
42 The RPM packaging system includes a C library that makes it easy to
43 manipulate RPM packages and databases. It is intended to ease the
44 creation of graphical package managers and other tools that need
45 %description -l pl devel
46 Pliki nag³ówkowe i biblioteki statyczne.
47 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
48 construir pacotes usando o RPM.
49 %setup  -q
50 %patch0 -p1
51 %patch1 -p1
52 %patch2 -p1
53 install %{SOURCE13} macros.python.in
54 mv -f perl.prov perl.prov.in)
55 autoconf
56 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
57 ./configure \
58         --prefix=/usr \
59         --disable-shared
60 make
61         --with-python
62
63
64 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
65 install -d $RPM_BUILD_ROOT/var/lib/rpm \
66         $RPM_BUILD_ROOT/usr/src/rpm/{SOURCES,SPECS,SRPMS,BUILD} \
67         $RPM_BUILD_ROOT/usr/src/rpm/RPMS/{$RPM_ARCH,noarch} \
68         $RPM_BUILD_ROOT/usr/man/{ru,pl}/man8
69
70 make DESTDIR="$RPM_BUILD_ROOT" install
71         pkgbindir="%{_bindir}"
72 install rpm.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm.8
73 install rpm2cpio.8ru $RPM_BUILD_ROOT/usr/man/ru/man8/rpm2cpio.8
74 install %{SOURCE2} $RPM_BUILD_ROOT/usr/man/pl/man8/rpm.8
75
76 install %{SOURCE1} docs/groups
77
78 gzip -9fn $RPM_BUILD_ROOT/usr/man/{ru/man8/*,man8/*} \
79         RPM-PGP-KEY CHANGES docs/*
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 /bin/rpm --initdb
86
87 %files
88
89 %doc {RPM-PGP-KEY,CHANGES}.gz docs/*
90 %postun -p /sbin/ldconfig
91
92 %attr(755,root,root) /usr/bin/gendiff
93 %attr(755,root,root) /usr/bin/rpm2cpio
94 %attr(755,root,root) %{_libdir}/rpm/rpmdb
95 /usr/man/man8/*
96 %lang(ru) /usr/man/ru/man8/*
97 %lang(pl) /usr/man/pl/man8/*
98
99 %attr(750,root,root) %dir /var/lib/rpm
100
101 %dir /usr/lib/rpm
102 %attr(755,root,root) /usr/lib/rpm/find-*
103 %attr(755,root,root) /usr/lib/rpm/freshen.sh
104 %attr(755,root,root) /usr/lib/rpm/mkinstalldirs
105
106 /usr/lib/rpm/rpm*
107 /usr/src/rpm
108
109 %lang(cs)    /usr/share/locale/cs/LC_MESSAGES/rpm.mo
110 %lang(de)    /usr/share/locale/de/LC_MESSAGES/rpm.mo
111 %lang(fi)    /usr/share/locale/fi/LC_MESSAGES/rpm.mo
112 %lang(fr)    /usr/share/locale/fr/LC_MESSAGES/rpm.mo
113 %lang(pt_BR) /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo
114 %lang(ru)    /usr/share/locale/ru/LC_MESSAGES/rpm.mo
115 #%lang(sk)    /usr/share/locale/sk/LC_MESSAGES/rpm.mo
116 %lang(sv)    /usr/share/locale/sv/LC_MESSAGES/rpm.mo
117 %lang(sr)    /usr/share/locale/sr/LC_MESSAGES/rpm.mo
118 %lang(tr)    /usr/share/locale/tr/LC_MESSAGES/rpm.mo
119 %lang(ru) %{_mandir}/ru/man8/rpm.8*
120 %attr(755,root,root) %{_libdir}/rpm/rpmi
121 %attr(755,root,root) %{_libdir}/rpm/rpmt
122 /usr/include/rpm
123 /usr/lib/librpm*.a
124 %files utils
125 %files -n python-rpm
126 * Wed Mar 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
127   [2.5.6-5]
128 - added rpm-find-requires.patch with beter finding list packages containing
129   required shared libraries (Artur Frysiak <wiget@usa.net>),
130 - added ru man pages,
131 - added "Requires: glibc >= 2.1" (rpm is linked statically but it use by
132   dlopen() some shared glibc libraries),
133 - removed man group from man pages.
134
135 * Fri Feb 19 1999 Marcin Dalecki <dalecki@cs.net.pl>
136   [2.5.6-4d]
137 - fixed ignorance about international character sets.
138
139 * Fri Jan 15 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
140   [2.5.6-1d]
141 - updated to latest stable version,
142 - added URL,
143 - added Group(pl) && changed gropup to Base,
144 - added small patch against GNU libc-2.1.
145
146 * Sun Nov 08 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
147   [2.5.5-1d]
148 - updated to 2.5.5. 
149
150 * Tue Sep 01 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
151   [2.5.2-2d]
152 - translation modified for pl,
153 - compressed man pages && documentation,
154 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
155 - moved /usr/src/redhat to /usr/src/rpm.
156
157 * Sun Aug 30 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
158   [2.5.2-2]
159 - fixed tr.po,
160 - added -q %setup parameter,
161 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
162 - added using %%{name} and %%{version} in Source,
163 - added %lang macros for /usr/share/locale/*/LC_MESSAGES/rpm.mo files,
164 - added %attr and %defattr macros in %files (allow build package from
165   non-root account),
166 - build against GNU libc-2.1.
167
168 Revision 1.79  2000/02/17 03:42:17  kloczek
169 - release 25,
170 - added "Conflicts: /usr/bin/id" and rebuilded in enviroment with id in
171   /bin.
This page took 0.053698 seconds and 3 git commands to generate.