]> git.pld-linux.org Git - packages/rpm.git/blob - rpm.spec
- upgraded to 3.0.4
[packages/rpm.git] / rpm.spec
1 Summary:        Red Hat & PLD Package Manager
2 Summary(pl):    Aplikacja do zarz±dzania pakietami
3 Name:           rpm
4 Version:        3.0.4
5 Release:        1
6 Group:          Base
7 Group(pl):      Podstawowe
8 Copyright:      GPL
9 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/%{name}-%{version}.tar.gz
10 Source1:        rpm.groups
11 Source3:        rpm.macros
12 Source5:        rpm-install-tree
13 Patch0:         rpm-rpmrc.patch
14 Patch1:         rpm-find-requires.patch
15 Patch2:         rpm-macros.patch
16 Patch3:         rpm-arch.patch
17 Patch4:         rpm-rpmpopt.patch
18 Patch5:         rpm-find-provides.patch
19 Patch6:         rpm-perl-macros.patch
20 Patch37:        %{name}-short_circuit.patch
21 Patch38:        %{name}-section_test.patch
22 BuildRequires:  bzip2-static
23 BuildRequires:  gdbm-static
24 BuildRequires:  zlib-static
25 BuildRequires:  gettext-devel >= 0.10.38-3
26 BuildRequires:  libtool
27 BuildRequires:  automake
28 BuildRequires:  autoconf >= 2.13-8
29 BuildRequires:  gettext-devel
30 Requires:       glibc >= 2.1
31 BuildRoot:      /tmp/%{name}-%{version}-root
32 Obsoletes:      rpm-libs
33 %define         pyrequires_eq() Requires:       %1 >= %py_ver %1 < %(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
34 RPM is a powerful package manager, which can be used to build, install, 
35 query, verify, update, and uninstall individual software packages. A 
36 package consists of an archive of files, and package information, including 
37 name, version, and description.
38 packages. A package consists of an archive of files, and package
39 nombre, versión y descripción.
40 RPM jest doskona³ym menad¿erem pakietów. Dziêki niemu bêdziesz móg³ przebudowaæ,
41 zainstalowaæ czy zweryfikowaæ dowolny pakiet. Informacje dotycz±ce ka¿dego 
42 pakietu s± przechowywane w bazie danych i dostêpne tylko dla administratora 
43 systemu.
44 przechowywane w bazie danych i mo¿na je uzyskaæ za pomoc± opcji
45 %package libs
46 Summary:        RPM shared libraries
47 Summary(pl):    Biblioteki wspó³dzielone rpm-a
48 Group:          Libraries
49 Group(pl):      Biblioteki
50 Requires:       %{name} = %{version}
51
52 %description libs
53 RPM shared libraries.
54
55 %description -l pl libs
56 Biblioteki wspó³dzielone rpm-a.
57
58 do pacote, permissões dos arquivos, etc.
59 Summary:        Header files and libraries 
60 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne 
61 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne
62 Group(pl):      Programowanie/Biblioteki
63 Requires:       %{name}-libs = %{version}
64 Requires:       %{name} = %{version}
65 Requires:       popt-devel
66
67 %description devel
68 The RPM packaging system includes a C library that makes it easy to
69 manipulate RPM packages and databases. It is intended to ease the
70 creation of graphical package managers and other tools that need
71 %description -l pl devel
72 Pliki nag³ówkowe i biblioteki statyczne.
73 graficznych mened¿erów pakietów oraz innych narzêdzi, które wymagaj±
74 ferramentas que precisem de conhecimento profundo de pacotes RPM.
75
76 Summary(pl):    Biblioteki statyczne rpm-a
77 Summary(pl):    Biblioteki statyczne RPM-a
78 Group(pl):      Programowanie/Biblioteki
79 Summary(pt_BR): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}
82
83 %description static
84 %description -l pl static
85 Biblioteki statyczne rpm-a.
86 %description static -l pl
87 Bibliotecas estáticas para desenvolvimento.
88
89 Summary(pl):    Dodatkowe narzêdzia do zarz±dzanai baz± rpm-a i pakietami
90 Group:          Utilities/File
91 Group(pl):      Narzêdzia/Pliki
92 Summary(pl):    Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami
93 Group:          Applications/File
94 Requires:       %{name} = %{version}
95
96 %description utils
97 %description -l pl utils
98 Dodatkowe narzêdzia do zarz±dzanai baz± rpm-a i pakietami.
99 %description utils -l pl
100 Dodatkowe narzêdzia do zarz±dzania baz± RPM-a i pakietami.
101 Summary:        Additional utilities for check perl provides/requires in rpm packages
102 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl w pakietach rpm
103 Group:          Utilities/File
104 Group(pl):      Narzêdzia/Pliki
105 Summary(pl):    Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w pakietach rpm
106 Requires:       perl-modules
107 Requires:       findutils
108 Additional utilities for check perl provides/requires in rpm packages.
109 Additional utilities for checking perl provides/requires in rpm
110 %description -l pl perlprov
111 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci dla skryptów perl 
112 w pakietach rpm.
113 Dodatkowe narzêdzia do sprawdzenia zale¿no¶ci skryptów perla w
114 Python para manipular pacotes e bancos de dados RPM.
115 Summary:        Scripts to build binary RPMs
116 Summary(pl):    Skrypty pomocnicze do budowania binarnych RPMów
117 Group:          Utilities/File
118 Group(pl):      Narzêdzia/Pliki
119 Summary(pt_BR): Scripts e programas executáveis usados para construir pacotes
120 Requires:       tar
121 Requires:       textutils
122 %description build
123
124 %description -l pl build
125 %description build -l pl
126
127 construir pacotes usando o RPM.
128 %setup  -q
129 %prep
130 %patch1 -p1
131 %patch0 -p1
132 %patch1 -p1
133 %patch4 -p1
134 %patch5 -p1
135 %patch6 -p1 
136 %patch31 -p1
137 install %{SOURCE3} macros.pld.in
138 install %{SOURCE13} macros.python.in
139 (cd scripts; 
140 mv perl.req perl.req.in
141 mv perl.prov perl.prov.in)
142
143 mv -f perl.prov perl.prov.in)
144 LDFLAGS="-s"; export LDFLAGS
145
146 (cd popt;
147  libtoolize --force --copy
148  aclocal
149  autoheader
150  automake --add-missing --gnu
151  autoconf)
152 autoheader
153 %{__automake}
154
155 autoheader
156 automake --add-missing --gnu
157 autoconf
158 %configure \
159         --enable-shared
160 %configure \
161 make
162         --with-python
163
164
165 %{__make} %{?_without_static:rpm_LDFLAGS="\\$(myLDFLAGS)"}
166 install -d $RPM_BUILD_ROOT/var/state/rpm \
167         $RPM_BUILD_ROOT%{_mandir}/{ru,pl}/man8
168
169 make DESTDIR="$RPM_BUILD_ROOT" pkgbindir="%{_bindir}" install
170
171 install macros.pld       $RPM_BUILD_ROOT%{_libdir}/rpm/macros.pld
172 install macros.perl      $RPM_BUILD_ROOT%{_libdir}/rpm/macros.perl
173 install -m755 %{SOURCE5} $RPM_BUILD_ROOT%{_libdir}/rpm/install-build-tree
174         pkgbindir="%{_bindir}"
175
176 install %{SOURCE8} $RPM_BUILD_ROOT%{_libdir}/rpm/find-spec-bcond
177 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
178
179 #%%_install_langs pl_PL:en_US
180 %%distribution PLD
181 EOF
182
183 gzip -9fn $RPM_BUILD_ROOT%{_mandir}/{{ru,pl}/man8/*,man8/*} \
184         RPM-PGP-KEY CHANGES doc/manual/*
185
186 %pre
187 if [ -L /var/state/rpm ]; then
188         echo "WARNING: upgrade cannot be done because /var/state/rpm is symlink"
189         exit 1
190 fi
191 if [ ! -d /var/state/rpm ]; then 
192         if [ -e /var/lib/rpm ] && [ ! -L /var/lib/rpm ]; then
193                 mkdir -p /var/state/rpm
194                 cp -ap /var/lib/rpm/* /var/state/rpm
195                 rm -rf /var/lib/rpm
196                 ln -sf /var/state/rpm /var/lib/rpm
197                 echo "RPM Database moved from /var/lib/rpm to /var/state/rpm" 1>&2
198                 echo "Run second time upgradeing rpm package for complete operation" 1>&2
199                 exit 1
200         fi
201         if [ -e /var/db/rpm ] && [ ! -L /var/db/rpm ]; then
202                 mkdir -p /var/state/rpm
203                 cp -ap /var/db/rpm/* /var/state/rpm
204                 rm -rf /var/db/rpm
205                 ln -sf /var/state/rpm /var/db/rpm
206                 echo "RPM Database moved from /var/db/rpm to /var/state/rpm" 1>&2
207                 echo "Run second time upgradeing rpm package for complete operation" 1>&2
208                 exit 1
209         fi
210 fi
211
212 %post
213 if [ -L /var/lib/rpm ]; then
214         rm -rf /var/lib/rpm
215 fi
216 if [ -L /var/db/rpm ]; then
217         rm -rf /var/db/rpm
218 fi
219 if [ ! -f /var/state/rpm/packages.rpm ]; then
220         /bin/rpm --initdb
221 fi
222
223 %clean
224 rm -rf $RPM_BUILD_ROOT
225
226 rm -rf $RPM_BUILD_ROOT
227
228 %post   -p /sbin/ldconfig
229 %postun -p /sbin/ldconfig
230
231 %attr(755,root,root) %{_libdir}/rpm/rpmdb
232 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
233 %{_mandir}/man8/rpm.8*
234 %lang(pl) %{_mandir}/pl/man8/rpm.8*
235 %lang(ja) %{_mandir}/ja/man8/rpm.8*
236 %lang(ja) %{_mandir}/ja/man8/rpm.8*
237 %dir /var/state/rpm
238 %dir /usr/lib/rpm
239 %lang(ru) %{_mandir}/ru/man8/rpm.8*
240 # przenie¶æ do %%doc
241 #%attr(755,root,root) %{_libdir}/rpm/convertrpmrc.sh
242
243 %dir /var/lib/rpm
244 %{_libdir}/rpm/rpmpopt
245
246 %{_libdir}/rpm/macros.pld
247
248 %ifarch ppc
249 %{_libdir}/rpm/ppc*
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_bindir}/rpmbuild
252 %attr(755,root,root) %{_bindir}/rpmu
253 %attr(755,root,root) %{_libdir}/rpm/freshen.sh
254 %attr(755,root,root) %{_libdir}/rpm/find-requires
255 %attr(755,root,root) %{_libdir}/rpm/find-provides
256 %attr(755,root,root) %{_libdir}/rpm/find-rpm-provides
257 %attr(755,root,root) %{_libdir}/rpm/find-spec-bcond
258 %attr(755,root,root) %{_libdir}/rpm/rpmb
259 %attr(755,root,root) %{_libdir}/rpm/rpmi
260 %attr(755,root,root) %{_libdir}/rpm/rpmt
261 %attr(755,root,root) %{_libdir}/rpm/rpme
262 %attr(755,root,root) %{_libdir}/librpm*.la
263 %attr(755,root,root) %{_libdir}/librpm*.so
264 %files devel
265 %files libs
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/librpm*.so.*.*
268
269 %defattr(644,root,root,755)
270 %{_includedir}/rpm
271 %attr(755,root,root) %{_libdir}/librpm*.la
272 %attr(755,root,root) %{_libdir}/librpm*.so
273
274 %files static
275 %attr(755,root,root) %{_bindir}/*
276 %files utils
277 %defattr(644,root,root,755)
278 %{_mandir}/man8/rpm2cpio.8*
279 %{_mandir}/man1/*
280 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
281 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
282 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
283 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
284 %attr(755,root,root) %{_libdir}/rpm/find-perl-*
285 %attr(755,root,root) %{_libdir}/rpm/find-*.perl
286 %attr(755,root,root) %{_libdir}/rpm/find-prov.pl
287
288
289 %files -n python-rpm
290 * %{date} PLD Team <pld-list@pld.org.pl>
291 %{py_sitedir}/*.so
This page took 0.039379 seconds and 3 git commands to generate.