]> git.pld-linux.org Git - packages/rpm-pld-macros.git/commitdiff
- respect spaces in args
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 29 Apr 2009 06:29:03 +0000 (06:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-build.sh -> 1.58

rpm-build.sh

index ffe07978971791a04e2568ec617a77d85335d2cd..255422c6a9e0cf063103dadef1b367140fe92419 100644 (file)
@@ -276,12 +276,12 @@ d() {
 }
 rpmb() {
        local SPEC SPECDIR
-       for arg in $@; do
+       for arg in "$@"; do
                case "$arg" in
                        *.spec) SPEC="$arg"
                                ;;
                esac
        done
        SPECDIR=$(dirname "$(pwd)/${SPEC:-.}")
-       command rpmbuild --define "_specdir $SPECDIR" --define "_sourcedir $SPECDIR" $@
+       command rpmbuild --define "_specdir $SPECDIR" --define "_sourcedir $SPECDIR" "$@"
 }
This page took 0.696365 seconds and 4 git commands to generate.