]> git.pld-linux.org Git - packages/rpm-pld-macros.git/commitdiff
adjust to build with git auto/th/rpm-build-macros-1.649-2
authorElan Ruusamäe <glen@delfi.ee>
Thu, 2 Aug 2012 19:38:44 +0000 (22:38 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 2 Aug 2012 19:38:44 +0000 (22:38 +0300)
rpm-build-macros.spec
rpm-find-lang
rpm.macros

index 6de164ec6ac35c4a9495efdf3cd91acf049d6408..9f150b04e487124e82e71e8a43177c8b3cf16bd7 100644 (file)
@@ -15,6 +15,7 @@ Source4:      dokuwiki-find-lang.sh
 Patch0:                disable-systemd.patch
 #Patchx: %{name}-pydebuginfo.patch
 BuildRequires: rpm >= 4.4.9-56
+BuildRequires: sed >= 4.0
 Requires:      findutils >= 1:4.2.26
 Provides:      rpmbuild(find_lang) = %{find_lang_rev}
 Provides:      rpmbuild(macros) = %{rpm_macros_rev}
@@ -56,12 +57,14 @@ cp -p %{SOURCE1} .
 %endif
 
 %build
-rev=$(awk '/^#.*Revision:.*Date/{print $3}' rpm.macros)
+%{__sed} -i -e 's,\$Revision\$,%{rpm_macros_rev},' rpm.macros
+
+rev=$(awk '/^%%rpm_build_macros/{print $2}' rpm.macros)
 if [ "$rev" != "%rpm_macros_rev" ]; then
        : Update rpm_macros_rev define to $rev, and retry
        exit 1
 fi
-rev=$(awk '/^#.*Id:.*/{print $4}' %{SOURCE3})
+rev=$(awk -F= '/^VERSION/{print $2}' %{SOURCE3})
 if [ "$rev" != "%find_lang_rev" ]; then
        : Update find_lang_rev define to $rev, and retry
        exit 1
index 12e47cd4721c1a6d52edbb32ed8d03f8a23e1da2..8b440fa563170173873261ed412a928d90c84d3d 100644 (file)
@@ -1,5 +1,4 @@
 #!/bin/sh
-# $Id$
 
 # find-lang - automagically generate list of language specific files
 # for inclusion in an rpm spec file.
@@ -35,7 +34,7 @@
 #   * start support for KDE help files
 
 PROG=${0##*/}
-VERSION=$(set -- $Revision$; echo $2)
+VERSION=1.35
 
 usage () {
 cat <<EOF
index 9bcf7a7d3b57f768f0311ba589eb7b141a799d0c..86a5e2c67d8b0b7e0cd945fefc5cb726147a3225 100644 (file)
@@ -1,11 +1,10 @@
-# $Revision$, $Date$
 # vim:ts=4 sw=4 noet ft=spec
 #
 # PLD Linux rpm macros.
 # <http://www.pld-linux.org/>
 
 # can be used by builder script to check for version
-%rpm_build_macros      %(R="$Revision$"; RR="${R##: }"; echo ${RR%%?})
+%rpm_build_macros      $Revision$
 
 %epoch         0
 %x8664         x86_64 amd64 ia32e
This page took 0.066747 seconds and 4 git commands to generate.