]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - shrc.sh
adapter updates
[packages/rpm-build-tools.git] / shrc.sh
diff --git a/shrc.sh b/shrc.sh
index 5210ecee851a2ba23db51ad6c6476ca36be37422..e20d20c607fbcf6ed3f45df011fb5f6724b38bbe 100755 (executable)
--- a/shrc.sh
+++ b/shrc.sh
@@ -194,7 +194,7 @@ get-buildlog() {
 fi # no $dist set
 
 alias adif="dif -x '*.m4' -x ltmain.sh -x install-sh -x depcomp -x 'Makefile.in' -x compile -x 'config.*' -x configure -x missing -x mkinstalldirs -x autom4te.cache"
-alias pclean="sed -i~ -e '/^\(?\|=\+$\|unchanged:\|diff\|only\|Only\|Tylko\|Files\|Common\|Index:\|RCS file\|retrieving\)/d'"
+alias pclean="sed -i~ -e '/^\(?\|=\+$\|unchanged:\|diff\|only\|Only\|Tylko\|Binary files\|Files\|Common\|index \|Index:\|RCS file\|retrieving\)/d'"
 
 # merges two patches
 # requires: patchutils
@@ -262,81 +262,3 @@ d() {
 rpm2spec() {
        sed -re 's,^(.+)-[^-]+-[^-]+$,\1.spec,'
 }
-
-
-#
-# A colorized bash prompt
-# - shows curret branch
-# - shows if branch is up to date/ahead/behind
-# - shows if last command exited with error (red)
-#
-# To use it, set $PROMPT_COMMAND env var:
-# PROMPT_COMMAND=__bash_prompt_command
-#
-__bash_prompt_command() {
-       local previous_return_value=$?
-
-       local RED="\[\033[0;31m\]"
-       local YELLOW="\[\033[0;33m\]"
-       local GREEN="\[\033[0;32m\]"
-       local BLUE="\[\033[0;34m\]"
-       local LIGHT_RED="\[\033[1;31m\]"
-       local LIGHT_GREEN="\[\033[1;32m\]"
-       local WHITE="\[\033[1;37m\]"
-       local LIGHT_GRAY="\[\033[0;37m\]"
-       local COLOR_NONE="\[\e[0m\]"
-
-       local rpmver=$(__package_rpmversion)
-       local prompt="${BLUE}[${RED}\w${GREEN}${rpmver:+($rpmver)}$(parse_git_branch)${BLUE}]${COLOR_NONE} "
-       if [ $previous_return_value -eq 0 ]; then
-               PS1="${prompt}➔ "
-       else
-               PS1="${prompt}${RED}➔${COLOR_NONE} "
-       fi
-}
-
-# helper for __bash_prompt_command
-# command line (git) coloring
-# note we use "\" here to avoid any "git" previous alias/func
-__bash_parse_git_branch() {
-       # not in git dir. return early
-       \git rev-parse --git-dir &> /dev/null || return
-
-       local git_status branch_pattern remote_pattern diverge_pattern
-       local state remote branch
-
-       git_status=$(\git -c color.ui=no status 2> /dev/null)
-       branch_pattern="^On branch ([^${IFS}]*)"
-       remote_pattern="Your branch is (behind|ahead) "
-       diverge_pattern="Your branch and (.*) have diverged"
-
-       if [[ ! ${git_status} =~ "working directory clean" ]]; then
-               state="${RED}⚡"
-       fi
-
-       # add an else if or two here if you want to get more specific
-       if [[ ${git_status} =~ ${remote_pattern} ]]; then
-               if [[ ${BASH_REMATCH[1]} == "ahead" ]]; then
-                       remote="${YELLOW}↑"
-               else
-                       remote="${YELLOW}↓"
-               fi
-       fi
-
-       if [[ ${git_status} =~ ${diverge_pattern} ]]; then
-               remote="${YELLOW}↕"
-       fi
-
-       if [[ ${git_status} =~ ${branch_pattern} ]]; then
-               branch=${BASH_REMATCH[1]}
-               echo " (${branch})${remote}${state}"
-       fi
-}
-
-# if we are in rpm subdir and have exactly one .spec in the dir, include package version
-__package_rpmversion() {
-       if [[ $PWD =~ $(rpm -E %_topdir) ]] && [ "$(\ls *.spec 2>/dev/null | wc -w)" = 1 ]; then
-               # give only first version (ignore subpackages)
-               rpm --define "_specdir $PWD" --specfile *.spec -q --qf '%{VERSION}\n' | head -n1
-       fi
-}
This page took 0.058566 seconds and 4 git commands to generate.