]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - rpm-build.sh
- known pkgs which can't be fixed
[packages/rpm-build-tools.git] / rpm-build.sh
index 1a976c00bcf01e6bf2b2e19e7f25613a1eaaf02b..0cdc432b7cd2f2ad57c1b4c40dcb14da9ae3d61b 100644 (file)
@@ -1,24 +1,63 @@
 # shell aliases and functions for PLD Developer
 # $Id$
 
+# set $dist, used by functions below
+[ -n "$dist" ] || dist=$(awk '/PLD Linux/ {print tolower($NF)}' /etc/pld-release 2>/dev/null | tr -d '()')
+
+case "$dist" in
+ac|th)
+       ;;
+*)
+       # invalid one ;)
+       dist=
+esac
+
+if [ "$dist" ]; then
+
+alias ipoldek-$dist="poldek -q --sn $dist --cmd"
+alias $dist-requires="ipoldek-$dist what-requires"
+alias $dist-provides="ipoldek-$dist what-provides"
+alias $dist-tag="./builder -cf -T $(echo $dist | tr '[a-z]' '[A-Z]')-branch -r HEAD"
+alias $dist-verify=dist-verify
+
+# undo spec utf8
+# note: it will do it blindly, so any lang other than -pl is most likely broken
+specutfundo() {
+       local spec="$1"
+       iconv -futf8 -tlatin2 "$spec" > m
+       sed -e 's/\.UTF-8//' m > "$spec"
+       rm -f m
+}
+
+dist-verify() {
+       case "$dist" in
+       ac)
+               args='--ignore=kdenetwork-kopete-tool-conectionstatus --ignore=gimp-plugin-swfdec --ignore=wine-drv-arts'
+               ;;
+       esac
+
+       poldek --sn $dist --sn $dist-ready --sn $dist-updates --up
+       poldek --sn $dist --sn $dist-ready --sn $dist-updates --noignore --verify=deps $args "$@"
+}
+
+# displays latest used tag for a specfile
+autotag() {
+       local out
+       for a in "$@"; do
+               s=${a%.spec}.spec
+               out=$(cvs status -v $s | awk "/auto-$dist-/{if (!a++) print \$1}")
+               echo "$s:$out"
+       done
+}
+
+fi # no $dist set
+
 alias cv='cvs status -v'
-alias ac='poldek -q --sn ac --cmd'
-alias ac-requires='ac what-requires'
-alias ac-provides='ac what-provides'
-alias ac-verify='poldek --sn ac --sn ac-ready --verify=deps'
-alias ac-tag='./builder -cf -T AC-branch -r HEAD'
 alias adif="dif -x '*.m4' -x ltmain.sh -x install-sh -x depcomp -x 'Makefile.in' -x compile -x 'config.*' -x configure -x missing -x mkinstalldirs -x autom4te.cache"
 alias pclean="sed -i~ -e '/^\(?\|=\+$\|unchanged:\|diff\|only\|Only\|Files\|Common\|Index:\|RCS file\|retrieving\)/d'"
 
-# merges two patches
-# requires: patchutils
-pmerge() {
-       combinediff -p1 $1 $2 > m.patch || return
-       pclean m.patch
-       dif $1 m.patch
-}
-
 # makes diff from PLD CVS urls
+# requires: cvs, tee
 urldiff() {
        local url="$1"
        if [ -z "$url" ]; then
@@ -33,7 +72,7 @@ urldiff() {
        file=${file##*/}
        local r1=${file#*r1=}
        local r2=${r1#*r2=}
-       r2=${r2%[&;]*}
+       r2=${r2%%[&;]*}
        r1=${r1%%[&;]*}
        file=${file%\?*}
        file=${file%.diff}
@@ -47,10 +86,42 @@ urldiff() {
        fi
 }
 
+# makes diff from kde svn path
+# requires: wget, tee
+kdediff() {
+       local url="$1"
+       # --- branches/KDE/3.5/kdepim/kpilot/conduits/vcalconduit/vcalRecord.cc #624744:624745
+       url=${url#*--- }
+       echo >&2 "Process $url"
+       r1=${url#*#}
+       r2=${r1#*:}
+       r1=${r1%:*}
+
+       #  http://websvn.kde.org/branches/KDE/3.5/kdepim/kpilot/conduits/vcalconduit/vcalRecord.cc?rev=624745&r1=612579&r2=624745&makepatch=1&diff_format=u
+       url=http://websvn.kde.org/${url% *}
+       url="$url?r1=$r1&r2=$r2&makepatch=1&diff_format=u"
+
+       if [ -t 1 ]; then
+               wget "$url" -O -| tee m.patch | diffcol
+       else
+               wget "$url" -O -
+       fi
+}
+
+# merges two patches
+# requires: patchutils
+pmerge() {
+       combinediff -p1 $1 $2 > m.patch || return
+       pclean m.patch
+       dif $1 m.patch
+}
+
 # downloads sourceforge url from specific mirror
 sfget() {
        local url="$1"
        url="${url%?download}"
+       url="${url%?use_mirror=*}"
+       url="${url#http://downloads.}"
        url="http://dl.${url#http://prdownloads.}"
        # use mirror
        local mirror="http://nchc.dl.sourceforge.net"
@@ -58,16 +129,6 @@ sfget() {
        wget -c "$url"
 }
 
-# displays latest used tag for a specfile
-autotag() {
-       local out
-       for a in "$@"; do
-               s=${a%.spec}.spec
-               out=$(cvs status -v $s | awk '/auto-ac-/{if (!a++) print $1}')
-               echo "$s:$out"
-       done
-}
-
 dif() {
        if [ -t 1 ]; then
                diff -ur "$@" | diffcol | less -R
@@ -98,3 +159,21 @@ cvslog() {
        [ "$d" = "$f" ] && d=.
        (builtin cd $d && cvs log ${f##*/})
 }
+
+# does diff between FILE and FILE~
+# the diff can be applied with patch -p1
+d() {
+       local file="$1"
+       local dir
+       if [[ "$file" = /* ]]; then
+               # full path -- no idea where to strip
+               dir=.
+               diff=$file
+       else
+               # relative path -- keep one path component from current dir
+               dir=..
+               diff=${PWD##*/}/${file}
+       fi
+
+       (builtin cd "$dir"; dif $diff{~,})
+}
This page took 0.123928 seconds and 4 git commands to generate.