]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - pearize.sh
- egrep is deprecated
[packages/rpm-build-tools.git] / pearize.sh
index bbfea5c5756a54545734ce904e1a51cbeebfdba6..12f8030609c3c82436f422db476ab916751876c9 100644 (file)
@@ -4,11 +4,18 @@
 # it is still better than nothing. if somebody wishes to add sorting in this
 # script. i'd be just glad :)
 #
-# needs 'pear' for 'pear makerpm' command, ./builder for fetching sources.
+# needs 'pear' for 'pear make-rpm-spec' command, ./builder for fetching sources.
 # You should have all PEAR packages installed to get best results (needed for epoch autodetection)
 #
-# todo: adjust similiarily noautoreqdeps
-# bugs: the beta portions in version deps could be wrong (php-4.3.0b1 and alike)
+# To create completely new PEAR package spec, follow something like this:
+# $ pear download RDF-alpha
+# File RDF-0.1.0alpha1.tgz downloaded
+# $ pear make-rpm-spec RDF-0.1.0alpha1.tgz
+# Wrote RPM spec file php-pear-RDF.spec
+# $
+#
+# TODO: adjust similiarily noautoreqdeps
+# BUGS: the beta portions in version deps could be wrong (php-4.3.0b1 and alike)
 # see php-pear-DBA_Relational.spec
 # Something strange: Requires: php-common < 4:3:5.1
 #
@@ -121,6 +128,9 @@ optional=$(grep '^Optional:' $template || :)
 if [ -n "$optional" ]; then
        echo "$optional" | while read tag dep; do
                for req in $dep; do
+                       # strip single quotes that default template includes in @optional@ expand
+                       # TODO: remove in php-pear-PEAR_Command_Packaging package
+                       req=${req#\'} req=${req%\'}
                        m=$(grep "^%define.*_noautoreq" $spec || :)
                        if [ -z "$m" ]; then
                                sed -i -e "/^BuildRoot:/{
@@ -138,7 +148,7 @@ if [ -n "$optional" ]; then
                done
        done
 fi
-has_opt=$(egrep -c '^Optional-(pkg|ext):' $template || :)
+has_opt=$(grep -Ec '^Optional-(pkg|ext):' $template || :)
 if [ "$has_opt" -gt 0 ]; then
        if ! grep -q '%{_docdir}/.*/optional-packages.txt' $spec; then
                sed -i -e '
This page took 0.037456 seconds and 4 git commands to generate.