]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - kde4devel2head.sh
When tripping over a GIT_ var, give a useful error
[packages/rpm-build-tools.git] / kde4devel2head.sh
old mode 100644 (file)
new mode 100755 (executable)
index d39dbb2..0006c82
@@ -2,7 +2,7 @@
 # merge kde4@DEVEL with kde4@HEAD - actually it replaces HEAD with DEVEL
 # so the actual merge must be done earlier manually.
 #
-# Author: Bartosz Swiatek (shadzik@pld-linux.org)
+# Author: Bartosz Świątek (shadzik@pld-linux.org)
 #
 # TODO:
 # - find a way to automatically detect whether to merge _all_ patches, or which to merge and which don't
@@ -10,7 +10,7 @@
 usage() {
        echo "Usage: $0 [-b] [-d] [-h] kde4-kdemodule[.spec]"
        echo ""
-       echo "-b => merge also the branchdiff"
+       echo "-b => move also the branchdiff"
        echo "-d => debug mode \(set +e\)"
        echo "-h => show this help"
        echo ""
@@ -64,7 +64,7 @@ mv /tmp/$kde4spec-dev packages/$PKG/$kde4spec
 echo "Changing to stable"
 sed -i -e 's/unstable/stable/g' packages/$PKG/$kde4spec
 echo "Done, seding"
-cvs ci -m "- merged from DEVEL" packages/$PKG/$kde4spec
+cvs ci -m "- moved from DEVEL" packages/$PKG/$kde4spec
 echo "Deleting DEVEL branch from spec"
 cvs tag -B -d DEVEL packages/$PKG/$kde4spec
 
@@ -73,7 +73,7 @@ if [ "x$BRANCHDIFF" == "xyes" ]; then
        mv packages/$PKG/$PKG-branch.diff /tmp/$PKG-branch.diff-dev
        cvs get packages/$PKG/$PKG-branch.diff
        mv /tmp/$PKG-branch.diff-dev packages/$PKG/$PKG-branch.diff
-       cvs ci -m "- merged from DEVEL" packages/$PKG/$PKG-branch.diff
+       cvs ci -m "- moved from DEVEL" packages/$PKG/$PKG-branch.diff
        echo "Deleting DEVEL branch from branchdiff"
        cvs tag -B -d DEVEL packages/$PKG/$PKG-branch.diff
 fi
This page took 0.06559 seconds and 4 git commands to generate.