]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - compile.sh
- bump copyright year
[packages/rpm-build-tools.git] / compile.sh
old mode 100644 (file)
new mode 100755 (executable)
index 59b915d..8aa5607
@@ -2,15 +2,24 @@
 # will build package, skipping %prep and %build stage
 # i use it a lot!
 #
+# Usage:
+# make only %build stage (i.e. after %prep has been done), for example after
+# modifying some sources for more complicated specs whose %build is not just
+# %{__make}:
+# SPECS$ ./compile.sh kdelibs.spec
+#
+# See also: SPECS/repackage.sh
+#
 # -glen 2005-03-03
 
-set -e
-
-rpmbuild() {
-       set -x
-       # i'd use ./builder to get all the ~/.bcondrc parsing,
-    # but builder doesn't understand -bi
-#      ./builder -ncs -nc -nn --opts --short-circuit "$@"
-       command rpmbuild --short-circuit "$@" || exit
-}
-rpmbuild -bc "$@"
+dir=$(dirname "$0")
+if [ $# = 0 ]; then
+       # if no spec name passed, glob *.spec
+       set -- *.spec
+       if [ ! -f "$1" -o $# -gt 1 ]; then
+               echo >&2 "ERROR: Too many or too few .spec files found"
+               echo >&2 "Usage: ${0##*/} PACKAGE.spec"
+               exit 1
+       fi
+fi
+exec $dir/builder --no-md5 -ncs -nn --short-circuit -bc "$@"
This page took 0.027188 seconds and 4 git commands to generate.