]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - builder.sh
- also update NoSource md5
[packages/rpm-build-tools.git] / builder.sh
index 414cee859c39c10553768fcdb381b43c3bdae1b5..e1e1ce1cd638b07885326de9d37f774629b86264 100644 (file)
@@ -39,7 +39,6 @@ NOCVSSPEC=""
 NODIST=""
 NOINIT=""
 UPDATE=""
-UPDATE5=""
 ADD5=""
 NO5=""
 ALWAYS_CVSUP=${ALWAYS_CVSUP:-"yes"}
@@ -79,6 +78,7 @@ CVS_RETRIES=${MAX_CVS_RETRIES:-1000}
 
 CVSTAG=""
 RES_FILE=""
+CVS_FORCE=""
 
 CVS_SERVER="cvs.pld-linux.org"
 DISTFILES_SERVER="://distfiles.pld-linux.org"
@@ -92,6 +92,10 @@ FAIL_IF_NO_SOURCES="yes"
 # let get_files skip over files which are present to get those damn files fetched
 SKIP_EXISTING_FILES="no"
 
+TRY_UPGRADE=""
+# should the specfile be restored if upgrade failed?
+REVERT_BROKEN_UPGRADE="yes"
+
 if [ -x /usr/bin/rpm-getdeps ]; then
        FETCH_BUILD_REQUIRES_RPMGETDEPS="yes"
 else
@@ -189,13 +193,11 @@ usage()
        if [ -n "$DEBUG" ]; then set -xv; fi
        echo "\
 Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
-
 [-bb|--build-binary] [-bs|--build-source] [-u|--try-upgrade]
-[{-B|--branch} <branch>] [{-d|--cvsroot} <cvsroot>] [-g|--get]
-[-h|--help] [--http] [{-l,--logtofile} <logfile>] [-m|--mr-proper]
+[{-cf|--cvs-force}] [{-B|--branch} <branch>] [{-d|--cvsroot} <cvsroot>] 
+[-g|--get] [-h|--help] [--http] [{-l,--logtofile} <logfile>] [-m|--mr-proper]
 [-q|--quiet] [--date <yyyy-mm-dd> [-r <cvstag>] [{-T--tag <cvstag>]
-[-Tvs|--tag-version-stable] [-Tvn|--tag-version-nest]
-[-Ts|--tag-stable] [-Tn|--tag-nest] [-Tv|--tag-version]
+[-Tvs|--tag-version-stable] [-Ts|--tag-stable] [-Tv|--tag-version]
 [{-Tp|--tag-prefix} <prefix>] [{-tt|--test-tag}]
 [-nu|--no-urls] [-v|--verbose] [--opts <rpm opts>] [--show-bconds]
 [--with/--without <feature>] [--define <macro> <value>] <package>[.spec][:cvstag]
@@ -220,6 +222,7 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
 -B, --branch        - add branch
 -c, --clean         - clean all temporarily created files (in BUILD, SOURCES,
                       SPECS and \$RPM_BUILD_ROOT),
+-cf, --cvs-force       - use -F when tagging (useful when moving branches)
 -d <cvsroot>, --cvsroot <cvsroot>
                     - setup \$CVSROOT,
 --define <macro> <value>
@@ -277,12 +280,8 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
                     - add cvs tag <cvstag> for files,
 -Tvs, --tag-version-stable
                     - add cvs tags STABLE and NAME-VERSION-RELEASE for files,
--Tvn, --tag-version-nest
-                    - add cvs tags NEST and NAME-VERSION-RELEASE for files,
 -Ts, --tag-stable
                     - add cvs tag STABLE for files,
--Tn, --tag-nest
-                    - add cvs tag NEST for files,
 -Tv, --tag-version
                     - add cvs tag NAME-VERSION-RELEASE for files,
 -Tp, --tag-prefix <prefix>
@@ -360,10 +359,10 @@ set_spec_target() {
 }
 
 cache_rpm_dump () {
-        if [ -n "$DEBUG" ]; then
-                 set -x;
-                 set -v;
-        fi
+       if [ -n "$DEBUG" ]; then
+               set -x;
+               set -v;
+       fi
 
        update_shell_title "cache_rpm_dump"
        local rpm_dump
@@ -396,6 +395,8 @@ cache_rpm_dump () {
 %php_major_version ERROR
 %php_api_version ERROR
 %py_ver ERROR
+%perl_vendorarch ERROR
+%perl_vendorlib ERROR
 EOF
        case "$RPMBUILD" in
        rpm)
@@ -432,7 +433,7 @@ EOF
 
 rpm_dump () {
        if [ -z "$rpm_dump_cache" ] ; then
-               echo "internal error: cache_rpm_dump not called!" 1>&2
+               echo "internal error: cache_rpm_dump not called! (missing %prep?)" 1>&2
        fi
        echo "$rpm_dump_cache"
 }
@@ -445,7 +446,7 @@ get_icons()
                return
        fi
 
-       rpm_dump_cache="kalasaba" NODIST="yes" UPDATE5= get_files $ICONS
+       rpm_dump_cache="kalasaba" NODIST="yes" get_files $ICONS
 }
 
 parse_spec()
@@ -540,8 +541,8 @@ Exit_error()
                        exit 11 ;;
 
        esac
-   echo "Unknown error."
-   exit 100
+       echo "Unknown error."
+       exit 100
 }
 
 init_builder()
@@ -670,7 +671,7 @@ src_md5()
                # we have empty SourceX-md5, but it is still possible
                # that we have NoSourceX-md5 AND NoSource: X
                nosource_md5=`grep -i "#[        ]*NoSource$no-md5[      ]*:" $SPECFILE | sed -e 's/.*://'`
-               if [ ! -z "$nosource_md5" -a -n "`grep -i "^NoSource:[   ]*$no$" $SPECFILE`" ] ; then
+               if [ -n "$nosource_md5" -a -n "`grep -i "^NoSource:[     ]*$no$" $SPECFILE`" ] ; then
                        echo $nosource_md5
                fi
        fi
@@ -759,6 +760,89 @@ cvsup()
        return $result
 }
 
+# returns true if "$1" is ftp, http or https protocol url
+is_url()
+{
+       case "$1" in
+       ftp://*|http://*|https://*)
+               return 0
+       ;;
+       esac
+       return 1
+}
+
+update_md5()
+{
+       if [ $# -eq 0 ]; then
+               return
+       fi
+
+       update_shell_title "update md5"
+       if [ -n "$DEBUG" ]; then
+               set -x;
+               set -v;
+       fi
+
+       cd "$SOURCE_DIR"
+
+       # pass 1: check files to be fetched
+       local todo
+       local need_files
+       for i in "$@"; do
+               local fp=$(nourl "$i")
+               local srcno=$(src_no "$i")
+               if [ -n "$ADD5" ]; then
+                       [ "$fp" = "$i" ] && continue # FIXME what is this check doing?
+                       grep -qiE '^#[  ]*Source'$srcno'-md5[   ]*:' $SPECS_DIR/$SPECFILE && continue
+               else
+                       grep -qiE '^#[  ]*Source'$srcno'-md5[   ]*:' $SPECS_DIR/$SPECFILE || continue
+               fi
+               if [ ! -f "$fp" ] || [ $ALWAYS_CVSUP = "yes" ]; then
+                       need_files="$need_files $i"
+               fi
+       done
+
+       # pass 1a: get needed files
+       if [ "$need_files" ]; then
+               get_files $need_files
+       fi
+
+       # pass 2: proceed with md5 adding or updating
+       for i in "$@"; do
+               local fp=$(nourl "$i")
+               local srcno=$(src_no "$i")
+               local md5=$(grep -iE '^#[       ]*(No)?Source'$srcno'-md5[      ]*:' $SPECS_DIR/$SPECFILE )
+               if [ -n "$ADD5" ] && is_url $i || [ -n "$md5" ]; then
+                       local tag="Source$srcno-md5"
+                       if [[ "$md5" == *NoSource* ]]; then
+                               tag="NoSource$srcno-md5"
+                       fi
+                       md5=$(md5sum "$fp" | cut -f1 -d' ')
+                       echo "Updating $tag ($md5)."
+                       perl -i -ne '
+                               print unless /^\s*#\s*(No)?Source'$srcno'-md5\s*:/i;
+                               print "# '$tag':\t'$md5'\n" if /^Source'$srcno'\s*:\s+/;
+                       ' \
+                       $SPECS_DIR/$SPECFILE
+               fi
+       done
+}
+
+check_md5()
+{
+       update_shell_title "check md5"
+
+       for i in "$@"; do
+               if good_md5 "$i" && good_size "$i"; then
+                       continue
+               fi
+
+               echo "MD5 sum mismatch or 0 size.  Use -U to refetch sources,"
+               echo "or -5 to update md5 sums, if you're sure files are correct."
+               Exit_error err_no_source_in_repo $i
+       done
+}
+
 get_files()
 {
        update_shell_title "get_files"
@@ -784,20 +868,18 @@ get_files()
                        SHELL_TITLE_PREFIX="get_files[$nc/$#]"
                        update_shell_title "$i"
                        local fp=`nourl "$i"`
-                       if [ -f "$fp" ] && [ "$SKIP_EXISTING_FILES" = "yes" ]; then
+                       if [ "$SKIP_EXISTING_FILES" = "yes" ] && [ -f "$fp" ]; then
                                continue
                        fi
-                       local srcno=$(src_no $i)
-                       if [ -n "$UPDATE5" ]; then
-                               if [ -n "$ADD5" ]; then
-                                       [ "$fp" = "$i" ] && continue
-                                       grep -qiE '^#[  ]*Source'$srcno'-md5[   ]*:' $SPECS_DIR/$SPECFILE && continue
-                               else
-                                       grep -qiE '^#[  ]*Source'$srcno'-md5[   ]*:' $SPECS_DIR/$SPECFILE || continue
-                               fi
-                       fi
+
                        FROM_DISTFILES=0
                        local srcmd5=$(src_md5 "$i")
+
+                       # we know if source/patch is present in cvs/distfiles
+                       # - has md5 (in distfiles)
+                       # - in cvs... ideas?
+
+                       # CHECK: local file didn't exist or always cvs up (first) requested.
                        if [ ! -f "$fp" ] || [ $ALWAYS_CVSUP = "yes" ]; then
                                if echo $i | grep -vE '(http|ftp|https|cvs|svn)://' | grep -qE '\.(gz|bz2)$']; then
                                        echo "Warning: no URL given for $i"
@@ -812,7 +894,8 @@ get_files()
                                        url=$(distfiles_url "$i")
                                        url_attic=$(distfiles_attic_url "$i")
                                        FROM_DISTFILES=1
-                                       if [ "`echo $url | grep -E '^(\.|/)'`" ]; then
+                                       # is $url local file?
+                                       if [[ "$url" = [./]* ]]; then
                                                update_shell_title "${GETLOCAL%% *}: $url"
                                                ${GETLOCAL} $url $target
                                        else
@@ -826,7 +909,9 @@ get_files()
                                                        ${GETURI2} ${OUTFILEOPT} "$target" "$url"
                                                fi
                                        fi
-                                       if ! test -s "$target"; then
+
+                                       # is it empty file?
+                                       if [ ! -s "$target" ]; then
                                                rm -f "$target"
                                                if [ `echo $url_attic | grep -E '^(\.|/)'` ]; then
                                                        update_shell_title "${GETLOCAL%% *}: $url_attic"
@@ -843,7 +928,8 @@ get_files()
                                                        fi
                                                fi
                                        fi
-                                       if test -s "$target"; then
+
+                                       if [ -s "$target" ]; then
                                                cvsignore_df $target
                                        else
                                                rm -f "$target"
@@ -878,23 +964,13 @@ get_files()
                                fi
 
                        fi
+
+                       # the md5 check must be moved elsewhere as if we've called from update_md5 the md5 is wrong.
                        if [ ! -f "$fp" -a "$FAIL_IF_NO_SOURCES" != "no" ]; then
                                Exit_error err_no_source_in_repo $i;
-                       elif [ -n "$UPDATE5" ] && \
-                               ( ( [ -n "$ADD5" ] && echo $i | grep -q -E 'ftp://|http://|https://' && \
-                               [ -z "$(grep -E -i '^NoSource[  ]*:[    ]*'$i'([        ]|$)' $SPECS_DIR/$SPECFILE)" ] ) || \
-                               grep -q -i -E '^#[      ]*source'$srcno'-md5[   ]*:' $SPECS_DIR/$SPECFILE )
-                       then
-                               echo "Updating source-$srcno md5."
-                               md5=$(md5sum "$fp" | cut -f1 -d' ')
-                               perl -i -ne '
-                               print unless /^\s*#\s*Source'$srcno'-md5\s*:/i;
-                               print "# Source'$srcno'-md5:\t'$md5'\n"
-                               if /^Source'$srcno'\s*:\s+/;
-                               ' \
-                               $SPECS_DIR/$SPECFILE
                        fi
 
+                       # we check md5 here just only to refetch immediately
                        if good_md5 "$i" && good_size "$i"; then
                                :
                        elif [ "$FROM_DISTFILES" = 1 ]; then
@@ -909,7 +985,7 @@ get_files()
                                        update_shell_title "${GETURI2%% *}: $url"
                                        ${GETURI2} ${OUTFILEOPT} "$target" "$url"
                                fi
-                               if ! test -s "$target"; then
+                               if [ ! -s "$target" ]; then
                                        rm -f "$target"
                                        update_shell_title "${GETURI%% *}: $url_attic"
                                        ${GETURI} ${OUTFILEOPT} "$target" "$url_attic" || \
@@ -920,14 +996,6 @@ get_files()
                                fi
                                test -s "$target" || rm -f "$target"
                        fi
-
-                       if good_md5 "$i" && good_size "$i" ; then
-                               :
-                       else
-                               echo "MD5 sum mismatch or 0 size.  Use -U to refetch sources,"
-                               echo "or -5 to update md5 sums, if you're sure files are correct."
-                               Exit_error err_no_source_in_repo $i
-                       fi
                done
                SHELL_TITLE_PREFIX=""
 
@@ -970,50 +1038,55 @@ tag_files()
                set -v;
        fi
 
-       if [ -n "$1$2$3$4$5$6$7$8$9${10}" ]; then
-               echo "Version: $PACKAGE_VERSION"
-               echo "Release: $PACKAGE_RELEASE"
+       echo "Version: $PACKAGE_VERSION"
+       echo "Release: $PACKAGE_RELEASE"
 
-               TAGVER=`make_tagver`
+       TAGVER=`make_tagver`
 
-               if [ "$TAG_VERSION" = "yes" ]; then
-                       echo "CVS tag: $TAGVER"
-               fi
-               if [ -n "$TAG" ]; then
-                       echo "CVS tag: $TAG"
-               fi
+       if [ "$TAG_VERSION" = "yes" ]; then
+               echo "CVS tag: $TAGVER"
+       fi
+       if [ -n "$TAG" ]; then
+               echo "CVS tag: $TAG"
+       fi
 
-               OPTIONS="tag -F"
-               if [ -n "$CVSROOT" ]; then
-                       OPTIONS="-d $CVSROOT $OPTIONS"
-               fi
+       local OPTIONS="tag $CVS_FORCE"
+       if [ -n "$CVSROOT" ]; then
+               OPTIONS="-d $CVSROOT $OPTIONS"
+       fi
 
-               cd "$SOURCE_DIR"
-               for i in $TAG_FILES
-               do
-                       # don't tag files stored on distfiles
-                       [ -n "`src_md5 $i`" ] && continue
-                       if [ -f "`nourl $i`" ]; then
-                               if [ "$TAG_VERSION" = "yes" ]; then
-                                       cvs $OPTIONS $TAGVER `nourl $i`
-                               fi
-                               if [ -n "$TAG" ]; then
-                                       cvs $OPTIONS $TAG `nourl $i`
-                               fi
-                       else
-                               Exit_error err_no_source_in_repo $i
-                       fi
-               done
+       cd "$SOURCE_DIR"
+       local tag_files
+       for i in $TAG_FILES; do
+               # don't tag files stored on distfiles
+               [ -n "`src_md5 $i`" ] && continue
+               local fp=`nourl "$i"`
+               if [ -f "$fp" ]; then
+                       tag_files="$tag_files $fp"
+               else
+                       Exit_error err_no_source_in_repo $i
+               fi
+       done
 
-               cd "$SPECS_DIR"
+       if [ "$tag_files" ]; then
                if [ "$TAG_VERSION" = "yes" ]; then
-                       cvs $OPTIONS $TAGVER $SPECFILE
+                       update_shell_title "tag sources: $TAGVER"
+                       cvs $OPTIONS $TAGVER $tag_files
                fi
                if [ -n "$TAG" ]; then
-                       cvs $OPTIONS $TAG $SPECFILE
+                       update_shell_title "tag sources: $TAG"
+                       cvs $OPTIONS $TAG $tag_files
                fi
+       fi
 
-               unset OPTIONS
+       cd "$SPECS_DIR"
+       if [ "$TAG_VERSION" = "yes" ]; then
+               update_shell_title "tag spec: $TAGVER"
+               cvs $OPTIONS $TAGVER $SPECFILE
+       fi
+       if [ -n "$TAG" ]; then
+               update_shell_title "tag spec: $TAG"
+               cvs $OPTIONS $TAG $SPECFILE
        fi
 }
 
@@ -1030,26 +1103,26 @@ branch_files()
                set -v;
        fi
 
-       if [ -n "$1$2$3$4$5$6$7$8$9${10}" ]; then
-
-               OPTIONS="tag -b"
-               if [ -n "$CVSROOT" ]; then
-                       OPTIONS="-d $CVSROOT $OPTIONS"
+       local OPTIONS="tag $CVS_FORCE -b"
+       if [ -n "$CVSROOT" ]; then
+               OPTIONS="-d $CVSROOT $OPTIONS"
+       fi
+       cd "$SOURCE_DIR"
+       local tag_files
+       for i in $TAG_FILES; do
+               local fp=`nourl "$i"`
+               if [ -f "$fp" ]; then
+                       tag_files="$tag_files $fp"
+               else
+                       Exit_error err_no_source_in_repo $i
                fi
-               cd "$SOURCE_DIR"
-               for i in $TAG_FILES
-               do
-                       if [ -f `nourl $i` ]; then
-                               cvs $OPTIONS $TAG `nourl $i`
-                       else
-                               Exit_error err_no_source_in_repo $i
-                       fi
-               done
-               cd "$SPECS_DIR"
-               cvs $OPTIONS $TAG $SPECFILE
-
-               unset OPTIONS
+       done
+       if [ "$tag_files" ]; then
+               cvs $OPTIONS $TAG $tag_files
        fi
+
+       cd "$SPECS_DIR"
+       cvs $OPTIONS $TAG $SPECFILE
 }
 
 
@@ -1077,12 +1150,16 @@ build_package()
                if [ -n "$TNEWVER" ]; then
                        TOLDVER=`echo $TNOTIFY | awk '{ print $3; }'`
                        echo "New version found, updating spec file to version " $TNEWVER
-                       cp -f $SPECFILE $SPECFILE.bak
+                       if [ "$REVERT_BROKEN_UPGRADE" = "yes" ]; then
+                               cp -f $SPECFILE $SPECFILE.bak
+                       fi
                        chmod +w $SPECFILE
                        eval "perl -pi -e 's/Version:\t"$TOLDVER"/Version:\t"$TNEWVER"/gs' $SPECFILE"
                        eval "perl -pi -e 's/Release:\t[1-9]{0,4}/Release:\t0.1/' $SPECFILE"
                        parse_spec;
-                       NODIST="yes" UPDATE5="yes" get_files $SOURCES $PATCHES;
+                       NODIST="yes" get_files $SOURCES $PATCHES;
+                       update_md5 $SOURCES
+
                        unset TOLDVER TNEWVER TNOTIFY
                fi
        fi
@@ -1128,7 +1205,9 @@ build_package()
        if [ "$RETVAL" -ne "0" ]; then
                if [ -n "$TRY_UPGRADE" ]; then
                        echo "\n!!! Package with new version cannot be built automagically\n"
-                       mv -f $SPECFILE.bak $SPECFILE
+                       if [ "$REVERT_BROKEN_UPGRADE" = "yes" ]; then
+                               mv -f $SPECFILE.bak $SPECFILE
+                       fi
                fi
                Exit_error err_build_fail;
        fi
@@ -1206,9 +1285,13 @@ set_bconds_values()
                                        # use only flags which are in this package.
                                        if [[ $bcond_avail = *${opt}* ]]; then
                                                if [[ $flag = -* ]]; then
-                                                       BCOND="$BCOND --without $opt"
+                                                       if [[ $BCOND != *--with?${opt}* ]]; then
+                                                               BCOND="$BCOND --without $opt"
+                                                       fi
                                                else
-                                                       BCOND="$BCOND --with $opt"
+                                                       if [[ $BCOND != *--without?${opt}* ]]; then
+                                                               BCOND="$BCOND --with $opt"
+                                                       fi
                                                fi
                                        fi
                                done
@@ -1629,13 +1712,13 @@ init_rpm_dir() {
        init_builder
 
        echo "To checkout *all* .spec files:"
-       echo "- remove $SPECS_DIR/CVS/Entries.Static"
-       echo "- run cvs up in $SPECS_DIR dir"
+       echo "- remove $SPECS_DIR/CVS/Entries.Static"
+       echo "- run cvs up in $SPECS_DIR dir"
 
        echo ""
        echo "To commit with your developer account:"
-       echo "- edit $SPECS_DIR/CVS/Root"
-       echo "- edit $SOURCE_DIR/CVS/Root"
+       echo "- edit $SPECS_DIR/CVS/Root"
+       echo "- edit $SOURCE_DIR/CVS/Root"
 }
 
 #---------------------------------------------
@@ -1650,17 +1733,15 @@ while test $# -gt 0
 do
        case "${1}" in
                -5 | --update-md5 )
-                       COMMAND="get";
+                       COMMAND="update_md5";
                        NODIST="yes"
                        NOCVSSPEC="yes"
-                       UPDATE5="yes"
                        shift ;;
                -a5 | --add-md5 )
-                       COMMAND="get";
+                       COMMAND="update_md5";
                        NODIST="yes"
                        NOCVS="yes"
                        NOCVSSPEC="yes"
-                       UPDATE5="yes"
                        ADD5="yes"
                        shift ;;
                -n5 | --no-md5 )
@@ -1684,6 +1765,8 @@ do
                        COMMAND="branch"; shift; TAG="${1}"; shift;;
                -c | --clean )
                        CLEAN="--clean --rmspec --rmsource"; shift ;;
+               -cf | --cvs-force )
+                       CVS_FORCE="-F"; shift;;
                -d | --cvsroot )
                        shift; CVSROOT="${1}"; shift ;;
                -g | --get )
@@ -1727,7 +1810,7 @@ do
                        NOINIT="yes"
                        shift;;
                --opts )
-                       shift; RPMOPTS="$RPM_OPTS ${1}"; shift ;;
+                       shift; RPMOPTS="${RPMOPTS} ${1}"; shift ;;
                --nopatch | -np )
                        shift; RPMOPTS="${RPMOPTS} --define \"patch${1} : ignoring patch${1}; exit 1; \""; shift ;;
                --with | --without )
@@ -1791,21 +1874,11 @@ do
                        TAG="STABLE"
                        TAG_VERSION="yes"
                        shift;;
-               -Tvn | --tag-version-nest )
-                       COMMAND="tag";
-                       TAG="NEST"
-                       TAG_VERSION="yes"
-                       shift;;
                -Ts | --tag-stable )
                        COMMAND="tag";
                        TAG="STABLE"
                        TAG_VERSION="no"
                        shift;;
-               -Tn | --tag-nest )
-                       COMMAND="tag";
-                       TAG="NEST"
-                       TAG_VERSION="no"
-                       shift;;
                -Tv | --tag-version )
                        COMMAND="tag";
                        TAG=""
@@ -1827,11 +1900,10 @@ do
                        INTEGER_RELEASE="yes"
                        shift;;
                -U | --update )
-                       COMMAND="get"
+                       COMMAND="update_md5"
                        UPDATE="yes"
                        NOCVSSPEC="yes"
                        NODIST="yes"
-                       UPDATE5="yes"
                        shift ;;
                -Upi | --update-poldek-indexes )
                        UPDATE_POLDEK_INDEXES="yes"
@@ -1848,9 +1920,14 @@ do
                --define)
                        shift
                        MACRO="${1}"
-                       VALUE="${2}"
-                       shift 2
-                       RPMOPTS="${RPMOPTS} --define \"${MACRO} ${VALUE}\""
+                       shift
+                       if echo "${MACRO}" | grep -q '\W'; then
+                               RPMOPTS="${RPMOPTS} --define \"${MACRO}\""
+                       else
+                               VALUE="${1}"
+                               shift
+                               RPMOPTS="${RPMOPTS} --define \"${MACRO} ${VALUE}\""
+                       fi
                        ;;
                --show-bconds | -show-bconds | -print-bconds | --print-bconds | -display-bconds | --display-bconds )
                        SHOW_BCONDS="yes"
@@ -1869,10 +1946,20 @@ do
                                CVSTAG="${SPECFILE##*:}";
                                SPECFILE="${SPECFILE%%:*}";
                        fi
-                       shift ;;
+                       shift
        esac
 done
 
+if [ -z "$CVSTAG" ]; then
+       CVSTAG=$(awk -vSPECFILE="${SPECFILE%.spec}.spec" -F/ '$2 == SPECFILE && $6 ~ /^T/{print substr($6, 2)}' CVS/Entries)
+       if [ "$CVSTAG" ]; then
+               echo "builder: Stick tag $CVSTAG active. Use -r TAGNAME to override."
+       fi
+elif [ "$CVSTAG" = "HEAD" ]; then
+       # assume -r HEAD is same as -A
+       CVSTAG=""
+fi
+
 if [ -n "$DEBUG" ]; then
        set -x;
        set -v;
@@ -1934,7 +2021,8 @@ case "$COMMAND" in
                        if [ -n "$NOSOURCE0" ] ; then
                                SOURCES=`echo $SOURCES | xargs | sed -e 's/[^ ]*//'`
                        fi
-                       get_files $SOURCES $PATCHES;
+                       get_files $SOURCES $PATCHES
+                       check_md5 $SOURCES
                        build_package;
                        if [ "$UPDATE_POLDEK_INDEXES" = "yes" -a "$COMMAND" != "build-prep" ]; then
                                run_poldek --sdir="${POLDEK_INDEX_DIR}" --mkidxz
@@ -1949,8 +2037,16 @@ case "$COMMAND" in
                if [ -n "$SPECFILE" ]; then
                        get_spec;
                        parse_spec;
-                       get_files $SOURCES $PATCHES;
-                       branch_files $TAG "$SOURCES $PATCHES $ICONS";
+                       # don't fetch sources from remote locations
+                       new_SOURCES=""
+                       for file in $SOURCES; do
+                               [ -n "`src_md5 $file`" ] && continue
+                               new_SOURCES="$new_SOURCES $file"
+                       done
+                       SOURCES="$new_SOURCES"
+                       get_files $SOURCES $PATCHES
+                       check_md5 $SOURCES
+                       branch_files $TAG $SOURCES $PATCHES $ICONS
                else
                        Exit_error err_no_spec_in_cmdl;
                fi
@@ -1965,6 +2061,21 @@ case "$COMMAND" in
                                SOURCES=`echo $SOURCES | xargs | sed -e 's/[^ ]*//'`
                        fi
                        get_files $SOURCES $PATCHES
+                       check_md5 $SOURCES
+               else
+                       Exit_error err_no_spec_in_cmdl;
+               fi
+               ;;
+       "update_md5" )
+               init_builder;
+               if [ -n "$SPECFILE" ]; then
+                       get_spec;
+                       parse_spec
+
+                       if [ -n "$NOSOURCE0" ] ; then
+                               SOURCES=`echo $SOURCES | xargs | sed -e 's/[^ ]*//'`
+                       fi
+                       update_md5 $SOURCES
                else
                        Exit_error err_no_spec_in_cmdl;
                fi
@@ -1979,14 +2090,14 @@ case "$COMMAND" in
 
                        # don't fetch sources from remote locations
                        new_SOURCES=""
-                       for file in $SOURCES
-                       do
+                       for file in $SOURCES; do
                                [ -n "`src_md5 $file`" ] && continue
                                new_SOURCES="$new_SOURCES $file"
                        done
                        SOURCES="$new_SOURCES"
-                       get_files $SOURCES $PATCHES;
-                       tag_files "$SOURCES $PATCHES $ICONS";
+                       get_files $SOURCES $PATCHES
+                       check_md5 $SOURCES
+                       tag_files $SOURCES $PATCHES $ICONS
                else
                        Exit_error err_no_spec_in_cmdl;
                fi
@@ -2000,8 +2111,7 @@ case "$COMMAND" in
                DONT_PRINT_REVISION="yes"
                get_spec
                parse_spec
-               SAPS="$SOURCES $PATCHES"
-               for SAP in $SAPS ; do
+               for SAP in $SOURCES $PATCHES; do
                        echo $SAP | awk '{gsub(/.*\//,"") ; print}'
                done
                ;;
@@ -2022,8 +2132,7 @@ case "$COMMAND" in
                DONT_PRINT_REVISION="yes"
                get_spec
                parse_spec
-               SAPS="$SOURCES $PATCHES"
-               for SAP in $SAPS ; do
+               for SAP in $SOURCES $PATCHES; do
                        echo $SOURCE_DIR/$(echo $SAP | awk '{gsub(/.*\//,"") ; print }')
                done
                ;;
@@ -2033,8 +2142,7 @@ case "$COMMAND" in
                DONT_PRINT_REVISION="yes"
                get_spec
                parse_spec
-               SAPS="$SOURCES $PATCHES"
-               for SAP in $SAPS ; do
+               for SAP in $SOURCES $PATCHES; do
                        if [ -n "$(src_md5 "$SAP")" ]; then
                                distfiles_path "$SAP"
                        fi
@@ -2046,8 +2154,7 @@ case "$COMMAND" in
                DONT_PRINT_REVISION="yes"
                get_spec
                parse_spec
-               SAPS="$SOURCES $PATCHES"
-               for SAP in $SAPS ; do
+               for SAP in $SOURCES $PATCHES; do
                        if [ -n "$(src_md5 "$SAP")" ]; then
                                distfiles_url "$SAP"
                        fi
@@ -2066,4 +2173,4 @@ if [ -f "`pwd`/.${SPECFILE}_INSTALLED_PACKAGES" -a "$REMOVE_BUILD_REQUIRES" != "
 fi
 cd "$__PWD"
 
-# vi:syntax=sh:ts=4:sw=4
+# vi:syntax=sh:ts=4:sw=4:noet
This page took 0.07613 seconds and 4 git commands to generate.