]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - builder.sh
- init NOINIT variable
[packages/rpm-build-tools.git] / builder.sh
index 4f2c07a214d53eac6ae5d7e3de99f00aed7abd37..ce3290bbb0538a74381a4dcf2b6fe0add08514f8 100644 (file)
@@ -22,7 +22,7 @@
 
 VERSION="\
 Build package utility from PLD Linux CVS repository
-V 0.13 (C) 1999-2005 Free Penguins".
+v0.15 (C) 1999-2006 Free Penguins".
 PATH="/bin:/usr/bin:/usr/sbin:/sbin:/usr/X11R6/bin"
 
 COMMAND="build"
@@ -37,6 +37,7 @@ NOURLS=""
 NOCVS=""
 NOCVSSPEC=""
 NODIST=""
+NOINIT=""
 UPDATE=""
 UPDATE5=""
 ADD5=""
@@ -61,6 +62,7 @@ LASTLOG_FILE=""
 CHMOD="no"
 CHMOD_MODE="0444"
 RPMOPTS=""
+RPMBUILDOPTS=""
 BCOND=""
 GROUP_BCONDS="no"
 CVSIGNORE_DF="no"
@@ -83,6 +85,7 @@ DISTFILES_SERVER="://distfiles.pld-linux.org"
 ATTICDISTFILES_SERVER="://attic-distfiles.pld-linux.org"
 
 DEF_NICE_LEVEL=19
+SCHEDTOOL="auto"
 
 FAIL_IF_NO_SOURCES="yes"
 
@@ -111,6 +114,7 @@ fi
 #REMOVE_BUILD_REQUIRES="force"
 #GROUP_BCONDS="yes"
 #LOGFILE='../LOGS/log.$PACKAGE_NAME.$DATE'
+#TITLECHANGE=no
 #
 SU_SUDO=""
 if [ -n "$HOME_ETC" ]; then
@@ -123,6 +127,14 @@ fi
 
 wget --help 2>&1 | grep -q ' \-\-no-check\-certificate ' && WGET_OPTS="$WGET_OPTS --no-check-certificate"
 
+if [ "$SCHEDTOOL" = "auto" ]; then
+       if [ -x /usr/bin/schedtool ] && schedtool -B -e echo >/dev/null; then
+               SCHEDTOOL="schedtool -B -e"
+       else
+               SCHEDTOOL="no"
+       fi
+fi
+
 if [ -n "$USE_PROZILLA" ]; then
        GETURI="proz --no-getch -r -P ./ -t$WGET_RETRIES $PROZILLA_OPTS"
        GETURI2="$GETURI"
@@ -161,10 +173,10 @@ run_poldek()
                if [ -n "$LASTLOG_FILE" ]; then
                        echo "LASTLOG=$LOG" > $LASTLOG_FILE
                fi
-               (nice -n ${DEF_NICE_LEVEL} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE})|tee -a $LOG
+               (${NICE_COMMAND} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE})|tee -a $LOG
                return $exit_pldk
        else
-               (nice -n ${DEF_NICE_LEVEL} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE}) 1>&2 >/dev/null
+               (${NICE_COMMAND} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE}) 1>&2 >/dev/null
                return `cat ${RES_FILE}`
                rm -rf ${RES_FILE}
        fi
@@ -231,6 +243,7 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
 -ns, --no-srcs      - don't download Sources
 -ns0, --no-source0  - don't download Source0
 -nn, --no-net       - don't download anything from the net
+-ni, --no-init      - don't initialize builder paths (SPECS and SOURCES)
 -ske,
 --skip-existing-files - skip existing files in get_files
 --opts <rpm opts>   - additional options for rpm
@@ -246,12 +259,19 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
 -FRB, --force-remove-build-requires
                     - remove all you fetched with -R or --fetch-build-requires
                       remember, this option works without confirmation,
+-sd, --source-distfiles - list sources available from distfiles (intended for offline
+                      operations; does not work when Icon field is present
+                      but icon file is absent),
+-sdp, --source-distfiles-paths - list sources available from distfiles -
+                      paths relative to distfiles directory (intended for offline
+                      operations; does not work when Icon field is present
+                      but icon file is absent),
 -sf, --source-files - list sources - bare filenames (intended for offline
                       operations; does not work when Icon field is present
-                                                        but icon file is absent),
+                      but icon file is absent),
 -sp, --source-paths - list sources - filenames with full local paths (intended for
                       offline operations; does not work when Icon field is present
-                                                        but icon file is absent),
+                      but icon file is absent),
 -su, --source-urls  - list urls - urls to sources and patches
                       intended for copying urls with spec with lots of macros in urls
 -T <cvstag> , --tag <cvstag>
@@ -289,7 +309,8 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
                       --with feat1 feat2 feat3 --without feat4 feat5 --with feat6
                       constructions. Set GROUP_BCONDS to yes to make use of it.
 --target <platform>, --target=<platform>
-                   - build for platform <platform>.
+                     - build for platform <platform>.
+--init-rpm-dir       - initialize ~/rpm directory structure
 "
 }
 
@@ -298,15 +319,28 @@ update_shell_title() {
        local len=${COLUMNS:-80}
        local msg=$(echo "$*" | cut -c-$len)
 
-       msg="builder[$SPECFILE] ${SHELL_TITLE_PREFIX:+$SHELL_TITLE_PREFIX }$msg"
-       case "$TERM" in
-               cygwin|xterm*)
-               echo >&2 -ne "\033]1;$msg\007\033]2;$msg\007"
-       ;;
-               screen*)
-               echo >&2 -ne "\033]0;$msg\007"
-       ;;
-       esac
+       if [ -n "$BE_VERBOSE" ]; then
+               echo >&2 "$(date +%s.%N) $*"
+       fi
+
+       if [ "x$TITLECHANGE" == "xyes" -o "x$TITLECHANGE" == "x" ]; then
+               local pkg
+               if [ -n "$PACKAGE_NAME" ]; then
+                       pkg=${PACKAGE_NAME}-${PACKAGE_VERSION}-${PACKAGE_RELEASE}
+               else
+                       pkg=${SPECFILE}
+               fi
+
+               msg="$pkg: ${SHELL_TITLE_PREFIX:+$SHELL_TITLE_PREFIX }$msg"
+               case "$TERM" in
+                       cygwin|xterm*)
+                       echo >&2 -ne "\033]1;$msg\007\033]2;$msg\007"
+               ;;
+                       screen*)
+                       echo >&2 -ne "\033]0;$msg\007"
+               ;;
+               esac
+       fi
 }
 
 # set TARGET from BuildArch: from SPECFILE
@@ -332,15 +366,61 @@ cache_rpm_dump () {
         fi
 
        update_shell_title "cache_rpm_dump"
-rpm_dump_cache=`
+       local rpm_dump
+       rpm_dump=`
+
+       # we reset macros not to contain macros.build as all the %() macros are
+       # executed here, while none of them are actually needed.
+       # what we need from dump is NAME, VERSION, RELEASE and PATCHES/SOURCES.
+       # at the time of this writing macros.build + macros contained 70 "%(...)" macros.
+       macrofiles="/usr/lib/rpm/macros:$SPECS_DIR/.builder-rpmmacros:~/etc/.rpmmacros:~/.rpmmacros"
+       dump='%{echo:dummy: PACKAGE_NAME %{name} }%dump'
+       # FIXME: better ideas than .rpmrc?
+       printf 'include:/usr/lib/rpm/rpmrc\nmacrofiles:%s\n' $macrofiles > .builder-rpmrc
+# TODO: move these to /usr/lib/rpm/macros
+       cat > .builder-rpmmacros <<'EOF'
+%requires_releq_kernel_up %{nil}
+%requires_releq_kernel_smp %{nil}
+%requires_releq() %{nil}
+%pyrequires_eq() %{nil}
+%requires_eq() %{nil}
+%requires_eq_to() %{nil}
+%releq_kernel_up ERROR
+%releq_kernel_smp ERROR
+%kgcc_package ERROR
+%_fontsdir ERROR
+%ruby_version ERROR
+%ruby_ver_requires_eq() %{nil}
+%ruby_mod_ver_requires_eq() %{nil}
+%__php_api_requires() %{nil}
+%php_major_version ERROR
+%php_api_version ERROR
+%py_ver ERROR
+EOF
        case "$RPMBUILD" in
-               rpm )
-                       rpm -bp --nodeps --define 'prep %dump' $BCOND $TARGET_SWITCH $SPECFILE 2>&1
-                       ;;
-               rpmbuild )
-                       rpmbuild --nodigest --nosignature --define 'prep %dump' $BCOND $TARGET_SWITCH $SPECFILE 2>&1
-                       ;;
-       esac`
+       rpm)
+               ARGS='-bp'
+               ;;
+       rpmbuild)
+               ARGS='--nodigest --nosignature --nobuild'
+               ;;
+       esac
+       $RPMBUILD --rcfile .builder-rpmrc $ARGS --nodeps --define "prep $dump" $BCOND $TARGET_SWITCH $SPECFILE 2>&1
+       `
+       if [ $? -gt 0 ]; then
+               error=$(echo "$rpm_dump" | sed -ne '/^error:/,$p')
+               echo "$error" >&2
+               Exit_error err_build_fail;
+       fi
+
+       # make small dump cache
+       rpm_dump_cache=`echo "$rpm_dump" | awk '
+               $2 ~ /^SOURCEURL/ {print}
+               $2 ~ /^PATCHURL/  {print}
+               $2 ~ /^nosource/ {print}
+               $2 ~ /^PACKAGE_/ {print}
+       '`
+
        update_shell_title "cache_rpm_dump: OK!"
 }
 
@@ -351,6 +431,17 @@ rpm_dump () {
        echo "$rpm_dump_cache"
 }
 
+get_icons()
+{
+       update_shell_title "get icons"
+       ICONS="`awk '/^Icon:/ {print $2}' ${SPECFILE}`"
+       if [ -z "$ICONS" ]; then
+               return
+       fi
+
+       rpm_dump_cache="böö" NODIST="yes" UPDATE5= get_files $ICONS
+}
+
 parse_spec()
 {
        update_shell_title "parsing specfile"
@@ -359,34 +450,25 @@ parse_spec()
                set -v;
        fi
 
-       cd $SPECS_DIR
+       # icons are needed for successful spec parse
+       get_icons;
 
+       cd $SPECS_DIR
        cache_rpm_dump
 
        if [ "$NOSRCS" != "yes" ]; then
                SOURCES="`rpm_dump | awk '/SOURCEURL[0-9]+/ {print $3}'`"
        fi
+
        if (rpm_dump | grep -qEi ":.*nosource.*1"); then
                FAIL_IF_NO_SOURCES="no"
        fi
 
-       update_shell_title "parse_spec: Patches!"
        PATCHES="`rpm_dump | awk '/PATCHURL[0-9]+/ {print $3}'`"
-       update_shell_title "parse_spec: Icons!"
        ICONS="`awk '/^Icon:/ {print $2}' ${SPECFILE}`"
-       update_shell_title "parse_spec: PACKAGE_NAME!"
-       PACKAGE_NAME="`$RPM -q --qf '%{NAME}\n' --specfile ${SPECFILE} 2> /dev/null | head -n 1`"
-       update_shell_title "parse_spec: PACKAGE_VERSION!"
-       PACKAGE_VERSION="`$RPM -q --qf '%{VERSION}\n' --specfile ${SPECFILE} 2> /dev/null| head -n 1`"
-       update_shell_title "parse_spec: PACKAGE_RELEASE!"
-       PACKAGE_RELEASE="`$RPM -q --qf '%{RELEASE}\n' --specfile ${SPECFILE} 2> /dev/null | head -n 1`"
-
-# These variables may be unset after first cache_rpm_dump call
-# (because of not-yet-retrieved icon file)
-#
-#      if [ -z "$PACKAGE_NAME" -o -z "$PACKAGE_VERSION" -o -z "$PACKAGE_RELEASE" ]; then
-#               Exit_error err_no_package_data;
-#      fi
+       PACKAGE_NAME=$(rpm_dump | awk '$2 == "PACKAGE_NAME" { print $3}')
+       PACKAGE_VERSION=$(rpm_dump | awk '$2 == "PACKAGE_VERSION" { print $3}')
+       PACKAGE_RELEASE=$(rpm_dump | awk '$2 == "PACKAGE_RELEASE" { print $3}')
 
        if [ -n "$BE_VERBOSE" ]; then
                echo "- Sources :  `nourl $SOURCES`"
@@ -463,8 +545,13 @@ init_builder()
                set -v;
        fi
 
-       SOURCE_DIR="`$RPM --eval '%{_sourcedir}'`"
-       SPECS_DIR="`$RPM --eval '%{_specdir}'`"
+       if [ "$NOINIT" != "yes" ] ; then
+               SOURCE_DIR="`eval $RPM $RPMOPTS --eval '%{_sourcedir}'`"
+               SPECS_DIR="`eval $RPM $RPMOPTS --eval '%{_specdir}'`"
+       else
+               SOURCE_DIR="."
+               SPECS_DIR="."
+       fi
 
        __PWD="`pwd`"
 }
@@ -572,14 +659,19 @@ src_md5 ()
        fi
 }
 
+distfiles_path ()
+{
+       echo "by-md5/$(src_md5 "$1" | sed -e 's|^\(.\)\(.\)|\1/\2/&|')/$(basename "$1")"
+}
+
 distfiles_url ()
 {
-       echo "$PROTOCOL$DISTFILES_SERVER/distfiles/by-md5/$(src_md5 "$1" | sed -e 's|^\(.\)\(.\)|\1/\2/&|')/$(basename "$1")"
+       echo "$PROTOCOL$DISTFILES_SERVER/distfiles/$(distfiles_path "$1")"
 }
 
 distfiles_attic_url ()
 {
-       echo "$PROTOCOL$ATTICDISTFILES_SERVER/distfiles/Attic/by-md5/$(src_md5 "$1" | sed -e 's|^\(.\)\(.\)|\1/\2/&|')/$(basename "$1")"
+       echo "$PROTOCOL$ATTICDISTFILES_SERVER/distfiles/Attic/$(distfiles_path "$1")"
 }
 
 good_md5 ()
@@ -627,7 +719,11 @@ cvsup()
 
         local result=1
         local retries_counter=0
-        update_shell_title "cvsup: $# files"
+        if [ $# = 1 ]; then
+                update_shell_title "cvsup: $*"
+        else
+                update_shell_title "cvsup: $# files"
+        fi
         while [ "$result" != "0" -a "$retries_counter" -le "$CVS_RETRIES" ]; do
                  retries_counter=$(( $retries_counter + 1 ))
                  output=$(LC_ALL=C cvs $OPTIONS "$@" 2>&1)
@@ -648,7 +744,7 @@ cvsup()
 
 get_files()
 {
-       update_shell_title "fetching sources"
+       update_shell_title "get_files"
 
        if [ -n "$DEBUG" ]; then
                set -x;
@@ -688,7 +784,7 @@ get_files()
                                        echo "Warning: no URL given for $i"
                                fi
 
-                               if [ -n "$(src_md5 "$i")" ] && [ -z "$NODIST" ]; then
+                               if [ -z "$NODIST" ] && [ -n "$(src_md5 "$i")" ]; then
                                        if good_md5 "$i" && good_size "$i"; then
                                                echo "$(nourl "$i") having proper md5sum already exists"
                                                continue
@@ -734,10 +830,14 @@ get_files()
                                                rm -f "$target"
                                                FROM_DISTFILES=0
                                        fi
-                               elif [ -z "$(src_md5 "$i")" -a "$NOCVS" != "yes" ]; then
-                                   get_files_cvs="$get_files_cvs $fp"
-                                       # we'll do cvs up later
-                                       cvsup=1
+                               elif [ "$NOCVS" != "yes" -a -z "$(src_md5 "$i")" ]; then
+                                       if [ $# -gt 1 ]; then
+                                               get_files_cvs="$get_files_cvs $fp"
+                                               update_shell_title "$fp (will cvs up later)"
+                                               cvsup=1
+                                       else
+                                               cvsup $fp
+                                       fi
                                fi
 
                                if [ -z "$NOURLS" ] && [ ! -f "$fp" -o -n "$UPDATE" ] && [ "`echo $i | grep -E 'ftp://|http://|https://'`" ]; then
@@ -965,10 +1065,6 @@ build_package()
                        eval "perl -pi -e 's/Version:\t"$TOLDVER"/Version:\t"$TNEWVER"/gs' $SPECFILE"
                        eval "perl -pi -e 's/Release:\t[1-9]{0,4}/Release:\t0.1/' $SPECFILE"
                        parse_spec;
-                       if [ -n "$ICONS" ]; then
-                               get_files $ICONS;
-                               parse_spec;
-                       fi
                        NODIST="yes" UPDATE5="yes" get_files $SOURCES $PATCHES;
                        unset TOLDVER TNEWVER TNOTIFY
                fi
@@ -998,7 +1094,7 @@ build_package()
                        echo "LASTLOG=$LOG" > $LASTLOG_FILE
                fi
                RES_FILE=~/tmp/$RPMBUILD-exit-status.$RANDOM
-               (time eval nice -n ${DEF_NICE_LEVEL} $RPMBUILD $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $BCOND $TARGET_SWITCH $SPECFILE; echo $? > $RES_FILE) 2>&1 |tee $LOG
+               (time eval ${NICE_COMMAND} $RPMBUILD $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND $TARGET_SWITCH $SPECFILE; echo $? > $RES_FILE) 2>&1 |tee $LOG
                RETVAL=`cat $RES_FILE`
                rm $RES_FILE
                if [ -n "$LOGDIROK" ] && [ -n "$LOGDIRFAIL" ]; then
@@ -1009,12 +1105,12 @@ build_package()
                        fi
                fi
        else
-               eval nice -n ${DEF_NICE_LEVEL} $RPMBUILD $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $BCOND $TARGET_SWITCH $SPECFILE
+               eval ${NICE_COMMAND} $RPMBUILD $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND $TARGET_SWITCH $SPECFILE
                RETVAL=$?
        fi
        if [ "$RETVAL" -ne "0" ]; then
                if [ -n "$TRY_UPGRADE" ]; then
-                       echo "\n!!! Package with new version cannot be build automagically\n"
+                       echo "\n!!! Package with new version cannot be built automagically\n"
                        mv -f $SPECFILE.bak $SPECFILE
                fi
                Exit_error err_build_fail;
@@ -1033,6 +1129,24 @@ install_required_packages()
        return $?
 }
 
+find_spec_bcond() {
+       # taken from find-spec-bcond, but with just getting the list
+       local SPEC="$1"
+       # quick revert hint: '$RPMBUILD --bcond $SPEC'
+       awk -F"\n" '
+       /^%changelog/ { exit }
+       /_with(out)?_[_a-zA-Z0-9]+/{
+               match($0, /_with(out)?_[_a-zA-Z0-9]+/);
+               print substr($0, RSTART, RLENGTH);
+       }
+       /^%bcond_with/{
+               match($0, /bcond_with(out)?[ \t]+[_a-zA-Z0-9]+/);
+               bcond = substr($0, RSTART +5 , RLENGTH -5);
+               gsub(/[ \t]+/,"_",bcond);
+               print bcond
+       }' $SPEC | LC_ALL=C sort -u
+}
+
 set_bconds_values()
 {
        update_shell_title "set bcond values"
@@ -1044,9 +1158,11 @@ set_bconds_values()
        elif `egrep -q ^#\ *_with ${SPECFILE}`; then
                BCOND_VERSION="OLD"
        else
-               BCOND_VERSION="NONE"
+               return
        fi
 
+       local bcond_avail=$(find_spec_bcond $SPECFILE)
+
        # expand bconds from ~/.bcondrc
        # The file structure is like gentoo's package.use:
        # ---
@@ -1055,27 +1171,23 @@ set_bconds_values()
        # w32codec-installer license_agreement
        # php +mysqli
        # ---
-       if [ "${BCOND_VERSION}" != "NONE" ] && ( [ -f $HOME/.bcondrc ] || ( [ -n $HOME_ETC ] && [ -f $HOME_ETC/.bcondrc ] ) ) ; then
-               # This takes package name, first defined in spec.
-               # so consider that when defining flags for package.
-               PN=`$RPM -q --qf '%{NAME}\n' --specfile $SPECFILE | head -n 1`
+       if ([ -f $HOME/.bcondrc ] || ([ -n $HOME_ETC ] && [ -f $HOME_ETC/.bcondrc ])); then
                SN=${SPECFILE%%\.spec}
-               AVAIL=`$RPMBUILD --bcond $SPECFILE`
 
-               BCONDRC=$HOME/.bcondrc
-               [ -n $HOME_ETC ] && [ -f $HOME_ETC/.bcondrc ] && BCONDRC=$HOME_ETC/.bcondrc
+               local bcondrc=$HOME/.bcondrc
+               [ -n $HOME_ETC ] && [ -f $HOME_ETC/.bcondrc ] && bcondrc=$HOME_ETC/.bcondrc
 
                while read pkg flags; do
                        # ignore comments
                        [[ "$pkg" == \#* ]] && continue
 
                        # any package or current package?
-                       if [ "$pkg" = "*" ] || [ "$pkg" = "$PN" ] || [ "$pkg" = "$SN" ]; then
+                       if [ "$pkg" = "*" ] || [ "$pkg" = "$PACKAGE_NAME" ] || [ "$pkg" = "$SN" ]; then
                                for flag in $flags; do
-                                       opt=${flag#[+-]}
+                                       local opt=${flag#[+-]}
 
                                        # use only flags which are in this package.
-                                       if [[ $AVAIL = *${opt}* ]]; then
+                                       if [[ $bcond_avail = *${opt}* ]]; then
                                                if [[ $flag = -* ]]; then
                                                        BCOND="$BCOND --without $opt"
                                                else
@@ -1084,29 +1196,31 @@ set_bconds_values()
                                        fi
                                done
                        fi
-               done < $BCONDRC
+               done < $bcondrc
+               update_shell_title "parse ~/.bcondrc: DONE!"
        fi
 
+       update_shell_title "parse bconds"
        case "${BCOND_VERSION}" in
-                NONE)
+               NONE)
                        :
                        ;;
                OLD)
                        echo "Warning: This spec has old style bconds. Fix it || die."
-                       for opt in `$RPMBUILD --bcond $SPECFILE |grep ^_without_`
+                       for opt in `echo "$bcond_avail" | grep ^_without_`
                        do
-                               AVAIL_BCOND_WITHOUT=`echo $opt|sed -e "s/^_without_//g"`
-                               if `echo $BCOND|grep -q -- "--without $AVAIL_BCOND_WITHOUT"`;then
+                               AVAIL_BCOND_WITHOUT=${opt#_without_}
+                               if [[ "$BCOND" = *--without?${AVAIL_BCOND_WITHOUT}* ]]; then
                                        AVAIL_BCONDS_WITHOUT="$AVAIL_BCONDS_WITHOUT <$AVAIL_BCOND_WITHOUT>"
                                else
                                        AVAIL_BCONDS_WITHOUT="$AVAIL_BCONDS_WITHOUT $AVAIL_BCOND_WITHOUT"
                                fi
                        done
 
-                       for opt in `$RPMBUILD --bcond $SPECFILE |grep ^_with_`
+                       for opt in `echo "$bcond_avail" | grep ^_with_`
                        do
-                               AVAIL_BCOND_WITH=`echo $opt|sed -e "s/^_with_//g"`
-                               if `echo $BCOND|grep -q -- "--with $AVAIL_BCOND_WITH"`;then
+                               AVAIL_BCOND_WITH=${opt#_with_}
+                               if [[ "$BCOND" = *--with?${AVAIL_BCOND_WITH}* ]]; then
                                        AVAIL_BCONDS_WITH="$AVAIL_BCONDS_WITH <$AVAIL_BCOND_WITH>"
                                else
                                        AVAIL_BCONDS_WITH="$AVAIL_BCONDS_WITH $AVAIL_BCOND_WITH"
@@ -1114,9 +1228,8 @@ set_bconds_values()
                        done
                        ;;
                NEW)
-                       cond_type="" # with || without
-                       for opt in `$RPMBUILD --bcond $SPECFILE`
-                       do
+                       local cond_type="" # with || without
+                       for opt in $bcond_avail; do
                                case "$opt" in
                                        _without)
                                                cond_type="without"
@@ -1125,16 +1238,16 @@ set_bconds_values()
                                                cond_type="with"
                                                ;;
                                        _without_*)
-                                               AVAIL_BCOND_WITHOUT="`echo $opt | sed 's/^_without_//g'`"
-                                               if `echo $BCOND|grep -q -- "--without $AVAIL_BCOND_WITHOUT"`;then
+                                               AVAIL_BCOND_WITHOUT=${opt#_without_}
+                                               if [[ "$BCOND" = *--without?${AVAIL_BCOND_WITHOUT}* ]]; then
                                                        AVAIL_BCONDS_WITHOUT="$AVAIL_BCONDS_WITHOUT <$AVAIL_BCOND_WITHOUT>"
                                                else
                                                        AVAIL_BCONDS_WITHOUT="$AVAIL_BCONDS_WITHOUT $AVAIL_BCOND_WITHOUT"
                                                fi
                                                ;;
                                        _with_*)
-                                               AVAIL_BCOND_WITH="`echo $opt | sed 's/^_with_//g'`"
-                                               if `echo $BCOND|grep -q -- "--with $AVAIL_BCOND_WITH"`;then
+                                               AVAIL_BCOND_WITH=${opt#_with_}
+                                               if [[ "$BCOND" = *--with?${AVAIL_BCOND_WITH}* ]]; then
                                                        AVAIL_BCONDS_WITH="$AVAIL_BCONDS_WITH <$AVAIL_BCOND_WITH>"
                                                else
                                                        AVAIL_BCONDS_WITH="$AVAIL_BCONDS_WITH $AVAIL_BCOND_WITH"
@@ -1145,7 +1258,7 @@ set_bconds_values()
                                                        with)
                                                                cond_type=''
                                                                AVAIL_BCOND_WITH="$opt"
-                                                               if `echo $BCOND|grep -q -- "--with $AVAIL_BCOND_WITH"`;then
+                                                               if [[ "$BCOND" = *--with?${AVAIL_BCOND_WITH}* ]]; then
                                                                        AVAIL_BCONDS_WITH="$AVAIL_BCONDS_WITH <$AVAIL_BCOND_WITH>"
                                                                else
                                                                        AVAIL_BCONDS_WITH="$AVAIL_BCONDS_WITH $AVAIL_BCOND_WITH"
@@ -1154,7 +1267,7 @@ set_bconds_values()
                                                        without)
                                                                cond_type=''
                                                                AVAIL_BCOND_WITHOUT="$opt"
-                                                               if `echo $BCOND|grep -q -- "--without $AVAIL_BCOND_WITHOUT"`;then
+                                                               if [[ "$BCOND" = *--without?${AVAIL_BCOND_WITHOUT}* ]]; then
                                                                        AVAIL_BCONDS_WITHOUT="$AVAIL_BCONDS_WITHOUT <$AVAIL_BCOND_WITHOUT>"
                                                                else
                                                                        AVAIL_BCONDS_WITHOUT="$AVAIL_BCONDS_WITHOUT $AVAIL_BCOND_WITHOUT"
@@ -1421,11 +1534,11 @@ fetch_build_requires()
                                                do
                                                        if [ "$package_name" = "$package" ]; then
                                                                echo -ne "Installing BuildRequired package:\t$package_name\n"
-                                                               export PROMPT_COMMAND=`echo -ne "\033]0;${SPECFILE}: Installing BuildRequired package: ${package_name}\007"`
+                                                               update_shell_title "Installing BuildRequired package: ${package_name}"
                                                                install_required_packages $package;
                                                        else
                                                                echo -ne "Installing (sub)Required package:\t$package_name\n"
-                                                               export PROMPT_COMMAND=`echo -ne "\033]0;${SPECFILE}: Installing (sub)Required package: ${package_name}\007"`
+                                                               update_shell_title "Installing (sub)Required package: ${package_name}"
                                                                install_required_packages $package_name;
                                                        fi
                                                        case $? in
@@ -1475,7 +1588,6 @@ fetch_build_requires()
                                fi
                        fi
                done
-               export PROMPT_COMMAND=`echo -ne "\033]0;${SPECFILE}\007"`
                if [ "$NOT_INSTALLED_PACKAGES" != "" ]; then
                        echo "Unable to install following packages and their dependencies:"
                        for pkg in "$NOT_INSTALLED_PACKAGES"
@@ -1488,6 +1600,27 @@ fetch_build_requires()
        fi
 }
 
+init_rpm_dir() {
+
+       TOP_DIR="`eval $RPM $RPMOPTS --eval '%{_topdir}'`"
+       CVSROOT=":pserver:cvs@$CVS_SERVER:/cvsroot"
+
+       mkdir -p $TOP_DIR/{RPMS,BUILD,SRPMS}
+       cd $TOP_DIR
+       cvs -d $CVSROOT co SOURCES/.cvsignore SPECS/{mirrors,adapter{,.awk},fetchsrc_request,builder,repackage.sh}
+
+       init_builder
+
+       echo "To checkout *all* .spec files:"
+       echo "- remove $SPECS_DIR/CVS/Entries.Static"
+       echo "- run cvs up in $SPECS_DIR dir"
+
+       echo ""
+       echo "To commit with your developer account:"
+       echo "- edit $SPECS_DIR/CVS/Root"
+       echo "- edit $SOURCE_DIR/CVS/Root"
+}
+
 #---------------------------------------------
 # main()
 
@@ -1573,6 +1706,9 @@ do
                        NOSRCS="yes"
                        ALWAYS_CVSUP="no"
                        shift;;
+               -ni | --no-init )
+                       NOINIT="yes"
+                       shift;;
                --opts )
                        shift; RPMOPTS="$RPM_OPTS ${1}"; shift ;;
                --nopatch | -np )
@@ -1618,6 +1754,12 @@ do
                -FRB | --force-remove-build-requires)
                        REMOVE_BUILD_REQUIRES="force"
                        shift ;;
+               -sd | --sources-distfiles)
+                       COMMAND="list-sources-distfiles"
+                       shift ;;
+               -sdp | --sources-distfiles-paths)
+                       COMMAND="list-sources-distfiles-paths"
+                       shift ;;
                -sf | --sources-files)
                        COMMAND="list-sources-files"
                        shift ;;
@@ -1677,6 +1819,9 @@ do
                -Upi | --update-poldek-indexes )
                        UPDATE_POLDEK_INDEXES="yes"
                        shift ;;
+               --init-rpm-dir)
+                       COMMAND="init_rpm_dir";
+                       shift ;;
                -u | --try-upgrade )
                        TRY_UPGRADE="1"; shift ;;
                -un | --try-upgrade-with-float-version )
@@ -1699,7 +1844,7 @@ do
                        RPMOPTS="${RPMOPTS} --nodeps"
                        ;;
                -debug)
-                       RPMOPTS="${RPMOPTS} -debug"; shift ;;
+                       RPMBUILDOPTS="${RPMBUILDOPTS} -debug"; shift ;;
                * )
                        SPECFILE="${1}"
                        # check if specname was passed as specname:cvstag
@@ -1707,7 +1852,6 @@ do
                                CVSTAG="${SPECFILE##*:}";
                                SPECFILE="${SPECFILE%%:*}";
                        fi
-                       export PROMPT_COMMAND=`echo -ne "\033]0;${SPECFILE}\007"`
                        shift ;;
        esac
 done
@@ -1726,18 +1870,24 @@ if [ -n "$TARGET" ]; then
        esac
 fi
 
+if [ "$SCHEDTOOL" != "no" ]; then
+       NICE_COMMAND="$SCHEDTOOL"
+else
+       NICE_COMMAND="nice -n ${DEF_NICE_LEVEL}"
+fi
+
 update_shell_title "$COMMAND"
 case "$COMMAND" in
        "build" | "build-binary" | "build-source" | "build-prep" )
                init_builder;
                if [ -n "$SPECFILE" ]; then
                        get_spec;
+                       parse_spec;
                        set_bconds_values;
                        display_bconds;
                        display_branches;
                        [ X"$SHOW_BCONDS" = X"yes" ] && exit 0
                        fetch_build_requires;
-                       parse_spec;
                        if [ "$INTEGER_RELEASE" = "yes" ]; then
                                echo "Checking release $PACKAGE_RELEASE..."
                                if echo $PACKAGE_RELEASE | grep -q '^[^.]*\.[^.]*$' 2>/dev/null ; then
@@ -1765,10 +1915,6 @@ case "$COMMAND" in
                                fi
                        fi
 
-                       if [ -n "$ICONS" ]; then
-                               get_files $ICONS;
-                               parse_spec;
-                       fi
                        if [ -n "$NOSOURCE0" ] ; then
                                SOURCES=`echo $SOURCES | xargs | sed -e 's/[^ ]*//'`
                        fi
@@ -1787,10 +1933,6 @@ case "$COMMAND" in
                if [ -n "$SPECFILE" ]; then
                        get_spec;
                        parse_spec;
-                       if [ -n "$ICONS" ]; then
-                               get_files $ICONS
-                               parse_spec;
-                       fi
                        get_files $SOURCES $PATCHES;
                        branch_files $TAG "$SOURCES $PATCHES $ICONS";
                else
@@ -1801,13 +1943,8 @@ case "$COMMAND" in
                init_builder;
                if [ -n "$SPECFILE" ]; then
                        get_spec;
-                       parse_spec;
-                       if [ -n "$ICONS" ]; then
-                               OLD_UPDATE5=$UPDATE5
-                               UPDATE5= get_files $ICONS
-                               UPDATE5=$OLD_UPDATE5
-                               parse_spec;
-                       fi
+                       parse_spec
+
                        if [ -n "$NOSOURCE0" ] ; then
                                SOURCES=`echo $SOURCES | xargs | sed -e 's/[^ ]*//'`
                        fi
@@ -1823,10 +1960,7 @@ case "$COMMAND" in
                if [ -n "$SPECFILE" ]; then
                        get_spec;
                        parse_spec;
-                       if [ -n "$ICONS" ]; then
-                               get_files $ICONS
-                               parse_spec;
-                       fi
+
                        # don't fetch sources from remote locations
                        new_SOURCES=""
                        for file in $SOURCES
@@ -1877,6 +2011,35 @@ case "$COMMAND" in
                         echo $SOURCE_DIR/$(echo $SAP | awk '{gsub(/.*\//,"") ; print }')
                done
                ;;
+       "list-sources-distfiles-paths" )
+               init_builder
+               NOCVSSPEC="yes"
+               DONT_PRINT_REVISION="yes"
+               get_spec
+               parse_spec
+               SAPS="$SOURCES $PATCHES"
+               for SAP in $SAPS ; do
+                       if [ -n "$(src_md5 "$SAP")" ]; then
+                               distfiles_path "$SAP"
+                       fi
+               done
+               ;;
+       "list-sources-distfiles" )
+               init_builder
+               NOCVSSPEC="yes"
+               DONT_PRINT_REVISION="yes"
+               get_spec
+               parse_spec
+               SAPS="$SOURCES $PATCHES"
+               for SAP in $SAPS ; do
+                       if [ -n "$(src_md5 "$SAP")" ]; then
+                               distfiles_url "$SAP"
+                       fi
+               done
+               ;;
+       "init_rpm_dir")
+               init_rpm_dir
+               ;;
        "usage" )
                usage;;
        "version" )
This page took 0.154099 seconds and 4 git commands to generate.