]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - builder.sh
Make sure readable file is uploaded.
[packages/rpm-build-tools.git] / builder.sh
index edd84a1ccd1b1b4562911568d171b2437babe420..47336ade958309dfe16f30f055d6195796575875 100755 (executable)
@@ -39,7 +39,7 @@ RCSID='$Id: builder,v 1.645 2011/02/13 17:54:10 glen Exp $' r=${RCSID#* * } rev=
 VERSION="v0.35/$rev"
 VERSIONSTRING="\
 Build package utility from PLD Linux Packages repository
-$VERSION (C) 1999-2012 Free Penguins".
+$VERSION (C) 1999-2013 Free Penguins".
 
 CLEAN_PATH="/bin:/usr/bin:/usr/sbin:/sbin:/usr/X11R6/bin"
 
@@ -84,6 +84,10 @@ TARGET=$(rpm -E %{_target})
 # Yes, you can use variable name! Note _single_ quotes!
 LOGFILE=''
 
+# use teeboth Perl wrapper
+# temporary option to disable if broken
+USE_TEEBOTH=yes
+
 LOGDIR=""
 LOGDIROK=""
 LOGDIRFAIL=""
@@ -241,6 +245,7 @@ fi
 POLDEK_INDEX_DIR="$($RPM --eval %_rpmdir)/"
 POLDEK_CMD="$SU_SUDO /usr/bin/poldek --noask"
 
+# TODO: add teeboth
 run_poldek() {
        RES_FILE=$(tempfile)
        if [ -n "$LOGFILE" ]; then
@@ -249,6 +254,7 @@ run_poldek() {
                        echo "LASTLOG=$LOG" > $LASTLOG_FILE
                fi
                (${NICE_COMMAND} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE})|tee -a $LOG
+               # FIXME $exit_pldk undefined
                return $exit_pldk
        else
                (${NICE_COMMAND} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE}) 1>&2 >/dev/null
@@ -283,6 +289,10 @@ download_lftp() {
 
 usage() {
        if [ -n "$DEBUG" ]; then set -xv; fi
+# NOTE:
+# to make this output parseable by bash-completion _parse_help()
+# if the line contains short and long option, it will take only the long option
+# but if you want both being completed, put the short option to separate line
        echo "\
 Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [-a|--add_cvs] [-b|-ba|--build]
 [-bb|--build-binary] [-bs|--build-source] [-bc] [-bi] [-bl] [-u|--try-upgrade]
@@ -295,46 +305,52 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 [--show-bconds] [--with/--without <feature>] [--define <macro> <value>]
 <package>[.spec][:tag]
 
--4                  - force ipv4 when transferring files
--5, --update-md5    - update md5 comments in spec, implies -nd -ncs
--6                  - force ipv6 when transferring files
--a5, --add-md5      - add md5 comments to URL sources, implies -nc -nd -ncs
+-4                  - force IPv4 when transferring files
+-6                  - force IPv6 when transferring files
+-5,
+--update-md5        - update md5 comments in spec, implies -nd -ncs
+-a5,
+--add-md5           - add md5 comments to URL sources, implies -nc -nd -ncs
 --all-branches      - make shallow fetch of all branches; --depth required
 -n5, --no-md5       - ignore md5 comments in spec
 -D, --debug         - enable builder script debugging mode,
 -debug              - produce rpm debug package (same as --opts -debug)
 -V, --version       - output builder version string
 --short-version     - output builder short version
--a, --add_vcs       - try add new package to PLD repo.
--b, -ba, --build    - get all files from PLD repo or HTTP/FTP and build package
+-a                  - try add new package to PLD repo.
+-b,
+-ba
+                    - get all files from PLD repo or HTTP/FTP and build package
                       from <package>.spec,
--bb, --build-binary - get all files from PLD repo or HTTP/FTP and build binary
+-bb                 - get all files from PLD repo or HTTP/FTP and build binary
                       only package from <package>.spec,
--bp, --build-prep   - execute the %prep phase of <package>.spec,
+-bp                 - execute the %prep phase of <package>.spec,
 -bc                 - execute the %build phase of <package>.spec,
 -bi                 - execute the %install phase of <package>.spec
 -bl                 - execute the %files phase of <package>.spec
--bs, --build-source - get all files from PLD repo or HTTP/FTP and only pack
+-bs                 - get all files from PLD repo or HTTP/FTP and only pack
                       them into src.rpm,
 --short-circuit     - short-circuit build
 -B, --branch        - add branch
--c, --clean         - clean all temporarily created files (in BUILD\$RPM_BUILD_ROOT) after rpmbuild commands.
+-c,
+--clean             - clean all temporarily created files (in BUILD\$RPM_BUILD_ROOT) after rpmbuild commands.
                       may be used with building process.
 -m, --mr-proper     - clean all temporarily created files (in BUILD, SOURCES,
                       SPECS and \$RPM_BUILD_ROOT). Doesn't run any rpm building.
 -cf, --cvs-force    - use -f when tagging
---define <macro> <value>
+--define '<macro> <value>'
                     - define a macro <macro> with value <value>,
 --depth <number>    - make shallow fetch
 --alt_kernel <kernel>
                     - same as --define 'alt_kernel <kernel>'
 --nodeps            - rpm won't check any dependences
--g, --get           - get <package>.spec and all related files from PLD repo
-                      or HTTP/FTP,
+-g
+--get               - get <package>.spec and all related files from PLD repo
 -h, --help          - this message,
--jN, -j N           - set %_smp_mflags to propagate concurrent jobs
---ftp, --http       - use ftp or http protocol to access distfiles server
--l <logfile>, --logtofile <logfile>
+-j N                - set %_smp_mflags to propagate concurrent jobs
+--ftp               - use FTP protocol to access distfiles server
+--http              - use HTTP protocol to access distfiles server
+-l <logfile>, --logtofile=<logfile>
                     - log all to file,
 -ncs, --no-cvs-specs
                     - don't pull from PLD repo
@@ -344,7 +360,7 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 -ns, --no-srcs      - don't download Sources/Patches
 -ns0, --no-source0  - don't download Source0
 -nn, --no-net       - don't download anything from the net
--pN, -p N           - set PARALLEL_DOWNLOADS to N (default $PARALLEL_DOWNLOADS)
+-p N                - set PARALLEL_DOWNLOADS to N (default $PARALLEL_DOWNLOADS)
 -pm, --prefer-mirrors
                     - prefer mirrors (if any) over distfiles for SOURCES
 --no-init           - don't initialize builder paths (SPECS and SOURCES)
@@ -390,8 +406,8 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
                     - add git tags STABLE and NAME-VERSION-RELEASE for files,
 -Ts, --tag-stable
                     - add git tag STABLE for files,
--Tv, --tag-version
-                    - add git tag NAME-VERSION-RELEASE for files,
+-Tv,
+--tag-version       - add git tag NAME-VERSION-RELEASE for files,
 -Tp, --tag-prefix <prefix>
                     - add <prefix> to NAME-VERSION-RELEASE tags,
 -tt, --test-tag <prefix>
@@ -407,16 +423,21 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 -U, --update        - refetch sources, don't use distfiles, and update md5 comments
 -Upi, --update-poldek-indexes
                     - refresh or make poldek package index files.
--sp, --skip-patch <patchnumber>
+-sp <patchnumber>,
+--skip-patch <patchnumber>
                     - don't apply <patchnumber>. may be repeated.
--np, --nopatch <patchnumber>
+-np <patchnumber>,
+--nopatch <patchnumber>
                     - abort instead of applying patch <patchnumber>
+--noinit
+                    - do not initialize SPECS_DIR and SOURCES_DIR (set them to .)
 --show-bconds       - show available conditional builds, which can be used
                     - with --with and/or --without switches.
 --show-bcond-args   - show active bconds, from ~/.bcondrc. this is used by ./repackage.sh script.
                       In other words, the output is parseable by scripts.
 --show-avail-bconds - show available bconds
---with/--without <feature>
+--with <feature>,
+--without <feature>
                     - conditional build package depending on %_with_<feature>/
                       %_without_<feature> macro switch.  You may now use
                       --with feat1 feat2 feat3 --without feat4 feat5 --with feat6
@@ -447,15 +468,28 @@ insert_gitlog() {
        # rpm5.org/rpm.org do not parse any other date format than 'Wed Jan 1 1997'
        # otherwise i'd use --date=iso here
        # http://rpm5.org/cvs/fileview?f=rpm/build/parseChangelog.c&v=2.44.2.1
-       # http://rpm.org/gitweb?p=rpm.git;a=blob;f=build/parseChangelog.c#l31
+       # http://rpm.org/gitweb?p=rpm.git;a=blob;f=build/parseChangelog.c;h=56ba69daa41d65ec9fd18c9f371b8ff14118cdca;hb=a113baa510a004476edc44b5ebaaf559238a18b6#l33
        # NOTE: changelog date is always in UTC for rpmbuild
        # * 1265749244 +0000 Random Hacker <nikt@pld-linux.org> 9370900
-       git rev-list --date-order -${log_entries:-20} HEAD | while read sha1; do
+       git rev-list --date-order -${log_entries:-20} HEAD 2>/dev/null | while read sha1; do
                local logfmt='%B%n'
-               git notes list $sha1 > /dev/null 2>&1 && logfmt=%N
-               git log -n 1 $sha1 --format=format:"* %ad %an <%ae> %h%n${logfmt}%n" --date=raw | sed '/^$/q'
+               git notes list $sha1 > /dev/null 2>&1 && logfmt='%N'
+               git log -n 1 $sha1 --format=format:"* %ad %an <%ae> %h%n- ${logfmt}%n" --date=raw | sed -re 's/^- +- */- /'| sed '/^$/q'
        done > $gitlog
-       LC_ALL=C gawk '/^\* /{printf("* %s %s\n", strftime("%a %b %d %Y", $2), substr($0, length($1)+length($2)+length($3)+4)); next}{print}' $gitlog > $speclog
+
+       # add link to full git logs
+       local giturl="http://git.pld-linux.org/?p=packages/$PACKAGE_NAME.git;a=log"
+       if [ -n "$CVSTAG" ]; then
+               giturl="$giturl;h=$CVSTAG"
+       fi
+       local gitauthor="PLD Linux Team <feedback@pld-linux.org>"
+       LC_ALL=C gawk -vgiturl="$giturl" -vgitauthor="$gitauthor" -vpackage=$PACKAGE_NAME 'BEGIN{
+               printf("* %s %s\n- For complete changelog see: %s\n", strftime("%a %b %d %Y"), gitauthor, giturl);
+               print;
+               exit
+       }' > $speclog
+
+       LC_ALL=C gawk '/^\* /{printf("* %s %s\n", strftime("%a %b %d %Y", $2), substr($0, length($1)+length($2)+length($3)+4)); next}{print}' $gitlog >> $speclog
        sed '/^%changelog/,$d' $SPECFILE | sed -e "\${
                        a%changelog
                        r $speclog
@@ -465,6 +499,29 @@ insert_gitlog() {
        echo $specdir
 }
 
+# @param string logfile
+# @param varargs... commands to execute
+teeboth() {
+       local rc
+       # use teeboth from toys/cleanbuild, if available and enabled
+       if [ "$USE_TEEBOTH" = "yes" ] && [ -x $APPDIR/teeboth ]; then
+               $APPDIR/teeboth "$@"
+               rc=$?
+       else
+               local efile rc logfile=$1; shift
+               if [ "$logfile" ]; then
+                       efile=$(tempfile)
+                       { "$@" 2>&1; echo $? > $efile; } | tee -a $logfile
+                       rc=$(< $efile)
+                       rm -f $efile
+               else
+                       "$@"
+                       rc=$?
+               fi
+       fi
+       return $rc
+}
+
 # change dependency to specname
 # common changes:
 # - perl(Package::Name) -> perl-Package-Name
@@ -508,9 +565,9 @@ update_shell_title() {
 # set TARGET from BuildArch: from SPECFILE
 set_spec_target() {
        if [ -n "$SPECFILE" ] && [ -z "$TARGET" ]; then
-               tmp=$(awk '/^BuildArch:/ { print $NF; exit }' $ASSUMED_NAME/$SPECFILE)
+               local tmp=$(awk '/^BuildArch:/ { print $NF; exit }' $ASSUMED_NAME/$SPECFILE)
                if [ "$tmp" ]; then
-                               target_platform=$(rpm -E '%{_target_vendor}-%{_target_os}%{?_gnu}')
+                               local target_platform=$(rpm -E '%{_target_vendor}-%{_target_os}%{?_gnu}')
                                TARGET="$tmp"
                                case "$RPMBUILD" in
                                "rpmbuild")
@@ -524,10 +581,7 @@ set_spec_target() {
 
 # runs rpm with minimal macroset
 minirpm() {
-       # we reset macros not to contain macros.build as all the %() macros are
-       # executed here, while none of them are actually needed.
-       # at the time of this writing macros.build + macros contained 70 "%(...)" macros.
-       safe_macrofiles=$(rpm $TARGET_SWITCH --showrc | awk -F: '/^macrofiles/ { gsub(/^macrofiles[ \t]+:/, "", $0); gsub(/:.*macros.build:/, ":", $0); print $0 } ')
+       safe_macrofiles=$(rpm $TARGET_SWITCH --showrc | awk -F: '/^macrofiles/ { gsub(/^macrofiles[ \t]+:/, "", $0); print $0 } ')
 
        # TODO: move these to /usr/lib/rpm/macros
        cat > $BUILDER_MACROS <<'EOF'
@@ -548,6 +602,7 @@ minirpm() {
 %releq_kernel_up(n:) ERROR
 %releq_kernel_smp(n:) ERROR
 %releq_kernel(n:) ERROR
+%py_postclean(x:) ERROR
 %kgcc_package ERROR
 %_fontsdir ERROR
 %ruby_version ERROR
@@ -601,7 +656,7 @@ cache_rpm_dump() {
 
        if [ -x /usr/bin/rpm-specdump ]; then
                update_shell_title "cache_rpm_dump using rpm-specdump command"
-               rpm_dump_cache=$(rpm-specdump $TARGET_SWITCH $BCOND $SPECFILE)
+               rpm_dump_cache=$(rpm-specdump $TARGET_SWITCH $BCOND --define "_specdir $PACKAGE_DIR" --define "_sourcedir $PACKAGE_DIR" $PACKAGE_DIR/$SPECFILE)
        else
                update_shell_title "cache_rpm_dump using rpmbuild command"
                local rpm_dump
@@ -759,6 +814,9 @@ Exit_error() {
                        remove_build_requires
                        echo >&2 "Error: problem with remote (${2})"
                        exit 13 ;;
+               "err_no_checkut" )
+                       echo >&2 "Error: cannot checkout $2"
+                       exit 14 ;;
                "err_not_implemented" )
                        remove_build_requires
                        echo >&2 "Error: functionality not yet imlemented"
@@ -790,8 +848,8 @@ init_builder() {
                        PACKAGE_DIR=$REPO_DIR/$ASSUMED_NAME
                fi
        else
-               REPO_DIR="."
-               PACKAGE_DIR="."
+               PACKAGE_DIR=$(pwd)
+               REPO_DIR=$PACKAGE_DIR
        fi
        export GIT_WORK_TREE=$PACKAGE_DIR
        export GIT_DIR=$PACKAGE_DIR/.git
@@ -846,18 +904,14 @@ get_spec() {
        fi
 
        cd "$REPO_DIR"
-       if [ ! -f "$ASSUMED_NAME/$SPECFILE" ]; then
-               # XXX: still needed?
-               SPECFILE=$(basename $SPECFILE)
-       fi
-
+       SPECFILE=$(basename $SPECFILE)
        if [ "$NOCVSSPEC" != "yes" ]; then
                if [ -z "$DEPTH" ]; then
-                       if [ -d "$ASSUMED_NAME/.git" ]; then
+                       if [ -d "$PACKAGE_DIR/.git" ]; then
                                git fetch $REMOTE_PLD || Exit_error err_no_spec_in_repo
                        elif [ "$ADD_PACKAGE_CVS" = "yes" ]; then
-                               if [ ! -r "$ASSUMED_NAME/$SPECFILE" ]; then
-                                       echo "ERROR: No package to add ($ASSUMED_NAME/$SPECFILE)" >&2
+                               if [ ! -r "$PACKAGE_DIR/$SPECFILE" ]; then
+                                       echo "ERROR: No package to add ($PACKAGE_DIR/$SPECFILE)" >&2
                                        exit 101
                                fi
                                Exit_error err_not_implemented
@@ -866,7 +920,7 @@ get_spec() {
                                        unset GIT_WORK_TREE
                                        git clone  -o $REMOTE_PLD ${GIT_SERVER}/${PACKAGES_DIR}/${ASSUMED_NAME}.git || {
                                                # softfail if new package, i.e not yet added to PLD rep
-                                               [ ! -f "$ASSUMED_NAME/$SPECFILE" ] && Exit_error err_no_spec_in_repo
+                                               [ ! -f "$PACKAGE_DIR/$SPECFILE" ] && Exit_error err_no_spec_in_repo
                                                echo "Warning: package not in CVS - assuming new package"
                                                NOCVSSPEC="yes"
                                        }
@@ -875,9 +929,9 @@ get_spec() {
                                )
                        fi
                else
-                       if [ ! -d "$ASSUMED_NAME/.git" ]; then
-                               if [ ! -d "$ASSUMED_NAME" ]; then
-                                       mkdir $ASSUMED_NAME
+                       if [ ! -d "$PACKAGE_DIR/.git" ]; then
+                               if [ ! -d "$PACKAGE_DIR" ]; then
+                                       install -d $PACKAGE_DIR
                                fi
                                git init
                                git remote add $REMOTE_PLD ${GIT_SERVER}/${PACKAGES_DIR}/${ASSUMED_NAME}.git
@@ -901,43 +955,50 @@ get_spec() {
                # add default log format to .gitignore if it is relative to package dir
                if [ -n "$LOGFILE" -a "$LOGFILE" = "${LOGFILE##*/}" ]; then
                        # substitute known "macros" to glob
-                       local logfile=$(echo "$LOGFILE" | sed -e 's,\$\(PACKAGE_NAME\|DATE\),*,g')
+                       local logfile=$(echo "$LOGFILE" | sed -e 's,\$\(PACKAGE_NAME\|DATE\|TARGET\),*,g')
                        if [ "$logfile" ]; then
                                cvsignore_df "$logfile"
                        fi
                fi
 
                # create symlinks for tools
-               if [ "$SYMLINK_TOOLS" != "no" -a -d "$ASSUMED_NAME" ]; then
+               if [ "$SYMLINK_TOOLS" != "no" -a -d "$PACKAGE_DIR" ]; then
                        for a in dropin md5 adapter builder {relup,compile,repackage,rsync,pearize}.sh pldnotify.awk; do
                                # skip tools that don't exist in top dir
                                [ -f $a ] || continue
                                # skip tools that already exist
-                               [ -f $ASSUMED_NAME/$a ] && continue
-                               ln -s ../$a $ASSUMED_NAME
+                               [ -f $PACKAGE_DIR/$a ] && continue
+                               ln -s ../$a $PACKAGE_DIR
                                cvsignore_df $a
                        done
                fi
        fi
 
        if [ -n "$CVSTAG" ]; then
-               git checkout "$CVSTAG" -- 2>/dev/null || git checkout -t "${REMOTE_PLD}/$CVSTAG" > /dev/null || exit
-               git symbolic-ref -q HEAD > /dev/null &&
-                       git merge '@{u}'
+               if git rev-parse --verify -q "$CVSTAG"; then
+                       git checkout "$CVSTAG" --
+               elif git rev-parse --verify -q "refs/remotes/${REMOTE_PLD}/$CVSTAG"; then
+                       git checkout -t "refs/remotes/${REMOTE_PLD}/$CVSTAG" > /dev/null
+               fi
+               if [ $(git rev-parse "$CVSTAG") != $(git rev-parse HEAD) ]; then
+                       Exit_error "err_no_checkut" "$CVSTAG"
+               fi
+                       git merge --ff-only '@{u}'
+               git symbolic-ref -q HEAD > /dev/null && [ "$NOCVSSPEC" != "yes" ] &&
                if [ -n "$CVSDATE" ]; then
                        git checkout $(git rev-list -n1 --before="'$CVSDATE'" $CVSTAG) || exit 1
                fi
        fi
 
-       if [ ! -f "$ASSUMED_NAME/$SPECFILE" ]; then
+       if [ ! -f "$PACKAGE_DIR/$SPECFILE" ]; then
                Exit_error err_no_spec_in_repo
        fi
 
        if [ "$CHMOD" = "yes" -a -n "$SPECFILE" ]; then
-               chmod $CHMOD_MODE $ASSUMED_NAME/$SPECFILE
+               chmod $CHMOD_MODE $PACKAGE_DIR/$SPECFILE
        fi
        unset OPTIONS
-       [ -n "$DONT_PRINT_REVISION" ] || grep -E -m 1 "^#.*Revision:.*Date" $ASSUMED_NAME/$SPECFILE
+       [ -n "$DONT_PRINT_REVISION" ] || grep -E -m 1 "^#.*Revision:.*Date" $PACKAGE_DIR/$SPECFILE
 
        set_spec_target
 }
@@ -946,7 +1007,7 @@ find_mirror() {
        cd "$REPO_DIR"
        local url="$1"
        if [ ! -f "mirrors"  ] ; then
-               ln -s rpm-build-tools/mirrors .
+               ln -s ../rpm-build-tools/mirrors .
        fi
 
        IFS="|"
@@ -986,15 +1047,16 @@ src_md5() {
        cd $PACKAGE_DIR
        local md5
 
-       if [ -f additional-md5sums ]; then
-               md5=$(grep -s -v '^#' additional-md5sums | \
-               grep -E "[      ]$(basename "$1")([     ,]|\$)" | \
+       # use "sources" file from package dir, like vim
+       if [ -f sources ]; then
+               md5=$(grep -s -v '^#' sources | \
+               grep -E "[      *]$(basename "$1")([    ,]|\$)" | \
                sed -e 's/^\([0-9a-f]\{32\}\).*/\1/' | \
                grep -E '^[0-9a-f]{32}$')
 
                if [ "$md5" ]; then
                        if [ $(echo "$md5" | wc -l) != 1 ] ; then
-                               echo "$SPECFILE: more then one entry in additional-md5sums for $1" 1>&2
+                               echo "$SPECFILE: more then one entry in sources for $1" 1>&2
                        fi
                        echo "$md5" | tail -n 1
                        return
@@ -1209,10 +1271,6 @@ get_files() {
                                                update_shell_title "${GETLOCAL%% *}: $url"
                                                ${GETLOCAL} $url $target
                                        else
-                                               if [ -z "$NOMIRRORS" ]; then
-                                                       url=$(find_mirror "$url")
-                                               fi
-
                                                local uri=${url}
                                                # make shorter message for distfiles urls
                                                if [[ "$uri" = ${PROTOCOL}${DISTFILES_SERVER}* ]] || [[ "$uri" = ${PROTOCOL}${ATTICDISTFILES_SERVER}* ]]; then
@@ -1235,9 +1293,6 @@ get_files() {
                                                        update_shell_title "${GETLOCAL%% *}: $url_attic"
                                                        ${GETLOCAL} $url_attic $target
                                                else
-                                                       if [ -z "$NOMIRRORS" ]; then
-                                                               url_attic=$(find_mirror "$url_attic")
-                                                       fi
                                                        update_shell_title "${GETURI%% *}: $url_attic"
                                                        ${GETURI} ${OUTFILEOPT} "$target" "$url_attic" || \
                                                        if [ "`echo $url_attic | grep -E 'ftp://'`" ]; then
@@ -1527,36 +1582,34 @@ build_package() {
        esac
 
        update_shell_title "build_package: $COMMAND"
+       local logfile retval
        if [ -n "$LOGFILE" ]; then
-               LOG=`eval echo $LOGFILE`
-               if [ -d "$LOG" ]; then
-                       echo "Log file $LOG is a directory."
+               logfile=`eval echo $LOGFILE`
+               if [ -d "$logfile" ]; then
+                       echo "Log file $logfile is a directory."
                        echo "Parse error in the spec?"
                        Exit_error err_build_fail
                fi
                if [ -n "$LASTLOG_FILE" ]; then
-                       echo "LASTLOG=$LOG" > $LASTLOG_FILE
+                       echo "LASTLOG=$logfile" > $LASTLOG_FILE
                fi
-               RES_FILE=$(tempfile)
-               local specdir=$(insert_gitlog $SPECFILE)
-
-               (time eval PATH=$CLEAN_PATH ${NICE_COMMAND} $RPMBUILD $TARGET_SWITCH $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND --define \'_specdir $PACKAGE_DIR\' --define \'_sourcedir $PACKAGE_DIR\' $specdir/$SPECFILE; echo $? > $RES_FILE) 2>&1 |tee $LOG
-               RETVAL=`cat $RES_FILE`
-               rm -r $RES_FILE $specdir
-               if [ -n "$LOGDIROK" ] && [ -n "$LOGDIRFAIL" ]; then
-                       if [ "$RETVAL" -eq "0" ]; then
-                               mv $LOG $LOGDIROK
-                       else
-                               mv $LOG $LOGDIRFAIL
-                       fi
+       fi
+
+       local specdir=$(insert_gitlog $SPECFILE)
+       # FIXME: eval here is exactly why?
+       PATH=$CLEAN_PATH eval teeboth "'$logfile'" ${NICE_COMMAND} $RPMBUILD $TARGET_SWITCH $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND --define \'_specdir $PACKAGE_DIR\' --define \'_sourcedir $PACKAGE_DIR\' $specdir/$SPECFILE
+       retval=$?
+       rm -r $specdir
+
+       if [ -n "$logfile" ] && [ -n "$LOGDIROK" ] && [ -n "$LOGDIRFAIL" ]; then
+               if [ "$retval" -eq "0" ]; then
+                       mv $logfile $LOGDIROK
+               else
+                       mv $logfile $LOGDIRFAIL
                fi
-       else
-               local specdir=$(insert_gitlog $SPECFILE)
-               eval PATH=$CLEAN_PATH ${NICE_COMMAND} $RPMBUILD $TARGET_SWITCH $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND --define \'_specdir $PACKAGE_DIR\' --define \'_sourcedir $PACKAGE_DIR\' $specdir/$SPECFILE
-               RETVAL=$?
-               rm -r $specdir
        fi
-       if [ "$RETVAL" -ne "0" ]; then
+
+       if [ "$retval" -ne "0" ]; then
                if [ -n "$TRY_UPGRADE" ]; then
                        echo "\nUpgrade package to new version failed."
                        if [ "$REVERT_BROKEN_UPGRADE" = "yes" ]; then
@@ -1787,7 +1840,7 @@ display_bconds() {
 
 display_branches() {
        echo -n "Available branches: "
-       git branch -r | grep "^  ${REMOTE_PLD}" | grep -v ${REMOTE_PLD}/HEAD | sed "s#^ *${REMOTE_PLD}/##" | xargs
+       git branch -r 2>/dev/null | grep "^  ${REMOTE_PLD}" | grep -v ${REMOTE_PLD}/HEAD | sed "s#^ *${REMOTE_PLD}/##" | xargs
 }
 
 # checks a given list of packages/files/provides agains current rpmdb.
@@ -2025,23 +2078,36 @@ fetch_build_requires()
                fi
 }
 
+init_repository() {
+       local remoterepo=$1
+       local localrepo=$2
+
+       if [ ! -e $localrepo ]; then
+               git clone -o $REMOTE_PLD ${GIT_SERVER}/$remoterepo $localrepo
+               git --git-dir=$localrepo/.git remote set-url --push  $REMOTE_PLD ssh://${GIT_PUSH}/$remoterepo
+       fi
+}
+
 init_rpm_dir() {
        local TOP_DIR=$(eval $RPM $RPMOPTS --eval '%{_topdir}')
        local rpmdir=$(eval $RPM $RPMOPTS --eval '%{_rpmdir}')
        local buildir=$(eval $RPM $RPMOPTS --eval '%{_builddir}')
        local srpmdir=$(eval $RPM $RPMOPTS --eval '%{_srcrpmdir}')
+       local TEMPLATES=template-specs
        local tmp
 
        echo "Initializing rpm directories to $TOP_DIR from $GIT_SERVER"
        mkdir -p $TOP_DIR $rpmdir $buildir $srpmdir
 
        cd "$TOP_DIR"
-       if [ ! -e ../rpm-build-tools ]; then
-               git clone  ${GIT_SERVER}/${PACKAGES_DIR}/rpm-build-tools.git ../rpm-build-tools
-       fi
-       for a in adapter builder fetchsrc_request; do
+       init_repository ${PACKAGES_DIR}/rpm-build-tools.git ../rpm-build-tools
+       init_repository projects/$TEMPLATES ../$TEMPLATES
+       for a in adapter builder fetchsrc_request compile repackage; do
                ln -sf ../rpm-build-tools/${a}.sh $a
        done
+       for a in md5; do
+               ln -sf ../rpm-build-tools/${a} $a
+       done
        ln -sf ../rpm-build-tools/mirrors mirrors
        init_builder
 }
@@ -2052,7 +2118,7 @@ mr_proper() {
        DONT_PRINT_REVISION="yes"
 
        # remove spec and sources
-       PATH=$CLEAN_PATH $RPMBUILD --clean --rmsource --rmspec --nodeps --define "_specdir $PACKAGE_DIR" --define "_sourcedir $PACKAGE_DIR" --define "_builddir $builddir" $PACKAGE_DIR/$SPECFILE
+       PATH=$CLEAN_PATH $RPMBUILD --clean --rmsource --rmspec --nodeps --define "__urlgetfile() %nil" --define "_specdir $PACKAGE_DIR" --define "_sourcedir $PACKAGE_DIR" --define "_builddir $builddir" $PACKAGE_DIR/$SPECFILE
        rm -rf $PACKAGE_DIR/{.git,.gitignore}
        rmdir --ignore-fail-on-non-empty $PACKAGE_DIR
 }
@@ -2178,7 +2244,7 @@ while [ $# -gt 0 ]; do
                -pm | --prefer-mirrors )
                        PREFMIRRORS="yes"
                        shift;;
-               --no-init )
+               --noinit | --no-init )
                        NOINIT="yes"
                        shift;;
                --opts )
@@ -2477,12 +2543,15 @@ case "$COMMAND" in
                # ./builder -bs test.spec -r AC-branch -Tp auto-ac- -tt
                if [ -n "$TEST_TAG" ]; then
                        local TAGVER=`make_tagver`
-                       tag_exist $TAGVER
+                       tag_exist $TAGVER || [ $TAGVER = $CVSTAG ] || Exit_error err_tag_exists $TAGVER
                        # check also tags created in CVS
-                       tag_exist $(echo $TAGVER | tr '[.@]' '[_#]')
+                       local TAGVER_CVS=$(echo $TAGVER | tr '[.@]' '[_#]')
+                       local CVSTAG_CVS=$(echo $CVSTAG | tr '[.@]' '[_#]')
+                       tag_exist $TAGVER_CVS || [ $TAGVER_CVS = $CVSTAG_CVS ] \
+                               || Exit_error err_tag_exists $TAGVER_CVS
                        # - do not allow to build from HEAD when XX-branch exists
                        TREE_PREFIX=$(echo "$TAG_PREFIX" | sed -e 's#^auto/\([a-zA-Z]\+\)/.*#\1#g')
-                       if [ "$TREE_PREFIX" != "$TAG_PREFIX" ]; then
+                       if [ "$TAGVER" != "$CVSTAG" -a "$TAGVER_CVS" != "$CVSTAG" -a  "$TREE_PREFIX" != "$TAG_PREFIX" ]; then
                                TAG_BRANCH="${TREE_PREFIX}-branch"
                                if [ -n "$DEPTH" ]; then
                                        cmd_branches="git ls-remote --heads"
@@ -2506,7 +2575,7 @@ case "$COMMAND" in
                case $? in
                        0)
                                get_files $SOURCES $PATCHES
-                               check_md5 $SOURCES
+                               check_md5 $SOURCES $PATCHES
                                ;;
                        *)
                                NODIST="yes" get_files $SOURCES $PATCHES
@@ -2610,13 +2679,13 @@ case "$COMMAND" in
                done
                ;;
        "list-sources-urls" )
-               init_builder
+               init_builder >&2
                NOCVSSPEC="yes"
                DONT_PRINT_REVISION="yes"
-               get_spec
-               parse_spec
+               get_spec >&2
+               parse_spec >&2
                SAPS="$SOURCES $PATCHES"
-               for SAP in $SAPS ; do
+               for SAP in $SAPS; do
                        echo $SAP
                done
                ;;
This page took 0.06526 seconds and 4 git commands to generate.