]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - builder.sh
builder: Check md5 sums of downloaded patches
[packages/rpm-build-tools.git] / builder.sh
index 88432f7225078bd3ed7016f886e0bfc1129214cb..405d47115ea5d206c124312f2466d9fd1ae22dce 100755 (executable)
@@ -39,9 +39,9 @@ RCSID='$Id: builder,v 1.645 2011/02/13 17:54:10 glen Exp $' r=${RCSID#* * } rev=
 VERSION="v0.35/$rev"
 VERSIONSTRING="\
 Build package utility from PLD Linux Packages repository
-$VERSION (C) 1999-2011 Free Penguins".
+$VERSION (C) 1999-2013 Free Penguins".
 
-PATH="/bin:/usr/bin:/usr/sbin:/sbin:/usr/X11R6/bin"
+CLEAN_PATH="/bin:/usr/bin:/usr/sbin:/sbin:/usr/X11R6/bin"
 
 # required rpm-build-macros
 RPM_MACROS_VER=1.534
@@ -84,6 +84,10 @@ TARGET=$(rpm -E %{_target})
 # Yes, you can use variable name! Note _single_ quotes!
 LOGFILE=''
 
+# use teeboth Perl wrapper
+# temporary option to disable if broken
+USE_TEEBOTH=yes
+
 LOGDIR=""
 LOGDIROK=""
 LOGDIRFAIL=""
@@ -111,6 +115,7 @@ PROTOCOL="http"
 # use lftp by default when available
 USE_LFTP=
 lftp --version > /dev/null 2>&1 && USE_LFTP=yes
+PARALLEL_DOWNLOADS=10
 
 WGET_RETRIES=${MAX_WGET_RETRIES:-0}
 
@@ -240,6 +245,7 @@ fi
 POLDEK_INDEX_DIR="$($RPM --eval %_rpmdir)/"
 POLDEK_CMD="$SU_SUDO /usr/bin/poldek --noask"
 
+# TODO: add teeboth
 run_poldek() {
        RES_FILE=$(tempfile)
        if [ -n "$LOGFILE" ]; then
@@ -248,6 +254,7 @@ run_poldek() {
                        echo "LASTLOG=$LOG" > $LASTLOG_FILE
                fi
                (${NICE_COMMAND} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE})|tee -a $LOG
+               # FIXME $exit_pldk undefined
                return $exit_pldk
        else
                (${NICE_COMMAND} ${POLDEK_CMD} `while test $# -gt 0; do echo "$1 ";shift;done` ; echo $? > ${RES_FILE}) 1>&2 >/dev/null
@@ -268,7 +275,7 @@ download_lftp() {
                set ssl:verify-certificate no;
                set net:max-retries $WGET_RETRIES;
                set http:user-agent \"$USER_AGENT\";
-               pget -n 10 -c \"$url\" -o \"$tmpfile\"
+               pget -n $PARALLEL_DOWNLOADS -c \"$url\" -o \"$tmpfile\"
        "
 
        retval=$?
@@ -282,6 +289,10 @@ download_lftp() {
 
 usage() {
        if [ -n "$DEBUG" ]; then set -xv; fi
+# NOTE:
+# to make this output parseable by bash-completion _parse_help()
+# if the line contains short and long option, it will take only the long option
+# but if you want both being completed, put the short option to separate line
        echo "\
 Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [-a|--add_cvs] [-b|-ba|--build]
 [-bb|--build-binary] [-bs|--build-source] [-bc] [-bi] [-bl] [-u|--try-upgrade]
@@ -294,46 +305,52 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 [--show-bconds] [--with/--without <feature>] [--define <macro> <value>]
 <package>[.spec][:tag]
 
--4                  - force ipv4 when transferring files
--5, --update-md5    - update md5 comments in spec, implies -nd -ncs
--6                  - force ipv6 when transferring files
--a5, --add-md5      - add md5 comments to URL sources, implies -nc -nd -ncs
+-4                  - force IPv4 when transferring files
+-6                  - force IPv6 when transferring files
+-5,
+--update-md5        - update md5 comments in spec, implies -nd -ncs
+-a5,
+--add-md5           - add md5 comments to URL sources, implies -nc -nd -ncs
 --all-branches      - make shallow fetch of all branches; --depth required
 -n5, --no-md5       - ignore md5 comments in spec
 -D, --debug         - enable builder script debugging mode,
 -debug              - produce rpm debug package (same as --opts -debug)
 -V, --version       - output builder version string
 --short-version     - output builder short version
--a, --add_vcs       - try add new package to PLD repo.
--b, -ba, --build    - get all files from PLD repo or HTTP/FTP and build package
+-a                  - try add new package to PLD repo.
+-b,
+-ba
+                    - get all files from PLD repo or HTTP/FTP and build package
                       from <package>.spec,
--bb, --build-binary - get all files from PLD repo or HTTP/FTP and build binary
+-bb                 - get all files from PLD repo or HTTP/FTP and build binary
                       only package from <package>.spec,
--bp, --build-prep   - execute the %prep phase of <package>.spec,
+-bp                 - execute the %prep phase of <package>.spec,
 -bc                 - execute the %build phase of <package>.spec,
 -bi                 - execute the %install phase of <package>.spec
 -bl                 - execute the %files phase of <package>.spec
--bs, --build-source - get all files from PLD repo or HTTP/FTP and only pack
+-bs                 - get all files from PLD repo or HTTP/FTP and only pack
                       them into src.rpm,
 --short-circuit     - short-circuit build
 -B, --branch        - add branch
--c, --clean         - clean all temporarily created files (in BUILD\$RPM_BUILD_ROOT) after rpmbuild commands.
+-c,
+--clean             - clean all temporarily created files (in BUILD\$RPM_BUILD_ROOT) after rpmbuild commands.
                       may be used with building process.
 -m, --mr-proper     - clean all temporarily created files (in BUILD, SOURCES,
                       SPECS and \$RPM_BUILD_ROOT). Doesn't run any rpm building.
 -cf, --cvs-force    - use -f when tagging
---define <macro> <value>
+--define '<macro> <value>'
                     - define a macro <macro> with value <value>,
 --depth <number>    - make shallow fetch
 --alt_kernel <kernel>
                     - same as --define 'alt_kernel <kernel>'
 --nodeps            - rpm won't check any dependences
--g, --get           - get <package>.spec and all related files from PLD repo
-                      or HTTP/FTP,
+-g
+--get               - get <package>.spec and all related files from PLD repo
 -h, --help          - this message,
--jN, -j N           - set %_smp_mflags to propagate concurrent jobs
---ftp, --http       - use ftp or http protocol to access distfiles server
--l <logfile>, --logtofile <logfile>
+-j N                - set %_smp_mflags to propagate concurrent jobs
+--ftp               - use FTP protocol to access distfiles server
+--http              - use HTTP protocol to access distfiles server
+-l <logfile>, --logtofile=<logfile>
                     - log all to file,
 -ncs, --no-cvs-specs
                     - don't pull from PLD repo
@@ -343,6 +360,7 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 -ns, --no-srcs      - don't download Sources/Patches
 -ns0, --no-source0  - don't download Source0
 -nn, --no-net       - don't download anything from the net
+-p N                - set PARALLEL_DOWNLOADS to N (default $PARALLEL_DOWNLOADS)
 -pm, --prefer-mirrors
                     - prefer mirrors (if any) over distfiles for SOURCES
 --no-init           - don't initialize builder paths (SPECS and SOURCES)
@@ -388,8 +406,8 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
                     - add git tags STABLE and NAME-VERSION-RELEASE for files,
 -Ts, --tag-stable
                     - add git tag STABLE for files,
--Tv, --tag-version
-                    - add git tag NAME-VERSION-RELEASE for files,
+-Tv,
+--tag-version       - add git tag NAME-VERSION-RELEASE for files,
 -Tp, --tag-prefix <prefix>
                     - add <prefix> to NAME-VERSION-RELEASE tags,
 -tt, --test-tag <prefix>
@@ -405,16 +423,21 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 -U, --update        - refetch sources, don't use distfiles, and update md5 comments
 -Upi, --update-poldek-indexes
                     - refresh or make poldek package index files.
--sp, --skip-patch <patchnumber>
+-sp <patchnumber>,
+--skip-patch <patchnumber>
                     - don't apply <patchnumber>. may be repeated.
--np, --nopatch <patchnumber>
+-np <patchnumber>,
+--nopatch <patchnumber>
                     - abort instead of applying patch <patchnumber>
+--noinit
+                    - do not initialize SPECS_DIR and SOURCES_DIR (set them to .)
 --show-bconds       - show available conditional builds, which can be used
                     - with --with and/or --without switches.
 --show-bcond-args   - show active bconds, from ~/.bcondrc. this is used by ./repackage.sh script.
                       In other words, the output is parseable by scripts.
 --show-avail-bconds - show available bconds
---with/--without <feature>
+--with <feature>,
+--without <feature>
                     - conditional build package depending on %_with_<feature>/
                       %_without_<feature> macro switch.  You may now use
                       --with feat1 feat2 feat3 --without feat4 feat5 --with feat6
@@ -427,11 +450,11 @@ Usage: builder [--all-branches] [-D|--debug] [-V|--version] [--short-version]  [
 
 # create tempfile. as secure as possible
 tempfile() {
-       mktemp -t builder.XXXXXX || ${TMPDIR:-/tmp}/builder.$RANDOM.$$
+       mktemp --tmpdir -t builder.$PACKAGE_NAME.XXXXXX || ${TMPDIR:-/tmp}/builder.$RANDOM.$$
 }
 
 tempdir() {
-       mktemp -d builder.XXXXXX
+       mktemp --tmpdir -d builder.$PACKAGE_NAME.XXXXXX
 }
 
 # inserts git log instead of %changelog
@@ -448,12 +471,25 @@ insert_gitlog() {
        # http://rpm.org/gitweb?p=rpm.git;a=blob;f=build/parseChangelog.c#l31
        # NOTE: changelog date is always in UTC for rpmbuild
        # * 1265749244 +0000 Random Hacker <nikt@pld-linux.org> 9370900
-       git rev-list -${log_entries:-20} HEAD | while read sha1; do
+       git rev-list --date-order -${log_entries:-20} HEAD 2>/dev/null | while read sha1; do
                local logfmt='%B%n'
-               git notes list $sha1 &> /dev/null && logfmt=%N
-               git log -n 1 $sha1 --format=format:"* %ad %an <%ae> %h%n${logfmt}%n" --date=raw | sed '/^$/q'
+               git notes list $sha1 > /dev/null 2>&1 && logfmt='%N'
+               git log -n 1 $sha1 --format=format:"* %ad %an <%ae> %h%n- ${logfmt}%n" --date=raw | sed -re 's/^- +- */- /'| sed '/^$/q'
        done > $gitlog
-       gawk '/^\* /{printf("* %s %s\n", strftime("%a %b %d %Y", $2), substr($0, length($1)+length($2)+length($3)+4)); next}{print}' $gitlog > $speclog
+
+       # add link to full git logs
+       local giturl="http://git.pld-linux.org/?p=packages/$PACKAGE_NAME.git;a=log"
+       if [ -n "$CVSTAG" ]; then
+               giturl="$giturl;h=$CVSTAG"
+       fi
+       local gitauthor="PLD Linux Team <feedback@pld-linux.org>"
+       LC_ALL=C gawk -vgiturl="$giturl" -vgitauthor="$gitauthor" -vpackage=$PACKAGE_NAME 'BEGIN{
+               printf("* %s %s\n- For complete changelog see: %s\n", strftime("%a %b %d %Y"), gitauthor, giturl);
+               print;
+               exit
+       }' > $speclog
+
+       LC_ALL=C gawk '/^\* /{printf("* %s %s\n", strftime("%a %b %d %Y", $2), substr($0, length($1)+length($2)+length($3)+4)); next}{print}' $gitlog >> $speclog
        sed '/^%changelog/,$d' $SPECFILE | sed -e "\${
                        a%changelog
                        r $speclog
@@ -463,6 +499,29 @@ insert_gitlog() {
        echo $specdir
 }
 
+# @param string logfile
+# @param varargs... commands to execute
+teeboth() {
+       local rc
+       # use teeboth from toys/cleanbuild, if available and enabled
+       if [ "$USE_TEEBOTH" = "yes" ] && [ -x $APPDIR/teeboth ]; then
+               $APPDIR/teeboth "$@"
+               rc=$?
+       else
+               local efile rc logfile=$1; shift
+               if [ "$logfile" ]; then
+                       efile=$(tempfile)
+                       { "$@" 2>&1; echo $? > $efile; } | tee -a $logfile
+                       rc=$(< $efile)
+                       rm -f $efile
+               else
+                       "$@"
+                       rc=$?
+               fi
+       fi
+       return $rc
+}
+
 # change dependency to specname
 # common changes:
 # - perl(Package::Name) -> perl-Package-Name
@@ -506,9 +565,9 @@ update_shell_title() {
 # set TARGET from BuildArch: from SPECFILE
 set_spec_target() {
        if [ -n "$SPECFILE" ] && [ -z "$TARGET" ]; then
-               tmp=$(awk '/^BuildArch:/ { print $NF; exit }' $ASSUMED_NAME/$SPECFILE)
+               local tmp=$(awk '/^BuildArch:/ { print $NF; exit }' $ASSUMED_NAME/$SPECFILE)
                if [ "$tmp" ]; then
-                               target_platform=$(rpm -E '%{_target_vendor}-%{_target_os}%{?_gnu}')
+                               local target_platform=$(rpm -E '%{_target_vendor}-%{_target_os}%{?_gnu}')
                                TARGET="$tmp"
                                case "$RPMBUILD" in
                                "rpmbuild")
@@ -546,6 +605,7 @@ minirpm() {
 %releq_kernel_up(n:) ERROR
 %releq_kernel_smp(n:) ERROR
 %releq_kernel(n:) ERROR
+%py_postclean(x:) ERROR
 %kgcc_package ERROR
 %_fontsdir ERROR
 %ruby_version ERROR
@@ -588,7 +648,7 @@ EOF
 %_sourcedir ./
 EOF
        fi
-       eval $RPMBUILD $TARGET_SWITCH --macros "$safe_macrofiles:$BUILDER_MACROS" $QUIET $RPMOPTS $RPMBUILDOPTS $BCOND $* 2>&1
+       eval PATH=$CLEAN_PATH $RPMBUILD $TARGET_SWITCH --macros "$safe_macrofiles:$BUILDER_MACROS" $QUIET $RPMOPTS $RPMBUILDOPTS $BCOND $* 2>&1
 }
 
 cache_rpm_dump() {
@@ -599,7 +659,7 @@ cache_rpm_dump() {
 
        if [ -x /usr/bin/rpm-specdump ]; then
                update_shell_title "cache_rpm_dump using rpm-specdump command"
-               rpm_dump_cache=$(rpm-specdump $TARGET_SWITCH $BCOND $SPECFILE)
+               rpm_dump_cache=$(rpm-specdump $TARGET_SWITCH $BCOND --define "_specdir $PACKAGE_DIR" --define "_sourcedir $PACKAGE_DIR" $PACKAGE_DIR/$SPECFILE)
        else
                update_shell_title "cache_rpm_dump using rpmbuild command"
                local rpm_dump
@@ -757,6 +817,9 @@ Exit_error() {
                        remove_build_requires
                        echo >&2 "Error: problem with remote (${2})"
                        exit 13 ;;
+               "err_no_checkut" )
+                       echo >&2 "Error: cannot checkout $2"
+                       exit 14 ;;
                "err_not_implemented" )
                        remove_build_requires
                        echo >&2 "Error: functionality not yet imlemented"
@@ -794,7 +857,7 @@ init_builder() {
        export GIT_WORK_TREE=$PACKAGE_DIR
        export GIT_DIR=$PACKAGE_DIR/.git
 
-       if [ -d "$GIT_DIR" ] && [ -z "$CVSTAG" ]; then
+       if [ -d "$GIT_DIR" ] &&  [ -z "$CVSTAG" ] && git rev-parse --verify -q HEAD > /dev/null; then
                if CVSTAG=$(GIT_DIR=$GIT_DIR git symbolic-ref HEAD) 2>/dev/null; then
                        CVSTAG=${CVSTAG#refs/heads/}
                        if [ "$CVSTAG" != "master" ]; then
@@ -827,7 +890,7 @@ create_git_repo() {
                exit 101
        fi
        [ -d "$ASSUMED_NAME/.git" ] || NEW_REPO=yes
-       # ssh $GIT_SERVER create ${ASSUMED_NAME} || Exit_error err_cvs_add_failed
+       ssh $GIT_PUSH create ${ASSUMED_NAME} || Exit_error err_cvs_add_failed
        git init
        git remote add $REMOTE_PLD ${GIT_SERVER}/${PACKAGES_DIR}/${ASSUMED_NAME}.git && \
                git remote set-url --push  $REMOTE_PLD ssh://${GIT_PUSH}/${PACKAGES_DIR}/${ASSUMED_NAME} \
@@ -844,18 +907,14 @@ get_spec() {
        fi
 
        cd "$REPO_DIR"
-       if [ ! -f "$ASSUMED_NAME/$SPECFILE" ]; then
-               # XXX: still needed?
-               SPECFILE=$(basename $SPECFILE)
-       fi
-
+       SPECFILE=$(basename $SPECFILE)
        if [ "$NOCVSSPEC" != "yes" ]; then
                if [ -z "$DEPTH" ]; then
-                       if [ -d "$ASSUMED_NAME/.git" ]; then
+                       if [ -d "$PACKAGE_DIR/.git" ]; then
                                git fetch $REMOTE_PLD || Exit_error err_no_spec_in_repo
                        elif [ "$ADD_PACKAGE_CVS" = "yes" ]; then
-                               if [ ! -r "$ASSUMED_NAME/$SPECFILE" ]; then
-                                       echo "ERROR: No package to add ($ASSUMED_NAME/$SPECFILE)" >&2
+                               if [ ! -r "$PACKAGE_DIR/$SPECFILE" ]; then
+                                       echo "ERROR: No package to add ($PACKAGE_DIR/$SPECFILE)" >&2
                                        exit 101
                                fi
                                Exit_error err_not_implemented
@@ -864,20 +923,23 @@ get_spec() {
                                        unset GIT_WORK_TREE
                                        git clone  -o $REMOTE_PLD ${GIT_SERVER}/${PACKAGES_DIR}/${ASSUMED_NAME}.git || {
                                                # softfail if new package, i.e not yet added to PLD rep
-                                               [ ! -f "$ASSUMED_NAME/$SPECFILE" ] && Exit_error err_no_spec_in_repo
+                                               [ ! -f "$PACKAGE_DIR/$SPECFILE" ] && Exit_error err_no_spec_in_repo
                                                echo "Warning: package not in CVS - assuming new package"
                                                NOCVSSPEC="yes"
                                        }
+                                       git config --local --add "remote.$REMOTE_PLD.fetch"  'refs/notes/*:refs/notes/*'
                                        git remote set-url --push  $REMOTE_PLD ssh://${GIT_PUSH}/${PACKAGES_DIR}/${ASSUMED_NAME}
                                )
                        fi
                else
-                       if [ ! -d "$ASSUMED_NAME/.git" ]; then
-                               if [ ! -d "$ASSUMED_NAME" ]; then
-                                       mkdir $ASSUMED_NAME
+                       if [ ! -d "$PACKAGE_DIR/.git" ]; then
+                               if [ ! -d "$PACKAGE_DIR" ]; then
+                                       install -d $PACKAGE_DIR
                                fi
                                git init
-                               git remote add $REMOTE_PLD ${GIT_SERVER}:${PACKAGES_DIR}/${ASSUMED_NAME}.git
+                               git remote add $REMOTE_PLD ${GIT_SERVER}/${PACKAGES_DIR}/${ASSUMED_NAME}.git
+                               git config --local --add "remote.$REMOTE_PLD.fetch"  'refs/notes/*:refs/notes/*'
+                               git remote set-url --push  $REMOTE_PLD ssh://${GIT_PUSH}/${PACKAGES_DIR}/${ASSUMED_NAME}
                                CVSTAG=${CVSTAG:-"master"}
                        fi
                        local refs=''
@@ -896,43 +958,50 @@ get_spec() {
                # add default log format to .gitignore if it is relative to package dir
                if [ -n "$LOGFILE" -a "$LOGFILE" = "${LOGFILE##*/}" ]; then
                        # substitute known "macros" to glob
-                       local logfile=$(echo "$LOGFILE" | sed -e 's,\$\(PACKAGE_NAME\|DATE\),*,g')
+                       local logfile=$(echo "$LOGFILE" | sed -e 's,\$\(PACKAGE_NAME\|DATE\|TARGET\),*,g')
                        if [ "$logfile" ]; then
                                cvsignore_df "$logfile"
                        fi
                fi
 
                # create symlinks for tools
-               if [ "$SYMLINK_TOOLS" != "no" ]; then
-                       for a in dropin md5 adapter builder {relup,compile,repackage,pearize}.sh pldnotify.awk; do
+               if [ "$SYMLINK_TOOLS" != "no" -a -d "$PACKAGE_DIR" ]; then
+                       for a in dropin md5 adapter builder {relup,compile,repackage,rsync,pearize}.sh pldnotify.awk; do
                                # skip tools that don't exist in top dir
                                [ -f $a ] || continue
                                # skip tools that already exist
-                               [ -f $ASSUMED_NAME/$a ] && continue
-                               ln -s ../$a $ASSUMED_NAME
+                               [ -f $PACKAGE_DIR/$a ] && continue
+                               ln -s ../$a $PACKAGE_DIR
                                cvsignore_df $a
                        done
                fi
        fi
 
        if [ -n "$CVSTAG" ]; then
-               git checkout "$CVSTAG" -- 2>/dev/null || git checkout -t "${REMOTE_PLD}/$CVSTAG" > /dev/null || exit
-               git symbolic-ref -q HEAD > /dev/null &&
-                       git merge '@{u}'
+               if git rev-parse --verify -q "$CVSTAG"; then
+                       git checkout "$CVSTAG" --
+               elif git rev-parse --verify -q "refs/remotes/${REMOTE_PLD}/$CVSTAG"; then
+                       git checkout -t "refs/remotes/${REMOTE_PLD}/$CVSTAG" > /dev/null
+               fi
+               if [ $(git rev-parse "$CVSTAG") != $(git rev-parse HEAD) ]; then
+                       Exit_error "err_no_checkut" "$CVSTAG"
+               fi
+                       git merge --ff-only '@{u}'
+               git symbolic-ref -q HEAD > /dev/null && [ "$NOCVSSPEC" != "yes" ] &&
                if [ -n "$CVSDATE" ]; then
                        git checkout $(git rev-list -n1 --before="'$CVSDATE'" $CVSTAG) || exit 1
                fi
        fi
 
-       if [ ! -f "$ASSUMED_NAME/$SPECFILE" ]; then
+       if [ ! -f "$PACKAGE_DIR/$SPECFILE" ]; then
                Exit_error err_no_spec_in_repo
        fi
 
        if [ "$CHMOD" = "yes" -a -n "$SPECFILE" ]; then
-               chmod $CHMOD_MODE $ASSUMED_NAME/$SPECFILE
+               chmod $CHMOD_MODE $PACKAGE_DIR/$SPECFILE
        fi
        unset OPTIONS
-       [ -n "$DONT_PRINT_REVISION" ] || grep -E -m 1 "^#.*Revision:.*Date" $ASSUMED_NAME/$SPECFILE
+       [ -n "$DONT_PRINT_REVISION" ] || grep -E -m 1 "^#.*Revision:.*Date" $PACKAGE_DIR/$SPECFILE
 
        set_spec_target
 }
@@ -941,7 +1010,7 @@ find_mirror() {
        cd "$REPO_DIR"
        local url="$1"
        if [ ! -f "mirrors"  ] ; then
-               ln -s rpm-build-tools/mirrors .
+               ln -s ../rpm-build-tools/mirrors .
        fi
 
        IFS="|"
@@ -981,22 +1050,23 @@ src_md5() {
        cd $PACKAGE_DIR
        local md5
 
-       if [ -f additional-md5sums ]; then
-               md5=$(grep -s -v '^#' additional-md5sums | \
-               grep -E "[      ]$(basename "$1")([     ,]|\$)" | \
+       # use "sources" file from package dir, like vim
+       if [ -f sources ]; then
+               md5=$(grep -s -v '^#' sources | \
+               grep -E "[      *]$(basename "$1")([    ,]|\$)" | \
                sed -e 's/^\([0-9a-f]\{32\}\).*/\1/' | \
                grep -E '^[0-9a-f]{32}$')
 
                if [ "$md5" ]; then
                        if [ $(echo "$md5" | wc -l) != 1 ] ; then
-                               echo "$SPECFILE: more then one entry in additional-md5sums for $1" 1>&2
+                               echo "$SPECFILE: more then one entry in sources for $1" 1>&2
                        fi
                        echo "$md5" | tail -n 1
                        return
                fi
        fi
 
-       source_md5=`grep -i "^#[        ]*$no-md5[      ]*:" $SPECFILE | sed -e 's/.*://'`
+       source_md5=$(grep -iE "^#[      ]*(No)?$no-md5[         ]*:" $SPECFILE | sed -e 's/.*://')
        if [ -n "$source_md5" ]; then
                echo $source_md5
        else
@@ -1204,10 +1274,6 @@ get_files() {
                                                update_shell_title "${GETLOCAL%% *}: $url"
                                                ${GETLOCAL} $url $target
                                        else
-                                               if [ -z "$NOMIRRORS" ]; then
-                                                       url=$(find_mirror "$url")
-                                               fi
-
                                                local uri=${url}
                                                # make shorter message for distfiles urls
                                                if [[ "$uri" = ${PROTOCOL}${DISTFILES_SERVER}* ]] || [[ "$uri" = ${PROTOCOL}${ATTICDISTFILES_SERVER}* ]]; then
@@ -1230,9 +1296,6 @@ get_files() {
                                                        update_shell_title "${GETLOCAL%% *}: $url_attic"
                                                        ${GETLOCAL} $url_attic $target
                                                else
-                                                       if [ -z "$NOMIRRORS" ]; then
-                                                               url_attic=$(find_mirror "$url_attic")
-                                                       fi
                                                        update_shell_title "${GETURI%% *}: $url_attic"
                                                        ${GETURI} ${OUTFILEOPT} "$target" "$url_attic" || \
                                                        if [ "`echo $url_attic | grep -E 'ftp://'`" ]; then
@@ -1317,14 +1380,20 @@ get_files() {
 }
 
 tag_exist() {
-       _tag="$1"
+# If tag exists and points to other commit exit with error
+# If it existsts and points to HEAD return 1
+# If it doesn't exist return 0
+       local _tag="$1"
+       local sha1=$(git rev-parse HEAD)
        echo "Searching for tag $_tag..."
        if [ -n "$DEPTH" ]; then
-               local ref=`git ls-remote $REMOTE_PLD "refs/tags/$_tag"`
-               [ -n  "$ref" ] && echo "$ref" && Exit_error err_tag_exists "$_tag"
+               local ref=$(git ls-remote $REMOTE_PLD "refs/tags/$_tag"  | cut -c -40)
        else
-               git show-ref "refs/tags/$_tag" && Exit_error err_tag_exists "$_tag"
+               local ref=$(git show-ref -s "refs/tags/$_tag")
        fi
+       [ -z "$ref" ] && return 0
+       [ "$ref" = "$sha1" ] || Exit_error err_tag_exists "$_tag"
+       return 1
 }
 
 make_tagver() {
@@ -1353,8 +1422,6 @@ make_tagver() {
 }
 
 tag_files() {
-       TAG_FILES="$@"
-
        if [ -n "$DEBUG" ]; then
                set -x
                set -v
@@ -1363,33 +1430,25 @@ tag_files() {
        echo "Version: $PACKAGE_VERSION"
        echo "Release: $PACKAGE_RELEASE"
 
-       local TAGVER
+       local _tag
        if [ "$TAG_VERSION" = "yes" ]; then
-               TAGVER=`make_tagver`
-               echo "tag: $TAGVER"
+               _tag=`make_tagver`
        fi
        if [ -n "$TAG" ]; then
-               echo "tag: $TAG"
+               _tag="$TAG"
        fi
+       echo "tag: $_tag"
 
        local OPTIONS="tag $CVS_FORCE"
 
-       local _tag=$TAG
-       if [ "$TAG_VERSION" = "yes" ]; then
-               _tag=$TAGVER
-       fi;
-
        cd "$PACKAGE_DIR"
 
-       if [ "$TAG_VERSION" = "yes" ]; then
-               update_shell_title "tag sources: $TAGVER"
-               git $OPTIONS $TAGVER || exit
-               git push $CVS_FORCE $REMOTE_PLD tag $TAGVER || Exit_error err_remote_problem $REMOTE_PLD
-       fi
-       if [ -n "$TAG" ]; then
-               update_shell_title "tag sources: $TAG"
-               git $OPTIONS $TAG $chunk || exit
-               git push $CVS_FORCE $REMOTE_PLD tag $TAG || Exit_error err_remote_problem $REMOTE_PLD
+       if tag_exist $_tag || [ -n "$CVS_FORCE" ]; then
+               update_shell_title "tag sources: $_tag"
+               git $OPTIONS $_tag || exit
+               git push $CVS_FORCE $REMOTE_PLD tag $_tag || Exit_error err_remote_problem $REMOTE_PLD
+       else
+               echo "Tag $_tag already exists and points to the same commit"
        fi
 }
 
@@ -1526,36 +1585,34 @@ build_package() {
        esac
 
        update_shell_title "build_package: $COMMAND"
+       local logfile retval
        if [ -n "$LOGFILE" ]; then
-               LOG=`eval echo $LOGFILE`
-               if [ -d "$LOG" ]; then
-                       echo "Log file $LOG is a directory."
+               logfile=`eval echo $LOGFILE`
+               if [ -d "$logfile" ]; then
+                       echo "Log file $logfile is a directory."
                        echo "Parse error in the spec?"
                        Exit_error err_build_fail
                fi
                if [ -n "$LASTLOG_FILE" ]; then
-                       echo "LASTLOG=$LOG" > $LASTLOG_FILE
+                       echo "LASTLOG=$logfile" > $LASTLOG_FILE
                fi
-               RES_FILE=$(tempfile)
-               local specdir=$(insert_gitlog $SPECFILE)
-
-               (time eval ${NICE_COMMAND} $RPMBUILD $TARGET_SWITCH $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND --define \'_specdir $PACKAGE_DIR\' --define \'_sourcedir $PACKAGE_DIR\' $specdir/$SPECFILE; echo $? > $RES_FILE) 2>&1 |tee $LOG
-               RETVAL=`cat $RES_FILE`
-               rm -r $RES_FILE $specdir
-               if [ -n "$LOGDIROK" ] && [ -n "$LOGDIRFAIL" ]; then
-                       if [ "$RETVAL" -eq "0" ]; then
-                               mv $LOG $LOGDIROK
-                       else
-                               mv $LOG $LOGDIRFAIL
-                       fi
+       fi
+
+       local specdir=$(insert_gitlog $SPECFILE)
+       # FIXME: eval here is exactly why?
+       PATH=$CLEAN_PATH eval teeboth "'$logfile'" ${NICE_COMMAND} $RPMBUILD $TARGET_SWITCH $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND --define \'_specdir $PACKAGE_DIR\' --define \'_sourcedir $PACKAGE_DIR\' $specdir/$SPECFILE
+       retval=$?
+       rm -r $specdir
+
+       if [ -n "$logfile" ] && [ -n "$LOGDIROK" ] && [ -n "$LOGDIRFAIL" ]; then
+               if [ "$retval" -eq "0" ]; then
+                       mv $logfile $LOGDIROK
+               else
+                       mv $logfile $LOGDIRFAIL
                fi
-       else
-               local specdir=$(insert_gitlog $SPECFILE)
-               eval ${NICE_COMMAND} $RPMBUILD $TARGET_SWITCH $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $RPMBUILDOPTS $BCOND --define \'_specdir $PACKAGE_DIR\' --define \'_sourcedir $PACKAGE_DIR\' $specdir/$SPECFILE
-               RETVAL=$?
-               rm -r $specdir
        fi
-       if [ "$RETVAL" -ne "0" ]; then
+
+       if [ "$retval" -ne "0" ]; then
                if [ -n "$TRY_UPGRADE" ]; then
                        echo "\nUpgrade package to new version failed."
                        if [ "$REVERT_BROKEN_UPGRADE" = "yes" ]; then
@@ -1786,7 +1843,7 @@ display_bconds() {
 
 display_branches() {
        echo -n "Available branches: "
-       git branch -r | grep "^  ${REMOTE_PLD}" | grep -v ${REMOTE_PLD}/HEAD | sed "s#^ *${REMOTE_PLD}/##" | xargs
+       git branch -r 2>/dev/null | grep "^  ${REMOTE_PLD}" | grep -v ${REMOTE_PLD}/HEAD | sed "s#^ *${REMOTE_PLD}/##" | xargs
 }
 
 # checks a given list of packages/files/provides agains current rpmdb.
@@ -2036,11 +2093,12 @@ init_rpm_dir() {
 
        cd "$TOP_DIR"
        if [ ! -e ../rpm-build-tools ]; then
-               git clone  ${GIT_SERVER}:${PACKAGES_DIR}/rpm-build-tools.git ../rpm-build-tools
+               git clone  ${GIT_SERVER}/${PACKAGES_DIR}/rpm-build-tools.git ../rpm-build-tools
        fi
-       for a in adapter builder; do
-               ln -s ../rpm-build-tools/${a}.sh $a
+       for a in adapter builder fetchsrc_request; do
+               ln -sf ../rpm-build-tools/${a}.sh $a
        done
+       ln -sf ../rpm-build-tools/mirrors mirrors
        init_builder
 }
 
@@ -2050,7 +2108,7 @@ mr_proper() {
        DONT_PRINT_REVISION="yes"
 
        # remove spec and sources
-       $RPMBUILD --clean --rmsource --rmspec --nodeps --define "_specdir $PACKAGE_DIR" --define "_sourcedir $PACKAGE_DIR" --define "_builddir $builddir" $PACKAGE_DIR/$SPECFILE
+       PATH=$CLEAN_PATH $RPMBUILD --clean --rmsource --rmspec --nodeps --define "_specdir $PACKAGE_DIR" --define "_sourcedir $PACKAGE_DIR" --define "_builddir $builddir" $PACKAGE_DIR/$SPECFILE
        rm -rf $PACKAGE_DIR/{.git,.gitignore}
        rmdir --ignore-fail-on-non-empty $PACKAGE_DIR
 }
@@ -2137,6 +2195,14 @@ while [ $# -gt 0 ]; do
                        RPMOPTS="${RPMOPTS} --define \"_smp_mflags $1\""
                        shift
                        ;;
+               -p)
+                       PARALLEL_DOWNLOADS=$2
+                       shift 2
+                       ;;
+               -p[0-9])
+                       PARALLEL_DOWNLOADS=${1#-p}
+                       shift
+                       ;;
                -l | --logtofile )
                        shift; LOGFILE="${1}"; shift ;;
                -ni| --nice )
@@ -2168,7 +2234,7 @@ while [ $# -gt 0 ]; do
                -pm | --prefer-mirrors )
                        PREFMIRRORS="yes"
                        shift;;
-               --no-init )
+               --noinit | --no-init )
                        NOINIT="yes"
                        shift;;
                --opts )
@@ -2231,7 +2297,7 @@ while [ $# -gt 0 ]; do
                -FRB | --force-remove-build-requires)
                        REMOVE_BUILD_REQUIRES="force"
                        shift ;;
-               -sc | --sources-cvs)
+               -sc | --source-cvs)
                        COMMAND="list-sources-cvs"
                        shift ;;
                -sd | --source-distfiles)
@@ -2467,12 +2533,15 @@ case "$COMMAND" in
                # ./builder -bs test.spec -r AC-branch -Tp auto-ac- -tt
                if [ -n "$TEST_TAG" ]; then
                        local TAGVER=`make_tagver`
-                       tag_exist $TAGVER
+                       tag_exist $TAGVER || [ $TAGVER = $CVSTAG ] || Exit_error err_tag_exists $TAGVER
                        # check also tags created in CVS
-                       tag_exist $(echo $TAGVER | tr '[.@]' '[_#]')
+                       local TAGVER_CVS=$(echo $TAGVER | tr '[.@]' '[_#]')
+                       local CVSTAG_CVS=$(echo $CVSTAG | tr '[.@]' '[_#]')
+                       tag_exist $TAGVER_CVS || [ $TAGVER_CVS = $CVSTAG_CVS ] \
+                               || Exit_error err_tag_exists $TAGVER_CVS
                        # - do not allow to build from HEAD when XX-branch exists
                        TREE_PREFIX=$(echo "$TAG_PREFIX" | sed -e 's#^auto/\([a-zA-Z]\+\)/.*#\1#g')
-                       if [ "$TREE_PREFIX" != "$TAG_PREFIX" ]; then
+                       if [ "$TAGVER" != "$CVSTAG" -a "$TAGVER_CVS" != "$CVSTAG" -a  "$TREE_PREFIX" != "$TAG_PREFIX" ]; then
                                TAG_BRANCH="${TREE_PREFIX}-branch"
                                if [ -n "$DEPTH" ]; then
                                        cmd_branches="git ls-remote --heads"
@@ -2481,8 +2550,8 @@ case "$COMMAND" in
                                        cmd_branches="git show-ref"
                                        ref_prefix=refs/remotes/${REMOTE_PLD}
                                fi
-                               TAG_STATUS=$($cmd_branches | grep -i "${ref_prefix}/$TAG_BRANCH$")
-                               if [ -n "$TAG_STATUS" -a "$TAG_STATUS" != "$CVSTAG" ]; then
+                               TAG_STATUS=$($cmd_branches | grep -i "${ref_prefix}/$TAG_BRANCH$" | cut -c'-40')
+                               if [ -n "$TAG_STATUS" -a "$TAG_STATUS" != $(git rev-parse "$CVSTAG") ]; then
                                        Exit_error err_branch_exists "$TAG_STATUS"
                                fi
                        fi
@@ -2496,7 +2565,7 @@ case "$COMMAND" in
                case $? in
                        0)
                                get_files $SOURCES $PATCHES
-                               check_md5 $SOURCES
+                               check_md5 $SOURCES $PATCHES
                                ;;
                        *)
                                NODIST="yes" get_files $SOURCES $PATCHES
@@ -2537,8 +2606,7 @@ case "$COMMAND" in
                                fi
                        done
                        git add $SPECFILE
-                       git commit -m 'Initial commit'
-                       git push --dry-run $REMOTE_PLD master || Exit_error err_cvs_add_failed
+                       echo "When you are ready commit your changes and run git push origin master"
                else
                        echo "You had already git repository. Push chosen branches to remote: ${REMOTE_PLD}"
                fi
@@ -2601,13 +2669,13 @@ case "$COMMAND" in
                done
                ;;
        "list-sources-urls" )
-               init_builder
+               init_builder >&2
                NOCVSSPEC="yes"
                DONT_PRINT_REVISION="yes"
-               get_spec
-               parse_spec
+               get_spec >&2
+               parse_spec >&2
                SAPS="$SOURCES $PATCHES"
-               for SAP in $SAPS ; do
+               for SAP in $SAPS; do
                        echo $SAP
                done
                ;;
This page took 0.151996 seconds and 4 git commands to generate.