]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - builder.sh
- make builder's chmod configurable
[packages/rpm-build-tools.git] / builder.sh
index 27e005a167bb61898c550bb8fc3b80ebcab0a8df..108327ff54d58ee588b295e19cb59963f6ce3f90 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 # -----------
-# $Revision$, $Date$
+# $Id$
 # Exit codes:
 #      0 - succesful
 #      1 - help dispayed
@@ -11,7 +11,7 @@
 
 VERSION="\
 Build package utility from PLD CVS repository
-V 0.8 (C) 1999 Tomasz K³oczko".
+V 0.9 (C) 1999-2001 Tomasz K³oczko".
 
 PATH="/bin:/usr/bin:/usr/sbin:/sbin:/usr/X11R6/bin"
  
@@ -25,10 +25,16 @@ DEBUG=""
 NOURLS=""
 NOCVS=""
 ALLWAYS_CVSUP="yes"
-CVSROOT=${CVSROOT:-""}
+if [ -s CVS/Root ]; then
+    CVSROOT=$(cat CVS/Root)
+else
+    CVSROOT=${CVSROOT:-""}
+fi
 LOGFILE=""
-CHMOD="yes"
+CHMOD=${CHMOD:-"yes"}
+CHMOD_MODE=${CHMOD_MODE:-444}
 RPMOPTS=""
+BCOND=""
 
 PATCHES=""
 SOURCES=""
@@ -36,10 +42,13 @@ ICONS=""
 PACKAGE_RELEASE=""
 PACKAGE_VERSION=""
 PACKAGE_NAME=""
+WGET_RETRIES=${MAX_WGET_RETRIES:-0}
 
 DEF_NICE_LEVEL=0
 
-GETURI="wget -c -nd -t0"
+FAIL_IF_NO_SOURCES="yes"
+
+GETURI="wget -c -nd -t$WGET_RETRIES"
 
 if [ -f ~/etc/builderrc ]; then
   . ~/etc/builderrc
@@ -59,7 +68,7 @@ Usage: builder [-D] [--debug] [-V] [--version] [-a] [--as_anon] [-b] [-ba]
        [-d <cvsroot>] [--cvsroot <cvsroot>] [-g] [--get] [-h] [--help]
        [-l <logfile>] [-m] [--mr-proper] [--logtofile <logfile>] [-q] [--quiet]
        [-r <cvstag>] [--cvstag <cvstag>] [-u] [--no-urls] [-v] [--verbose]
-       [--opts <rpm opts>] <package>.spec
+       [--opts <rpm opts>] [--with/--without pkg] <package>.spec
 
        -D, --debug     - enable script debugging mode,
        -V, --version   - output builder version
@@ -85,10 +94,12 @@ Usage: builder [-D] [--debug] [-V] [--version] [-a] [--as_anon] [-b] [-ba]
                          all work resources,
        -nc, --no-cvs   - don't download from CVS, if source URL is given,
        -nu, --no-urls  - don't try to download from FTP/HTTP location,
+       -ns, --no-srcs  - don't downland Sources
        --opts          - additional options for rpm
        -q, --quiet     - be quiet,
        -r, --cvstag    - build package using resources from specified CVS
                          tag,
+       -T, --tag       - add cvs tags for files,
        -v, --verbose   - be verbose,
 
 "
@@ -97,16 +108,25 @@ Usage: builder [-D] [--debug] [-V] [--version] [-a] [--as_anon] [-b] [-ba]
 parse_spec()
 {
     if [ -n "$DEBUG" ]; then 
-       set -x;
-       set -v; 
+       set -x;
+       set -v;
+    fi
+
+    cd $SPECS_DIR
+
+    if [ "$NOSRCS" != "yes" ]; then
+        SOURCES="`rpm -bp --nobuild --define 'prep %dump' $SPECFILE 2>&1 | awk '/SOURCEURL[0-9]+/ {print $3}'`"
     fi
+    if (rpm -bp --nobuild --define 'prep %dump' $SPECFILE 2>&1 | grep -qEi ":.*nosource.*1"); then
+       FAIL_IF_NO_SOURCES="no"
+    fi
+
 
-    SOURCES="`rpm -bp --nobuild --define "__spec_prep_pre %{dump}" $SPECFILE 2>&1 | awk '/ SOURCEURL[0-9]+/ {print $3}'`"
-    PATCHES="`rpm -bp --nobuild --define "__spec_prep_pre %{dump}" $SPECFILE 2>&1 | awk '/ PATCHURL[0-9]+/ {print $3}'`"
+    PATCHES="`rpm -bp --nobuild --define 'prep %dump' $SPECFILE 2>&1 | awk '/PATCHURL[0-9]+/ {print $3}'`"
     ICONS="`awk '/^Icon:/ {print $2}' ${SPECFILE}`"
-    PACKAGE_NAME="`rpm -bp --nobuild --define "__spec_prep_pre %{dump}" $SPECFILE 2>&1 | awk '/ name/ {print $3}'`"
-    PACKAGE_VERSION="`rpm -bp --nobuild --define "__spec_prep_pre %{dump}" $SPECFILE 2>&1 | awk '/ PACKAGE_VERSION/ {print $3}'`"
-    PACKAGE_RELEASE="`rpm -bp --nobuild --define "__spec_prep_pre %{dump}" $SPECFILE 2>&1 | awk '/ PACKAGE_RELEASE/ {print $3}'`"
+    PACKAGE_NAME="`rpm -q --qf '%{NAME}\n' --specfile ${SPECFILE} 2> /dev/null | head -1`"
+    PACKAGE_VERSION="`rpm -q --qf '%{VERSION}\n' --specfile ${SPECFILE} 2> /dev/null| head -1`"
+    PACKAGE_RELEASE="`rpm -q --qf '%{RELEASE}\n' --specfile ${SPECFILE} 2> /dev/null | head -1`"
 
     if [ -n "$BE_VERBOSE" ]; then
        echo "- Sources :  `nourl $SOURCES`" 
@@ -135,7 +155,7 @@ Exit_error()
 
     cd $__PWD
 
-    case "$@" in
+    case "$1" in
     "err_no_spec_in_cmdl" )
        echo "ERROR: spec file name not specified.";
        exit 2 ;;
@@ -143,7 +163,7 @@ Exit_error()
        echo "Error: spec file not stored in CVS repo.";
        exit 3 ;;
     "err_no_source_in_repo" )
-       echo "Error: some source, patch or icon files not stored in CVS repo.";
+       echo "Error: some source, patch or icon files not stored in CVS repo. ($2)";
        exit 4 ;;
     "err_build_fail" )
        echo "Error: package build failed.";
@@ -158,8 +178,8 @@ init_builder()
        set -v; 
     fi
 
-    SOURCE_DIR="`rpm --eval "%{_sourcedir}"`"
-    SPECS_DIR="`rpm --eval "%{_specdir}"`"
+    SOURCE_DIR="`rpm --eval '%{_sourcedir}'`"
+    SPECS_DIR="`rpm --eval '%{_specdir}'`"
 
     __PWD=`pwd`
 }
@@ -192,20 +212,22 @@ get_spec()
        Exit_error err_no_spec_in_repo;
        fi
     
-    if [ "$CHMOD" = "yes" ]; then
-        chmod 444 $SPECFILE
+    if [ "$CHMOD" = "yes" -a -n "$SPECFILE" ]; then
+        chmod $CHMOD_MODE $SPECFILE
     fi
     unset OPTIONS
 }
 
-get_all_files()
+get_files()
 {
+    GET_FILES="$@"
+
     if [ -n "$DEBUG" ]; then 
        set -x;
        set -v; 
     fi
 
-    if [ -n "$SOURCES$PATCHES$ICONS" ]; then
+    if [ -n "$1$2$3$4$5$6$7$8$9${10}" ]; then
        cd $SOURCE_DIR
 
        OPTIONS="up "
@@ -217,7 +239,7 @@ get_all_files()
        else
            OPTIONS="$OPTIONS -A"
        fi
-       for i in $SOURCES $PATCHES $ICONS; do
+       for i in $GET_FILES; do
            if [ ! -f `nourl $i` ] || [ $ALLWAYS_CVSUP = "yes" ] 
              then
                if 
@@ -239,15 +261,56 @@ get_all_files()
                        ${GETURI} "$i"
                fi
 
-               if [ ! -f "`nourl $i`" ]; then
-                       Exit_error err_no_source_in_repo;
+               if [ ! -f "`nourl $i`" -a "$FAIL_IF_NO_SOURCES" != "no" ]; then
+                       Exit_error err_no_source_in_repo $i;
                fi
            fi
        done
        
        if [ "$CHMOD" = "yes" ]; then
-           chmod 444 `nourl $SOURCES $PATCHES $ICONS`
+           CHMOD_FILES="`nourl $GET_FILES`"
+           if [ -n "$CHMOD_FILES" ]; then
+                   chmod $CHMOD_MODE $CHMOD_FILES
+           fi
+       fi
+       unset OPTIONS
+    fi
+}
+
+tag_files()
+{
+    TAG_FILES="$@"
+
+    if [ -n "$DEBUG" ]; then 
+       set -x;
+       set -v; 
+    fi
+
+    if [ -n "$1$2$3$4$5$6$7$8$9${10}" ]; then
+       echo $PACKAGE_VERSION
+       echo $PACKAGE_RELEASE
+       TAG=$PACKAGE_NAME-`echo $PACKAGE_VERSION | sed -e "s/\./\_/g"`-`echo $PACKAGE_RELEASE | sed -e "s/\./\_/g"`
+       echo "CVS tag: $TAG"
+
+       OPTIONS="tag -F"
+       if [ -n "$CVSROOT" ]; then
+           OPTIONS="-d $CVSROOT $OPTIONS"
        fi
+
+       cd $SOURCE_DIR
+       for i in $TAG_FILES; do
+           if [ -f `nourl $i` ]; then
+               cvs $OPTIONS $TAG `nourl $i`
+               cvs $OPTIONS STABLE `nourl $i`
+           else
+               Exit_error err_no_source_in_repo $i
+           fi
+       done
+
+       cd $SPECS_DIR
+       cvs $OPTIONS $TAG $SPECFILE
+       cvs $OPTIONS STABLE $SPECFILE
+
        unset OPTIONS
     fi
 }
@@ -268,7 +331,7 @@ build_package()
        build-source )
            BUILD_SWITCH="-bs --nodeps" ;;
     esac
-    nice -n ${DEF_NICE_LEVEL} rpm $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $SPECFILE 
+    nice -n ${DEF_NICE_LEVEL} rpm $BUILD_SWITCH -v $QUIET $CLEAN $RPMOPTS $BCOND $SPECFILE 
 
     if [ "$?" -ne "0" ]; then
        Exit_error err_build_fail;
@@ -320,12 +383,18 @@ while test $# -gt 0 ; do
            NOCVS="yes"; shift ;;
        -nu | --no-urls )
            NOURLS="yes"; shift ;;
+       -ns | --no-srcs )
+           NOSRCS="yes"; shift ;;
        --opts )
            shift; RPMOPTS="${1}"; shift ;;
+       --with | --without )
+           BCOND="$BCOND $1 $2" ; shift 2 ;;
        -q | --quiet )
            QUIET="--quiet"; shift ;;
        -r | --cvstag )
            shift; CVSTAG="${1}"; shift ;;
+       -T | --tag )
+           COMMAND="tag"; shift;;
        -v | --verbose )
            BE_VERBOSE="1"; shift ;;
        * )
@@ -344,7 +413,11 @@ case "$COMMAND" in
        if [ -n "$SPECFILE" ]; then
            get_spec;
            parse_spec;
-           get_all_files;
+           if [ -n "$ICONS" ]; then
+               get_files $ICONS;
+               parse_spec;
+           fi
+           get_files "$SOURCES $PATCHES";
            build_package;
        else
            Exit_error err_no_spec_in_cmdl;
@@ -355,7 +428,26 @@ case "$COMMAND" in
        if [ -n "$SPECFILE" ]; then
            get_spec;
            parse_spec;
-           get_all_files;
+           if [ -n "$ICONS" ]; then
+                   get_files $ICONS
+                   parse_spec;
+           fi
+           get_files $SOURCES $PATCHES
+       else
+           Exit_error err_no_spec_in_cmdl;
+       fi
+       ;;
+    "tag" )
+       init_builder;
+       if [ -n "$SPECFILE" ]; then
+           get_spec;
+           parse_spec;
+           if [ -n "$ICONS" ]; then
+                   get_files $ICONS
+                   parse_spec;
+           fi
+           get_files $SOURCES $PATCHES;
+           tag_files "$SOURCES $PATCHES $ICONS";
        else
            Exit_error err_no_spec_in_cmdl;
        fi
@@ -370,3 +462,52 @@ case "$COMMAND" in
 esac
 
 cd $__PWD
+
+# $Log$
+# Revision 1.83  2001/10/10 08:41:32  misiek
+# - allow more bconds than one
+#
+# Revision 1.82  2001/09/18 10:55:37  ankry
+# - added support for limitting number of wget retries when fetching a file
+#   from ftp/http server via environment variable MAX_WGET_RETRIES.
+#   Defaults to infinite (0).
+#
+# Revision 1.81  2001/07/06 16:52:30  misiek
+# - by default use CVSroot from CVS/Root and if it doesn't exist use from CVSROOT variable
+#
+# Revision 1.80  2001/06/22 18:52:39  misiek
+# - added support for --with/--without options
+#
+# Revision 1.79  2001/05/28 14:44:16  baggins
+# - if file is not in repo TELL which fucking file it is!
+#
+# Revision 1.78  2001/05/13 19:04:44  misiek
+# fixes for ksh93
+#
+# Revision 1.77  2001/05/13 10:51:30  misiek
+# don't fail if no sources found (hack to allow build nosrc packages)
+#
+# Revision 1.76  2001/04/19 23:24:06  misiek
+# fix chmod again
+#
+# Revision 1.75  2001/04/19 23:14:25  misiek
+# redirect errors from query to /dev/null
+#
+# Revision 1.74  2001/04/02 15:39:29  misiek
+# fix problems with get_files when no files passed
+#
+# Revision 1.73  2001/03/30 14:06:10  wiget
+# massive typo by kloczek
+#
+# Revision 1.72  2001/03/26 22:16:22  kloczek
+# - fixed grabbing name, version and release in parse_spec(),
+# - added -T option (tag) (temporary it tags also additional STABLE tag - must
+#   be added -Ts for separate tagging as STABLE).
+#
+# Revision 1.71  2001/03/05 14:12:27  misiek
+# fix chmod
+#
+# Revision 1.70  2001/03/03 19:55:42  misiek
+# workaround for problems with rpm when icons isn't cvs up'ed
+#
+#
This page took 0.076727 seconds and 4 git commands to generate.