]> git.pld-linux.org Git - packages/rpm-build-tools.git/blobdiff - adapter.awk
- separated from rpm.spec
[packages/rpm-build-tools.git] / adapter.awk
index 1407bdbdc0e4fb4e0ba6015ca28b31c4c235c9fb..4c97a90d2c08a72f6b03f9c580f70b42bbd37b81 100644 (file)
@@ -1,15 +1,17 @@
-#!/bin/awk -f
+#!/usr/bin/gawk -f
 #
-# This is adapter v0.27. Adapter adapts .spec files for PLD Linux.
+# This is adapter v0.28. Adapter adapts .spec files for PLD Linux.
+# $Id$
 #
-# Copyright (C) 1999-2005 PLD-Team <feedback@pld-linux.org>
+# Copyright (C) 1999-2007 PLD-Team <feedback@pld-linux.org>
 # Authors:
-#      Micha³ Kuratczyk <kura@pld.org.pl>
+#      Michał Kuratczyk <kura@pld.org.pl>
 #      Sebastian Zagrodzki <s.zagrodzki@mimuw.edu.pl>
-#      Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
+#      Tomasz Kłoczko <kloczek@rudy.mif.pg.gda.pl>
 #      Artur Frysiak <wiget@pld-linux.org>
 #      Michal Kochanowicz <mkochano@pld.org.pl>
-#      Elan Ruusamä¤e <glen@pld-linux.org>
+#      Jakub Bogusz <qboosh@pld-linux.org>
+#      Elan Ruusamäe <glen@pld-linux.org>
 #
 # See cvs log adapter{,.awk} for list of contributors
 #
 # - desc wrapping is totally fucked up on global.spec,1.25, dosemu.spec,1.115-
 
 BEGIN {
-       RPM_SECTIONS = "package|build|changelog|clean|description|install|post|posttrans|postun|pre|prep|pretrans|preun|triggerin|triggerpostun|triggerun"
+       RPM_SECTIONS = "package|build|changelog|clean|description|install|post|posttrans|postun|pre|prep|pretrans|preun|triggerin|triggerpostun|triggerun|verifyscript|check"
        SECTIONS = "^%(" RPM_SECTIONS ")"
 
-       PREAMBLE_TAGS = "(Summary|Name|Version|Release|License|Group|URL|BuildArch|BuildRoot|Obsoletes|Conflicts|Provides|ExclusiveArch|ExcludeArch|PreReq|(Build)?Requires)"
+       PREAMBLE_TAGS = "(Summary|Name|Version|Release|Epoch|License|Group|URL|BuildArch|BuildRoot|Obsoletes|Conflicts|Provides|ExclusiveArch|ExcludeArch|Pre[Rr]eq|(Build)?Requires)"
 
-       preamble = 1            # Is it part of preamble? Default - yes
+       preamble = 1    # Is it part of preamble? Default - yes
        boc = 4                 # Beginning of %changelog
        bod = 0                 # Beginning of %description
        tw = 70                 # Descriptions width
 
        b_idx = 0               # index of BR/R arrays
+       BR_count = 0    # number of additional BuildRequires
 
        # If variable removed, then 1 (for removing it from export)
        removed["LDFLAGS"] = 0
@@ -53,6 +56,7 @@ BEGIN {
        "rpm --eval %_sourcedir" | getline groups_file
        groups_file = groups_file "/rpm.groups"
        system("cd `rpm --eval %_sourcedir`; [ -f rpm.groups ] || cvs up rpm.groups >/dev/null")
+       system("[ -d ../PLD-doc ] && cd ../PLD-doc && ([ -f BuildRequires.txt ] || cvs up BuildRequires.txt >/dev/null)");
 
        # Temporary file for changelog section
        changelog_file = ENVIRON["HOME"] "/tmp/adapter.changelog"
@@ -69,6 +73,9 @@ BEGIN {
        "rpm --eval %_infodir"  | getline infodir
        "rpm --eval %_examplesdir"      | getline examplesdir
        "rpm --eval %_defaultdocdir"    | getline docdir
+       "rpm --eval %_kdedocdir"        | getline kdedocdir
+       "rpm --eval %_desktopdir" | getline desktopdir
+       "rpm --eval %_pixmapsdir" | getline pixmapsdir
 
        "rpm --eval %perl_sitearch" | getline perl_sitearch
        "rpm --eval %perl_archlib" | getline perl_archlib
@@ -77,7 +84,18 @@ BEGIN {
        "rpm --eval %perl_vendorarch" | getline perl_vendorarch
        "rpm --eval %perl_sitelib" | getline perl_sitelib
 
-       "rpm --eval %py_sitescriptdir" | getline py_sitescriptdir
+       "rpm --eval %py_sitescriptdir 2>/dev/null" | getline py_sitescriptdir
+       "rpm --eval %py_sitedir 2>/dev/null" | getline py_sitedir
+       "rpm --eval %py_scriptdir 2>/dev/null" | getline py_scriptdir
+
+       "rpm --eval %ruby_archdir" | getline ruby_archdir
+       "rpm --eval %ruby_ridir" | getline ruby_ridir
+       "rpm --eval %ruby_rubylibdir" | getline ruby_rubylibdir
+       "rpm --eval %ruby_sitearchdir" | getline ruby_sitearchdir
+       "rpm --eval %ruby_sitelibdir" | getline ruby_sitelibdir
+
+       "rpm --eval %php_pear_dir" | getline php_pear_dir
+       "rpm --eval %tmpdir" | getline tmpdir
 }
 
 # There should be a comment with CVS keywords on the first line of file.
@@ -105,28 +123,31 @@ defattr == 1 {
 function b_makekey(a, b,       s) {
        s = a "" b;
        # kill bcond
-    gsub(/[#%]+{[!?]+[_a-zA-Z0-9]+:/, "", s);
+       gsub(/[#%]+{[!?]+[_a-zA-Z0-9]+:/, "", s);
 
        # kill commented out items
-    gsub(/^#[ \t]*/, "", s);
+       gsub(/^#[ \t]*/, "", s);
 
        # force order
-    gsub(/^Summary\(/, "11Summary(", s);
-    gsub(/^Summary/, "10Summary", s);
-    gsub(/^Name/, "2Name", s);
-    gsub(/^Version/, "3Version", s);
-    gsub(/^Release/, "4Release", s);
-    gsub(/^License/, "5License", s);
-    gsub(/^Group/, "6Group", s);
-    gsub(/^URL/, "7URL", s);
-
-    gsub(/^Provides/, "X1Provides", s);
-    gsub(/^Obsoletes/, "X2Obsoletes", s);
-    gsub(/^Conflicts/, "X3Conflicts", s);
-    gsub(/^BuildArch/, "X4BuildArch", s);
-    gsub(/^ExclusiveArch/, "X6ExclusiveArch", s);
-    gsub(/^ExcludeArch/, "X7ExcludeArch", s);
-    gsub(/^BuildRoot/, "X9BuildRoot", s);
+       gsub(/^Summary\(/, "11Summary(", s);
+       gsub(/^Summary/, "10Summary", s);
+       gsub(/^Name/, "2Name", s);
+       gsub(/^Version/, "3Version", s);
+       gsub(/^Release/, "4Release", s);
+       gsub(/^Epoch/, "5Epoch", s);
+       gsub(/^License/, "5License", s);
+       gsub(/^Group/, "6Group", s);
+       gsub(/^URL/, "7URL", s);
+
+       gsub(/^BuildRequires/, "B1BuildRequires", s);
+       gsub(/^BuildConflicts/, "B2BuildConflicts", s);
+       gsub(/^Provides/, "X1Provides", s);
+       gsub(/^Obsoletes/, "X2Obsoletes", s);
+       gsub(/^Conflicts/, "X3Conflicts", s);
+       gsub(/^BuildArch/, "X4BuildArch", s);
+       gsub(/^ExclusiveArch/, "X6ExclusiveArch", s);
+       gsub(/^ExcludeArch/, "X7ExcludeArch", s);
+       gsub(/^BuildRoot/, "X9BuildRoot", s);
 
 #      printf("%s -> %s\n", a""b, s);
        return s;
@@ -158,6 +179,11 @@ function b_makekey(a, b,   s) {
        }
        if ($2 == "date") {
                date = 1
+               if (did_files == 0) {
+                       print "%files"
+                       print ""
+                       did_files = 1
+               }
        }
 
        # Do not add %define of _prefix if it already is.
@@ -174,8 +200,14 @@ function b_makekey(a, b,   s) {
                bindir = $3
        if ($2 ~ /_sbindir/)
                sbindir = $3
-       if ($2 ~ /_libdir/)
-               libdir = $3
+       if ($2 ~ /_libdir/) {
+               if ($3 ~ /^%\(/) {
+                       # TODO: should escape for latter checks like: ($c ~ sysconfdir "/{?cron.")
+                       libdir = "%%%%%%%%%%%%%%"
+               } else {
+                       libdir = $3
+               }
+       }
        if ($2 ~ /_sysconfdir/) {
                if ($3 ~ /^%\(/) {
                        # TODO: should escape for latter checks like: ($c ~ sysconfdir "/{?cron.")
@@ -184,8 +216,14 @@ function b_makekey(a, b,   s) {
                        sysconfdir = $3
                }
        }
-       if ($2 ~ /_datadir/)
-               datadir = $3
+       if ($2 ~ /_datadir/) {
+               if ($3 ~ /^%\(/) {
+                       # TODO: should escape for latter checks like: ($c ~ sysconfdir "/{?cron.")
+                       datadir = "%%%%%%%%%%%%%%"
+               } else {
+                       datadir = $3
+               }
+       }
        if ($2 ~ /_includedir/)
                includedir = $3
        if ($2 ~ /_mandir/)
@@ -200,6 +238,8 @@ function b_makekey(a, b,    s) {
                _beta = $3
        if ($2 ~ /^_rc$/)
                _rc = $3
+       if ($2 ~ /^_pre$/)
+               _pre = $3
        if ($2 ~ /^_snap$/)
                _snap = $3
 
@@ -214,6 +254,7 @@ function b_makekey(a, b,    s) {
        if ($2 ~ /^mod_name$/)
                mod_name = $3
 
+       sub(/[ \t]+$/, "");
        # do nothing further, otherwise adapter thinks we're at preamble
        print
        next
@@ -278,6 +319,7 @@ function b_makekey(a, b,    s) {
 #########
 /^%prep/, (!/^%prep/ && $0 ~ SECTIONS) {
        preamble = 0
+       did_prep = 1
 
        use_macros()
 
@@ -286,7 +328,7 @@ function b_makekey(a, b,    s) {
                sub(/^%setup/, "%setup -q")
        }
 
-       if (/^%setup/) {
+       if (/^%setup/ && name != "setup") {
                $0 = fixedsub(name, "%{name}", $0);
                $0 = fixedsub(version, "%{version}", $0);
                if (_beta) {
@@ -295,6 +337,9 @@ function b_makekey(a, b,    s) {
                if (_rc) {
                        $0 = fixedsub(_rc, "%{_rc}", $0);
                }
+               if (_pre) {
+                       $0 = fixedsub(_pre, "%{_pre}", $0);
+               }
                if (_snap) {
                        $0 = fixedsub(_snap, "%{_snap}", $0);
                }
@@ -303,6 +348,7 @@ function b_makekey(a, b,    s) {
        if (/^%setup/ && /-n %{name}-%{version}( |$)/) {
                $0 = fixedsub(" -n %{name}-%{version}", "", $0)
        }
+       sub("^%patch ", "%patch0 ");
 
        # invalid in %prep
        sub("^rm -rf \$RPM_BUILD_ROOT.*", "");
@@ -314,7 +360,14 @@ function b_makekey(a, b,   s) {
 /^%build/, (!/^%build/ && $0 ~ SECTIONS) {
        preamble = 0
 
+       if (did_prep == 0) {
+               print "%prep"
+               print ""
+               did_prep = 1
+       }
+
        use_macros()
+       use_tabs()
 
        if (/^automake$/)
                sub(/$/, " -a -c")
@@ -364,13 +417,17 @@ function b_makekey(a, b,  s) {
        $0 = fixedsub("glib-gettextize --copy --force","%{__glib_gettextize}", $0);
        $0 = fixedsub("intltoolize --copy --force", "%{__intltoolize}", $0);
        $0 = fixedsub("automake --add-missing --copy", "%{__automake}", $0);
-       $0 = fixedsub("libtoolize -c -f --automake", "%{__libtoolize}", $0);
+       $0 = fixedsub("automake -a --foreign --copy", "%{__automake}", $0);
        $0 = fixedsub("automake -a -c --foreign", "%{__automake}", $0);
+       $0 = fixedsub("automake -a -c", "%{__automake}", $0);
+       $0 = fixedsub("libtoolize --force --automake --copy", "%{__libtoolize}", $0);
+       $0 = fixedsub("libtoolize -c -f --automake", "%{__libtoolize}", $0);
 
        sub(/^aclocal$/, "%{__aclocal}");
        sub(/^autoheader$/, "%{__autoheader}");
        sub(/^autoconf$/, "%{__autoconf}");
        sub(/^automake$/, "%{__automake}");
+       sub(/^libtoolize$/, "%{__libtoolize}");
 
        # atrpms
        $0 = fixedsub("%perl_configure", "%{__perl} Makefile.PL \\\n\tINSTALLDIRS=vendor", $0);
@@ -383,10 +440,7 @@ function b_makekey(a, b,   s) {
 /^%clean/, (!/^%clean/ && $0 ~ SECTIONS) {
        did_clean = 1
 
-       # prevent next section header like "%post -p /sbin/ldconfig" being adapterized
-       if (!/^%/) {
-               use_macros()
-       }
+       use_macros()
 }
 
 ############
@@ -396,7 +450,12 @@ function b_makekey(a, b,   s) {
 
        preamble = 0
 
-       if (/^[ \t]*rm([ \t]+-[rf]+)*[ \t]+\${?RPM_BUILD_ROOT}?/ && did_rmroot==0) {
+       # foreign rpms
+       sub("^%{__rm} -rf %{buildroot}", "rm -rf $RPM_BUILD_ROOT")
+       sub("%buildroot", "$RPM_BUILD_ROOT");
+       sub("%{buildroot}", "$RPM_BUILD_ROOT");
+
+       if (/^[ \t]*rm([ \t]+-[rf]+)*[ \t]+(\${?RPM_BUILD_ROOT}?|%{?buildroot}?)/ && did_rmroot==0) {
                did_rmroot=1
                print "rm -rf $RPM_BUILD_ROOT"
                next
@@ -407,15 +466,23 @@ function b_makekey(a, b,  s) {
                did_rmroot=1
        }
 
+       if (tmpdir) {
+               buildroot = tmpdir "/" name "-" version "-root-" ENVIRON["USER"]
+               gsub(buildroot, "$RPM_BUILD_ROOT")
+       }
+
+       if (!/%{_lib}/) {
+               sub("\$RPM_BUILD_ROOT/%", "$RPM_BUILD_ROOT%")
+       }
+
        use_macros()
 
        # 'install -d' instead 'mkdir -p'
        if (/mkdir -p/)
                sub(/mkdir -p/, "install -d")
 
-       # 'install' instead 'cp -p'
-       if (/cp -p\b/)
-               sub(/cp -p/, "install")
+       # cp -a already implies cp -r
+       sub(/^cp -ar/, "cp -a")
 
        # No '-u root' or '-g root' for 'install'
        if (/^install/ && /-[ug][ \t]*root/)
@@ -432,10 +499,6 @@ function b_makekey(a, b,   s) {
        if ($1 ~ /chmod/ && $2 ~ /644/)
                next
 
-       # foreign rpms
-       $0 = fixedsub("%buildroot", "$RPM_BUILD_ROOT", $0)
-       $0 = fixedsub("%{buildroot}", "$RPM_BUILD_ROOT", $0)
-
        # atrpms
        $0 = fixedsub("%perl_makeinstall", "%{__make} pure_install \\\n\tDESTDIR=$RPM_BUILD_ROOT", $0);
 }
@@ -445,6 +508,7 @@ function b_makekey(a, b,    s) {
 ##########
 /^%files/, (!/^%files/ && $0 ~ SECTIONS) {
        preamble = 0
+       did_files = 1
 
        if ($0 ~ /^%files/)
                defattr = 1
@@ -461,24 +525,27 @@ function b_makekey(a, b,  s) {
        skip = 0
        # There should be some CVS keywords on the first line of %changelog.
        if (boc == 3) {
-               if ($0 !~ _cvsmailfeedback)
+               if ($0 !~ _cvsmailfeedback) {
                        print "* %{date} " _cvsmailfeedback > changelog_file
-               else
+               } else {
                        skip = 1
+               }
                boc = 2
        }
        if (boc == 2 && !skip) {
                if (!/All persons listed below/) {
                        printf "All persons listed below can be reached at " > changelog_file
                        print "<cvs_login>" _cvsmaildomain "\n" > changelog_file
-               } else
+               } else {
                        skip = 1
+               }
                boc = 1
        }
        if (boc == 1 && !skip) {
                if (!/^$/) {
-                       if (!/\$.*Log:.*\$/)
+                       if (!/\$.*Log:.*\$/) {
                                print "$" "Log:$" > changelog_file
+                       }
                        boc = 0
                }
        }
@@ -492,11 +559,19 @@ function b_makekey(a, b,  s) {
                boc = 3
        }
 
-       sub(/[ \t]+$/, "")
-       if (!/^%[a-z]+$/ || /changelog/)
+       sub(/[ \t]+$/, "");
+       if (!/^%[a-z]+$/ || /changelog/) {
+               # stop changelog if "real" changelog starts
+               if (boc == 0 && /^\* /) {
+                       boc = -1
+               }
+               if (boc == -1) {
+                       next;
+               }
                print > changelog_file
-       else
+       } else {
                print
+       }
        next
 }
 
@@ -506,12 +581,18 @@ function b_makekey(a, b,  s) {
 /^%pre/, (!/^%pre/ && $0 ~ SECTIONS) {
        preamble = 0
 
+       if (gsub("/usr/sbin/useradd", "%useradd")) {
+               sub(" 2> /dev/null \|\| :", "");
+               sub(" >/dev/null 2>&1 \|\|:", "");
+       }
+
        # %useradd and %groupadd may not be wrapped
        if (/%(useradd|groupadd).*\\$/) {
                a = $0; getline;
                sub(/^[\s\t]*/, "");
                $0 = substr(a, 1, length(a) - 1) $0;
        }
+       use_script_macros()
 }
 
 /^%post/, (!/^%post/ && $0 ~ SECTIONS) {
@@ -520,24 +601,39 @@ function b_makekey(a, b,  s) {
 }
 /^%preun/, (!/^%preun/ && $0 ~ SECTIONS) {
        preamble = 0
+       use_macros()
 }
 /^%postun/, (!/^%postun/ && $0 ~ SECTIONS) {
        preamble = 0
+       use_script_macros()
 }
 /^%triggerin/, (!/^%triggerin/ && $0 ~ SECTIONS) {
        preamble = 0
+       use_script_macros()
 }
 /^%triggerun/, (!/^%triggerun/ && $0 ~ SECTIONS) {
        preamble = 0
+       use_script_macros()
 }
 /^%triggerpostun/, (!/^%triggerpostun/ && $0 ~ SECTIONS) {
        preamble = 0
+       use_script_macros()
 }
 /^%pretrans/, (!/^%pretrans/ && $0 ~ SECTIONS) {
        preamble = 0
+       use_script_macros()
 }
 /^%posttrans/, (!/^%posttrans/ && $0 ~ SECTIONS) {
        preamble = 0
+       use_script_macros()
+}
+/^%verifyscript/, (!/^%verifyscript/ && $0 ~ SECTIONS) {
+       preamble = 0
+       use_script_macros()
+}
+/^%check/, (!/^%check/ && $0 ~ SECTIONS) {
+       preamble = 0
+       use_script_macros()
 }
 
 #############
@@ -556,7 +652,7 @@ preamble == 1 {
 
        field = tolower($1)
        fieldnlower = $1
-       if (field ~ /summary:/ && !/etc\.$/) {
+       if (field ~ /summary:/ && !/etc\.$/ && !/Inc\.$/) {
                sub(/\.$/, "", $0);
        }
        if (field ~ /group(\([^)]+\)):/)
@@ -574,8 +670,10 @@ preamble == 1 {
                sub(/^X11\/GNOME/,"X11/Applications", group)
                sub(/^X11\/Utilities/,"X11/Applications", group)
                sub(/^X11\/Games\/Strategy/,"X11/Applications/Games/Strategy", group)
+               sub(/^X11\/Library/,"X11/Libraries", group)
                sub(/^Shells/,"Applications/Shells", group)
                sub(/^System Environment\/Libraries$/, "Libraries", group)
+               sub(/^Library\/Development$/, "Development/Libraries", group)
                sub(/^System Environment\/Daemons$/, "Daemons", group)
                sub(/^Applications\/Internet$/, "Applications/Networking", group)
                sub(/^Applications\/Daemons$/, "Daemons", group)
@@ -587,6 +685,21 @@ preamble == 1 {
                sub(/^Applications\/Internet\/Peer to Peer/, "Applications/Networking", group)
                sub(/^Networking\/Deamons$/, "Networking/Daemons", group)
                sub(/^Development\/Docs$/, "Documentation", group)
+               sub(/^Development\/Documentation$/, "Documentation", group)
+               sub(/^System Environment\/Kernel$/, "Base/Kernel", group)
+               sub(/^Development\/Libraries\/Java$/, "Development/Languages/Java", group)
+               sub(/^Development\/Java/, "Development/Languages/Java", group)
+               sub(/^Development\/Testing$/, "Development", group)
+               sub(/^Text Processing\/Markup\/HTML$/, "Applications/Text", group)
+               sub(/^Text Processing\/Markup\/XML$/, "Applications/Text", group)
+               sub(/^Web\/Database$/, "Applications/WWW", group)
+               sub(/^System Environment\/Base$/, "Base", group)
+               sub(/^System$/, "Base", group)
+               sub(/^Applications\/Productivity$/, "X11/Applications", group)
+               sub(/^Database$/, "Applications/Databases", group)
+               sub(/^Development\/Code Generators$/, "Development", group)
+               sub(/^Emulators$/, "Applications/Emulators", group)
+               sub(/^System\/Libraries$/, "Libraries", group)
 
                $0 = "Group:\t\t" group
 
@@ -609,28 +722,86 @@ preamble == 1 {
                        print "######\t\t" "Unknown group!"
 
                close(groups_file)
+               did_groups = 1
        }
 
        if (field ~ /prereq:/) {
-               sub(/PreReq:/, "Requires:", $1);
+               sub(/Pre[Rr]eq:/, "Requires:", $1);
        }
 
        # split (build)requires, obsoletes on commas
-       if (field ~ /(obsoletes|requires):/ && NF > 2) {
+       if (field ~ /(obsoletes|requires|provides|conflicts):/ && NF > 2) {
                value = substr($0, index($0, $2));
                $0 = format_requires($1, value);
        }
 
-       if (field ~ /packager:|distribution:|docdir:|prefix:/) {
+       # BR: tar (and others) is to common (rpm-build requires it)
+       if (field ~ /^buildrequires:/) {
+               l = substr($0, index($0, $2));
+               if (l == "awk" ||
+                       l == "binutils" ||
+                       l == "bzip2" ||
+                       l == "cpio" ||
+                       l == "diffutils" ||
+                       l == "elfutils" ||
+                       l == "fileutils" ||
+                       l == "findutils" ||
+                       l == "glibc-devel" ||
+                       l == "grep" ||
+                       l == "gzip" ||
+                       l == "make" ||
+                       l == "patch" ||
+                       l == "sed" ||
+                       l == "sh-utils" ||
+                       l == "tar" ||
+                       l == "textutils") {
+                       next
+               }
+
+               # perhaps we have common known name?
+
+               # jpackages
+               sub(/^java-devel$/, "jdk", $2);
+               sub(/^log4j$/, "jakarta-log4j", $2);
+               sub(/^oro$/, "jakarta-oro", $2);
+               sub(/^jakarta-ant$/, "ant", $2);
+               sub(/^xerces-j2$/, "xerces-j", $2);
+               sub(/^ldapjdk$/, "ldapsdk", $2);
+               sub(/^saxon-scripts$/, "saxon", $2);
+               sub(/^xalan-j2$/, "xalan-j", $2);
+               sub(/^xerces-j2$/, "xerces-j", $2);
+
+               replace_php_virtual_deps();
+       }
+
+       if (field ~ /^requires:/) {
+               replace_php_virtual_deps();
+       }
+
+
+       # obsolete/unwanted tags
+       if (field ~ /vendor:|packager:|distribution:|docdir:|prefix:|icon:|author:|author-email:|metadata-version:/) {
                next
        }
 
-       if (field ~ /buildroot:/)
+       if (field ~ /buildroot:/) {
                $0 = $1 "%{tmpdir}/%{name}-%{version}-root-%(id -u -n)"
+               did_build_root = 1
+       }
 
        # Use "License" instead of "Copyright" if it is (L)GPL or BSD
-       if (field ~ /copyright:/ && $2 ~ /GPL|BSD/)
+       if (field ~ /copyright:/ && $2 ~ /GPL|BSD/) {
                $1 = "License:"
+       }
+
+       if (field ~ /license:/) {
+               l = substr($0, index($0, $2));
+               if (l == "Python Software Foundation License") {
+                       l = "PSF"
+               }
+               $0 = "License:\t" l;
+       }
+
 
        if (field ~ /name:/) {
                if ($2 == "%{name}" && name) {
@@ -652,17 +823,25 @@ preamble == 1 {
                if ($2 == "%{release}" && release) {
                        $2 = release
                }
+               sub(/%atrelease /, "0.", $0)
                release = $2
                release_seen = 1;
        }
 
+
        if (field ~ /serial:/)
                $1 = "Epoch:"
 
+       if (field ~ /home-page:/)
+               $1 = "URL:"
+
        # proper caps
        if (field ~ /^url:$/)
                $1 = "URL:"
 
+       if (field ~ /^description:$/)
+               $1 = "\n%description\n"
+
        # Use %{name} and %{version} in the filenames in "Source:"
        if (field ~ /^source/ || field ~ /patch/) {
                n = split($2, url, /\//)
@@ -721,20 +900,33 @@ preamble == 1 {
                        if (_rc) {
                                url[n] = fixedsub(_rc, "%{_rc}", url[n])
                        }
+                       if (_pre) {
+                               url[n] = fixedsub(_pre, "%{_pre}", url[n])
+                       }
                        if (_snap) {
                                url[n] = fixedsub(_snap, "%{_snap}", url[n])
                        }
                }
+               # assigning to $2 kills preamble formatting
                $2 = fixedsub(filename, url[n], $2)
 
                # sourceforge urls
+               sub("[?&]big_mirror=.*$", "", $2);
+               sub("[?&]modtime=.*$", "", $2);
+
                sub("[?]use_mirror=.*$", "", $2);
                sub("[?]download$", "", $2);
+
                sub("^http://prdownloads\.sourceforge\.net/", "http://dl.sourceforge.net/", $2)
+               sub("^http://download\.sf\.net/", "http://dl.sourceforge.net/", $2)
+               sub("^http://downloads\.sourceforge\.net/", "http://dl.sourceforge.net/", $2)
 
                sub("^http://.*\.dl\.sourceforge\.net/", "http://dl.sourceforge.net/", $2)
                sub("^http://dl\.sourceforge\.net/sourceforge/", "http://dl.sourceforge.net/", $2)
                sub("^http://dl\.sf\.net/", "http://dl.sourceforge.net/", $2)
+
+               sub("^ftp://ftp\.gnome\.org/", "http://ftp.gnome.org/", $2)
+               sub("^http://ftp\.gnome\.org/pub/gnome/", "http://ftp.gnome.org/pub/GNOME/", $2)
        }
 
 
@@ -753,20 +945,25 @@ preamble == 1 {
        }
 }
 
+/^%bcond_/ {
+       # do nothing
+       print
+       next
+}
 
 # sort BR/R!
 #
 # NOTES:
 # - mixing BR/R and anything else confuses this (all will be sorted together)
-#   so don't do that.
+#      so don't do that.
 # - comments leading the BR/R can not be associated,
-#   so don't adapterize when the BR/R are mixed with comments
+#      so don't adapterize when the BR/R are mixed with comments
 ENVIRON["SKIP_SORTBR"] != 1 && preamble == 1 && $0 ~ PREAMBLE_TAGS, $0 ~ PREAMBLE_TAGS {
-       if ($1 ~ /PreReq:/) {
-               sub(/PreReq:/, "Requires:", $1);
+       if ($1 ~ /Pre[Rr]eq:/) {
+               sub(/Pre[Rr]eq:/, "Requires:", $1);
        }
        format_preamble()
-       kill_preamble_macros();
+#      kill_preamble_macros(); # breaks tabbing
 
        b_idx++;
        l = substr($0, index($0, $2));
@@ -777,17 +974,13 @@ ENVIRON["SKIP_SORTBR"] != 1 && preamble == 1 && $0 ~ PREAMBLE_TAGS, $0 ~ PREAMBL
        next;
 }
 
-/^%bcond_/ {
-       # do nothing
-       print
-       next
-}
-
 preamble == 1 {
        if (b_idx > 0) {
                isort(b_key, b_idx);
                for (i = 1; i <= b_idx; i++) {
-                       print "" b_val[b_key[i]];
+                       v = b_val[b_key[i]];
+                       sub(/[ \t]+$/, "", v);
+                       print "" v;
                }
                b_idx = 0
        }
@@ -801,7 +994,7 @@ preamble == 1 {
        print
 
        if (name_seen == 0 && name) {
-               print "Name:\t" name
+               print "Name:\t\t" name
                name_seen = 1
        }
 
@@ -814,6 +1007,15 @@ preamble == 1 {
                print "Release:\t" release
                release_seen = 1
        }
+
+       if (did_build_root == 0) {
+#              print "BuildRoot:\t%{tmpdir}/%{name}-%{version}-root-%(id -u -n)"
+               did_build_root = 1
+       }
+       if (did_groups == 0) {
+#              print "Group:\t\tunknown"
+               did_groups = 1
+       }
 }
 
 
@@ -821,6 +1023,13 @@ END {
        if (do_not_touch_anything)
                exit 0
 
+       # TODO: need to output these in proper place
+       if (BR_count > 0) {
+               for (i = 0; i <= BR_count; i++) {
+                       print BR[i];
+               }
+       }
+
        close(changelog_file)
        while ((getline < changelog_file) > 0)
                print
@@ -837,17 +1046,20 @@ END {
                print "%define date\t%(echo `LC_ALL=\"C\" date +\"%a %b %d %Y\"`)"
        }
 
-       if (has_changelog == 0)
+       if (has_changelog == 0) {
                print "%changelog"
+       }
 
-       if (boc > 2)
+       if (boc > 2) {
                print "* %{date} PLD Team <feedback@pld-linux.org>"
+       }
        if (boc > 1) {
                printf "All persons listed below can be reached at "
                print "<cvs_login>@pld-linux.org\n"
        }
-       if (boc > 0)
+       if (boc > 0) {
                print "$" "Log:$"
+       }
 }
 
 function fixedsub(s1,s2,t, ind) {
@@ -860,12 +1072,16 @@ function fixedsub(s1,s2,t, ind) {
 # There should be one or two tabs after the colon.
 function format_preamble()
 {
+       if (/^#/ || /^%bcond_with/) {
+               return;
+       }
        sub(/:[ \t]*/, ":")
-       if (match($0, /[A-Za-z0-9(),#_ \t]+[ \t]*:[ \t]*/) == 1) {
-               if (RLENGTH < 8)
+       if (match($0, /[A-Za-z0-9(),#_ \t.-]+[ \t]*:[ \t]*/) == 1) {
+               if (RLENGTH < 8) {
                        sub(/:/, ":\t\t")
-               else
+               } else {
                        sub(/:/, ":\t")
+               }
        }
 }
 
@@ -877,6 +1093,17 @@ function use_macros()
                return
        }
 
+       # leave inline sed lines alone
+       if (/(%{__sed}|sed) -i -e/) {
+               return;
+       }
+
+       sub("%{_defaultdocdir}", "%{_docdir}");
+       sub("%{_bindir}/perl", "%{__perl}");
+       sub("%{_bindir}/python", "%{__python}");
+
+       gsub(infodir, "%{_infodir}")
+
        gsub(perl_sitearch, "%{perl_sitearch}")
        gsub(perl_archlib, "%{perl_archlib}")
        gsub(perl_privlib, "%{perl_privlib}")
@@ -885,10 +1112,25 @@ function use_macros()
        gsub(perl_sitelib, "%{perl_sitelib}")
        
        gsub(py_sitescriptdir, "%{py_sitescriptdir}")
+       gsub(py_sitedir, "%{py_sitedir}")
+       gsub(py_scriptdir, "%{py_scriptdir}")
+       gsub("%{_libdir}/python2.4/site-packages", "%{py_sitedir}")
+       gsub("%{python_sitelib}", "%{py_sitedir}")
+
+       gsub(ruby_archdir, "%{ruby_archdir}")
+       gsub(ruby_ridir, "%{ruby_ridir}")
+       gsub(ruby_rubylibdir, "%{ruby_rubylibdir}")
+       gsub(ruby_sitearchdir, "%{ruby_sitearchdir}")
+       gsub(ruby_sitelibdir, "%{ruby_sitelibdir}")
+
+       gsub("%{_datadir}/applications", "%{_desktopdir}")
+       gsub("%{_datadir}/pixmaps", "%{_pixmapsdir}")
+
+       gsub(libdir, "%{_libdir}")
 
        gsub(bindir, "%{_bindir}")
        gsub("%{prefix}/bin", "%{_bindir}")
-       if(prefix"/bin" == bindir)
+       if (prefix"/bin" == bindir)
                gsub("%{_prefix}/bin", "%{_bindir}")
 
        for (c = 1; c <= NF; c++) {
@@ -896,16 +1138,23 @@ function use_macros()
                        continue;
                if ($c ~ sbindir "/webapp")
                        continue;
+               if ($c ~ sbindir "/ldconfig")
+                       continue;
                if ($c ~ sbindir "/chsh")
                        continue;
                if ($c ~ sbindir "/usermod")
                        continue;
+               if ($c ~ sbindir "/chkconfig")
+                       continue;
+               if ($c ~ sbindir "/installzope(product|3package)")
+                       continue;
                gsub(sbindir, "%{_sbindir}", $c)
        }
 
        gsub("%{prefix}/sbin", "%{_sbindir}")
-       if (prefix"/sbin" == sbindir)
+       if (prefix"/sbin" == sbindir) {
                gsub("%{_prefix}/sbin", "%{_sbindir}")
+       }
 
        for (c = 1; c <= NF; c++) {
                if ($c ~ sysconfdir "/{?cron.")
@@ -914,6 +1163,10 @@ function use_macros()
                        continue;
                if ($c ~ sysconfdir "/{?env.d")
                        continue;
+               if ($c ~ sysconfdir "/{?modprobe.(d|conf)")
+                       continue;
+               if ($c ~ sysconfdir "/{?udev/rules.d")
+                       continue;
                if ($c ~ sysconfdir "/{?logrotate.d")
                        continue;
                if ($c ~ sysconfdir "/{?pam.d")
@@ -936,12 +1189,22 @@ function use_macros()
                        continue;
                if ($c ~ sysconfdir "/{?ld.so.conf.d")
                        continue;
-               if ($c ~ sysconfdir "/{?httpd") # temp
+               if ($c ~ sysconfdir "/{?rpm")
+                       continue;
+               if ($c ~ sysconfdir "/{?bash_completion.d")
+                       continue;
+               if ($c ~ sysconfdir "/{?samba")
+                       continue;
+               if ($c ~ sysconfdir "/shells")
+                       continue;
+               if ($c ~ sysconfdir "/ppp")
                        continue;
                gsub(sysconfdir, "%{_sysconfdir}", $c)
        }
 
+       gsub(kdedocdir, "%{_kdedocdir}")
        gsub(docdir, "%{_docdir}")
+       gsub(php_pear_dir, "%{php_pear_dir}")
 
        for (c = 1; c <= NF; c++) {
                if ($c ~ datadir "/automake")
@@ -998,6 +1261,8 @@ function use_macros()
                                        continue;
                                if ($c ~ prefix "/sbin/usermod")
                                        continue;
+                               if ($c ~ prefix "/sbin/installzope(product|3package)")
+                                       continue;
                                if ($c ~ prefix "/share/automake")
                                        continue;
                                if ($c ~ prefix "/share/unsermake")
@@ -1044,7 +1309,7 @@ function use_macros()
        gsub("%{compat_perl_vendorarch}", "%{perl_vendorarch}")
 
        gsub("^%{__make} install DESTDIR=\$RPM_BUILD_ROOT", "%{__make} install \\\n\tDESTDIR=$RPM_BUILD_ROOT")
-       gsub("^fix-info-dir$", "[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>\&1")
+       gsub("^fix-info-dir$", "[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>\\&1")
        $0 = fixedsub("%buildroot", "$RPM_BUILD_ROOT", $0)
        $0 = fixedsub("%{buildroot}", "$RPM_BUILD_ROOT", $0)
        $0 = fixedsub("CXXFLAGS=%{rpmcflags} %configure", "CXXFLAGS=%{rpmcflags}\n%configure", $0);
@@ -1060,9 +1325,23 @@ function use_macros()
        gsub("%_sbindir", "%{_sbindir}")
        gsub("%_mandir", "%{_mandir}")
        gsub("%name", "%{name}")
+       gsub(/%__rm/, "rm");
+       gsub(/%__mkdir_p/, "install -d");
+       gsub(/%__cp/, "cp");
+       gsub(/%__ln_s/, "ln -s");
+       gsub(/%__sed/, "%{__sed}");
+       gsub(/%__cat/, "cat");
+       gsub(/%__chmod/, "chmod");
 
        gsub("/usr/src/linux", "%{_kernelsrcdir}")
        gsub("%{_prefix}/src/linux", "%{_kernelsrcdir}")
+
+       if (/^ant /) {
+               sub(/^ant/, "%ant")
+               add_br("BuildRequires:  jpackage-utils");
+               add_br("BuildRequires:  rpmbuild(macros) >= 1.300");
+       }
+
 }
 
 function format_configure(line,                n, a, s) {
@@ -1098,6 +1377,8 @@ function use_files_macros(        i, n, t, a)
                return;
        }
 
+       sub("^%doc %{_mandir}", "%{_mandir}")
+
        gsub("^%{_sbindir}", "%attr(755,root,root) %{_sbindir}")
        gsub("^%{_bindir}", "%attr(755,root,root) %{_bindir}")
 
@@ -1150,11 +1431,11 @@ function use_files_macros(      i, n, t, a)
        # %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/*
        # attr not required, allow default 644 attr
        if (!/network-scripts/ && !/%dir/ && !/\.d$/ && !/functions/ && !/\/etc\/sysconfig\/wmstyle/) {
-               if (/\/etc\/sysconfig\// && /%config/ && !/%config\(noreplace\)/) {
+               if (/\/etc\/sysconfig\// && /%config/ && !/%config\(noreplace/) {
                        gsub("%config", "%config(noreplace)")
                }
 
-               if (/\/etc\/sysconfig\// && !/%config\(noreplace\)/) {
+               if (/\/etc\/sysconfig\// && !/%config\(noreplace/) {
                        $NF = "%config(noreplace) " $NF
                }
 
@@ -1172,6 +1453,16 @@ function use_files_macros(       i, n, t, a)
                gsub("%attr\\(0", "%attr(")
        }
 
+       # kill leading whitespace
+       gsub(/^ +/, "");
+
+       # kill default attrs
+       gsub(/%dir %attr\(755,root,root\)/, "%dir");
+       gsub(/%attr\(755,root,root\) %dir/, "%dir");
+       if (!/%dir/) {
+               gsub(/%attr\(644,root,root\) /, "");
+       }
+
        # sort %verify attrs
        if (match($0, /%verify\(not([^)]+)\)/)) {
                t = substr($0, RSTART, RLENGTH)
@@ -1214,6 +1505,14 @@ function use_files_macros(       i, n, t, a)
        gsub("%{_datadir}/pixmaps", "%{_pixmapsdir}");
 }
 
+function use_script_macros()
+{
+       if (gsub("/sbin/service", "%service")) {
+               sub(" >/dev/null 2>&1 \|\|:", "");
+               sub(" 2> /dev/null \|\| :", "");
+       }
+}
+
 function fill(ch, n, i) {
        for (i = 0; i < n; i++)
                printf("%c", ch)
@@ -1265,8 +1564,12 @@ function cflags(var)
 
 function demacroize(str)
 {
-       sub("%{mod_name}", mod_name, str);
-       sub("%{name}", name, str);
+       if (mod_name) {
+               sub("%{mod_name}", mod_name, str);
+       }
+       if (name) {
+               sub("%{name}", name, str);
+       }
        if (version) {
                sub("%{version}", version, str);
        }
@@ -1276,6 +1579,9 @@ function demacroize(str)
        if (_rc) {
                sub("%{_rc}", _rc, str);
        }
+       if (_pre) {
+               sub("%{_pre}", _pre, str);
+       }
        if (_snap) {
                sub("%{_snap}", _snap, str);
        }
@@ -1285,16 +1591,40 @@ function demacroize(str)
 function kill_preamble_macros()
 {
        if ($1 ~ /^URL:/ || $1 ~ /^Obsoletes:/) {
+               # NB! assigning $2 a value breaks tabbing
                $2 = demacroize($2);
                # unify sourceforge url
                sub("\.sf\.net/$", ".sourceforge.net/", $2);
        }
 }
 
+function get_epoch(pkg, ver,   epoch)
+{
+       return
+# should parse the BR lines more adequately:
+#      freetype = 2.0.0 -> correct
+#      freetype = 2.1.9 -> with epoch 1, as epoch 1 was added in 2.1.7
+
+       shell = "grep -o '^" pkg ":[^:]\+' ../PLD-doc/BuildRequires.txt | awk '{print $NF}'";
+       shell | getline epoch;
+       return epoch;
+}
+
 function format_requires(tag, value,   n, p, i, deps, ndeps) {
+       # skip any formatting for commented out items or some weird macros
+       if (/^#/ || /%\(/) {
+               return tag "\t" value
+       }
        n = split(value, p, / *,? */);
        for (i = 1; i <= n; i++) {
                if (p[i+1] ~ /[<=>]/) {
+                       # add epoch if the version doesn't have it but BuildRequires.txt has
+                       if (p[i] ~ /^[a-z]/ && p[i+2] !~ /^[0-9]+:/) {
+                               epoch = get_epoch(p[i], p[i+2])
+                               if (epoch) {
+                                       p[i+2] = epoch ":" p[i+2];
+                               }
+                       }
                        deps[ndeps++] = p[i] " " p[i+1] " " p[i+2];
                        i += 2;
                } else {
@@ -1307,3 +1637,46 @@ function format_requires(tag, value,     n, p, i, deps, ndeps) {
        }
        return substr(s, 1, length(s)-1);
 }
+
+function use_tabs()
+{
+       # reverse vim: ts=4 sw=4 et
+       gsub(/    /, "\t");
+}
+
+function add_br(br)
+{
+       BR[BR_count++] = br
+}
+
+# php virtual deps as discussed in devel-en
+function replace_php_virtual_deps()
+{
+       pkg = $2
+#      if (pkg == "php-program") {
+#              $0 = $1 "\t/usr/bin/php"
+#              return
+#      }
+
+#      if (pkg ~ /^php-[a-z]/ && pkg !~ /^php-(pear|common|cli|devel|fcgi|cgi|dirs|program|pecl-)/) {
+#              sub(/^php-/, "php(", pkg);
+#              sub(/$/, ") # verify this correctness -- it may be wanted to use specific not virtual dep", pkg);
+#              $2 = pkg
+#      }
+
+       if (pkg ~/^php$/) {
+               $2 = "webserver(php)";
+               if ($4 ~ /^[0-9]:/) {
+                       $4 = substr($4, 3);
+               }
+       }
+
+       if (pkg ~/^php4$/) {
+               $2 = "webserver(php)";
+               if ($4 ~ /^[0-9]:/) {
+                       $4 = substr($4, 3);
+               }
+       }
+}
+
+# vim:ts=4:sw=4
This page took 0.070989 seconds and 4 git commands to generate.