]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
1.686: %{__php} macro is always versioned to ensure we need just %{php_name}-cli... auto/th/rpm-build-macros-1.686-1
authorElan Ruusamäe <glen@delfi.ee>
Wed, 29 Jan 2014 13:26:25 +0000 (15:26 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 29 Jan 2014 13:26:25 +0000 (15:26 +0200)
rpm-build-macros.spec
rpm.macros

index 930df97e6281ce12420180781b2f39b8712880f6..c2eb08abfc5326cb962493b8af91dd7bf198766c 100644 (file)
@@ -5,7 +5,7 @@
 %if "%{pld_release}" == "ac"
 %define        with_rpm4       1
 %endif
-%define                rpm_macros_rev  1.685
+%define                rpm_macros_rev  1.686
 %define                find_lang_rev   1.36
 Summary:       PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
index 82c3763e262b60b44a577a73b50d3f80d4e99676..1e48117ab829a1b450eaae955db854ba05acaef6 100644 (file)
@@ -958,8 +958,11 @@ fi; \
 # NOTE: error output must be empty. otherwise can't build pecl packages if no php*-devel is installed
 %php_suffix                            %{expand:%%global php_suffix %(c=$(php-config --sysconfdir 2>/dev/null) || echo '' && echo ${c#/etc/php})%%{nil}}%php_suffix
 
+# phpXY, version always present for using current php version (in regards of php*-devel package)
+%php_versuffix                 %{expand:%%global php_versuffix %((IFS=.; set -- $(php-config --version); echo $1$2))%%{nil}}%php_versuffix
+
 # php cli. version that php headers are installed for
-%__php                                 /usr/bin/%{php_name}
+%__php                                 /usr/bin/php%{php_versuffix}
 
 # helper macro
 %__php_api_requires(v:) Requires: %{php_name}(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
This page took 0.043403 seconds and 4 git commands to generate.