]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- autotag: work without .spec extension
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 9 Dec 2006 15:15:05 +0000 (15:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-build.sh -> 1.11

rpm-build.sh

index 6eb3d556a37453d7a1d7e955f4514aa8b48c342f..1a976c00bcf01e6bf2b2e19e7f25613a1eaaf02b 100644 (file)
@@ -62,8 +62,9 @@ sfget() {
 autotag() {
        local out
        for a in "$@"; do
-               out=$(cvs status -v $a | awk '/auto-ac-/{if (!a++) print $1}')
-               echo "$a:$out"
+               s=${a%.spec}.spec
+               out=$(cvs status -v $s | awk '/auto-ac-/{if (!a++) print $1}')
+               echo "$s:$out"
        done
 }
 
This page took 0.100476 seconds and 4 git commands to generate.