]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- use readlink -m instead of readlink -f to allow missing paths
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 19 Feb 2010 16:10:49 +0000 (16:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-build-macros.spec -> 1.240
    rpm.macros -> 1.542

rpm-build-macros.spec
rpm.macros

index 82611e1ed9a63765cbeaa160c8b6de6a1febafea..f7daebce46212af2eb2a08c526678a70a85d2799 100644 (file)
@@ -1,4 +1,4 @@
-%define                rpm_macros_rev  1.540
+%define                rpm_macros_rev  1.541
 %define                find_lang_rev   1.32
 Summary:       PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
 %define                find_lang_rev   1.32
 Summary:       PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
@@ -67,11 +67,11 @@ fi
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_usrlibrpm},/etc/shrc.d}
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_usrlibrpm},/etc/shrc.d}
-cp rpm.macros $RPM_BUILD_ROOT%{_usrlibrpm}/macros.build
-install %{SOURCE1} $RPM_BUILD_ROOT%{_usrlibrpm}/service_generator.sh
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/shrc.d/rpm-build.sh
-install %{SOURCE3} $RPM_BUILD_ROOT%{_usrlibrpm}/find-lang.sh
-install %{SOURCE4} $RPM_BUILD_ROOT%{_usrlibrpm}
+cp -a rpm.macros $RPM_BUILD_ROOT%{_usrlibrpm}/macros.build
+install -p %{SOURCE1} $RPM_BUILD_ROOT%{_usrlibrpm}/service_generator.sh
+install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/shrc.d/rpm-build.sh
+install -p %{SOURCE3} $RPM_BUILD_ROOT%{_usrlibrpm}/find-lang.sh
+install -p %{SOURCE4} $RPM_BUILD_ROOT%{_usrlibrpm}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
index a9e456bb0fd12ad43f38abc280b0e9a70e07845e..648a95450817cf5b04dfbb95a405566044caab05 100644 (file)
 %_topdir    %{expand:%%global _topdir %(
        if [ -d SPECS -a -d SOURCES ]; then
                # old style rpmdir: in topdir
 %_topdir    %{expand:%%global _topdir %(
        if [ -d SPECS -a -d SOURCES ]; then
                # old style rpmdir: in topdir
-               readlink -f .
+               readlink -m .
        elif [ -d ../SPECS -a -d ../SOURCES ]; then
                # old style rpmdir: in subdir
        elif [ -d ../SPECS -a -d ../SOURCES ]; then
                # old style rpmdir: in subdir
-               readlink -f ..
+               readlink -m ..
        elif [ -d $HOME/rpm/SPECS -a -d $HOME/rpm/SOURCES ]; then \
                # if old style rpm dir exist, go with it
                echo $HOME/rpm; \
        elif [ -x ../builder -a ! -d ../builder ]; then
                # relative new style rpmdir: in package dir
        elif [ -d $HOME/rpm/SPECS -a -d $HOME/rpm/SOURCES ]; then \
                # if old style rpm dir exist, go with it
                echo $HOME/rpm; \
        elif [ -x ../builder -a ! -d ../builder ]; then
                # relative new style rpmdir: in package dir
-               readlink -f ..
+               readlink -m ..
        elif [ -x builder -a ! -d builder ]; then
                # relative new style rpmdir: in packages
        elif [ -x builder -a ! -d builder ]; then
                # relative new style rpmdir: in packages
-               readlink -f .
+               readlink -m .
        elif [ -x packages/builder -a ! -d packages/builder ]; then
                # relative new style rpmdir: packages dir in current dir
        elif [ -x packages/builder -a ! -d packages/builder ]; then
                # relative new style rpmdir: packages dir in current dir
-               readlink -f packages
+               readlink -m packages
        else
                # fallback to new style rpmdir
                echo $HOME/rpm/packages
        else
                # fallback to new style rpmdir
                echo $HOME/rpm/packages
@@ -88,9 +88,9 @@
 # BUILD/RPMS/SRPMS are one same level by default as packages dir, if these exist
 # if they don't exist assume we are having custom topdir (which is not named as
 # "packages", i.e ~/rpm/kde/{kdelibs,BUILD/RPMS/SRPMS})
 # BUILD/RPMS/SRPMS are one same level by default as packages dir, if these exist
 # if they don't exist assume we are having custom topdir (which is not named as
 # "packages", i.e ~/rpm/kde/{kdelibs,BUILD/RPMS/SRPMS})
-%_builddir             %{expand:%%global _builddir %(if [ -d %{_topdir}/../BUILD ]; then readlink -f %{_topdir}/../BUILD; else echo %{_topdir}/BUILD; fi)}%_builddir
-%_rpmdir               %{expand:%%global _rpmdir %(if [ -d %{_topdir}/../RPMS ]; then readlink -f %{_topdir}/../RPMS; else echo %{_topdir}/RPMS; fi)}%_rpmdir
-%_srcrpmdir            %{expand:%%global _srcrpmdir %(if [ -d %{_topdir}/../SRPMS ]; then readlink -f %{_topdir}/../SRPMS; else echo %{_topdir}/SRPMS; fi)}%_srcrpmdir
+%_builddir             %{expand:%%global _builddir %(if [ -d %{_topdir}/../BUILD ]; then readlink -m %{_topdir}/../BUILD; else echo %{_topdir}/BUILD; fi)}%_builddir
+%_rpmdir               %{expand:%%global _rpmdir %(if [ -d %{_topdir}/../RPMS ]; then readlink -m %{_topdir}/../RPMS; else echo %{_topdir}/RPMS; fi)}%_rpmdir
+%_srcrpmdir            %{expand:%%global _srcrpmdir %(if [ -d %{_topdir}/../SRPMS ]; then readlink -m %{_topdir}/../SRPMS; else echo %{_topdir}/SRPMS; fi)}%_srcrpmdir
 
 #      The number of cvs changelog entries kept when building package.
 %_buildchangelogtruncate 20
 
 #      The number of cvs changelog entries kept when building package.
 %_buildchangelogtruncate 20
This page took 0.098265 seconds and 4 git commands to generate.