]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
fix __jobs macro for < 3 cpus
authorElan Ruusamäe <glen@delfi.ee>
Thu, 18 Apr 2013 09:06:24 +0000 (12:06 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 18 Apr 2013 09:06:24 +0000 (12:06 +0300)
memoized macros must have a "value"

rpm-build-macros.spec
rpm.macros

index df6f4d6caa666db0745f23c75f8227dfcda03e7c..496157b7f9fd74b43aa8e3daccb943884d7ed235 100644 (file)
@@ -4,7 +4,7 @@ Summary:        PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
 Name:          rpm-build-macros
 Version:       %{rpm_macros_rev}
-Release:       1
+Release:       2
 License:       GPL
 Group:         Development/Building
 Source0:       rpm.macros
index ee6b6851f0649c68013934bd5232f99d2e4efeb3..351e41adf388268f87923b6d2fddfc27e2bebe20 100644 (file)
@@ -30,7 +30,7 @@
 #
 # if you want to disable parallel build do:
 # echo '%__jobs %{nil}' >> ~/.rpmmacros
-%__jobs                %{expand:%%global __jobs %(_NCPUS=$(/usr/bin/getconf _NPROCESSORS_ONLN); [ "$_NCPUS" -gt 2 ] && echo $(($_NCPUS / 2)))}%__jobs
+%__jobs                %{expand:%%global __jobs %(_NCPUS=$(/usr/bin/getconf _NPROCESSORS_ONLN); [ "$_NCPUS" -gt 2 ] && echo $(($_NCPUS / 2)))%%{nil}}%__jobs
 
 # expands to -jN if %__jobs has a value
 %_smp_mflags   %{expand:%%global _smp_mflags %(jobs=%{__jobs}; echo ${jobs:+-j$jobs}%%{nil})}%_smp_mflags
This page took 0.092916 seconds and 4 git commands to generate.