]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- up to 1.734; always skip checking std::__once_callable and std::__once_call symbols... auto/th/rpm-build-macros-1.734-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 20 Jun 2018 04:48:10 +0000 (06:48 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 20 Jun 2018 04:48:10 +0000 (06:48 +0200)
rpm-build-macros.spec
rpm.macros

index e94b4d71746f364f6cda29e8504a761de7331ff8..76b7d1f4ea1b9ffaf445347902d65eabb22b6649 100644 (file)
@@ -1,4 +1,4 @@
-%define                rpm_macros_rev  1.733
+%define                rpm_macros_rev  1.734
 %define                find_lang_rev   1.40
 Summary:       PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
index 9934a02a583f64950aa6d45e1f151d4dfda6ac82..896c95375a3ccc4b54bcfc3f9583a3a60e4fd6ca 100644 (file)
@@ -739,7 +739,7 @@ __spec_install_post_check_so() { \
        fail=0; \
        printf "Searching for shared objects with unresolved symbols..."; \
        for f in $(find $RPM_BUILD_ROOT -type f -name '*.so.*' -print); do \
-               LC_ALL=C objdump -T $f 2> /dev/null | LC_ALL=C awk -v "file=$f" 'BEGIN { found=0; skip["program_name"]=1; symbols = "" } /^[0-9a-z]+ +D +\*UND\*/ { if ($NF in skip) { next; }; found = 1; symbols = symbols "\n\t" $NF } END { if (found) { print "\nUnresolved symbols found in: " file symbols; %{?skip_post_check_so:split("%{skip_post_check_so}", R); for (i=1; i in R; i++) { if (file ~ "(^|/)" R[i] "$") { print "Library marked with skip_post_check_so, ignoring errors.\n"; exit(0); } } } exit(1); } } ' || fail=1 ; \
+               LC_ALL=C objdump -T $f 2> /dev/null | LC_ALL=C awk -v "file=$f" 'BEGIN { found=0; skip["program_name"]=1; skip["_ZSt15__once_callable"]=1; skip["_ZSt11__once_call"]=1; symbols = "" } /^[0-9a-z]+ +D +\*UND\*/ { if ($NF in skip) { next; }; found = 1; symbols = symbols "\n\t" $NF } END { if (found) { print "\nUnresolved symbols found in: " file symbols; %{?skip_post_check_so:split("%{skip_post_check_so}", R); for (i=1; i in R; i++) { if (file ~ "(^|/)" R[i] "$") { print "Library marked with skip_post_check_so, ignoring errors.\n"; exit(0); } } } exit(1); } } ' || fail=1 ; \
        done ; \
        echo " DONE"; \
        %{!?no_install_post_check_so:return $fail;} \
This page took 0.068018 seconds and 4 git commands to generate.