]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- more checking auto/ac/rpm-build-macros-1.669-1 auto/th/rpm-build-macros-1.669-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 6 Jul 2013 19:44:34 +0000 (21:44 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 6 Jul 2013 19:44:34 +0000 (21:44 +0200)
rpm-build-macros.spec
rpm.macros

index bfb1d2f49a590654c49d50fc7adc7bdaaebc688c..4621da6715d42e9dedcdd6c2239586884d0c4225 100644 (file)
@@ -5,7 +5,7 @@
 %if "%{pld_release}" == "ac"
 %define        with_rpm4       1
 %endif
-%define                rpm_macros_rev  1.668
+%define                rpm_macros_rev  1.669
 %define                find_lang_rev   1.36
 Summary:       PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
index 8064a617355b118a39bcc11c77b7b1344ce49091..843f44b51a1dc4a6df6a8aef5f1626851357c199 100644 (file)
@@ -1608,7 +1608,7 @@ fi \
 f = io.open("%{_docdir}/%{name}-%{version}/optional-packages.txt", "r") \
 if f then \
        for l in f:lines() do print(l); end \
-       f.close() \
+       f:close() \
 end \
 %{nil}
 
@@ -1969,7 +1969,10 @@ end\
 for _, s in ipairs({%{expand:%%__lua_split %*}}) do\
        if not t[s] then\
                print("Adding "..s.." to /etc/shells")\
-               f = io.open("/etc/shells", "a"); f:write(s.."\\n"); f:close()\
+               f = io.open("/etc/shells", "a")
+               if f then\
+                       f:write(s.."\\n")\
+                       f:close()\
        end\
 end\
 %{nil}
This page took 0.052807 seconds and 4 git commands to generate.