]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
- added now macro %ix86 rpm-3_0_1-5_19990513 rpm-3_0_1_19990507-1
authorArtur Frysiak <artur@frysiak.net>
Fri, 7 May 1999 02:02:42 +0000 (02:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed %requires_eq, %{perl_archlib}, %{perl_sitearch}
- FHS 2.0 compilant changes

Changed files:
    rpm.macros -> 1.5

rpm.macros

index 36679316483a168021b75208a1ca53961b4a5e9a..d4c3d00f9608d744ab431c90fca14bcbe5efc024 100644 (file)
@@ -1,8 +1,5 @@
-%requires_eq() %(LC_ALL="C" rpm -q --queryformat 'Requires: %%{NAME} = %%{VERSION}' %1|grep -v "is not")
-%perl_sitearch  %(eval "`perl -V:installsitearch`"; echo $installsitearch)
-%perl_archlib  %(eval "`perl -V:installarchlib`"; echo $installarchlib)
-# %%requires_pkg macro is obsoletes. Use %%requires_eq instead
-#%requires_pkg() %(LC_ALL="C" rpm -q --queryformat 'Requires: %%{NAME} = %%{VERSION}' %1|grep -v "is not")
+# arch macro for Intel i?86 compatibile processors
+%ix86  i386 i486 i586 i686 i786 i886 i986
 
 #------------------------------------------------------------------------------
 # The GNUconfigure macro does the following:
 # Based on autogen.sh from GNOME and orginal GNUconfigure
 #
 %GNUconfigure(MCs:)      \
-  %{-C:_mydir="`pwd`"; %{-M; %{__mkdirp} %{-C*};} cd %{-C*}} \
-  for coin in `find ${_mydir} -name configure.in -print` \
+  CFLAGS="${CFLAGS} %{optflags}" ; export CFLAGS; \
+  LDFLAGS="${LDFLAGS} %{-s:-s}"  ; export LDFLAGS; \
+  %{-C:_mydir="`pwd`"; %{-M: %{__mkdir} -p %{-C*};} cd %{-C*}} \
+  dirs="`find ${_mydir} -name configure.in -print`"; export dirs; \
+    for coin in `echo ${dirs}` \
 do \
   dr=`dirname ${coin}`; \
 if test -f ${dr}/NO-AUTO-GEN; then \
@@ -54,68 +54,4 @@ else \
     ); \
   fi \
 done \
-  CFLAGS="${CFLAGS} %{optflags}" LDFLAGS="${LDFLAGS}" %{-C:${_mydir}}%{!-C:.}/configure %{_target_platform} --prefix=%{_prefix} %* \
-  %{-C:cd ${_mydir}; unset _mydir}
-
-#------------------------------------------------------------------------------
-# The GNUconfigureS macro does the following:
-#       update config.guess and config.sub.
-#       regenerate all autoconf/automake files
-#       optionally change to a directory (make the directory if requested).
-#       run configure with correct prefix, platform, CFLAGS and adds -s 
-#      to LDFLAGS.
-#       optionally restore current directory.
-#
-# Based on autogen.sh from GNOME and orginal GNUconfigure
-#
-%GNUconfigureS(MC:)      \
-  %{-C:_mydir="`pwd`"; %{-M; %{__mkdirp} %{-C*};} cd %{-C*}} \
-  for coin in `find ${_mydir} -name configure.in -print` \
-do \
-  dr=`dirname ${coin}`; \
-if test -f ${dr}/NO-AUTO-GEN; then \
- : \
-else \
-     macrodirs=`sed -n -e 's,AM_ACLOCAL_INCLUDE(\(.*\)),\1,gp' < ${coin}`; \
-    ( cd ${dr}; \
-      aclocalinclude="${ACLOCAL_FLAGS}"; \
-      for k in ${macrodirs}; do \
-        if test -d ${k}; then \
-          aclocalinclude="${aclocalinclude} -I ${k}"; \
-        ##else \
-        ##  echo "**Warning**: No such directory \`${k}'.  Ignored." \
-        fi \
-      done \
-      if grep "^AM_GNU_GETTEXT" configure.in >/dev/null; then \
-        if grep "sed.*POTFILES" configure.in >/dev/null; then \
-          : do nothing -- we still have an old unmodified configure.in \
-        else \
-          test -r ${dr}/aclocal.m4 || touch ${dr}/aclocal.m4; \
-          echo "no" | gettextize --force --copy; \
-          test -r ${dr}/aclocal.m4 && %{__chmod} u+w ${dr}/aclocal.m4; \
-        fi \
-      fi \
-      if grep "^AM_PROG_LIBTOOL" configure.in >/dev/null; then \
-        %{__libtoolize} --force --copy; \
-      fi \
-      aclocal ${aclocalinclude}; \
-      if grep "^AM_CONFIG_HEADER" configure.in >/dev/null; then \
-        %{__autoheader}; \
-      fi \
-      echo "Running automake --gnu ${am_opt} ..."; \
-      %{__automake} --add-missing --gnu ${am_opt}; \
-      %{__autoconf}; \
-    ); \
-  fi \
-done \
-  CFLAGS="${CFLAGS} %{optflags}" LDFLAGS="${LDFLAGS} -s" %{-C:${_mydir}}%{!-C:.}/configure %{_target_platform} --prefix=%{_prefix} %* \
-  %{-C:cd ${_mydir}; unset _mydir}
-
-##############################
-# run ./configure with corect target, CFLAGS and LDFLAGS
-
-%configureS \
-  CFLAGS="${CFLAGS} %{optflags}" LDFLAGS="${LDFLAGS} -s" %{-C:${_mydir}}%{!-C:.}/configure %{_target_platform} --prefix=%{_prefix}
-
-%configure \
-  CFLAGS="${CFLAGS} %{optflags}" LDFLAGS="${LDFLAGS}" %{-C:${_mydir}}%{!-C:.}/configure %{_target_platform} --prefix=%{_prefix}
+  %{-C:${_mydir}}%{!-C:.}/configure %{_target_platform} --prefix=%{_prefix} %* \  %{-C:cd ${_mydir}; unset _mydir}
This page took 0.102849 seconds and 4 git commands to generate.