]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
py_postclean - do not use relative paths auto/th/rpm-build-macros-1.661-3
authorElan Ruusamäe <glen@delfi.ee>
Sat, 20 Apr 2013 10:38:49 +0000 (13:38 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 20 Apr 2013 10:38:49 +0000 (13:38 +0300)
somehow i686 builder fails with negative priority:
/tmp/B.53c70a4e-e1f2-4783-a355-9a2777bab4c6/BUILD/tmp/rpm-tmp.33435[258]: can't create __rpm_pyc: No such file or directory

rpm-build-macros.spec
rpm.macros

index 496157b7f9fd74b43aa8e3daccb943884d7ed235..a0094bc073bb7c08920d47b9b3ec4a367170cb68 100644 (file)
@@ -4,7 +4,7 @@ Summary:        PLD Linux RPM build macros
 Summary(pl.UTF-8):     Makra do budowania pakietów RPM dla Linuksa PLD
 Name:          rpm-build-macros
 Version:       %{rpm_macros_rev}
-Release:       2
+Release:       3
 License:       GPL
 Group:         Development/Building
 Source0:       rpm.macros
index 3bcd3c543f5b34ce2350594d4904521c33196dd5..de5658455dc89dc2ec81a86d50a57d417b5be1b5 100644 (file)
@@ -1077,9 +1077,9 @@ fi \
 %__spec_install_post_py_hardlink {\
 %{!?no_install_post_py_hardlink: __spec_install_post_py_hardlink() { \
 %{!?debug:set +x;} \
-local a b c=0 t=0; \
+local a b c=0 t=0 pyc=%{tmpdir}/%{name}-%{version}-%{release}__rpm_pyc; \
 if [ -d "$RPM_BUILD_ROOT" ]; then \
-       find "$RPM_BUILD_ROOT" -name '*.pyc' > __rpm_pyc; \
+       find "$RPM_BUILD_ROOT" -name '*.pyc' > $pyc; \
        while read a; do \
                b="${a%.pyc}.pyo"; \
                if cmp -s "$a" "$b"; then \
@@ -1087,9 +1087,9 @@ if [ -d "$RPM_BUILD_ROOT" ]; then \
                        c=$((c + 1)); \
                fi; \
                t=$((t + 1)); \
-       done < __rpm_pyc; \
+       done < $pyc; \
        [ $t -gt 0 ] && printf "Hardlink Python files: %d/%d files hardlinked\n" $c $t; \
-       rm -f __rpm_pyc; \
+       rm -f $pyc; \
 fi; \
 }; __spec_install_post_py_hardlink } }
 
This page took 0.052224 seconds and 4 git commands to generate.