]> git.pld-linux.org Git - packages/rpm-build-macros.git/commitdiff
fetch tags before figuring out last tag
authorElan Ruusamäe <glen@delfi.ee>
Mon, 6 Aug 2012 18:48:17 +0000 (21:48 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 6 Aug 2012 18:48:17 +0000 (21:48 +0300)
rpm-build.sh

index ac44f38e84dd071c27ec39bc6d4edd246e7d88e1..a04dc94ea6383e7b6b37c1b44e75ad5e306e0dbc 100755 (executable)
@@ -120,6 +120,7 @@ autotag() {
                s=${s%:*}
                # ensure package ends with .spec
                s=${s%.spec}.spec
                s=${s%:*}
                # ensure package ends with .spec
                s=${s%.spec}.spec
+               git fetch --tags
                out=$(git for-each-ref --count=1 --sort=-authordate refs/tags/auto/$dist \
                        --format='%(refname:short)')
                echo "$s:$out"
                out=$(git for-each-ref --count=1 --sort=-authordate refs/tags/auto/$dist \
                        --format='%(refname:short)')
                echo "$s:$out"
This page took 0.062762 seconds and 4 git commands to generate.