]> git.pld-linux.org Git - packages/rocksdb.git/commitdiff
- request make targets sequentially, make static_lib removes shared library files auto/th/rocksdb-6.29.5-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 15 Sep 2022 18:47:42 +0000 (20:47 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 15 Sep 2022 18:47:42 +0000 (20:47 +0200)
rocksdb.spec

index 53ed5a1eec6b3fed542f9ef327f2478403726e82..57cdde98744c9167a32b46b91c6c31de953206de 100644 (file)
@@ -87,10 +87,11 @@ export ROCKSDB_DISABLE_BENCHMARK=1
 export ROCKSDB_DISABLE_TBB=1
 %endif
 
+for target in %{?with_static_libs:static_lib} shared_lib tools_lib tools %{?with_tests:check} ; do
 %ifarch i386 i486
 PLATFORM_LDFLAGS="-latomic" \
 %endif
-%{__make} shared_lib %{?with_static_libs:static_lib} tools tools_lib %{?with_tests:check} \
+%{__make} $target \
        AM_DEFAULT_VERBOSITY=1 \
        CC="%{__cc}" \
        CXX="%{__cxx}" \
@@ -100,6 +101,7 @@ PLATFORM_LDFLAGS="-latomic" \
        PORTABLE=1 \
        USE_RTTI=1 \
        WARNING_FLAGS="%{rpmcppflags} -Wall"
+done
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -111,8 +113,6 @@ export ROCKSDB_DISABLE_BENCHMARK=1
 export ROCKSDB_DISABLE_TBB=1
 %endif
 
-ls -la
-
 %{__make} install \
        %{!?with_debug:DEBUG_LEVEL=0} \
        PORTABLE=1 \
@@ -120,8 +120,6 @@ ls -la
        PREFIX=%{_prefix} \
        LIBDIR=%{_libdir}
 
-ls -la
-
 # reduntant symlink
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librocksdb.so.6
 
This page took 0.060555 seconds and 4 git commands to generate.