]> git.pld-linux.org Git - packages/rocksdb.git/blobdiff - rocksdb.spec
- updated to 6.0.2 (note: new soname)
[packages/rocksdb.git] / rocksdb.spec
index ab9c78c16be1d3d8d3e5d0248d81dbd1b8fb8bdc..8f4c1e834c51955007dedd63ceefe9a4a909ad21 100644 (file)
@@ -1,24 +1,39 @@
+# TODO: hdfs/java
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%bcond_without static_libs     # don't build static libraries
+%bcond_without tbb             # Threading Building Blocks support
+
 Summary:       RocksDB: A Persistent Key-Value Store for Flash and RAM Storage
 Summary(pl.UTF-8):     RocksDB - trwała baza danych klucz-wartość dla pamięci Flash i RAM
 Name:          rocksdb
-Version:       3.6.1
+Version:       6.0.2
 Release:       1
 License:       BSD
 Group:         Libraries
-Source0:       https://github.com/facebook/rocksdb/archive/%{name}-%{version}.tar.gz
-# Source0-md5: 57536681f119049c19d71f2d6711da3b
+#Source0Download: https://github.com/facebook/rocksdb/releases
+Source0:       https://github.com/facebook/rocksdb/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: a8f2f594182e97a08629bcc66dfd3fa0
 Patch0:                %{name}-libdir.patch
+Patch1:                make-programs.patch
+Patch2:                %{name}-detect-flags.patch
 URL:           http://rocksdb.org/
-BuildRequires: bzip2-devel
+BuildRequires: bzip2-devel >= 1.0.6
 BuildRequires: gflags-devel
+# libtcmalloc also supported, but jemalloc is preferred
+BuildRequires: jemalloc-devel
 %ifarch i386 i486
 BuildRequires: libatomic-devel
 %endif
 BuildRequires: libstdc++-devel >= 6:4.7
-BuildRequires: libtcmalloc-devel
-BuildRequires: lz4-devel
-BuildRequires: snappy-devel
-BuildRequires: zlib-devel
+BuildRequires: lz4-devel >= 1:1.8.3
+BuildRequires: numactl-devel
+BuildRequires: rpmbuild(macros) >= 1.734
+BuildRequires: snappy-devel >= 1.1.7
+%{?with_tbb:BuildRequires:     tbb-devel}
+BuildRequires: zlib-devel >= 1.2.11
+BuildRequires: zstd-devel >= 1.3.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -53,25 +68,36 @@ Static RocksDB library.
 Statyczna biblioteka RocksDB.
 
 %prep
-%setup -q -n %{name}-%{name}-%{version}
+%setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %ifarch i386 i486
 PLATFORM_LDFLAGS="-latomic" \
 %endif
-%{__make} all shared_lib \
+%{__make} shared_lib %{?with_static_libs:static_lib} programs %{?with_tests:check} \
+       AM_DEFAULT_VERBOSITY=1 \
        CC="%{__cc}" \
        CXX="%{__cxx}" \
+       %{!?with_debug:DEBUG_LEVEL=0}
+       EXTRA_CFLAGS="$(pkg-config --cflags liblz4)" \
        OPT="%{rpmcflags} %{!?debug:-DNDEBUG}" \
+       PORTABLE=1 \
+       %{!?with_tbb:ROCKSDB_DISABLE_TBB=1} \
        WARNING_FLAGS="%{rpmcppflags} -Wall"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
+       %{!?with_debug:DEBUG_LEVEL=0} \
        INSTALL_PATH=$RPM_BUILD_ROOT%{_prefix} \
-       INSTALL_LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
+       INSTALL_LIBDIR=$RPM_BUILD_ROOT%{_libdir}
+
+# reduntant symlink
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/librocksdb.so.6
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -81,14 +107,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc HISTORY.md LICENSE PATENTS README.md ROCKSDB_LITE.md
-%attr(755,root,root) %{_libdir}/librocksdb.so
+%doc AUTHORS DEFAULT_OPTIONS_HISTORY.md DUMP_FORMAT.md HISTORY.md LANGUAGE-BINDINGS.md LICENSE.leveldb README.md ROCKSDB_LITE.md USERS.md
+%attr(755,root,root) %{_libdir}/librocksdb.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/librocksdb.so.6.0
 
 %files devel
 %defattr(644,root,root,755)
-%doc doc/*
+%attr(755,root,root) %{_libdir}/librocksdb.so
 %{_includedir}/rocksdb
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/librocksdb.a
+%endif
This page took 0.087035 seconds and 4 git commands to generate.