]> git.pld-linux.org Git - packages/rocksdb.git/commitdiff
- updated to 6.0.2 (note: new soname) auto/th/rocksdb-6.0.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 15 May 2019 17:32:13 +0000 (19:32 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 15 May 2019 17:32:13 +0000 (19:32 +0200)
- updated libdir patch
- removed obsolete jemalloc patch

rocksdb-jemalloc.patch [deleted file]
rocksdb-libdir.patch
rocksdb.spec

diff --git a/rocksdb-jemalloc.patch b/rocksdb-jemalloc.patch
deleted file mode 100644 (file)
index bed1f75..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- rocksdb-rocksdb-4.9/db/db_impl.cc.orig     2016-06-10 02:53:03.000000000 +0200
-+++ rocksdb-rocksdb-4.9/db/db_impl.cc  2016-09-16 21:57:34.811440413 +0200
-@@ -580,7 +580,7 @@
-   std::unique_ptr<char> buf{new char[kMallocStatusLen + 1]};
-   mstat.cur = buf.get();
-   mstat.end = buf.get() + kMallocStatusLen;
--  malloc_stats_print(GetJemallocStatus, &mstat, "");
-+  je_malloc_stats_print(GetJemallocStatus, &mstat, "");
-   stats->append(buf.get());
- #endif  // ROCKSDB_JEMALLOC
- }
index 5ef3efd2977612b1d568b041a5eeaffcdfd7b8ac..6e26e96d383fd0d85a6bc6d3c693e40d5be50d37 100644 (file)
@@ -1,6 +1,6 @@
---- rocksdb-rocksdb-3.13.1/Makefile.orig       2015-09-14 21:39:12.629620988 +0200
-+++ rocksdb-rocksdb-3.13.1/Makefile    2015-09-15 15:38:46.103569369 +0200
-@@ -928,17 +928,18 @@
+--- rocksdb-6.0.2/Makefile.orig        2019-04-24 00:20:22.000000000 +0200
++++ rocksdb-6.0.2/Makefile     2019-04-28 10:13:08.180185516 +0200
+@@ -1574,17 +1574,18 @@
  #-------------------------------------------------
  # make install related stuff
  INSTALL_PATH ?= /usr/local
  install-headers:
 -      install -d $(INSTALL_PATH)/lib
 +      install -d $(INSTALL_LIBDIR)
-       for header_dir in `find "include/rocksdb" -type d`; do \
+       for header_dir in `$(FIND) "include/rocksdb" -type d`; do \
                install -d $(INSTALL_PATH)/$$header_dir; \
        done
-@@ -947,13 +948,13 @@
+@@ -1593,13 +1594,13 @@
        done
  
  install-static: install-headers $(LIBRARY)
index 472d22c6c835d83f618dcf1f5ebd30c675bf3ba8..8f4c1e834c51955007dedd63ceefe9a4a909ad21 100644 (file)
@@ -3,23 +3,23 @@
 # Conditional build:
 %bcond_with    tests           # build with tests
 %bcond_without static_libs     # don't build static libraries
+%bcond_without tbb             # Threading Building Blocks support
 
 Summary:       RocksDB: A Persistent Key-Value Store for Flash and RAM Storage
 Summary(pl.UTF-8):     RocksDB - trwała baza danych klucz-wartość dla pamięci Flash i RAM
 Name:          rocksdb
-Version:       5.2.1
+Version:       6.0.2
 Release:       1
 License:       BSD
 Group:         Libraries
 #Source0Download: https://github.com/facebook/rocksdb/releases
-Source0:       https://github.com/facebook/rocksdb/archive/%{name}-%{version}.tar.gz
-# Source0-md5: 843b4360dbe3d3869c95d3001644dc41
+Source0:       https://github.com/facebook/rocksdb/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: a8f2f594182e97a08629bcc66dfd3fa0
 Patch0:                %{name}-libdir.patch
 Patch1:                make-programs.patch
-Patch2:                %{name}-jemalloc.patch
-Patch3:                %{name}-detect-flags.patch
+Patch2:                %{name}-detect-flags.patch
 URL:           http://rocksdb.org/
-BuildRequires: bzip2-devel
+BuildRequires: bzip2-devel >= 1.0.6
 BuildRequires: gflags-devel
 # libtcmalloc also supported, but jemalloc is preferred
 BuildRequires: jemalloc-devel
@@ -27,12 +27,13 @@ BuildRequires:      jemalloc-devel
 BuildRequires: libatomic-devel
 %endif
 BuildRequires: libstdc++-devel >= 6:4.7
-BuildRequires: lz4-devel >= 1:1.7
+BuildRequires: lz4-devel >= 1:1.8.3
 BuildRequires: numactl-devel
 BuildRequires: rpmbuild(macros) >= 1.734
-BuildRequires: snappy-devel
-BuildRequires: zlib-devel
-BuildRequires: zstd-devel >= 0.8.0
+BuildRequires: snappy-devel >= 1.1.7
+%{?with_tbb:BuildRequires:     tbb-devel}
+BuildRequires: zlib-devel >= 1.2.11
+BuildRequires: zstd-devel >= 1.3.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -67,11 +68,10 @@ Static RocksDB library.
 Statyczna biblioteka RocksDB.
 
 %prep
-%setup -q -n %{name}-%{name}-%{version}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
 %ifarch i386 i486
@@ -81,10 +81,11 @@ PLATFORM_LDFLAGS="-latomic" \
        AM_DEFAULT_VERBOSITY=1 \
        CC="%{__cc}" \
        CXX="%{__cxx}" \
+       %{!?with_debug:DEBUG_LEVEL=0}
        EXTRA_CFLAGS="$(pkg-config --cflags liblz4)" \
        OPT="%{rpmcflags} %{!?debug:-DNDEBUG}" \
        PORTABLE=1 \
-       %{!?with_debug:DEBUG_LEVEL=0}
+       %{!?with_tbb:ROCKSDB_DISABLE_TBB=1} \
        WARNING_FLAGS="%{rpmcppflags} -Wall"
 
 %install
@@ -96,7 +97,7 @@ rm -rf $RPM_BUILD_ROOT
        INSTALL_LIBDIR=$RPM_BUILD_ROOT%{_libdir}
 
 # reduntant symlink
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/librocksdb.so.5
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/librocksdb.so.6
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -106,9 +107,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS DEFAULT_OPTIONS_HISTORY.md DUMP_FORMAT.md HISTORY.md LANGUAGE-BINDINGS.md LICENSE PATENTS README.md ROCKSDB_LITE.md USERS.md
+%doc AUTHORS DEFAULT_OPTIONS_HISTORY.md DUMP_FORMAT.md HISTORY.md LANGUAGE-BINDINGS.md LICENSE.leveldb README.md ROCKSDB_LITE.md USERS.md
 %attr(755,root,root) %{_libdir}/librocksdb.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/librocksdb.so.5.2
+%attr(755,root,root) %ghost %{_libdir}/librocksdb.so.6.0
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.160559 seconds and 4 git commands to generate.