]> git.pld-linux.org Git - packages/remmina.git/blob - remmina.spec
- up to 1.4.28
[packages/remmina.git] / remmina.spec
1 #
2 # note: disabling plugins will still build them if deps are met
3 #
4 # Conditional build:
5 %bcond_without  exec            # do not build exec plugin
6 %bcond_without  rdp             # do not build rdp plugin
7 %bcond_without  secret          # do not build secret plugin
8 %bcond_without  spice           # do not build spice plugin
9 %bcond_without  vnc             # do not build vnc plugin
10 %bcond_without  vte             # do not build vte plugin
11 %bcond_without  www             # do not build www plugin
12 #
13 Summary:        Remote Desktop Client
14 Name:           remmina
15 Version:        1.4.28
16 Release:        1
17 License:        GPLv2+ and MIT
18 Group:          X11/Applications
19 Source0:        https://gitlab.com/Remmina/Remmina/-/archive/v%{version}/Remmina-v%{version}.tar.bz2
20 # Source0-md5:  6cd0c29ce48218d0fdda79d51232c73e
21 # Cmake helper file to easy build plugins outside remmina source tree
22 # See http://www.muflone.com/remmina-plugin-rdesktop/english/install.html which
23 # use http://www.muflone.com/remmina-plugin-builder/ with remmina bundled source.
24 # So we can't use it directly only as instructions.
25 Source1:        pluginBuild-CMakeLists.txt
26 Patch0:         fix-shebangs.patch
27 URL:            http://remmina.org
28 BuildRequires:  appstream-glib
29 BuildRequires:  avahi-ui-gtk3-devel >= 0.6.30
30 BuildRequires:  cmake >= 2.8
31 BuildRequires:  cups-devel
32 BuildRequires:  desktop-file-utils
33 %{?with_rdp:BuildRequires:      freerdp2-devel >= 2.0.0-0.20190320}
34 BuildRequires:  gettext
35 BuildRequires:  gtk+3-devel
36 %{?with_www:BuildRequires:      gtk-webkit4-devel}
37 BuildRequires:  intltool
38 BuildRequires:  json-glib-devel
39 BuildRequires:  libappindicator-gtk3-devel
40 BuildRequires:  libgcrypt-devel
41 %{?with_secret:BuildRequires:   libsecret-devel}
42 BuildRequires:  libsodium-devel
43 BuildRequires:  libsoup-devel
44 %{?with_vnc:BuildRequires:      libvncserver-devel}
45 BuildRequires:  pcre2-8-devel
46 BuildRequires:  python3-devel
47 BuildRequires:  rpmbuild(macros) >= 1.742
48 %{?with_spice:BuildRequires:    spice-gtk-devel}
49 %{?with_vte:BuildRequires:      vte-devel}
50 BuildRequires:  xorg-lib-libxkbfile-devel
51 Requires(post,postun):  gtk-update-icon-cache
52 Requires:       avahi-ui-gtk3 >= 0.6.30
53 Requires:       hicolor-icon-theme
54 Obsoletes:      remmina-plugins-nx < 1.4.20
55 Obsoletes:      remmina-plugins-xdmcp < 1.4.20
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Remmina is a remote desktop client written in GTK+, aiming to be
60 useful for system administrators and travelers, who need to work with
61 lots of remote computers in front of either large monitors or tiny
62 net-books.
63
64 Remmina supports multiple network protocols in an integrated and
65 consistent user interface. Currently RDP, VNC, XDMCP and SSH are
66 supported.
67
68 Please don't forget to install the plugins for the protocols you want
69 to use.
70
71 %package        devel
72 Summary:        Development files for %{name}
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       pkgconfig
75
76 %description    devel
77 The %{name}-devel package contains header files for developing plugins
78 for %{name}.
79
80 %package        plugins-exec
81 Summary:        External execution plugin for Remmina Remote Desktop Client
82 Requires:       %{name} = %{version}-%{release}
83
84 %description    plugins-exec
85 Remmina is a remote desktop client written in GTK+, aiming to be
86 useful for system administrators and travelers, who need to work with
87 lots of remote computers in front of either large monitors or tiny
88 net-books.
89
90 This package contains the plugin to execute external processes
91 (commands or applications) from the Remmina window.
92
93 %package        plugins-python_wrapper
94 Summary:        Python Wrapper plugin for Remmina Remote Desktop Client
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       freerdp2-libs >= 2.0.0-0.20190320
97
98 %description    plugins-python_wrapper
99 Remmina is a remote desktop client written in GTK+, aiming to be
100 useful for system administrators and travelers, who need to work with
101 lots of remote computers in front of either large monitors or tiny
102 net-books.
103
104 This package enables Python plugins for Remmina.
105
106 %package        plugins-rdp
107 Summary:        RDP plugin for Remmina Remote Desktop Client
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       freerdp2-libs >= 2.0.0-0.20190320
110
111 %description    plugins-rdp
112 Remmina is a remote desktop client written in GTK+, aiming to be
113 useful for system administrators and travelers, who need to work with
114 lots of remote computers in front of either large monitors or tiny
115 net-books.
116
117 This package contains the Remote Desktop Protocol (RDP) plugin for the
118 Remmina remote desktop client.
119
120 %package        plugins-secret
121 Summary:        Keyring integration for Remmina Remote Desktop Client
122 Requires:       %{name} = %{version}-%{release}
123 Provides:       %{name}-plugins-gnome%{?_isa} = %{version}-%{release}
124 Obsoletes:      remmina-plugins-gnome < %{version}-%{release}
125
126 %description    plugins-secret
127 Remmina is a remote desktop client written in GTK+, aiming to be
128 useful for system administrators and travelers, who need to work with
129 lots of remote computers in front of either large monitors or tiny
130 net-books.
131
132 This package contains the plugin with keyring support for the Remmina
133 remote desktop client.
134
135 %package        plugins-spice
136 Summary:        SPICE plugin for Remmina Remote Desktop Client
137 Requires:       %{name} = %{version}-%{release}
138
139 %description    plugins-spice
140 Remmina is a remote desktop client written in GTK+, aiming to be
141 useful for system administrators and travelers, who need to work with
142 lots of remote computers in front of either large monitors or tiny
143 net-books.
144
145 This package contains the SPICE plugin for the Remmina remote desktop
146 client.
147
148 %package        plugins-vnc
149 Summary:        VNC plugin for Remmina Remote Desktop Client
150 Requires:       %{name} = %{version}-%{release}
151
152 %description    plugins-vnc
153 Remmina is a remote desktop client written in GTK+, aiming to be
154 useful for system administrators and travelers, who need to work with
155 lots of remote computers in front of either large monitors or tiny
156 net-books.
157
158 This package contains the VNC plugin for the Remmina remote desktop
159 client.
160
161 %package        plugins-www
162 Summary:        Browser plugin for Remmina Remote Desktop Client
163 Requires:       %{name} = %{version}-%{release}
164
165 %description    plugins-www
166 Remmina is a remote desktop client written in GTK+, aiming to be
167 useful for system administrators and travelers, who need to work with
168 lots of remote computers in front of either large monitors or tiny
169 net-books.
170
171 This package contains the www plugin for the Remmina remote desktop
172 client.
173
174 %prep
175 %setup -qn Remmina-v%{version}
176 %{__sed} -i s/^pt_PT$// po/LINGUAS
177 %{__rm} -f po/pt_PT.po
178 %patch0 -p1
179
180 %build
181 mkdir -p build
182 cd build
183 %cmake \
184         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
185         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
186         -DWITH_APPINDICATOR=ON \
187         -DWITH_AVAHI=ON \
188         -DWITH_CUPS=ON \
189         -DWITH_GCRYPT=ON \
190         -DWITH_GETTEXT=ON \
191         -DWITH_LIBSECRET=ON \
192         %{cmake_on_off vnc WITH_LIBVNCSERVER} \
193         %{cmake_on_off spice WITH_SPICE} \
194         %{cmake_on_off vte WITH_VTE} \
195         ..
196
197 %{__make}
198
199 %install
200 rm -rf $RPM_BUILD_ROOT
201 cd build
202 %{__make} install \
203         DESTDIR=$RPM_BUILD_ROOT
204 cd ..
205
206 install -d $RPM_BUILD_ROOT%{_libdir}/cmake/%{name}/
207 cp -pr cmake/*.cmake $RPM_BUILD_ROOT%{_libdir}/cmake/%{name}/
208 cp -pr config.h.in $RPM_BUILD_ROOT%{_includedir}/%{name}/
209 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/%{name}/
210
211 # not supported by glibc yet
212 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ber,br,ckb,eo,ie,ka,hi,shn}
213
214 %find_lang %{name}
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %post
220 %update_icon_cache hicolor
221
222 %postun
223 %update_icon_cache hicolor
224
225 %files -f %{name}.lang
226 %defattr(644,root,root,755)
227 %doc LICENSE AUTHORS ChangeLog README.md
228 %attr(755,root,root) %{_bindir}/remmina-file-wrapper
229 %attr(755,root,root) %{_bindir}/remmina
230 %{_datadir}/metainfo/*.appdata.xml
231 %{_desktopdir}/*.desktop
232 %{_iconsdir}/hicolor/*/actions/*.*
233 %{_iconsdir}/hicolor/*/apps/*.*
234 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-sftp-symbolic.svg
235 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-ssh-symbolic.svg
236 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-tool-symbolic.svg
237 %{_iconsdir}/hicolor/*/status/org.remmina.Remmina-status.svg
238 %dir %{_iconsdir}/hicolor/apps
239 %{_iconsdir}/hicolor/apps/*.*
240 %{_datadir}/mime/packages/*.xml
241 %{_datadir}/%{name}/
242 %dir %{_libdir}/remmina/
243 %dir %{_libdir}/remmina/plugins/
244 %{_mandir}/man1/remmina.1*
245 %{_mandir}/man1/remmina-file-wrapper.1*
246
247 %files devel
248 %defattr(644,root,root,755)
249 %{_includedir}/%{name}/
250 %{_pkgconfigdir}/%{name}.pc
251 %dir %{_libdir}/cmake/%{name}
252 %{_libdir}/cmake/%{name}/*.cmake
253
254 %if %{with exec}
255 %files plugins-exec
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-exec.so
258 %endif
259
260 %files plugins-python_wrapper
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-python_wrapper.so
263
264 %if %{with rdp}
265 %files plugins-rdp
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-rdp.so
268 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-rdp-ssh-symbolic.svg
269 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-rdp-symbolic.svg
270 %endif
271
272 %if %{with secret}
273 %files plugins-secret
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-secret.so
276 %endif
277
278 %if %{with spice}
279 %files plugins-spice
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-spice.so
282 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-spice-symbolic.svg
283 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-spice-ssh-symbolic.svg
284 %endif
285
286 %if %{with vnc}
287 %files plugins-vnc
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-vnc.so
290 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-vnc-ssh-symbolic.svg
291 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-vnc-symbolic.svg
292 %endif
293
294 %if %{with www}
295 %files plugins-www
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-www.so
298 %{_iconsdir}/hicolor/*/emblems/org.remmina.Remmina-www-symbolic.svg
299 %endif
300
301 %changelog
This page took 0.089801 seconds and 4 git commands to generate.