]> git.pld-linux.org Git - packages/remmina.git/blob - remmina.spec
versioned runtime deps
[packages/remmina.git] / remmina.spec
1 #
2 # note: disabling plugins will still build them if deps are met
3 #
4 # Conditional build:
5 %bcond_without  exec            # do not build exec plugin
6 %bcond_with     nx              # build nx plugin
7 %bcond_without  rdp             # do not build rdp plugin
8 %bcond_without  secret          # do not build secret plugin
9 %bcond_without  spice           # do not build spice plugin
10 %bcond_without  telepathy       # do not build telepathy plugin
11 %bcond_without  vnc             # do not build vnc plugin
12 %bcond_without  vte             # do not build vte plugin
13 %bcond_without  xdmcp           # do not build xdmcp plugin
14 #
15 Summary:        Remote Desktop Client
16 Name:           remmina
17 Version:        1.3.4
18 Release:        1
19 License:        GPLv2+ and MIT
20 Group:          X11/Applications
21 Source0:        https://gitlab.com/Remmina/Remmina/-/archive/v1.3.4/Remmina-v%{version}.tar.bz2
22 # Source0-md5:  cd00d28c5b895037901d8aa9f9ace9fc
23 # Cmake helper file to easy build plugins outside remmina source tree
24 # See http://www.muflone.com/remmina-plugin-rdesktop/english/install.html which
25 # use http://www.muflone.com/remmina-plugin-builder/ with remmina bundled source.
26 # So we can't use it directly only as instructions.
27 Source1:        pluginBuild-CMakeLists.txt
28 URL:            http://remmina.org
29 BuildRequires:  appstream-glib
30 BuildRequires:  avahi-ui-gtk3-devel >= 0.6.30
31 BuildRequires:  cmake >= 2.8
32 BuildRequires:  desktop-file-utils
33 %{?with_rdp:BuildRequires:      freerdp2-devel >= 2.0.0-0.20190320}
34 BuildRequires:  gettext
35 BuildRequires:  gtk+3-devel
36 BuildRequires:  intltool
37 BuildRequires:  json-glib-devel
38 BuildRequires:  libappindicator-gtk3-devel
39 BuildRequires:  libgcrypt-devel
40 %{?with_secret:BuildRequires:   libsecret-devel}
41 BuildRequires:  libsoup-devel
42 BuildRequires:  libssh-devel >= 0.6
43 %{?with_vnc:BuildRequires:      libvncserver-devel}
44 BuildRequires:  rpmbuild(macros) >= 1.742
45 %{?with_spice:BuildRequires:    spice-gtk-devel}
46 %{?with_telepathy:BuildRequires:        telepathy-glib-devel}
47 %{?with_vte:BuildRequires:      vte2.90-devel}
48 BuildRequires:  xorg-lib-libxkbfile-devel
49 Requires(post,postun):  gtk-update-icon-cache
50 Requires:       avahi-ui-gtk3 >= 0.6.30
51 Requires:       hicolor-icon-theme
52 Requires:       libssh >= 0.6
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Remmina is a remote desktop client written in GTK+, aiming to be
57 useful for system administrators and travelers, who need to work with
58 lots of remote computers in front of either large monitors or tiny
59 net-books.
60
61 Remmina supports multiple network protocols in an integrated and
62 consistent user interface. Currently RDP, VNC, XDMCP and SSH are
63 supported.
64
65 Please don't forget to install the plugins for the protocols you want
66 to use.
67
68 %package        devel
69 Summary:        Development files for %{name}
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       pkgconfig
72
73 %description    devel
74 The %{name}-devel package contains header files for developing plugins
75 for %{name}.
76
77 %package        plugins-exec
78 Summary:        External execution plugin for Remmina Remote Desktop Client
79 Requires:       %{name} = %{version}-%{release}
80
81 %description    plugins-exec
82 Remmina is a remote desktop client written in GTK+, aiming to be
83 useful for system administrators and travelers, who need to work with
84 lots of remote computers in front of either large monitors or tiny
85 net-books.
86
87 This package contains the plugin to execute external processes
88 (commands or applications) from the Remmina window.
89
90 %package        plugins-nx
91 Summary:        NX plugin for Remmina Remote Desktop Client
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       nxproxy
94
95 %description    plugins-nx
96 Remmina is a remote desktop client written in GTK+, aiming to be
97 useful for system administrators and travelers, who need to work with
98 lots of remote computers in front of either large monitors or tiny
99 net-books.
100
101 This package contains the NX plugin for the Remmina remote desktop
102 client.
103
104 %package        plugins-rdp
105 Summary:        RDP plugin for Remmina Remote Desktop Client
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       freerdp2-libs >= 2.0.0-0.20190320
108
109 %description    plugins-rdp
110 Remmina is a remote desktop client written in GTK+, aiming to be
111 useful for system administrators and travelers, who need to work with
112 lots of remote computers in front of either large monitors or tiny
113 net-books.
114
115 This package contains the Remote Desktop Protocol (RDP) plugin for the
116 Remmina remote desktop client.
117
118 %package        plugins-secret
119 Summary:        Keyring integration for Remmina Remote Desktop Client
120 Requires:       %{name} = %{version}-%{release}
121 Provides:       %{name}-plugins-gnome%{?_isa} = %{version}-%{release}
122 Obsoletes:      remmina-plugins-gnome < %{version}-%{release}
123
124 %description    plugins-secret
125 Remmina is a remote desktop client written in GTK+, aiming to be
126 useful for system administrators and travelers, who need to work with
127 lots of remote computers in front of either large monitors or tiny
128 net-books.
129
130 This package contains the plugin with keyring support for the Remmina
131 remote desktop client.
132
133 %package        plugins-spice
134 Summary:        SPICE plugin for Remmina Remote Desktop Client
135 Requires:       %{name} = %{version}-%{release}
136
137 %description    plugins-spice
138 Remmina is a remote desktop client written in GTK+, aiming to be
139 useful for system administrators and travelers, who need to work with
140 lots of remote computers in front of either large monitors or tiny
141 net-books.
142
143 This package contains the SPICE plugin for the Remmina remote desktop
144 client.
145
146 %package        plugins-telepathy
147 Summary:        Telepathy plugin for Remmina Remote Desktop Client
148 Requires:       %{name} = %{version}-%{release}
149
150 %description    plugins-telepathy
151 Remmina is a remote desktop client written in GTK+, aiming to be
152 useful for system administrators and travelers, who need to work with
153 lots of remote computers in front of either large monitors or tiny
154 net-books.
155
156 This package contains the Telepathy plugin for the Remmina remote
157 desktop client.
158
159 %package        plugins-vnc
160 Summary:        VNC plugin for Remmina Remote Desktop Client
161 Requires:       %{name} = %{version}-%{release}
162
163 %description    plugins-vnc
164 Remmina is a remote desktop client written in GTK+, aiming to be
165 useful for system administrators and travelers, who need to work with
166 lots of remote computers in front of either large monitors or tiny
167 net-books.
168
169 This package contains the VNC plugin for the Remmina remote desktop
170 client.
171
172 %package        plugins-xdmcp
173 Summary:        XDMCP plugin for Remmina Remote Desktop Client
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       xorg-xserver-Xephyr
176
177 %description    plugins-xdmcp
178 Remmina is a remote desktop client written in GTK+, aiming to be
179 useful for system administrators and travelers, who need to work with
180 lots of remote computers in front of either large monitors or tiny
181 net-books.
182
183 This package contains the XDMCP plugin for the Remmina remote desktop
184 client.
185
186 %prep
187 %setup -qn Remmina-v%{version}
188 %{__sed} -i s/^pt_PT$// po/LINGUAS
189 %{__rm} -f po/pt_PT.po
190
191 %build
192 mkdir -p build
193
194 %cmake --build=build \
195         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
196         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
197         -DWITH_APPINDICATOR=ON \
198         -DWITH_AVAHI=ON \
199         %{cmake_on_off rdp FREERDP} \
200         -DWITH_GCRYPT=ON \
201         -DWITH_GETTEXT=ON \
202         -DWITH_LIBSSH=ON \
203         %{cmake_on_off vnc LIBVNCSERVER} \
204         %{cmake_on_off spice SPICE} \
205         %{cmake_on_off telepathy TELEPATHY} \
206         %{cmake_on_off vte VTE} \
207         .
208
209 %{__make}
210
211 %install
212 rm -rf $RPM_BUILD_ROOT
213 %{__make} install \
214         DESTDIR=$RPM_BUILD_ROOT
215
216 install -d $RPM_BUILD_ROOT/%{_libdir}/cmake/%{name}/
217 cp -pr cmake/*.cmake $RPM_BUILD_ROOT/%{_libdir}/cmake/%{name}/
218 cp -pr config.h.in $RPM_BUILD_ROOT/%{_includedir}/%{name}/
219 cp -p %{SOURCE1} $RPM_BUILD_ROOT/%{_includedir}/%{name}/
220
221 %find_lang %{name}
222
223 %clean
224 rm -rf $RPM_BUILD_ROOT
225
226 %post
227 %update_icon_cache hicolor
228
229 %postun
230 %update_icon_cache hicolor
231
232 %files -f %{name}.lang
233 %defattr(644,root,root,755)
234 %doc LICENSE AUTHORS ChangeLog README.md
235 %attr(755,root,root) %{_bindir}/gnome-session-remmina
236 %attr(755,root,root) %{_bindir}/remmina
237 %attr(755,root,root) %{_bindir}/remmina-gnome
238 %{_datadir}/metainfo/*.appdata.xml
239 %{_desktopdir}/*.desktop
240 %{_iconsdir}/hicolor/*/actions/*.*
241 %{_iconsdir}/hicolor/*/apps/*.*
242 %{_iconsdir}/hicolor/*/emblems/remmina-sftp-symbolic.svg
243 %{_iconsdir}/hicolor/*/emblems/remmina-ssh-symbolic.svg
244 %{_iconsdir}/hicolor/*/emblems/remmina-tool-symbolic.svg
245 %{_datadir}/mime/packages/*.xml
246 %{_datadir}/%{name}/
247 %{_datadir}/xsessions/remmina-gnome.desktop
248 %dir %{_libdir}/remmina/
249 %dir %{_libdir}/remmina/plugins/
250 %{_libdir}/remmina/plugins/remmina-plugin-st.so
251 %{_mandir}/man1/remmina.1*
252 %{_mandir}/man1/gnome-session-remmina.1*
253 %{_mandir}/man1/remmina-gnome.1*
254
255 %files devel
256 %defattr(644,root,root,755)
257 %{_includedir}/%{name}/
258 %{_pkgconfigdir}/%{name}.pc
259 %dir %{_libdir}/cmake/%{name}
260 %{_libdir}/cmake/%{name}/*.cmake
261
262 %if %{with exec}
263 %files plugins-exec
264 %defattr(644,root,root,755)
265 %{_libdir}/remmina/plugins/remmina-plugin-exec.so
266 %endif
267
268 %if %{with nx}
269 %files plugins-nx
270 %defattr(644,root,root,755)
271 %{_libdir}/remmina/plugins/remmina-plugin-nx.so
272 %{_iconsdir}/hicolor/*/emblems/remmina-nx-symbolic.svg
273 %endif
274
275 %if %{with rdp}
276 %files plugins-rdp
277 %defattr(644,root,root,755)
278 %{_libdir}/remmina/plugins/remmina-plugin-rdp.so
279 %{_iconsdir}/hicolor/*/emblems/remmina-rdp-ssh-symbolic.svg
280 %{_iconsdir}/hicolor/*/emblems/remmina-rdp-symbolic.svg
281 %endif
282
283 %if %{with secret}
284 %files plugins-secret
285 %defattr(644,root,root,755)
286 %{_libdir}/remmina/plugins/remmina-plugin-secret.so
287 %endif
288
289 %if %{with spice}
290 %files plugins-spice
291 %defattr(644,root,root,755)
292 %{_libdir}/remmina/plugins/remmina-plugin-spice.so
293 %{_iconsdir}/hicolor/*/emblems/remmina-spice-symbolic.svg
294 %{_iconsdir}/hicolor/*/emblems/remmina-spice-ssh-symbolic.svg
295 %endif
296
297 %if %{with telepathy}
298 %files plugins-telepathy
299 %defattr(644,root,root,755)
300 %{_libdir}/remmina/plugins/remmina-plugin-telepathy.so
301 %{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.Remmina.service
302 %{_datadir}/telepathy/clients/Remmina.client
303 %endif
304
305 %if %{with vnc}
306 %files plugins-vnc
307 %defattr(644,root,root,755)
308 %{_libdir}/remmina/plugins/remmina-plugin-vnc.so
309 %{_iconsdir}/hicolor/*/emblems/remmina-vnc-ssh-symbolic.svg
310 %{_iconsdir}/hicolor/*/emblems/remmina-vnc-symbolic.svg
311 %endif
312
313 %if %{with xdmcp}
314 %files plugins-xdmcp
315 %defattr(644,root,root,755)
316 %{_libdir}/remmina/plugins/remmina-plugin-xdmcp.so
317 %{_iconsdir}/hicolor/*/emblems/remmina-xdmcp-ssh-symbolic.svg
318 %{_iconsdir}/hicolor/*/emblems/remmina-xdmcp-symbolic.svg
319 %endif
320
321 %changelog
This page took 0.07709 seconds and 3 git commands to generate.