]> git.pld-linux.org Git - packages/rc-scripts.git/commitdiff
fix checking if pidfile was specified <Krzysztof Mazur> auto/th/rc-scripts-0.4.15-2
authorElan Ruusamäe <glen@delfi.ee>
Mon, 23 Nov 2015 12:06:40 +0000 (14:06 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 23 Nov 2015 12:06:40 +0000 (14:06 +0200)
rc-scripts-git.patch
rc-scripts.spec

index a4338572b75498429be1e309c2e6dee93b40d93b..4cab90a9bbe6e8988fa6003c31309a223c171784 100644 (file)
@@ -1,36 +1,13 @@
-commit f60ef786cf271e20da75988326a8c0cf90a7c485
-Author: Arkadiusz Miśkiewicz <arekm@maven.pl>
-Date:   Thu Jul 9 09:18:37 2015 +0200
-
-    Make DELAY_LOGIN checks consistent with the one in rc.sysinit (broken in 277e5f5352e622c4317852cded63e2a287506655).
-
-diff --git a/rc.d/init.d/allowlogin b/rc.d/init.d/allowlogin
-index dcd789e..d837189 100755
---- a/rc.d/init.d/allowlogin
-+++ b/rc.d/init.d/allowlogin
-@@ -24,14 +24,14 @@ esac
- . /etc/rc.d/init.d/functions
- start() {
--      if is_yes "$DELAY_LOGIN" && [ -f /etc/nologin.boot ]; then
-+      if ! is_no "$DELAY_LOGIN" && [ -f /etc/nologin.boot ]; then
-               run_cmd "Allowing users to login" rm -f /etc/nologin /etc/nologin.boot
+diff --git a/lib/functions b/lib/functions
+index 8d018f7..501cac9 100644
+--- a/lib/functions
++++ b/lib/functions
+@@ -1009,7 +1009,7 @@ pidofproc() {
        fi
- }
  
- stop() {
-       # /etc/nologin when shutting down system
--      if is_yes "$DELAY_LOGIN" && [ ! -f /etc/nologin ]; then
-+      if ! is_no "$DELAY_LOGIN" && [ ! -f /etc/nologin ]; then
-               nls "System shutdown in progress\n" > /etc/nologin
-               chmod 644 /etc/nologin
-               cp -fp /etc/nologin /etc/nologin.boot
-@@ -39,7 +39,7 @@ stop() {
- }
+       # Next try "pidof" if pidfile is not specified
+-      if [ -z "$pid" ] && [ -z "$pidfile" ]; then
++      if [ -z "$pid" ] && [ -z "$2" ]; then
+               pid=$(pidof -o $$ -o $PPID -o %PPID -x "$1")
+       fi
  
- status() {
--      if is_yes "$DELAY_LOGIN"; then
-+      if ! is_no "$DELAY_LOGIN"; then
-               nls "Delay login is enabled"
-       else
-               nls "Delay login is not enabled"
index 3253431a2347dcd544e6ef68f34910554b6c510b..e45888a3801d997a4cb597f6be1f8bc5a2eb6a26 100644 (file)
@@ -9,7 +9,7 @@ Summary(pl.UTF-8):      inittab i skrypty startowe z katalogu /etc/rc.d
 Summary(tr.UTF-8):     inittab ve /etc/rc.d dosyaları
 Name:          rc-scripts
 Version:       0.4.15
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Base
 #Source0:      ftp://distfiles.pld-linux.org/src/%{name}-%{version}.tar.gz
@@ -18,7 +18,7 @@ Source0:      %{name}-%{version}.tar.gz
 Source1:       rc-local.service
 Source2:       sys-chroots.service
 Source3:       %{name}.tmpfiles
-#Patch0:               %{name}-git.patch
+Patch0:                %{name}-git.patch
 URL:           http://svn.pld-linux.org/trac/svn/wiki/packages/rc-scripts
 BuildRequires: autoconf
 BuildRequires: automake
@@ -129,7 +129,7 @@ directories are silently ignored.
 
 %prep
 %setup -q
-#%patch0 -p1
+%patch0 -p1
 
 # hack, currently this results in errno@@GLIBC_PRIVATE symbol in ppp-watch:
 #GLIB_LIBS="-Wl,-static `$PKG_CONFIG --libs --static glib-2.0` -Wl,-Bdynamic"
This page took 0.083389 seconds and 4 git commands to generate.