]> git.pld-linux.org Git - packages/radsecproxy.git/commitdiff
- rel.2 - upstart support
authorPaweł Gołaszewski <blues@pld-linux.org>
Mon, 28 Jun 2010 14:42:04 +0000 (14:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    radsecproxy.init -> 1.4
    radsecproxy.spec -> 1.10

radsecproxy.init
radsecproxy.spec

index 564c10450d590ead0a1ad7ddcab4eebbc464f10c..2a15f18ec996131954469db3e877ec76d3cbf6ec 100644 (file)
@@ -20,6 +20,8 @@
 # Get service config
 [ -f /etc/sysconfig/radsecproxy ] && . /etc/sysconfig/radsecproxy
 
+upstart_controlled
+
 # Check that networking is up.
 if is_yes "${NETWORKING}"; then
        if [ ! -f /var/lock/subsys/network -a "$1" != stop -a "$1" != status ]; then
index e36311543fe639d077dc167d3b708af7cf357af1..91963a3b658d168a7e0813dbb8d5e37acc843bd4 100644 (file)
@@ -4,13 +4,14 @@
 Summary:       RADIUS proxy that in addition to to usual RADIUS UDP transport, also supports TLS (RadSec)
 Name:          radsecproxy
 Version:       1.4
-Release:       1
+Release:       2
 License:       GPLv2+ or BSD-like
 Group:         Networking/Daemons/Radius
 Source0:       http://software.uninett.no/radsecproxy/%{name}-%{version}.tar.gz
 # Source0-md5: 7b5248b2a7a133561cf685730824c893
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
+Source3:       %{name}.upstart
 URL:           http://software.uninett.no/radsecproxy/
 #For manual creation:
 #BuildRequires:        docbook2x-to-man
@@ -25,6 +26,19 @@ time to be small, efficient and easy to configure. Currently the
 executable on Linux is only about 48 Kb, and it uses about 64 Kb
 (depending on the number of peers) while running.
 
+%package upstart
+Summary:       Upstart job description for %{name}
+Summary(pl.UTF-8):     Opis zadania Upstart dla %{name}
+Group:         Daemons
+Requires:      %{name} = %{version}-%{release}
+Requires:      upstart >= 0.6
+
+%description upstart
+Upstart job description for %{name}.
+
+%description upstart -l pl.UTF-8
+Opis zadania Upstart dla %{name}.
+
 %prep
 %setup -q
 
@@ -35,7 +49,7 @@ executable on Linux is only about 48 Kb, and it uses about 64 Kb
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/radsecproxy.conf.d \
-       $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d}
+       $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,init}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -44,6 +58,7 @@ install radsecproxy.conf-example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/init/%{name}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -58,6 +73,12 @@ if [ "$1" = "0" ]; then
         /sbin/chkconfig --del %{name}
 fi
 
+%post upstart
+%upstart_post %{name}
+
+%postun upstart
+%upstart_postun %{name}
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
@@ -70,3 +91,7 @@ fi
 %{_mandir}/man1/*
 # With manual created:
 #%{_mandir}/man5/*
+
+%files upstart
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) /etc/init/%{name}.conf
This page took 0.053811 seconds and 4 git commands to generate.