]> git.pld-linux.org Git - packages/radsecproxy.git/blob - radsecproxy.spec
- up to 1.7.1
[packages/radsecproxy.git] / radsecproxy.spec
1 # TODO:
2 # - own UID/GID
3 Summary:        RADIUS proxy that in addition to to usual RADIUS UDP transport, also supports TLS (RadSec)
4 Name:           radsecproxy
5 Version:        1.7.1
6 Release:        1
7 License:        GPLv2+ or BSD-like
8 Group:          Networking/Daemons/Radius
9 Source0:        https://github.com/radsecproxy/radsecproxy/releases/download/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  070ec707aa2f351bdc5387b474b58e7a
11 Source1:        %{name}.init
12 Source2:        %{name}.logrotate
13 URL:            http://software.uninett.no/radsecproxy/
14 # For manual creation:
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  docbook2X
18 BuildRequires:  nettle-devel
19 Requires:       openssl >= 1.0.0b
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       rc-scripts >= 0.4.3.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 radsecproxy is a generic RADIUS proxy that in addition to to usual
26 RADIUS UDP transport, also supports TLS (RadSec). The aim is for the
27 proxy to have sufficient features to be flexible, while at the same
28 time to be small, efficient and easy to configure. Currently the
29 executable on Linux is only about 48 Kb, and it uses about 64 Kb
30 (depending on the number of peers) while running.
31
32 %package upstart
33 Summary:        Upstart job description for %{name}
34 Summary(pl.UTF-8):      Opis zadania Upstart dla %{name}
35 Group:          Daemons
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       upstart >= 0.6
38
39 %description upstart
40 Upstart job description for %{name}.
41
42 %description upstart -l pl.UTF-8
43 Opis zadania Upstart dla %{name}.
44
45 %prep
46 %setup -q
47
48 %build
49 %{__aclocal}
50 %{__autoconf}
51 %{__automake}
52 %configure \
53         --enable-fticks
54 # Some trash comes with tar:
55 %{__make} clean
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_sysconfdir}/radsecproxy.conf.d \
61         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,init}
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 cp -p radsecproxy.conf-example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
67
68 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
69 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
70
71 install -p radsecproxy.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 /sbin/chkconfig --add %{name}
78 %service %{name} restart "RADIUS secure proxy"
79
80 %preun
81 if [ "$1" = "0" ]; then
82         %service %{name} stop
83         /sbin/chkconfig --del %{name}
84 fi
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog README
89 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/radsecproxy.conf
90 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
91 %attr(750,root,root) %dir %{_sysconfdir}/radsecproxy.conf.d
92 %attr(755,root,root) %{_sbindir}/radsecproxy
93 %attr(755,root,root) %{_bindir}/radsecproxy-conf
94 %attr(755,root,root) %{_bindir}/radsecproxy-hash
95 %attr(754,root,root) /etc/rc.d/init.d/%{name}
96 %{_mandir}/man1/*
97 %{_mandir}/man5/*
This page took 0.085218 seconds and 3 git commands to generate.