]> git.pld-linux.org Git - packages/radsecproxy.git/blob - radsecproxy.spec
2a8665fecb77e890da1dca282418ce5382bbec80
[packages/radsecproxy.git] / radsecproxy.spec
1 # TODO:
2 # - own UID/GID
3 Summary:        RADIUS proxy that in addition to to usual RADIUS UDP transport, also supports TLS (RadSec)
4 Name:           radsecproxy
5 Version:        1.7.1
6 Release:        2
7 License:        GPLv2+ or BSD-like
8 Group:          Networking/Daemons/Radius
9 Source0:        https://github.com/radsecproxy/radsecproxy/releases/download/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  070ec707aa2f351bdc5387b474b58e7a
11 Source1:        %{name}.init
12 Source2:        %{name}.logrotate
13 Patch0:         %{name}-paths.patch
14 URL:            http://software.uninett.no/radsecproxy/
15 # For manual creation:
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  docbook2X
19 BuildRequires:  nettle-devel
20 Requires:       openssl >= 1.0.0b
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       rc-scripts >= 0.4.3.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 radsecproxy is a generic RADIUS proxy that in addition to to usual
27 RADIUS UDP transport, also supports TLS (RadSec). The aim is for the
28 proxy to have sufficient features to be flexible, while at the same
29 time to be small, efficient and easy to configure. Currently the
30 executable on Linux is only about 48 Kb, and it uses about 64 Kb
31 (depending on the number of peers) while running.
32
33 %package upstart
34 Summary:        Upstart job description for %{name}
35 Summary(pl.UTF-8):      Opis zadania Upstart dla %{name}
36 Group:          Daemons
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       upstart >= 0.6
39
40 %description upstart
41 Upstart job description for %{name}.
42
43 %description upstart -l pl.UTF-8
44 Opis zadania Upstart dla %{name}.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 %{__aclocal}
52 %{__autoconf}
53 %{__automake}
54 %configure \
55         --enable-fticks
56 # Some trash comes with tar:
57 %{__make} clean
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_sysconfdir}/radsecproxy.conf.d \
63         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,logrotate.d,init}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 cp -p radsecproxy.conf-example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
69
70 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
71 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
72
73 install -p radsecproxy.conf.5 $RPM_BUILD_ROOT/%{_mandir}/man5
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 /sbin/chkconfig --add %{name}
80 %service %{name} restart "RADIUS secure proxy"
81
82 %preun
83 if [ "$1" = "0" ]; then
84         %service %{name} stop
85         /sbin/chkconfig --del %{name}
86 fi
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS ChangeLog README
91 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/radsecproxy.conf
92 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
93 %attr(750,root,root) %dir %{_sysconfdir}/radsecproxy.conf.d
94 %attr(755,root,root) %{_sbindir}/radsecproxy
95 %attr(755,root,root) %{_bindir}/radsecproxy-conf
96 %attr(755,root,root) %{_bindir}/radsecproxy-hash
97 %attr(754,root,root) /etc/rc.d/init.d/%{name}
98 %{_mandir}/man1/*
99 %{_mandir}/man5/*
This page took 0.055122 seconds and 2 git commands to generate.