]> git.pld-linux.org Git - packages/r8168.git/commitdiff
- fix building with linux 4.7 auto/th/r8168-8.042.00-1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Aug 2016 19:35:27 +0000 (21:35 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Aug 2016 19:35:27 +0000 (21:35 +0200)
linux-4.7.patch [new file with mode: 0644]
r8168.spec

diff --git a/linux-4.7.patch b/linux-4.7.patch
new file mode 100644 (file)
index 0000000..6ef62d0
--- /dev/null
@@ -0,0 +1,34 @@
+--- r8168-8.042.00/src/r8168_n.c.orig  2016-08-01 21:20:42.000000000 +0200
++++ r8168-8.042.00/src/r8168_n.c       2016-08-01 21:32:49.488072441 +0200
+@@ -22800,7 +22800,9 @@
+                         dev->hw_features &= ~NETIF_F_IPV6_CSUM;
+                         netif_set_gso_max_size(dev, LSO_32K);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+                         dev->gso_min_segs = NIC_MIN_PHYS_BUF_COUNT;
++#endif
+                         dev->gso_max_segs = NIC_MAX_PHYS_BUF_COUNT_LSO_64K;
+ #endif
+                 } else {
+@@ -22808,7 +22810,9 @@
+                         dev->features |=  NETIF_F_IPV6_CSUM | NETIF_F_TSO6;
+                         netif_set_gso_max_size(dev, LSO_64K);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,0)
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+                         dev->gso_min_segs = NIC_MIN_PHYS_BUF_COUNT;
++#endif
+                         dev->gso_max_segs = NIC_MAX_PHYS_BUF_COUNT_LSO2;
+ #endif
+                 }
+@@ -24970,7 +24974,11 @@
+         wmb();
+         txd->opts1 = cpu_to_le32(opts1);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+         dev->trans_start = jiffies;
++#else
++        netif_trans_update(dev);
++#endif
+         tp->cur_tx += frags + 1;
index 3b2a2b77cf449102f5a363b3a92e9da1f8486005..876d74ebec00700d5fa2a62096a3659c0c427fa4 100644 (file)
@@ -20,6 +20,7 @@ URL:          http://www.realtek.com.tw/
 Source0:       %{pname}-%{version}.tar.bz2
 # Source0-md5: 2c583809d1ebf26ed7f5e775c83e68e0
 Patch0:                linux-4.5.patch
+Patch1:                linux-4.7.patch
 BuildRequires: rpmbuild(macros) >= 1.701
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
@@ -72,6 +73,7 @@ Express Gigabit Ethernet.\
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{expand:%build_kernel_packages}
This page took 0.114768 seconds and 4 git commands to generate.