]> git.pld-linux.org Git - packages/qutebrowser.git/blob - qutebrowser.spec
up to 1.4.2
[packages/qutebrowser.git] / qutebrowser.spec
1 %define         qtver   5.7.1
2 Summary:        A keyboard-driven, vim-like browser based on PyQt5
3 Name:           qutebrowser
4 Version:        1.4.2
5 Release:        1
6 License:        GPL v3+
7 Group:          X11/Applications/Networking
8 Source0:        https://github.com/qutebrowser/qutebrowser/archive/v%{version}.tar.gz
9 # Source0-md5:  2abf8e530db1182765d610a16a5e41b0
10 URL:            https://www.qutebrowser.org/
11 BuildRequires:  asciidoc
12 BuildRequires:  python3 >= 3.6
13 BuildRequires:  python3-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       Qt5Core >= %{qtver}
17 Requires:       Qt5OpenGL >= %{qtver}
18 Requires:       Qt5Sql >= %{qtver}
19 Requires:       Qt5WebEngine >= %{qtver}
20 Requires:       bash
21 Requires:       hicolor-icon-theme
22 Requires:       python3 >= 3.6
23 Requires:       python3-PyQt5 >= 5.7.0
24 Requires:       python3-PyYAML
25 Requires:       python3-attrs
26 Requires:       python3-jinja2
27 Requires:       python3-pyPEG2
28 Requires:       python3-pygments
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 qutebrowser is a keyboard-focused browser with a minimal GUI. It’s
33 based on Python, PyQt5 and QtWebEngine and free software, licensed
34 under the GPL. It was inspired by other browsers/addons like dwb and
35 Vimperator/Pentadactyl.
36
37 %prep
38 %setup -q
39
40 grep -r '#!.*env bash' -l . | xargs %{__sed} -i -e '1 s,#!.*env bash.*,#!/bin/bash,'
41 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python.*,#!%{__python3},'
42
43 %build
44 %py3_build
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %py3_install
50
51 %{__make} -f misc/Makefile install PYTHON=/bin/true DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %update_desktop_database_post
58 %update_icon_cache hicolor
59
60 %postun
61 %update_desktop_database_postun
62 %update_icon_cache hicolor
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README.asciidoc
67 %attr(755,root,root) %{_bindir}/qutebrowser
68 %{py3_sitescriptdir}/qutebrowser
69 %{py3_sitescriptdir}/qutebrowser-%{version}-py*.egg-info
70 %{_desktopdir}/qutebrowser.desktop
71 %{_iconsdir}/hicolor/*x*/apps/qutebrowser.png
72 %{_iconsdir}/hicolor/scalable/apps/qutebrowser.svg
73 %{_mandir}/man1/qutebrowser.1*
74 %{_datadir}/metainfo/qutebrowser.appdata.xml
75 %dir %{_datadir}/qutebrowser
76 %dir %{_datadir}/qutebrowser/scripts
77 %{_datadir}/qutebrowser/scripts/*.js
78 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.py
79 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.sh
80 %dir %{_datadir}/qutebrowser/userscripts
81 %attr(755,root,root) %{_datadir}/qutebrowser/userscripts/*
This page took 0.034162 seconds and 4 git commands to generate.