]> git.pld-linux.org Git - packages/qutebrowser.git/blob - qutebrowser.spec
f72621162398a7cdde22840930279ee6e1d85312
[packages/qutebrowser.git] / qutebrowser.spec
1 %define         qtver   5.12.1
2 Summary:        A keyboard-driven, vim-like browser based on PyQt5
3 Name:           qutebrowser
4 Version:        2.3.0
5 Release:        1
6 License:        GPL v3+
7 Group:          X11/Applications/Networking
8 Source0:        https://github.com/qutebrowser/qutebrowser/archive/v%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  9a2f948cce166845b958485b721b734e
10 URL:            https://www.qutebrowser.org/
11 BuildRequires:  asciidoc
12 BuildRequires:  python3 >= 1:3.6.1
13 BuildRequires:  python3-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       Qt5Core >= %{qtver}
17 Requires:       Qt5DBus >= %{qtver}
18 Requires:       Qt5Gui >= %{qtver}
19 Requires:       Qt5Network >= %{qtver}
20 Requires:       Qt5OpenGL >= %{qtver}
21 Requires:       Qt5PrintSupport >= %{qtver}
22 Requires:       Qt5Qml >= %{qtver}
23 Requires:       Qt5Sql >= %{qtver}
24 Requires:       Qt5Sql-sqldriver-sqlite3 >= %{qtver}
25 Requires:       Qt5WebEngine >= %{qtver}
26 Requires:       Qt5Widgets >= %{qtver}
27 Requires:       bash
28 Requires:       hicolor-icon-theme
29 Requires:       python3 >= 1:3.6.1
30 Requires:       python3-PyQt5 >= 5.12.0
31 Requires:       python3-PyQtWebEngine
32 Requires:       python3-PyYAML
33 Requires:       python3-jinja2
34 Suggests:       python3-adblock
35 Suggests:       python3-pygments
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 qutebrowser is a keyboard-focused browser with a minimal GUI. It’s
41 based on Python, PyQt5 and QtWebEngine and free software, licensed
42 under the GPL. It was inspired by other browsers/addons like dwb and
43 Vimperator/Pentadactyl.
44
45 %package userscripts
46 Summary:        User scripts for qutebrowser
47 Group:          X11/Applications/Networking
48 Requires:       %{name} = %{version}-%{release}
49
50 %description userscripts
51 User scripts for qutebrowser.
52
53 %prep
54 %setup -q
55
56 grep -r '#!.*env bash' -l . | xargs %{__sed} -i -e '1 s,#!.*env bash.*,#!/bin/bash,'
57 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python.*,#!%{__python3},'
58 grep -r '#!.*env node' -l . | xargs %{__sed} -i -e '1 s,#!.*env node.*,#!/usr/bin/node,'
59
60 %build
61 %py3_build
62
63 %{__python3} scripts/asciidoc2html.py
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %py3_install
69
70 %{__make} -f misc/Makefile install PYTHON=/bin/true DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %update_desktop_database_post
77 %update_icon_cache hicolor
78
79 %postun
80 %update_desktop_database_postun
81 %update_icon_cache hicolor
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README.asciidoc
86 %attr(755,root,root) %{_bindir}/qutebrowser
87 %{py3_sitescriptdir}/qutebrowser
88 %{py3_sitescriptdir}/qutebrowser-%{version}-py*.egg-info
89 %{_desktopdir}/org.qutebrowser.qutebrowser.desktop
90 %{_iconsdir}/hicolor/*x*/apps/qutebrowser.png
91 %{_iconsdir}/hicolor/scalable/apps/qutebrowser.svg
92 %{_mandir}/man1/qutebrowser.1*
93 %{_datadir}/metainfo/org.qutebrowser.qutebrowser.appdata.xml
94 %dir %{_datadir}/qutebrowser
95 %dir %{_datadir}/qutebrowser/scripts
96 %{_datadir}/qutebrowser/scripts/*.js
97 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.py
98 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.sh
99
100 %files userscripts
101 %defattr(644,root,root,755)
102 %dir %{_datadir}/qutebrowser/userscripts
103 %attr(755,root,root) %{_datadir}/qutebrowser/userscripts/*
This page took 0.058767 seconds and 2 git commands to generate.