]> git.pld-linux.org Git - packages/qt5-qtwebkit.git/commitdiff
- fix asm on x32 auto/th/qt5-qtwebkit-5.4.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 5 Mar 2015 00:29:53 +0000 (01:29 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 5 Mar 2015 00:29:53 +0000 (01:29 +0100)
qt5-qtwebkit.spec
x32-asm.patch [new file with mode: 0644]

index bc601880bb78935e363e7102012f3bf75e274cf8..b3b9ed1a135ce6f98319a09867008b9b6dd28494 100644 (file)
@@ -25,6 +25,7 @@ License:      LGPL v2+
 Group:         X11/Libraries
 Source0:       http://download.qt-project.org/official_releases/qt/5.4/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
 # Source0-md5: 186627b1ea5b614811fbd0cfa9b4d073
+Patch0:                x32-asm.patch
 URL:           http://qt-project.org/
 BuildRequires: OpenGL-devel
 BuildRequires: Qt5Core-devel >= %{qtbase_ver}
@@ -162,6 +163,9 @@ Dokumentacja do bibliotek Qt5 WebKit w formacie QCH.
 
 %prep
 %setup -q -n %{orgname}-opensource-src-%{version}
+%ifarch x32
+%patch0 -p1
+%endif
 
 %build
 qmake-qt5 \
diff --git a/x32-asm.patch b/x32-asm.patch
new file mode 100644 (file)
index 0000000..34a859d
--- /dev/null
@@ -0,0 +1,11 @@
+--- qtwebkit-opensource-src-5.3.2+dfsg/Source/WTF/wtf/Atomics.h~       2014-09-11 12:48:11.000000000 +0200
++++ qtwebkit-opensource-src-5.3.2+dfsg/Source/WTF/wtf/Atomics.h        2015-02-13 22:32:03.647863539 +0100
+@@ -188,7 +188,7 @@
+ #if CPU(X86_64)
+     bool result;
+     asm volatile(
+-        "lock; cmpxchgq %3, %2\n\t"
++        "lock; cmpxchg %3, %2\n\t"
+         "sete %1"
+         : "+a"(expected), "=q"(result), "+m"(*location)
+         : "r"(newValue)
This page took 0.043794 seconds and 4 git commands to generate.