]> git.pld-linux.org Git - packages/qt5-qtwebengine.git/commitdiff
- rename qch bcond to doc (all docs require qtassistant now)
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 23 May 2017 10:15:14 +0000 (12:15 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 23 May 2017 10:15:14 +0000 (12:15 +0200)
qt5-qtwebengine.spec

index 54e2079e91aad7e9bb55e0d6634e7fa0eb63919d..664bb712430b410171554af0ad3e21bd1894731d 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_without qch     # documentation in QCH format
+%bcond_without doc     # Documentation
 
 %define                orgname         qtwebengine
 %define                qtbase_ver              %{version}
@@ -24,7 +24,7 @@ BuildRequires:        Qt5Qml-devel >= %{qtdeclarative_ver}
 BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
 BuildRequires: Qt5WebChannel-devel >= %{qtwebchannel_ver}
 BuildRequires: Qt5Widgets-devel >= %{qtbase_ver}
-%if %{with qch}
+%if %{with doc}
 BuildRequires: qt5-assistant >= %{qttools_ver}
 %endif
 BuildRequires: qt5-build >= %{qtbase_ver}
@@ -133,15 +133,17 @@ Przykłady do biblioteki Qt5 WebEngine.
 %build
 qmake-qt5
 %{__make}
-%{__make} %{!?with_qch:html_}docs
+%{?with_doc:%{__make} docs}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-%{__make} install_%{!?with_qch:html_}docs \
+%if %{with doc}
+%{__make} install_docs \
        INSTALL_ROOT=$RPM_BUILD_ROOT
+%endif
 
 # useless symlinks
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
@@ -199,11 +201,11 @@ rm -rf $RPM_BUILD_ROOT
 %{qt5dir}/mkspecs/modules/qt_lib_webengine.pri
 %{qt5dir}/mkspecs/modules/qt_lib_webengine_private.pri
 
+%if %{with doc}
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebengine
 
-%if %{with qch}
 %files doc-qch
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebengine.qch
This page took 0.146807 seconds and 4 git commands to generate.