]> git.pld-linux.org Git - packages/qt5-qtwebengine.git/commitdiff
bring back condition on ffmpeg 5+ patches from fa199ea with adjustments
authorJan Palus <atler@pld-linux.org>
Sat, 23 Dec 2023 15:20:46 +0000 (16:20 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 23 Dec 2023 15:20:46 +0000 (16:20 +0100)
- when querying ffmpeg-devel version use --quiet so it does not return
  "package ffmpeg-devel is not installed"
- do not quote arguments passed to _ver_ge as quotes are passed
  literally. since _ver_ge accepts two arguments it meant previously
  effective call was: %{_ver_ge "package ffmpeg-devel} where '"package'
  was first argument wheres 'ffmpeg-devel' was second

qt5-qtwebengine.spec

index ca85d35e8ff46314637622af9ed2eef0883faafc..ebab3e92478cde465de89a3b3a7e8f27880f2d9a 100644 (file)
@@ -122,6 +122,8 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                qt5bindir       %(qtpaths-qt5 --binaries-dir)
 
+%define                ffmpeg_ver      %(rpm --quiet -q --qf=%%{V} ffmpeg-devel)
+
 %description
 Qt is a cross-platform application and UI framework. Using Qt, you can
 write web-enabled applications once and deploy them across desktop,
@@ -285,10 +287,12 @@ PrzykĹ‚ady do biblioteki Qt5 WebEngine.
 %endif
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1 -d src/3rdparty
 %patch4 -p1 -d src/3rdparty
 %patch5 -p1 -d src/3rdparty/chromium
+%if %{_ver_ge %ffmpeg_ver 5}
+%patch3 -p1 -d src/3rdparty
 %patch6 -p1 -d src/3rdparty/chromium
+%endif
 
 %{qt5bindir}/syncqt.pl -version %{version}
 
This page took 0.054559 seconds and 4 git commands to generate.