]> git.pld-linux.org Git - packages/qt5-qttools.git/commitdiff
fix build with qtwebkit
authorJan Palus <atler@pld-linux.org>
Mon, 1 Jun 2020 15:14:50 +0000 (17:14 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 1 Jun 2020 15:14:50 +0000 (17:14 +0200)
see https://bugreports.qt.io/browse/QTBUG-83938

qt5-qttools.spec
qtwebkit.patch [new file with mode: 0644]

index 950496ff5e9a1e665b05d9e99b1c2aa48850ac3b..d1db187af1bc1191cb6ce9749df7906a6a885713 100644 (file)
@@ -29,6 +29,7 @@ Source0:      http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%
 # Source0-md5: cbf72f34c9d53508f95b9a4db5322ffa
 Source1:       http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/qttranslations-everywhere-src-%{version}.tar.xz
 # Source1-md5: 7cbff3badaf760badbcdb5fcba109c1b
 # Source0-md5: cbf72f34c9d53508f95b9a4db5322ffa
 Source1:       http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/qttranslations-everywhere-src-%{version}.tar.xz
 # Source1-md5: 7cbff3badaf760badbcdb5fcba109c1b
+Patch0:                qtwebkit.patch
 URL:           http://www.qt.io/
 BuildRequires: OpenGL-devel
 BuildRequires: Qt5Core-devel >= %{qtbase_ver}
 URL:           http://www.qt.io/
 BuildRequires: OpenGL-devel
 BuildRequires: Qt5Core-devel >= %{qtbase_ver}
@@ -323,6 +324,7 @@ Przykłady do narzędzi Qt5.
 
 %prep
 %setup -q -n %{orgname}-everywhere-src-%{version} %{?with_qm:-a1}
 
 %prep
 %setup -q -n %{orgname}-everywhere-src-%{version} %{?with_qm:-a1}
+%patch0 -p1
 
 %build
 qmake-qt5
 
 %build
 qmake-qt5
diff --git a/qtwebkit.patch b/qtwebkit.patch
new file mode 100644 (file)
index 0000000..c1811d5
--- /dev/null
@@ -0,0 +1,14 @@
+--- qttools-everywhere-src-5.15.0/src/assistant/assistant/helpviewer_qwv.cpp.orig      2020-06-01 17:00:23.023062657 +0200
++++ qttools-everywhere-src-5.15.0/src/assistant/assistant/helpviewer_qwv.cpp   2020-06-01 17:00:44.593008843 +0200
+@@ -363,6 +363,11 @@
+     QWebView::mouseReleaseEvent(event);
+ }
++void HelpViewer::resizeEvent(QResizeEvent *e)
++{
++    QWebView::resizeEvent(e);
++}
++
+ // -- private slots
+ void HelpViewer::actionChanged()
This page took 0.310034 seconds and 4 git commands to generate.