]> git.pld-linux.org Git - packages/qt5-qttools.git/blob - qt5-qttools.spec
- release 2
[packages/qt5-qttools.git] / qt5-qttools.spec
1 #
2 # Conditional build:
3 %bcond_without  qch     # QCH documentation
4
5 %define         orgname         qttools
6 %define         qtbase_ver      %{version}
7 Summary:        Development tools for Qt 5
8 Summary(pl.UTF-8):      Narzędzia programistyczne dla Qt 5
9 Name:           qt5-%{orgname}
10 Version:        5.2.1
11 Release:        2
12 License:        LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
13 Group:          X11/Libraries
14 Source0:        http://download.qt-project.org/official_releases/qt/5.2/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
15 # Source0-md5:  f56b2e6c537f6853d9bf10380c39418b
16 URL:            http://qt-project.org/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
19 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Network-devel >= %{qtbase_ver}
21 BuildRequires:  Qt5PrintSupport-devel >= %{qtbase_ver}
22 BuildRequires:  Qt5Sql-devel >= %{qtbase_ver}
23 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
24 BuildRequires:  Qt5Xml-devel >= %{qtbase_ver}
25 %{?with_qch:BuildRequires:      qt5-assistant >= 5.2}
26 BuildRequires:  qt5-build >= %{qtbase_ver}
27 BuildRequires:  qt5-doc-common >= %{qtbase_ver}
28 BuildRequires:  qt5-qmake >= %{qtbase_ver}
29 BuildRequires:  rpmbuild(macros) >= 1.654
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 # pixeltool: Core, Gui, Widgets
33 # qtpaths: Core
34 Requires:       Qt5Core >= %{qtbase_ver}
35 Requires:       Qt5Gui >= %{qtbase_ver}
36 Requires:       Qt5Widgets >= %{qtbase_ver}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         specflags       -fno-strict-aliasing
40 %define         qt5dir          %{_libdir}/qt5
41
42 %description
43 Qt is a cross-platform application and UI framework. Using Qt, you can
44 write web-enabled applications once and deploy them across desktop,
45 mobile and embedded systems without rewriting the source code.
46
47 This package contains additional tools for building Qt applications.
48
49 %description -l pl.UTF-8
50 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
51 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
52 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
53 źródłowego.
54
55 Ten pakiet zawiera dodatkowe narzędzia do budowania aplikacji Qt.
56
57 %package -n qt5-assistant
58 Summary:        Qt documentation browser
59 Summary(pl.UTF-8):      Przeglądarka dokumentacji Qt
60 Group:          X11/Development/Tools
61 # assistant: Core, Gui, Help, Network, PrintSupport, Sql, Widgets
62 # qcollectiongenerator: Core, Gui, Help
63 # qhelpconverter: Core, Gui, Widgets
64 # qhelpgenerator: Core, Gui, Help; sqldriver-sqlite3 to work
65 Requires:       Qt5Core >= %{qtbase_ver}
66 Requires:       Qt5Help = %{version}-%{release}
67 Requires:       Qt5Gui >= %{qtbase_ver}
68 Requires:       Qt5Network >= %{qtbase_ver}
69 Requires:       Qt5PrintSupport >= %{qtbase_ver}
70 Requires:       Qt5Sql >= %{qtbase_ver}
71 Requires:       Qt5Sql-sqldriver-sqlite3 >= %{qtbase_ver}
72 Requires:       Qt5Widgets >= %{qtbase_ver}
73
74 %description -n qt5-assistant
75 Qt Assistant is a tool for browsing on-line documentation with
76 indexing, bookmarks and full-text search.
77
78 %description -n qt5-assistant -l pl.UTF-8
79 Qt Assistant to narzędzie do przeglądania dokumentacji z możliwością
80 indeksowania, dodawania zakładek i pełnotekstowego wyszukiwania.
81
82 %package -n qt5-designer
83 Summary:        IDE used for GUI designing with Qt 5 library
84 Summary(pl.UTF-8):      IDE służące do projektowania GUI przy użyciu biblioteki Qt 5
85 Group:          X11/Applications
86 Requires:       Qt5Core >= %{qtbase_ver}
87 Requires:       Qt5Designer = %{version}-%{release}
88 Requires:       Qt5Gui >= %{qtbase_ver}
89 Requires:       Qt5Network >= %{qtbase_ver}
90 Requires:       Qt5PrintSupport >= %{qtbase_ver}
91 Requires:       Qt5Widgets >= %{qtbase_ver}
92 Requires:       Qt5Xml >= %{qtbase_ver}
93
94 %description -n qt5-designer
95 An advanced tool used for GUI designing with Qt 5 library.
96
97 %description -n qt5-designer -l pl.UTF-8
98 Zaawansowane narzędzie służące do projektowania interfejsu graficznego
99 przy użyciu biblioteki Qt 5.
100
101 %package -n qt5-linguist
102 Summary:        Translation helper for Qt 5
103 Summary(pl.UTF-8):      Aplikacja ułatwiająca tłumaczenie aplikacji opartych na Qt 5
104 Group:          X11/Development/Tools
105 # lconvert,lrelease,lupdate: Core, Xml
106 # linguist: Core, Gui, PrintSupport, Widgets, Xml
107 Requires:       Qt5Core >= %{qtbase_ver}
108 Requires:       Qt5Gui >= %{qtbase_ver}
109 Requires:       Qt5PrintSupport >= %{qtbase_ver}
110 Requires:       Qt5Widgets >= %{qtbase_ver}
111 Requires:       Qt5Xml >= %{qtbase_ver}
112
113 %description -n qt5-linguist
114 Translation helper for Qt 5.
115
116 %description -n qt5-linguist -l pl.UTF-8
117 Aplikacja ułatwiająca tłumaczenie aplikacji opartych na Qt 5.
118
119 %package -n qt5-qdbus
120 Summary:        Qt5 DBus tools
121 Summary(pl.UTF-8):      Narzędzia Qt5 do magistrali DBus
122 Group:          X11/Applications
123 # qdbus: Core, DBus, Xml
124 # qdbusviewer: Core, DBus, Gui, Widgets, Xml
125 Requires:       Qt5Core >= %{qtbase_ver}
126 Requires:       Qt5DBus >= %{qtbase_ver}
127 Requires:       Qt5Gui >= %{qtbase_ver}
128 Requires:       Qt5Widgets >= %{qtbase_ver}
129 Requires:       Qt5Xml >= %{qtbase_ver}
130
131 %description -n qt5-qdbus
132 This package contains the qdbus and qdbusviewer tools.
133
134 %description -n qt5-qdbus -l pl.UTF-8
135 Ten pakiet zawiera narzędzia qdbus i qdbusviewer.
136
137 %package -n Qt5CLucene
138 Summary:        Qt5 CLucene library
139 Summary(pl.UTF-8):      Biblioteka Qt5 CLucene
140 Group:          Libraries
141 Requires:       Qt5Core >= %{qtbase_ver}
142
143 %description -n Qt5CLucene
144 The Qt5 CLucene library provides Qt API to CLucene, a C++ port of
145 Lucene high-performance, full-featured text search engine.
146
147 %description -n Qt5CLucene -l pl.UTF-8
148 Biblioteka Qt5 CLucene dostarcza API Qt do CLucene - portu C++
149 wysoko wydajnego, w pełni funkcjonalnego silnika wyszukiwania
150 pełnotekstowego.
151
152 %package -n Qt5CLucene-devel
153 Summary:        Qt5 CLucene library - development files
154 Summary(pl.UTF-8):      Biblioteka Qt5 CLucene - pliki programistyczne
155 Group:          Development/Libraries
156 Requires:       Qt5CLucene = %{version}-%{release}
157 Requires:       Qt5Core-devel >= %{qtbase_ver}
158 Obsoletes:      qt5-qttools-devel
159
160 %description -n Qt5CLucene-devel
161 Header files for Qt5 CLucene library.
162
163 %description -n Qt5CLucene-devel -l pl.UTF-8
164 Pliki nagłówkowe biblioteki Qt5 CLucene.
165
166 %package -n Qt5Designer
167 Summary:        Qt5 Designer libraries
168 Summary(pl.UTF-8):      Biblioteki Qt5 Designer
169 Group:          X11/Libraries
170 Requires:       Qt5Core >= %{qtbase_ver}
171 Requires:       Qt5Gui >= %{qtbase_ver}
172 Requires:       Qt5Widgets >= %{qtbase_ver}
173 Requires:       Qt5Xml >= %{qtbase_ver}
174
175 %description -n Qt5Designer
176 The Qt5 Designer libraries provide classes to create your own custom
177 widget plugins for Qt Designer and classes to access Qt Designer
178 components.
179
180 %description -n Qt5Designer -l pl.UTF-8
181 Biblioteki Qt5 Designer dostarczają klasy do tworzenia wtyczek Qt
182 Designera do obsługi własnych widgetów oraz klasy pozwalające na
183 dostęp do komponentów Qt Designera.
184
185 %package -n Qt5Designer-devel
186 Summary:        Qt5 Designer libraries - development files
187 Summary(pl.UTF-8):      Biblioteki Qt5 Designer - pliki programistyczne
188 Group:          X11/Development/Libraries
189 Requires:       OpenGL-devel
190 Requires:       Qt5Core >= %{qtbase_ver}
191 Requires:       Qt5Designer = %{version}-%{release}
192 Requires:       Qt5Gui >= %{qtbase_ver}
193 Requires:       Qt5Widgets >= %{qtbase_ver}
194 Requires:       Qt5Xml >= %{qtbase_ver}
195 Obsoletes:      qt5-qttools-devel
196
197 %description -n Qt5Designer-devel
198 Header files for Qt5 Designer libraries.
199
200 %description -n Qt5Designer-devel -l pl.UTF-8
201 Pliki nagłówkowe bibliotek Qt5 Designer.
202
203 %package -n Qt5Help
204 Summary:        Qt5 Help library
205 Summary(pl.UTF-8):      Biblioteka Qt5 Help
206 Group:          X11/Libraries
207 Requires:       Qt5CLucene = %{version}-%{release}
208 Requires:       Qt5Core >= %{qtbase_ver}
209 Requires:       Qt5Gui >= %{qtbase_ver}
210 Requires:       Qt5Network >= %{qtbase_ver}
211 Requires:       Qt5Sql >= %{qtbase_ver}
212 Requires:       Qt5Widgets >= %{qtbase_ver}
213
214 %description -n Qt5Help
215 Qt5 Help library provides classes for integrating online documentation
216 in applications.
217
218 %description -n Qt5Help -l pl.UTF-8
219 Biblioteka Qt5 Help dostarcza klasy służące do integracji dokumentacji
220 online w aplikacjach.
221
222 %package -n Qt5Help-devel
223 Summary:        Qt5 Help library - development files
224 Summary(pl.UTF-8):      Biblioteka Qt5 Help - pliki programistyczne
225 Group:          X11/Development/Libraries
226 Requires:       Qt5CLucene-devel = %{version}-%{release}
227 Requires:       Qt5Core-devel >= %{qtbase_ver}
228 Requires:       Qt5Gui-devel >= %{qtbase_ver}
229 Requires:       Qt5Help = %{version}-%{release}
230 Requires:       Qt5Network-devel >= %{qtbase_ver}
231 Requires:       Qt5Sql-devel >= %{qtbase_ver}
232 Requires:       Qt5Widgets-devel >= %{qtbase_ver}
233 Obsoletes:      qt5-qttools-devel
234
235 %description -n Qt5Help-devel
236 Header files for Qt5 Help library.
237
238 %description -n Qt5Help-devel -l pl.UTF-8
239 Pliki nagłówkowe biblioteki Qt5 Help.
240
241 %package -n Qt5UiTools-devel
242 Summary:        Qt5 Ui Tools library - development files
243 Summary(pl.UTF-8):      Biblioteka Qt5 Ui Tools - pliki programistyczne
244 Group:          X11/Development/Libraries
245 Requires:       OpenGL-devel
246 Requires:       Qt5Core-devel >= %{qtbase_ver}
247 Requires:       Qt5Gui-devel >= %{qtbase_ver}
248 Requires:       Qt5Widgets-devel >= %{qtbase_ver}
249 Obsoletes:      qt5-qttools-devel
250
251 %description -n Qt5UiTools-devel
252 Header files and static Qt5 Ui Tools library.
253
254 Qt5 Ui Tools library provides classes to handle forms created with Qt
255 Designer.
256
257 %description -n Qt5UiTools-devel -l pl.UTF-8
258 Pliki nagłówkowe i statyczna biblioteka Qt5 Ui Tools.
259
260 Biblioteka Qt5 Ui Tools dostarcza klasy do obsługi formularzy
261 utworzonych przy użyciu Qt Designera.
262
263 %package doc
264 Summary:        Qt5 Tools documentation in HTML format
265 Summary(pl.UTF-8):      Dokumentacja do narzędzi Qt5 w formacie HTML
266 Group:          X11/Development/Libraries
267 Requires:       qt5-doc-common >= %{qtbase_ver}
268 %if "%{_rpmversion}" >= "5"
269 BuildArch:      noarch
270 %endif
271
272 %description doc
273 Qt5 Tools documentation in HTML format.
274
275 %description doc -l pl.UTF-8
276 Dokumentacja do narzędzi Qt5 w formacie HTML.
277
278 %package doc-qch
279 Summary:        Qt5 Tools documentation in QCH format
280 Summary(pl.UTF-8):      Dokumentacja do narzędzi Qt5 w formacie QCH
281 Group:          X11/Development/Libraries
282 Requires:       qt5-doc-common >= %{qtbase_ver}
283 %if "%{_rpmversion}" >= "5"
284 BuildArch:      noarch
285 %endif
286
287 %description doc-qch
288 Qt5 Tools documentation in QCH format.
289
290 %description doc-qch -l pl.UTF-8
291 Dokumentacja do narzędzi Qt5 w formacie QCH.
292
293 %package examples
294 Summary:        Qt5 Tools examples
295 Summary(pl.UTF-8):      Przykłady do narzędzi Qt5
296 Group:          X11/Development/Libraries
297 %if "%{_rpmversion}" >= "5"
298 BuildArch:      noarch
299 %endif
300
301 %description examples
302 Qt5 Tools - examples.
303
304 %description examples -l pl.UTF-8
305 Przykłady do narzędzi Qt5.
306
307 %prep
308 %setup -q -n %{orgname}-opensource-src-%{version}
309
310 %build
311 qmake-qt5
312 %{__make}
313
314 # build only HTML docs if without qch (which needs already installed qhelpgenerator)
315 %{__make} %{!?with_qch:html_}docs
316
317 %install
318 rm -rf $RPM_BUILD_ROOT
319 install -d $RPM_BUILD_ROOT%{_bindir}
320
321 %{__make} install \
322         INSTALL_ROOT=$RPM_BUILD_ROOT
323
324 %{__make} install_%{!?with_qch:html_}docs \
325         INSTALL_ROOT=$RPM_BUILD_ROOT
326
327 # kill unnecessary -L%{_libdir} from *.la, *.prl, *.pc
328 %{__sed} -i -e "s,-L%{_libdir} \?,,g" \
329         $RPM_BUILD_ROOT%{_libdir}/*.{la,prl} \
330         $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
331
332 # useless symlinks
333 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
334 # actually drop *.la, follow policy of not packaging them when *.pc exist
335 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
336
337 # symlinks in system bin dir
338 cd $RPM_BUILD_ROOT%{_bindir}
339 ln -sf ../%{_lib}/qt5/bin/assistant assistant-qt5
340 ln -sf ../%{_lib}/qt5/bin/designer designer-qt5
341 ln -sf ../%{_lib}/qt5/bin/lconvert lconvert-qt5
342 ln -sf ../%{_lib}/qt5/bin/linguist linguist-qt5
343 ln -sf ../%{_lib}/qt5/bin/lrelease lrelease-qt5
344 ln -sf ../%{_lib}/qt5/bin/lupdate lupdate-qt5
345 ln -sf ../%{_lib}/qt5/bin/pixeltool pixeltool-qt5
346 ln -sf ../%{_lib}/qt5/bin/qcollectiongenerator qcollectiongenerator-qt5
347 ln -sf ../%{_lib}/qt5/bin/qdbus qdbus-qt5
348 ln -sf ../%{_lib}/qt5/bin/qdbusviewer qdbusviewer-qt5
349 ln -sf ../%{_lib}/qt5/bin/qhelpconverter qhelpconverter-qt5
350 ln -sf ../%{_lib}/qt5/bin/qhelpgenerator qhelpgenerator-qt5
351 ln -sf ../%{_lib}/qt5/bin/qtpaths qtpaths-qt5
352 cd -
353
354 # Prepare some files list
355 ifecho() {
356         r="$RPM_BUILD_ROOT$2"
357         if [ -d "$r" ]; then
358                 echo "%%dir $2" >> $1.files
359         elif [ -x "$r" ] ; then
360                 echo "%%attr(755,root,root) $2" >> $1.files
361         elif [ -f "$r" ]; then
362                 echo "$2" >> $1.files
363         else
364                 echo "Error generation $1 files list!"
365                 echo "$r: no such file or directory!"
366                 return 1
367         fi
368 }
369 ifecho_tree() {
370         ifecho $1 $2
371         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
372                 ifecho $1 $2/$f
373         done
374 }
375
376 echo "%defattr(644,root,root,755)" > examples.files
377 ifecho_tree examples %{_examplesdir}/qt5/assistant
378 ifecho_tree examples %{_examplesdir}/qt5/designer
379 ifecho_tree examples %{_examplesdir}/qt5/help
380 ifecho_tree examples %{_examplesdir}/qt5/linguist
381 ifecho_tree examples %{_examplesdir}/qt5/uitools
382
383 %clean
384 rm -rf $RPM_BUILD_ROOT
385
386 %post   -n Qt5CLucene -p /sbin/ldconfig
387 %postun -n Qt5CLucene -p /sbin/ldconfig
388
389 %post   -n Qt5Designer -p /sbin/ldconfig
390 %postun -n Qt5Designer -p /sbin/ldconfig
391
392 %post   -n Qt5Help -p /sbin/ldconfig
393 %postun -n Qt5Help -p /sbin/ldconfig
394
395 %files
396 %defattr(644,root,root,755)
397 %doc LGPL_EXCEPTION.txt dist/changes-*
398 %attr(755,root,root) %{_bindir}/pixeltool-qt5
399 %attr(755,root,root) %{_bindir}/qtpaths-qt5
400 %attr(755,root,root) %{qt5dir}/bin/pixeltool
401 %attr(755,root,root) %{qt5dir}/bin/qtpaths
402
403 %files -n qt5-assistant
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_bindir}/assistant-qt5
406 %attr(755,root,root) %{_bindir}/qcollectiongenerator-qt5
407 %attr(755,root,root) %{_bindir}/qhelpconverter-qt5
408 %attr(755,root,root) %{_bindir}/qhelpgenerator-qt5
409 %attr(755,root,root) %{qt5dir}/bin/assistant
410 %attr(755,root,root) %{qt5dir}/bin/qcollectiongenerator
411 %attr(755,root,root) %{qt5dir}/bin/qhelpconverter
412 %attr(755,root,root) %{qt5dir}/bin/qhelpgenerator
413
414 %files -n qt5-designer
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_bindir}/designer-qt5
417 %attr(755,root,root) %{qt5dir}/bin/designer
418
419 %files -n qt5-linguist
420 %defattr(644,root,root,755)
421 %attr(755,root,root) %{_bindir}/lconvert-qt5
422 %attr(755,root,root) %{_bindir}/linguist-qt5
423 %attr(755,root,root) %{_bindir}/lrelease-qt5
424 %attr(755,root,root) %{_bindir}/lupdate-qt5
425 %attr(755,root,root) %{qt5dir}/bin/lconvert
426 %attr(755,root,root) %{qt5dir}/bin/linguist
427 %attr(755,root,root) %{qt5dir}/bin/lrelease
428 %attr(755,root,root) %{qt5dir}/bin/lupdate
429 %dir %{_datadir}/qt5
430 %{_datadir}/qt5/phrasebooks
431 %{_libdir}/cmake/Qt5LinguistTools
432
433 %files -n qt5-qdbus
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_bindir}/qdbus-qt5
436 %attr(755,root,root) %{_bindir}/qdbusviewer-qt5
437 %attr(755,root,root) %{qt5dir}/bin/qdbus
438 %attr(755,root,root) %{qt5dir}/bin/qdbusviewer
439
440 %files -n Qt5CLucene
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_libdir}/libQt5CLucene.so.*.*.*
443 %attr(755,root,root) %ghost %{_libdir}/libQt5CLucene.so.5
444
445 %files -n Qt5CLucene-devel
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{_libdir}/libQt5CLucene.so
448 %{_libdir}/libQt5CLucene.prl
449 %{_includedir}/qt5/QtCLucene
450 %{_pkgconfigdir}/Qt5CLucene.pc
451 %{qt5dir}/mkspecs/modules/qt_lib_clucene_private.pri
452
453 %files -n Qt5Designer
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_libdir}/libQt5Designer.so.*.*.*
456 %attr(755,root,root) %ghost %{_libdir}/libQt5Designer.so.5
457 %attr(755,root,root) %{_libdir}/libQt5DesignerComponents.so.*.*.*
458 %attr(755,root,root) %ghost %{_libdir}/libQt5DesignerComponents.so.5
459
460 %dir %{qt5dir}/plugins
461 %dir %{qt5dir}/plugins/designer
462 %attr(755,root,root) %{qt5dir}/plugins/designer/libcontainerextension.so
463 %attr(755,root,root) %{qt5dir}/plugins/designer/libcustomwidgetplugin.so
464 %attr(755,root,root) %{qt5dir}/plugins/designer/libtaskmenuextension.so
465 %attr(755,root,root) %{qt5dir}/plugins/designer/libworldtimeclockplugin.so
466
467 %files -n Qt5Designer-devel
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_libdir}/libQt5Designer.so
470 %attr(755,root,root) %{_libdir}/libQt5DesignerComponents.so
471 %{_libdir}/libQt5Designer.prl
472 %{_libdir}/libQt5DesignerComponents.prl
473 %{_includedir}/qt5/QtDesigner
474 %{_includedir}/qt5/QtDesignerComponents
475 %{_pkgconfigdir}/Qt5Designer.pc
476 %{_pkgconfigdir}/Qt5DesignerComponents.pc
477 %{_libdir}/cmake/Qt5Designer
478 %{qt5dir}/mkspecs/modules/qt_lib_designer.pri
479 %{qt5dir}/mkspecs/modules/qt_lib_designer_private.pri
480 %{qt5dir}/mkspecs/modules/qt_lib_designercomponents_private.pri
481
482 %files -n Qt5Help
483 %defattr(644,root,root,755)
484 %attr(755,root,root) %{_libdir}/libQt5Help.so.*.*.*
485 %attr(755,root,root) %ghost %{_libdir}/libQt5Help.so.5
486
487 %files -n Qt5Help-devel
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/libQt5Help.so
490 %{_libdir}/libQt5Help.prl
491 %{_includedir}/qt5/QtHelp
492 %{_pkgconfigdir}/Qt5Help.pc
493 %{_libdir}/cmake/Qt5Help
494 %{qt5dir}/mkspecs/modules/qt_lib_help.pri
495 %{qt5dir}/mkspecs/modules/qt_lib_help_private.pri
496
497 %files -n Qt5UiTools-devel
498 %defattr(644,root,root,755)
499 # static-only
500 %{_libdir}/libQt5UiTools.a
501 %{_libdir}/libQt5UiTools.prl
502 %{_includedir}/qt5/QtUiTools
503 %{_pkgconfigdir}/Qt5UiTools.pc
504 %{_libdir}/cmake/Qt5UiTools
505 %{qt5dir}/mkspecs/modules/qt_lib_uitools.pri
506 %{qt5dir}/mkspecs/modules/qt_lib_uitools_private.pri
507
508 %files examples -f examples.files
509 %defattr(644,root,root,755)
510 # XXX: dir shared with qt5-qtbase-examples
511 %dir %{_examplesdir}/qt5
512
513 %files doc
514 %defattr(644,root,root,755)
515 %{_docdir}/qt5-doc/qtassistant
516 %{_docdir}/qt5-doc/qtdesigner
517 %{_docdir}/qt5-doc/qthelp
518 %{_docdir}/qt5-doc/qtlinguist
519 %{_docdir}/qt5-doc/qtuitools
520
521 %if %{with qch}
522 %files doc-qch
523 %defattr(644,root,root,755)
524 %{_docdir}/qt5-doc/qtassistant.qch
525 %{_docdir}/qt5-doc/qtdesigner.qch
526 %{_docdir}/qt5-doc/qthelp.qch
527 %{_docdir}/qt5-doc/qtlinguist.qch
528 %{_docdir}/qt5-doc/qtuitools.qch
529 %endif
This page took 0.087573 seconds and 3 git commands to generate.