]> git.pld-linux.org Git - packages/qt5-qtspeech.git/blob - qt5-qtspeech.spec
b4e56a309234da2273409c10c5def745e132274d
[packages/qt5-qtspeech.git] / qt5-qtspeech.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4 %bcond_with     flite   # Flite plugin
5
6 %define         orgname         qtspeech
7 %define         qtbase_ver      %{version}
8 %define         qttools_ver     %{version}
9 Summary:        The Qt5 Speech library
10 Summary(pl.UTF-8):      Biblioteka Qt5 Speech
11 Name:           qt5-%{orgname}
12 Version:        5.15.0
13 Release:        1
14 License:        FDL or GPL v2.0 or LGPL v3.0
15 Group:          Libraries
16 Source0:        http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
17 # Source0-md5:  e4939722b84d5fff0ac0175dd57fae30
18 URL:            http://www.qt.io/
19 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
21 BuildRequires:  Qt5Multimedia-devel >= %{qtbase_ver}
22 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
23 BuildRequires:  Qt5XmlPatterns-devel >= %{qtbase_ver}
24 BuildRequires:  qt5-doc-common >= %{qtbase_ver}
25 %if %{with flite}
26 BuildRequires:  flite-devel >= 2.1
27 %endif
28 %if %{with doc}
29 BuildRequires:  qt5-assistant >= %{qttools_ver}
30 %endif
31 BuildRequires:  qt5-build >= %{qtbase_ver}
32 BuildRequires:  qt5-qmake >= %{qtbase_ver}
33 BuildRequires:  rpmbuild(macros) >= 1.654
34 BuildRequires:  speech-dispatcher-devel
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         specflags       -fno-strict-aliasing
40 %define         qt5dir          %{_libdir}/qt5
41
42 %description
43 Qt is a cross-platform application and UI framework. Using Qt, you can
44 write web-enabled applications once and deploy them across desktop,
45 mobile and embedded systems without rewriting the source code.
46
47 This package contains Qt5 Speech library.
48
49 %description -l pl.UTF-8
50 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
51 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
52 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
53 źródłowego.
54
55 Ten pakiet zawiera bibliotekę Qt5 Speech.
56
57 %package -n Qt5Speech
58 Summary:        The Qt5 Speech library
59 Summary(pl.UTF-8):      Biblioteka Qt5 Speech
60 Group:          Libraries
61 Requires:       Qt5Core >= %{qtbase_ver}
62
63 %description -n Qt5Speech
64 Qt5 Speech library.
65
66 %description -n Qt5Speech -l pl.UTF-8
67 Biblioteka Qt5 Speech.
68
69 %package -n Qt5Speech-devel
70 Summary:        Qt5 Speech library - development files
71 Summary(pl.UTF-8):      Biblioteka Qt5 Speech - pliki programistyczne
72 Group:          Development/Libraries
73 Requires:       Qt5Core-devel >= %{qtbase_ver}
74 Requires:       Qt5Speech = %{version}-%{release}
75
76 %description -n Qt5Speech-devel
77 Qt5 Speech library - development files.
78
79 %description -n Qt5Speech-devel -l pl.UTF-8
80 Biblioteka Qt5 Speech - pliki programistyczne.
81
82 %package -n Qt5Speech-plugin-flite
83 Summary:        flite plugin for Qt5 Speech library
84 Summary(pl.UTF-8):      Wtyczka flite do biblioteki Qt5 Speech
85 Group:          Libraries
86 Requires:       Qt5Speech = %{version}-%{release}
87 Requires:       flite >= 2.1
88
89 %description -n Qt5Speech-plugin-flite
90 flite plugin for Qt5 Speech library.
91
92 %description -n Qt5Speech-plugin-flite -l pl.UTF-8
93 Wtyczka flite do biblioteki Qt5 Speech
94
95 %package doc
96 Summary:        Qt5 Speech documentation in HTML format
97 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Speech w formacie HTML
98 Group:          Documentation
99 Requires:       qt5-doc-common >= %{qtbase_ver}
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description doc
105 Qt5 Speech documentation in HTML format.
106
107 %description doc -l pl.UTF-8
108 Dokumentacja do biblioteki Qt5 Speech w formacie HTML.
109
110 %package doc-qch
111 Summary:        Qt5 Speech documentation in QCH format
112 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Speech w formacie QCH
113 Group:          Documentation
114 Requires:       qt5-doc-common >= %{qtbase_ver}
115 %if "%{_rpmversion}" >= "5"
116 BuildArch:      noarch
117 %endif
118
119 %description doc-qch
120 Qt5 Speech documentation in QCH format.
121
122 %description doc-qch -l pl.UTF-8
123 Dokumentacja do biblioteki Qt5 Speech w formacie QCH.
124
125 %package examples
126 Summary:        Qt5 Speech examples
127 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Speech
128 Group:          Development/Libraries
129 %if "%{_rpmversion}" >= "5"
130 BuildArch:      noarch
131 %endif
132
133 %description examples
134 Qt5 Speech examples.
135
136 %description examples -l pl.UTF-8
137 Przykłady do biblioteki Qt5 Speech.
138
139 %prep
140 %setup -q -n %{orgname}-everywhere-src-%{version}
141
142 %build
143 qmake-qt5
144 %{__make}
145 %{?with_doc:%{__make} docs}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 %{__make} install \
150         INSTALL_ROOT=$RPM_BUILD_ROOT
151
152 %if %{with doc}
153 %{__make} install_docs \
154         INSTALL_ROOT=$RPM_BUILD_ROOT
155 %endif
156
157 # useless symlinks
158 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
159 # actually drop *.la, follow policy of not packaging them when *.pc exist
160 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
161
162 # Prepare some files list
163 ifecho() {
164         r="$RPM_BUILD_ROOT$2"
165         if [ -d "$r" ]; then
166                 echo "%%dir $2" >> $1.files
167         elif [ -x "$r" ] ; then
168                 echo "%%attr(755,root,root) $2" >> $1.files
169         elif [ -f "$r" ]; then
170                 echo "$2" >> $1.files
171         else
172                 echo "Error generation $1 files list!"
173                 echo "$r: no such file or directory!"
174                 return 1
175         fi
176 }
177 ifecho_tree() {
178         ifecho $1 $2
179         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
180                 ifecho $1 $2/$f
181         done
182 }
183
184 echo "%defattr(644,root,root,755)" > examples.files
185 ifecho_tree examples %{_examplesdir}/qt5/speech
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %post   -n Qt5Speech -p /sbin/ldconfig
191 %postun -n Qt5Speech -p /sbin/ldconfig
192
193 %files -n Qt5Speech
194 %defattr(644,root,root,755)
195 %doc LICENSE.* dist/changes-*
196 %attr(755,root,root) %{_libdir}/libQt5TextToSpeech.so.*.*.*
197 %attr(755,root,root) %ghost %{_libdir}/libQt5TextToSpeech.so.5
198 %dir %{_libdir}/qt5/plugins/texttospeech
199 %attr(755,root,root) %{_libdir}/qt5/plugins/texttospeech/libqtexttospeech_speechd.so
200
201 %files -n Qt5Speech-devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libQt5TextToSpeech.so
204 %{_libdir}/libQt5TextToSpeech.prl
205 %{_includedir}/qt5/QtTextToSpeech
206 %{_pkgconfigdir}/Qt5TextToSpeech.pc
207 %{_libdir}/cmake/Qt5TextToSpeech
208 %{qt5dir}/mkspecs/modules/qt_lib_texttospeech.pri
209 %{qt5dir}/mkspecs/modules/qt_lib_texttospeech_private.pri
210
211 %if %{with flite}
212 %files -n Qt5Speech-plugin-flite
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/qt5/plugins/texttospeech/libqttexttospeech_flite.so
215 %endif
216
217 %if %{with doc}
218 %files doc
219 %defattr(644,root,root,755)
220 %{_docdir}/qt5-doc/qtspeech
221
222 %files doc-qch
223 %defattr(644,root,root,755)
224 %{_docdir}/qt5-doc/qtspeech.qch
225 %endif
226
227 %files examples -f examples.files
228 %defattr(644,root,root,755)
229 # XXX: dir shared with qt5-qtbase-examples
230 %dir %{_examplesdir}/qt5
This page took 0.123256 seconds and 2 git commands to generate.