]> git.pld-linux.org Git - packages/qt5-qtimageformats.git/blob - qt5-qtimageformats.spec
- pl, partially cleaned up/unified with other qt5-*
[packages/qt5-qtimageformats.git] / qt5-qtimageformats.spec
1 # TODO:
2 # - cleanup
3 #
4 # Conditional build:
5 %bcond_without  qch     # documentation in QCH format
6
7 %define         orgname         qtimageformats
8 %define         qtbase_ver      %{version}
9 %define         qttools_ver     %{version}
10 Summary:        The Qt5 Image Formats plugins
11 Summary(pl.UTF-8):      Wtyczki Qt5 Image Formats
12 Name:           qt5-%{orgname}
13 Version:        5.2.0
14 Release:        0.1
15 License:        LGPL v2.1 or GPL v3.0
16 Group:          X11/Libraries
17 Source0:        http://download.qt-project.org/official_releases/qt/5.2/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
18 # Source0-md5:  fe9898272b3952e3d97eacbaca484b55
19 URL:            http://qt-project.org/
20 BuildRequires:  libmng-devel
21 BuildRequires:  libtiff-devel
22 BuildRequires:  qt5-qtbase-devel >= %{qtbase_ver}
23 BuildRequires:  qt5-qttools-devel >= %{qttools_ver}
24 %if %{with qch}
25 BuildRequires:  qt5-assistant >= %{qttools_ver}
26 %endif
27 BuildRequires:  qt5-build >= %{qtbase_ver}
28 BuildRequires:  qt5-qmake >= %{qtbase_ver}
29 BuildRequires:  rpmbuild(macros) >= 1.654
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         specflags       -fno-strict-aliasing
35 %define         qt5dir          %{_libdir}/qt5
36
37 %description
38 Qt is a cross-platform application and UI framework. Using Qt, you can
39 write web-enabled applications once and deploy them across desktop,
40 mobile and embedded systems without rewriting the source code.
41
42 This package contains Qt5 Image Formats plugins.
43
44 %description -l pl.UTF-8
45 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
46 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
47 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
48 źródłowego.
49
50 Ten pakiet zawiera wtyczki Qt5 Image Formats.
51
52 %package devel
53 Summary:        The Qt5 Image Formats - development files
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description devel
58 Qt5 Image Formats - development files.
59
60 %package doc
61 Summary:        Qt5 Image Formats documentation in HTML format
62 Summary(pl.UTF-8):      Dokumentacja do wtyczek Qt5 Image Formats w formacie HTML
63 Group:          Documentation
64 Requires:       qt5-doc-common >= %{qtbase_ver}
65 %if "%{_rpmversion}" >= "5"
66 BuildArch:      noarch
67 %endif
68
69 %description doc
70 Qt5 Image Formats documentation in HTML format.
71
72 %description doc -l pl.UTF-8
73 Dokumentacja do wtyczek Qt5 Image Formats w formacie HTML.
74
75 %package doc-qch
76 Summary:        Qt5 Image Formats documentation in QCH format
77 Summary(pl.UTF-8):      Dokumentacja do wtyczek Qt5 Image Formats w formacie QCH
78 Group:          Documentation
79 Requires:       qt5-doc-common >= %{qtbase_ver}
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description doc-qch
85 Qt5 Image Formats documentation in QCH format.
86
87 %description doc-qch -l pl.UTF-8
88 Dokumentacja do wtyczek Qt5 Image Formats w formacie QCH.
89
90 %package examples
91 Summary:        Qt5 Image Formats examples
92 Group:          X11/Development/Libraries
93 %if "%{_rpmversion}" >= "5"
94 BuildArch:      noarch
95 %endif
96
97 %description examples
98 Qt5 Formats - examples.
99
100 %prep
101 %setup -q -n %{orgname}-opensource-src-%{version}
102
103 %build
104 qmake-qt5
105 %{__make}
106 %{__make} %{!?with_qch:html_}docs
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 %{__make} install \
111         INSTALL_ROOT=$RPM_BUILD_ROOT
112
113 %{__make} install_%{!?with_qch:html_}docs \
114         INSTALL_ROOT=$RPM_BUILD_ROOT
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{qt5dir}/plugins/*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %{_libdir}/cmake/Qt5Gui/*.cmake
126
127 %files doc
128 %defattr(644,root,root,755)
129 %{_docdir}/qt5-doc/qtimageformats
This page took 0.213565 seconds and 4 git commands to generate.