]> git.pld-linux.org Git - packages/qt5-qtbase.git/commitdiff
patch for keyboard input regression in QWebEngine auto/th/qt5-qtbase-5.13.1-1
authorJan Palus <atler@pld-linux.org>
Wed, 25 Sep 2019 23:14:30 +0000 (01:14 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 25 Sep 2019 23:14:30 +0000 (01:14 +0200)
https://bugreports.qt.io/browse/QTBUG-77364

qt5-qtbase.spec
qtbug-77364.patch [new file with mode: 0644]

index e808a099e14ad3f63bed42953e9feeabf0c17144..e4aa1a5a6223a393ae85df974c62217869137d73 100644 (file)
@@ -76,6 +76,7 @@ Source1:      http://download.qt.io/official_releases/qt/5.13/%{version}/submodules/q
 # Source1-md5: 8f2e2ce52c296a1bfd814610770663ae
 Patch0:                %{name}-system_cacerts.patch
 Patch1:                qdoc_default_incdirs.diff
+Patch2:                qtbug-77364.patch
 URL:           http://www.qt.io/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 BuildRequires: EGL-devel
@@ -1177,6 +1178,7 @@ Generator plików makefile dla aplikacji Qt5.
 %setup -q -n %{orgname}-everywhere-src-%{version} %{?with_qm:-a1}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/,g' mkspecs/linux-g++-64/qmake.conf
 
diff --git a/qtbug-77364.patch b/qtbug-77364.patch
new file mode 100644 (file)
index 0000000..54b0969
--- /dev/null
@@ -0,0 +1,35 @@
+From 947883141d9d8b3079a8a21981ad8a5ce3c4798e Mon Sep 17 00:00:00 2001
+From: David Faure <david.faure@kdab.com>
+Date: Mon, 9 Sep 2019 18:12:26 +0200
+Subject: [PATCH] QWidget::setFocusProxy: adjust focus widget properly
+
+My commit 3e7463411e adjusted the focus widget by setting
+QApplicationPrivate::focus_widget directly, while there is a method for
+doing this properly, including setFocus_sys() and emitting signals.
+
+Fixes: QTBUG-77364
+Change-Id: I218acf7a9de39173d282ced46def4f65594f80b4
+Reviewed-by: Florian Bruhin <qt-project.org@the-compiler.org>
+Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
+Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
+Reviewed-by: Shawn Rutledge <shawn.rutledge@qt.io>
+---
+ src/widgets/kernel/qwidget.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/widgets/kernel/qwidget.cpp b/src/widgets/kernel/qwidget.cpp
+index 04290a4ce12..0fa59077449 100644
+--- a/src/widgets/kernel/qwidget.cpp
++++ b/src/widgets/kernel/qwidget.cpp
+@@ -6446,7 +6446,7 @@ void QWidget::setFocusProxy(QWidget * w)
+     if (changingAppFocusWidget) {
+         QWidget *newDeepestFocusProxy = d_func()->deepestFocusProxy();
+-        QApplicationPrivate::focus_widget = newDeepestFocusProxy ? newDeepestFocusProxy : this;
++        QApplicationPrivate::setFocusWidget(newDeepestFocusProxy ? newDeepestFocusProxy : this, Qt::NoFocusReason);
+     }
+ }
+-- 
+2.16.3
+
This page took 0.267975 seconds and 4 git commands to generate.