]> git.pld-linux.org Git - packages/qt4.git/commitdiff
- rel 3; segfault fix
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 7 Dec 2009 15:37:25 +0000 (15:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    qt4-git.patch -> 1.1
    qt4.spec -> 1.232

qt4-git.patch [new file with mode: 0644]
qt4.spec

diff --git a/qt4-git.patch b/qt4-git.patch
new file mode 100644 (file)
index 0000000..569cd6c
--- /dev/null
@@ -0,0 +1,39 @@
+commit 705880f0045ac39140f980d69aec68869213e379
+Author: Alexis Menard <alexis.menard@nokia.com>
+Date:   Thu Nov 26 13:47:34 2009 +0100
+
+    Fix a crash in KDE/Plasma with QGraphicsView. TopLevel list of items
+    was corrupted.
+    
+    This nasty bug was triggered when the index sort the top level list of
+    items. We forgot to set the flag topLevelSequentialOrdering to false
+    so when an item was removed from the top level list it was using the
+    sibling index which can be not valid anymore since the list is not
+    sorted by sequential order. So it let some dangling pointers in the
+    list which make processDirtyItemRecursive crash the next paint event.
+    
+    Reviewed-by:bnilsen
+    Reviewed-by:andreas
+
+diff --git a/src/gui/graphicsview/qgraphicsscene_p.h b/src/gui/graphicsview/qgraphicsscene_p.h
+index a1d0496..69e4d5b 100644
+--- a/src/gui/graphicsview/qgraphicsscene_p.h
++++ b/src/gui/graphicsview/qgraphicsscene_p.h
+@@ -78,7 +78,7 @@ class QGraphicsSceneIndex;
+ class QGraphicsView;
+ class QGraphicsWidget;
+-class QGraphicsScenePrivate : public QObjectPrivate
++class Q_AUTOTEST_EXPORT QGraphicsScenePrivate : public QObjectPrivate
+ {
+     Q_DECLARE_PUBLIC(QGraphicsScene)
+ public:
+@@ -265,6 +265,7 @@ public:
+     {
+         if (needSortTopLevelItems) {
+             qSort(topLevelItems.begin(), topLevelItems.end(), qt_notclosestLeaf);
++            topLevelSequentialOrdering = false;
+             needSortTopLevelItems = false;
+         }
+     }
+
index 5fe9ad346c2db60d94e4abe87552a3ae53f848ef..2298d5cf299eb995cf1e9b491c6f3f7658340df5 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -76,7 +76,7 @@ Summary(pl.UTF-8):    Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
 Version:       4.6.0
-Release:       2
+Release:       3
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
 Source0:       http://download.qt.nokia.com/qt/source/qt-everywhere-opensource-src-%{version}.tar.gz
@@ -90,6 +90,7 @@ Source5:      %{name}-linguist.desktop
 # git checkout -b 4.6.0-patched origin/4.6.0-patched
 # git diff v4.6.0..4.6.0-patched > qt4-kde-git.patch
 Patch100:      %{name}-kde-git.patch
+Patch101:      %{name}-git.patch
 
 Patch0:                %{name}-tools.patch
 Patch1:                %{name}-qt_copy.patch
@@ -1348,6 +1349,7 @@ Programas exemplo para o Qt versão.
 %setup -q -n qt-everywhere-opensource-src-%{version}
 
 %patch100 -p1
+%patch101 -p1
 
 %patch0 -p1
 %patch1 -p0
This page took 0.047999 seconds and 4 git commands to generate.